Raspbian: Die folgenden Pakete haben unerfüllte Abhängigkeiten:

  • Hallo,


    nach dem Update von Raspbian "Wheezy" auf "Jessie" kann ich die Plugins "tv-browser" und "skinflatplus" auf dem Raspberry Pi nicht mehr bauen, da sich libmagick++-dev nicht installieren lässt.

    Code
    1. Die folgenden Pakete haben unerfüllte Abhängigkeiten: libmagick++-dev : Hängt ab von: libmagick++-6.q16-dev soll aber nicht installiert werden E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.




    Ist das nur bei mir so? z.B. durch Probleme beim Update




    Gruß Sig

  • Was verhindert denn die Installation von libmagick++-6.q16-dev ?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • In dem du versuchst es zu installieren.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Der Text in der Box im ersten Post ist die Fehlermeldung die dann kommt wenn ich es mit "apt-get install" installieren will!


    Da hilft auch kein "apt-get update" oder "apt-get install -f" oder was sonst noch die üblichen Versuche sind. Auch habe ich schon alle Pakete deinstalliert, die ich über "dpkg -l | grep magick" gefunden habe.



    Gruß Sig

  • Der Text in der Box im ersten Post ist die Fehlermeldung die dann kommt wenn ich es mit "apt-get install" installieren will!

    Da sollte dann aber ein anderer Text kommen - spiel das einfach mal durch:

    Code
    1. Die folgenden Pakete haben unerfüllte Abhängigkeiten: libmagick++-dev : Hängt ab von: libmagick++-6.q16-dev soll aber nicht installiert werden E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
    2. # Also:
    3. sudo apt-get install libmagick++-dev libmagick++-6.q16-dev
    4. # dann die Pakete aus der nächsten Fehlermeldung in den install-Befehl aufnehmen usw. bis du den wahren Konflikt siehst

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Der Text in der Box im ersten Post ist die Fehlermeldung die dann kommt wenn ich es mit "apt-get install" installieren will!


    Das ist, mit Verlaub, Quatsch! Wenn du ein anderes Paket installierst, dann kann nicht der selbe Text kommen!


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Jetzt hab ichs kapiert!


    Code
    1. apt-get install libmagick++-dev libmagick++-6.q16-dev libmagickwand-6.q16-dev libmagickcore-6.q16-dev librsvg2-dev libcairo2-dev libpixman-1-de




    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    libpixman-1-dev : Hängt ab von: libpixman-1-0 (= 0.32.6-3) aber 0.33.1+git20140627-c37ff5-rpi2rpi1 soll installiert werden
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.



    Das Problem hat also wahrscheinlich hier die Ursache?

  • Das Problem hat also wahrscheinlich hier die Ursache?

    Genau. Die Frage ist jetzt wo libpixman-1-0-0.33.1+git20140627-c37ff5-rpi2rpi1 herkommt (normalerweise sind die Pakete aus den Debian-Quellen ja sauber aufsteigend Versioniert und beinhalten keine Git-Versionen) und welche Pakete noch davon abhängen:

    Code
    1. apt-cache policy libpixman-1-0
    2. apt-cache showpkg libpixman-1-0

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • apt-cache policy libpixman-1-0

    Code
    1. libpixman-1-0:
    2. Installiert: 0.33.1+git20140627-c37ff5-rpi2rpi1
    3. Installationskandidat: 0.33.1+git20140627-c37ff5-rpi2rpi1
    4. Versionstabelle:
    5. *** 0.33.1+git20140627-c37ff5-rpi2rpi1 0
    6. 100 /var/lib/dpkg/status
    7. 0.32.6-3 0
    8. 500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages


    apt-cache showpkg libpixman-1-0

  • Und was passiert, wenn du gezielt die ältere Version installierst?

    Code
    1. apt-get install libmagick++-dev libmagick++-6.q16-dev libmagickwand-6.q16-dev libmagickcore-6.q16-dev librsvg2-dev libcairo2-dev libpixman-1-de libpixman-1-0=0.32.6\*

    Ich verstehe immer noch nicht, wie du die bekommen hast, in den Paketquellen scheint sie nicht (mehr) zu sein.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • apt-get install libpixman-1-dev libpixman-1-0=0.32.6

    Code
    1. E: Version »0.32.6« für »libpixman-1-0« konnte nicht gefunden werden.


    Ich hab mir mal die Quellen geladen "apt-get source..." und die libpixmap Pakete damit gebaut.
    "libpixman-1-0_0.32.6-3_armhf.deb libpixman-1-0-dbg_0.32.6-3_armhf.deb libpixman-1-dev_0.32.6-3_armhf.deb"
    und diese Pakete dann installiert. Damit sind die Abhähängigkeisprobleme weg.


    Danke für die Hilfe!


    Gruß Sig

  • Die Paketverwaltung von Raspbian würde bei jedem Upgrade die neu gebauten Pakete überschreiben.
    Deshalb müssen bis zur Fehlerkorrektur von Raspbian Jessie die Pakete vom Upgrade ausgeschlossen werden.


    Um die Pakete zukünftig vom Upgrade auszuschließen:

    Code
    1. echo "libpixman-1-0 hold"| sudo dpkg --set-selections
    2. echo "libpixman-1-0-dbg hold"| sudo dpkg --set-selections
    3. echo "libpixman-1-dev hold"| sudo dpkg --set-selections


    Überprüfen welche Pakete vom Updgrade ausgeschlossen sind

    Code
    1. dpkg --get-selections |awk '$2 == "hold" { print $1 }'


    Um die Pakete wieder in das regelmäßige Upgrade aufzunehmen:

    Code
    1. echo "libpixman-1-0 install" | sudo dpkg --set-selections
    2. echo "libpixman-1-0-dbg install" | sudo dpkg --set-selections
    3. echo "libpixman-1-dev install" | sudo dpkg --set-selections