Mein neuer yaVDR - 2015

  • Hallo Leute,


    nachdem ich 2010 meinen ersten yaVDR in Betrieb genommen habe und sehr zufrieden war musste ich das Gerät der neuen Wohnsituation anpassen:

    • Das Gehäuse (Silverstone LC16MR) war zu gross und passte in keine Standard-Möbel im Wohnzimmer
    • Das neue Gehäuse sollte Standard-Hifi-Maße besitzen und in Low-Profile ausgeführt sein
    • Das LCD Display habe ich nie wirklich verwendet, genauso wenig die zusätzlichen Bedienelemente (da haben nur die Kids mit rumgespielt)

    Folgende Hardware habe ich neu verbaut, bzw, aus dem alten yaVDR wiederverwendet:

    • MB: Asrock Z87M Extreme4, µ-ATX, LGA 1150, Intel Z87 Chipsatz
    • CPU: Intel Celeron G1820 2.7 GHz
    • Lüfter: Scythe Big Shuriken 2 Rev. B
    • RAM: Corsair XMS3 DDR3-1600 2x2GB CL9 (CMX4GX3M2A1600C9)
    • Grafik: Zotac GeForce GT730 Zone 1GB DDR3 (GK208 "Kepler", ZT-71114-20L, low-profile)
    • SAT-Karte: Digital Devices Cine S2
    • Case: Silverstone MILO ML03 Black
    • Netzteil: beQuiet! Pure Power L8 300W
    • DVD: Pioneer DVR-TD11RS Slim mit Delock Einbaurahmen für Slimdrive (47200) und Slimline SATA/Power Kabel
    • HDD: 40GB Intel SSD für System, 2TB WD20EARS für Daten
    • Fans: 2x Sharkoon Silent Eagle 1000 (1000 rpm, 8.9 dB(A))
    • IR: Atric IR-Einschalter Rev. 5
    • Remote: One for All, X-Sight Lite (URC8610)

    Da das MILO ML03 im Gegensatz zu meinem alten LC16MR kein IR-Empfänger/Einschalter enthält habe ich den Atric verbaut, den ich damals zu Testzwecken gekauft hatte.


    Als Fernbedienung habe ich eine One for All verwendet, die auf Microsoft-MCE Kodierung eingestellt wurde.


    Aufgrund der Abmessungen des Gehäuses musste ich mich entscheiden entweder

    • kleineres Netzteil als Standard-ATX in Kombination mit einem Standard DVD-Laufwerk
    • oder ein platzsparendes DVD-Laufwerk neben einem Standard Netzteil zu verwenden.

    Die Wahl fiel auf ein Notebook-Laufwerk mit Adapter und Standardnetzteil aufgrund einfacherer Verfügbarkeit. Da ich das Laufwerk bisher nur für Installation verwendet hatte auch kein Problem - schick wäre natürlich ein Slot-In Laufwerk gewesen, aber das war mir dann zu teuer.


    Hier erst mal ein paar Fotos vom neuen HTPC


    Zur Installation der Software komme ich später... das war nicht ganz so easy mit der Konfig, aber es läuft mittlerweile alles...
    Die Lösungen zu den einzelnen Problemen habe ich fast alle hier im Forum gefunden - daür allen erstmal ein dickes Dankeschön !!! :applaus


    Viele Grüsse
    Sir Han


    PS: Die übrige Hardware stelle ich demnächst zum Verkauf hier ins Forum...

    Hardware 2015: Silverstone MILO ML03B, BeQuiet PurePower L8 300W, Asrock Z87M Extreme4, Intel Celeron G1820, Big Shuriken 2 Rev.B, 4GB DDR3-1600, Zotac GT730 "Kepler" 1GB HDMI passiv low-profile, Digital Devices Cine S2, 40GB Intel SSD, 2TB WD20EARS, Atric-IR mit One-for-All X-Sight, Sony LCD-TV 40W5800
    Hardware 2010:
    Silverstone LC16MR, BeQuiet PurePower L7 300W, Asus P5Q SE2, Intel E5300, Silverstone NT06-E, 2GB DDR2-800, Gainward 9500GT 1024MB HDMI passiv, Digital Devices Cine S2, 40GB Intel SSD, 2TB WD20EARS, Sony LCD-TV 40W5800
    Software: yaVDR 0.5.0a, softhddevice

  • Also dass in das ML03 kein ATX-NT + normal großes DVD-Laufwerk rein passt kann ich zwar widerlegen (ist etwas eng, geht aber), deine Lösung hat aber auch durchaus ihren Reiz. Auch interessantes Plätzchen für den IR-Empfänger, ich hab stattdessen eine der beiden USB-Frontbuchsen von der Mini-Platine gelöst und in das Loch den Empfänger und die Status-LED des Atric rein geklebt.
    Was mich dran erinnert dass ich gar keine Fotos von meinem Kabel-Chaos gemacht habe... Aber ich schweife ab xD


    Auf jeden Fall ein schickes Baby, möge er dir lange und problemfrei dienen :)

    VDR (2020): yaVDR ansible@focal | ASRock A320M-HDV | Athlon 3000G | PNY GeForce GT720 | DD Cine C2T2 V7 (L4M Edition) | 120GB SSD (System) | 2TB WD Blue (Daten) | Silverstone ML03B | STM32 & SMK RC6 MCE

    VDR (2014, RIP): yaVDR 0.6.2 | ASRock B85M-HDS | Celeron G1820 | Atric IR R5 & Harmony 300
    Aktiv im täglichen Kampf für mehr RAM-Nudismus ;) Nieder mit den Blechdeckeln!

  • Danke Niya,


    stimmt - passen würde es gerade so - war für meinen Geschmack etwas zu wenig Luft dazwischen, daher die Lösung mit dem Laptop-Drive.


    Grüsse,
    Sir Han

    Hardware 2015: Silverstone MILO ML03B, BeQuiet PurePower L8 300W, Asrock Z87M Extreme4, Intel Celeron G1820, Big Shuriken 2 Rev.B, 4GB DDR3-1600, Zotac GT730 "Kepler" 1GB HDMI passiv low-profile, Digital Devices Cine S2, 40GB Intel SSD, 2TB WD20EARS, Atric-IR mit One-for-All X-Sight, Sony LCD-TV 40W5800
    Hardware 2010:
    Silverstone LC16MR, BeQuiet PurePower L7 300W, Asus P5Q SE2, Intel E5300, Silverstone NT06-E, 2GB DDR2-800, Gainward 9500GT 1024MB HDMI passiv, Digital Devices Cine S2, 40GB Intel SSD, 2TB WD20EARS, Sony LCD-TV 40W5800
    Software: yaVDR 0.5.0a, softhddevice

  • Zur Installation der Software wollte ich noch ein paar Takte schreiben:


    Basis für die Installation war meine vorhandene existierende Systempartition (40GB, mit yaVDR64 0.5.0a Hybrid) die ich auf ein neue HDD geklont habe.
    Idee war, dass die ganzen Bibliotheken (VDR-Aufnahmen, XBMC-Bibliothekt)
    ohne Aufwand nachher wiederverwendet werden können (und das funktioniert auch so) - die Daten liegen auf einer 2. HDD (2TB) die als extra Partition eingebunden wird.


    Für das Setup habe ich nur die Systemplatte angehängt - keine Datenplatte damit beim rumspielen nicht irgendwelche Daten verlorengehen.


    Nach dem Einbau und dem ersten Booten kam allerdings gleich die erste Ernüchterung - kein Bild und kein Netzwerk verfügbar ;(. Gut, das hätte man auch vorher wissen können wenn man hier im Forum besser recherchiert hätte. :wand


    Hier so ungefähr was ich gemacht habe...


    1. Intel Netzwerk Treiber:
    Geholfen hat mir die Diskussion in diesem Thread: 121220-gelöst-hilfe-intel-dh87rl-board-haswell-yavdr-0-5-erkennt-die-intel-onboard-lan-karte-nicht/


    Habe den Kernel-Upgrade auf 3.9.0-030900rc8-generic gemacht, wie dort beschrieben bzw. verlinkt. Die Packages habe ich per USB-Stick reingeladen.
    Da ich nicht soo oft mit Linux rummache, hatte ich hier auch viele neue Erkenntnisse... z.B. mit den Zugriffsrechten auf den USB-Stick.


    Ergebnis:

    Code
    1. root@yavdr:/# uname -a
    2. Linux yavdr 3.9.0-030900rc8-generic #201304211835 SMP Sun Apr 21 22:35:53 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


    2. drm i915 init error on boot:
    Den Fehler hatte ich auch (hier beschrieben: drm-i915-init-error-on-boot ) und über einen blacklist Eintrag In der /etc/modprobe.d/blacklist.conf gelöst (am Ende hinzugefügt):

    Code
    1. # yavdr install 17.02.2015
    2. blacklist i915


    Update nicht vergessen:

    Code
    1. sudo update-initramfs -u


    2. Grafikkarte Nvidia GT730:
    Da für die neue GraKa die Treiber (glaube 319) nicht mehr ausreichend waren, musste ein Update her. Daher gemäss folgender Anleitung installiert:
    nvidia-gt-730-zum-laufen-bringen-gelöst


    Nachdem ich per Terminal Zugriff hatte musste ich die Treiber für die Grafikkarte aktualisieren...


    Irgendwie hat das mit den Splash-screens trotzdem nicht hingehauen...


    3. Splash-Screens richten
    Das Thema bekomme ich nicht mehr so richtig erinnerungsmässig hin. Es gab auch viele Artikel die ich dazu gelesen habe. Problem ist irgendwie der Framebuffer. Einige Diskussionen dazu gibts hier im Board aber auch ausserhalb in diversen Ubuntu-Foren... Geholfen hat mir u.a. dies hier: [Gelöst!] uefi-boot-fatal-error-inserting-vesafb-lib-modules-3-2-0-31-generic-initrd-vesafb-ko-no-such-device/


    Aktuelle /etc/initramfs-tools/modules:

    Aktuelle /etc/default/grub:


    Erstellte/geänderte Templates:
    /etc/yavdr/templates_custom/etc/default/grub/10_main


    /etc/yavdr/templates_custom/etc/initramfs-tools/modules/10_main

    Folgende Einstellungen sind jetzt bei mir aktiv:


    hwinfo --framebuffer

    root@yavdr:/# fbset -i


    Danach ging's dann auch wieder mit dem yaVDR Splash-Screen.. :D Natürlich müssen die templates entsprechend verarbeitet und grub etc. updated werden...


    4. Sonstiges
    Skin: Habe irgendwo im Forum das Skin nOpacity gesehen und installiert. Zusammen mit den Channellogos sieht es Klasse aus. Zu den Logos: C3PO-skinnopacity-kanallogos/
    TV-Guide: Nette Übersicht über das laufende Programm
    Systeminfo: Das Plugin hatte ich schon bisher drin. Die Config musste ich natürlich anpassen und bekomme damit aber auch verschiedene Temperaturen etc...


    Hier meine /usr/share/vdr-plugin-systeminfo/systeminfo.sh:


    5. Weitere geplante Installation:
    - Das iStreamdev möchte ich mal installieren um besser zu streamen im Heimnetz auf iPad und Laptop. Geht zwar auch über VLC aber umständlich....siehe link: Announce-ivdr-0-3-3-istreamdev-1-0-1-ffmpeg-segmenter-paket-installation


    6. Probleme mit Tonaussetzern und Rucklern:
    - Zu Beginn hatte ich recht regelmässig Rucker und Tonaussetzer. Ich habe danach an den PArametern rumgeschraubt für die Buffer. Momentan habe ich das Gefühl das die Probleme behoben sind, aber da bin ich mir noch nicht 100% sicher... Mit der Einstellung klappts wohl:

    Code
    1. softhddevice.AudioBufferTime = 600


    Zu guter letzt...


    7. yaVDR Package updates
    Hier habe ich mir während meinen Versuchen beim Installieren irgendwie alles zerschossen und musste nochmal von vorne anfangen.
    Kann es sein dass nach dem Kernel-Update der normale Package update nicht mehr sauber läuft?

    Code
    1. sudo apt-get update
    2. sudo apt-get dist-upgrade


    Momentan sieht's so aus:

    Code
    1. Welcome to Ubuntu 12.04.5 LTS (GNU/Linux 3.9.0-030900rc8-generic x86_64)
    2. * Documentation: https://help.ubuntu.com/
    3. 53 packages can be updated.
    4. 39 updates are security updates.


    Kann mir hier jemand einen Tipp zum weiteren Vorgehen geben???

    Mein Fazit
    : Wenn man hier im Forum sucht, dann findet man meistens auch die Lösung!!! :portal1
    VIELEN DANK AN ALLE DIE HIER MITMACHEN !!!


    Grüsse
    Sir Han

    Hardware 2015: Silverstone MILO ML03B, BeQuiet PurePower L8 300W, Asrock Z87M Extreme4, Intel Celeron G1820, Big Shuriken 2 Rev.B, 4GB DDR3-1600, Zotac GT730 "Kepler" 1GB HDMI passiv low-profile, Digital Devices Cine S2, 40GB Intel SSD, 2TB WD20EARS, Atric-IR mit One-for-All X-Sight, Sony LCD-TV 40W5800
    Hardware 2010:
    Silverstone LC16MR, BeQuiet PurePower L7 300W, Asus P5Q SE2, Intel E5300, Silverstone NT06-E, 2GB DDR2-800, Gainward 9500GT 1024MB HDMI passiv, Digital Devices Cine S2, 40GB Intel SSD, 2TB WD20EARS, Sony LCD-TV 40W5800
    Software: yaVDR 0.5.0a, softhddevice