yavdr 0.4-pre1, eventlircd und lirc_serial

  • Hallo zusammen,


    nach längerer vdr-Abstinenz (Umzug usw) bin ich gerade dabei mir wieder ein Testsystem hochzuziehen. Ich hab das ganze vorher schon mal mit archLinux versucht und habs da auch einigermaßen zum laufen bekommen, aber ein paar Sachen passten mir da nicht so richtig. Also wollte ich nun man das neue yavdr 0.4-pre1 ausprobieren. Bild hab ich ja bereits mit yavdr ... nur komme ich irgendwie mit der Einrichtung meiner Fernbedienung nicht klar.


    Ich habe einen atric IR-Einschalter und muss ihn demzufolge mit lirc_serial ansprechen. Eine funktionierende lirc.conf habe ich (aus der arch-Installation) ... meine Frage ist eher wie der "offizielle" Weg mit yavdr0.4 und eventlircd ist. Ich habe auch schon viel hier im Forum gesucht, aber die Aussagen waren entweder "Das ging ganz einfach" oder "Ich habs nicht hinbekommen" ... aber nirgends wie es gemacht wurde.


    Im Webfrontend unter Einstellungen -> Einstellungen der Fernbedienung:
    Hier sollte ich eventlircd ja eingestellt lassen, oder?


    Welche Dateien muss ich jetzt anpassen? Immernoch die lirc.conf und hardware.conf unter /etc/lirc? Werden diese Dateien noch benutzt oder macht eventlircd das anders? Wo muss ich die Module (lirc_serial) eintragen die geladen werden sollen? Was ist mit mit setserial?


    Ihr merkt schon ... ich brächte echt ne Schritt-für-Schritt-Anleitung für yavdr 0.4, eventlircd und lirc_serial. Könnt ihr mir bitte helfen?


    Ciao,
    Andreas

    MS-Tech MC-380 ATX / Asrock H61M / Intel Pentium G630 / Geforce GT220 / 2x TechniSat CableStar HD2 / ArchLinux mit ArchVDR-Paketen

    The post was edited 1 time, last by highscore ().

  • Hallo,


    genau vor dem Problem stehe ich gerade, nach Umstieg auf DVB-S habe ich eine Neuinstallation von 0.3 auf 0.4 gemacht und natürlich vorher die Problematik bezügl. lirc hier mitgelesen. Ich hatte fälschlicherweise angenommen eine Anpassung der lirc.conf würde ausreichen.
    Nachdem das mit eventlirc nicht funktioniert hatte bzw. ich da nicht weiterkam hatte ich versucht auf herkömmlichem Wege lirc einzubinden. Aber auch die Umstellung per WFE auf lirc hatte keinen Erfolg bzw. die Konfiguration von Hand endete an dem Punkt, dass ich feststellen mußte, dass es keinen lirc initscript mehr gibt bzw. nicht da wo ich ihn erwartete.
    Ist das dem neuen init oder dem eventlicd geschuldet oder gibt es da andere Gründe, dass es kein /etc/init.d/lircd mehr gibt? In yavdr 0.3 konnte ich das noch so konfigurieren. Ein apt-get install lirc hatte auch keinen Erfolg.


    Ich bitte um Hilfe.... Momentan geht nur Tastatur und da auch nicht alle Tasten (kein + und kein esc, die keysonic ACK-340RF+)


    Vielen Dank im Voraus,


    raoul

  • Hallo,


    hat niemand ein atric einschalter mit yavdr 0.4 pre1?


    Mittlerweile habe ich ja rausgefunden, dass das fehlende init-script an upstart liegt und nun über remoted gesteuert wird, aber leider hilft mir das auch nicht weiter, da kein lircd gestartet wird und somit auch keine lirctreiber sondern eventlircd.


    Ich hoffe es findet sich noch jemand der diese Kombination erfoglreich in Funktion hat und uns helfen kann.


    Gruss,
    raoul

  • Es muss ja nicht mal speziell der atric sein ... ist ja mit jedem seriellen Empfänger das selbe.

    MS-Tech MC-380 ATX / Asrock H61M / Intel Pentium G630 / Geforce GT220 / 2x TechniSat CableStar HD2 / ArchLinux mit ArchVDR-Paketen

  • Moin,


    ich habe mir die 0.4-pre1 nun auch mal auf einer sep. HD zum testen installiert. Also wenn ich das richtig sehe, dann ist die Konfiguration des Lirc / Eventlircd noch nicht fertig. Bei der 0.3er werden die /etc/lirc/hardware.conf und die /etc/serial.conf nach der Auswahl im Konfig - Backend wunschgemäß angepasst. In meinem Fall:


    Code
    1. #Chosen Remote Control
    2. REMOTE="Home-brew (16x50 UART compatible serial port)"
    3. REMOTE_MODULES="lirc_dev lirc_serial"


    und


    Code
    1. #COM1 equivalent, /dev/ttyS0
    2. /dev/ttyS0 uart none
    3. #COM2 equivalent, /dev/ttyS1
    4. #/dev/ttyS1 uart none


    Beides wird bei der 0.4-pre1 derzeit nicht gemacht. Ich habe die beiden Konfigs händisch bearbeitet und siehe da, es funktioniert. Nur noch die /etc/lirc/lircd.conf gemäß der neuen Namenskonventionen hinterlegen. Hier ein Auszug aus meiner:



    Dann klappt auch das Zusammenspiel lirc und eventlircd. Näheres zur Namenskonvention: [0.4 pre1] vorhandene lircd.conf yavdr konform modifizieren oder in /usr/share/yavdr-remote/remotes/.


    Gruß


    Obelix