[0.4] LIRC and Terratec remote with usb irda

  • Hi,


    I am using yaVDR 0.3.0 with newest updates.


    I bought Terratec remote with usb receiver. See picture -> http://static.letsbuyit.com/fi…rnbedienung-12983627.jpeg


    But now i have problem. Why i can't repeat my commands? I mean that when i press up and keep pressed i want that that channel or record list going up until i let go.


    I has looking that where is problem but not found anything. ;( And last... There's not anywhere english-area?


    My hardware.conf:


    lircd.conf:




    lsusb


    Code
    1. Bus 002 Device 005: ID 0419:0001 Samsung Info. Systems America, Inc. IrDA Remote Controller



    lsusb -v



  • Hi,


    I noticed that there is two remotes in lircd.conf and i want to try only use that Terratec conf. So i remoted that Samsung remote and this files etc. But how i can get make new lirc settings? Is there something command? I was trying that sudo dpkg-reconfigure lirc -command but that not run that configuration wizard in the VDR screen.

  • Hi,


    Again...


    I noticed that only remote.conf is needed to reconfiguration my remote. And i also removed that Samsung remote on my configuration. But that's not help me nothing. Same one key only. Maybe problem is my ir-usb and this driver. Maybe i need to try another ir receiver.

  • Hi perusmuro,
    The terratec and the satelco remote does not support this. i use the samsung reciever with the hauppauge mvp remote and it works.
    Buntspecht

    Server : Yavdr 0.4 :: Satelco Easywatch DVB-C, Terratec Cinergy C, Technisat cablestar HD2, Seagate Barracuda Green 1,5 T auf Asrock ALiveXfire-eSata2, headless
    Client1: Yavdr 0.4 auf Zotac Z-box ID-41, MCE Remote,
    Client2: Media MVP

  • Hi perusmuro,
    The terratec and the satelco remote does not support this. i use the samsung reciever with the hauppauge mvp remote and it works.
    Buntspecht

    Hi Buntspecht,


    this is not working for me. The LED in the receiver flickers constantly while holding down something like volume up. But there's still a single event when I look directly in the event file in /dev.
    (I am using a harmony remote with mvp configuration though).
    Can you definitely confirm that repeat works? I haven't found anything in google, just that the receiver doe not repeat at all.


    greetz Pilotfish

  • Hi,


    I have problem with this remote. Where i can found working config to yavdr 0.4?


    I tried create config irrecord but got too much zeros.



    In 0.3 this worked fine:
    http://pastebin.com/jiXyqGq5


    I tried this configuration too: https://github.com/yavdr/yavdr…d-conf/samsung-lircd.conf but that seems to work only Satelco remote, because if i try my Terratec there is same kay but only different place, example ei press CH+ on Terratec i got Volume+ what is Satelco remote. But all buttons don't work that way. I tried looking on my Harmony Satelco configure but i didn't find anything.

  • Have you tried to adapt your old lircd.conf to the new namespace in yaVDR 0.4? /var/lib/vdr/remote.conf should not be modyfied.
    Just replace the key names by the names provided in the column "Event" in this table: https://bugs.yavdr.com/project…tegration_04#Eventmapping
    So for example

    Code
    1. UP 0xffcc0017
    2. LEFT 0xffcc0018
    3. OK 0xffcc0019
    4. RIGHT 0xffcc001a
    5. DOWN 0xffcc001b


    becomes

    Code
    1. KEY_UP 0xffcc0017
    2. KEY_LEFT 0xffcc0018
    3. KEY_OK 0xffcc0019
    4. KEY_RIGHT 0xffcc001a
    5. KEY_DOWN 0xffcc001b


    To change the behaviour of eventlircd to filter repeating keystrokes there are some prebuild eventlircd packages that provide different delays until a key is recognised as held down and sends repeated keystrokes: Umfrage zu Eventlircd - Einstellung des Repeat-Filters

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Hi,


    I tried change that old configuration to 0.4 but nope. I only got wrong codes still. I think that something driver or else have changes because i got Satelco and Samsung codes with this Terratec remote.


    I think that easies way is to change my USB IR to this: http://www.dvbshop.net/product…nd-Fernbedienung-SET.html But i don't know is this ir repeating keystrokes what Samsung didn't do.


    And also i first installed that 0.9s packages because, i got multiple keystrokes when i pressed button one time on Terratec. Only what i got worked right is those up, down, right, down and ok keys.