[geloest] [yaVDR 0.3] Kein Sound

  • Hallo,
    trotz langer Suche in den vielen Threads zu diesem Thema bin ich noch nicht fündig geworden.
    Ich versuche erstmal nach einer Neuinstallation den analogen Sound zu aktivieren, da ich mit SPDIF noch Verbindungprobleme habe (siehe anderer Beitrag).
    Ausgangslage:
    Mobo Gigabyte M68M-S2P
    Kopfhörer an grüner Ausgangsbuchse angeschlossen.
    update und dist-upgrade durchgeführt
    von der yavdr-Seite die Einrichtung für HDMI durchgeführt (war wahrscheinlich unnötig, da ich eine Geforce 9500 GT habe)
    Im BIOS ist onboard Sound aktiviert.


    Ich höre aber keinen Sound. Warum findet er keine Soundkarte (mehr)? Vor einigen Stunden hatte er noch eine gefunden (aber kein Sound). Inzwischen habe ich aber viel ausprobiert.

    Code
    1. aplay -l
    2. aplay: device_list:223: keine Soundkarten gefunden ...
    Code
    1. aplay -L
    2. null
    3. Discard all samples (playback) or generate zero samples (capture)
    Code
    1. sudo alsamixer
    2. Fehler beim Öffen des Mixer-Gerätes: No such file or directory
    Code
    1. lsmod | grep snd
    2. snd_hda_intel 20799 0
    3. snd_hda_codec 87096 1 snd_hda_intel
    4. snd_hwdep 5668 1 snd_hda_codec
    5. snd_pcm 71646 2 snd_hda_intel,snd_hda_codec
    6. snd_timer 18710 1 snd_pcm
    7. snd 56687 5 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
    8. soundcore 6620 1 snd
    9. snd_page_alloc 7140 2 snd_hda_intel,snd_pcm

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

    Dieser Beitrag wurde bereits 5 Mal editiert, zuletzt von ctvdrnoob ()

  • Ich habe yaVDR neu installiert. Jetzt findet er die Soundkarte. Ich bekomme aber noch keine Ausgabe.
    Hier die neuen Analysen:

    Im Webfrontend ist Analog angekreuzt.
    Kann mir noch jemand weiterhelfen?
    Welches argument ist invalid beim Aufruf von alsamixer?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von ctvdrnoob ()

  • Ja ich hab seit heute das selbe problem, update und schwupps ging kein sound mehr.



    Bei mir ist es allerdings so das meine kernelmodule für sound nicht laden.



    Ich werde weiter nach einer lösung suchen, vllt bringt es dich ja weiter.

  • ich hab eine lösung für mein problem gefunden.


    Zitat


    apt-get remove alsa-dkms
    apt-get install linux-backports-modules-alsa-2.6.32-27-generic



    Ich hoff dir wird dies auch helfen.

  • Leider hat es bei mir nicht funktioniert.
    Beim Deinstallieren hat er nichts gefunden.
    Beim Installieren hat er dann das Paket installiert.


    Hat noch jemand eine Idee?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Hat noch jemand einen Tip für mich, wie ich die Fehlersuche weiter durchführen kann?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Alsamixer funktioniert ja nicht (siehe oben).
    "alsamixer
    Fehler beim Laden der Mixer-Regler: Invalid argument"

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Ich habe die .deb (siehe Link von XThunder, dann #8) installiert und rebootet. Leider funktioniert der Aufruf von alsamixer immer noch nicht.
    Hat noch jemand einen Tip?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Ich habe jetzt auf die aktuelle alsa-Version geupdatet. Jetzt wird die Soundkarte mit cat /proc/asound/cards wieder nicht erkannt, sondern nur noch mit

    Code
    1. lspci | grep -i audio
    2. 00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)

    (sieht aber anders aus als die vorige Ausgabe!).


    In der /etc/modprobe.d/alsa-base.conf habe ich am Ende "options snd-hda-intel model=3stack-dig" und in /etc/modules "snd-hda-intel model=3stack-dig" eingetragen laut Anleitung.
    Aber es funktioniert immer noch nicht.

    Code
    1. sudo modprobe snd-hda-intel model=3stack-die
    2. WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
    3. FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.32-28-generic/updates/dkms/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)


    Was kann ich machen?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • habe eben auch ein Update gemacht => kein Sound mehr :-(


    Code
    1. /etc/modprobe.d$ aplay -l
    2. **** Liste der Hardware-Geräte (PLAYBACK) ****


    Code
    1. /etc/modprobe.d$ lspci | grep -i audio
    2. 01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)


    in /etc/modprobe.d/alsa-base.conf:
    options snd-hda-intel model=auto probe_mask=1


    in /etc/modules:
    snd-hda-intel model=auto


    alsamixer Version 1.0.23:
    Gerät: HDA NVidia
    Chip: Nvidia ID b
    "Dieses Gerät hat keine Regler"


    Was kann ich nun machen??

  • Ich habe jetzt einen Teilerfolg. Der PCI-Soundkarte habe ich im Terminal Geräusche entlocken können mit speaker-test.
    Aber in yavdr funktioniert sie nicht. In der asound.conf habe ich

    Code
    1. pcm.analog {
    2. type hw
    3. card 0
    4. device 0
    5. channels 2
    6. }

    eingetragen.


    Was kann ich machen, um den Sound analog auszugeben?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Ich hab es jetzt hinbekommen.
    In der Gruppe audio fehlte mein Benutzername. Es war nur vdr eingetragen.
    Hier nochmal zum Nachvollziehen:
    sudo vi /etc/groups
    dort in der Zeile mit audio steht vdr am Ende. Da habe ich mit Komma getrennt meinen Benutzernamen hinzugefügt.
    Neustart, und es läuft.


    Ein weiteres Problem ist jetzt, daß der Sony Bravia auf HDMI5 keinen Ton ausgibt. Wenn ich die Cinch-Buchsen an den AV6 Anschluß stecke, kommt Ton (dann hab ich aber kein Bild).
    Wenn jemand dazu noch Tipps hat, immer her damit.

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Ich habe im alsamixer spdif un-muted. Danach ging der Ton nicht mehr.
    Danach habe ich die Einstellung wieder zurückgenommen, aber Ton ging immer noch nicht.
    Im WF dann nochmal analog ausgewählt und "Setze Ton Einstellung". Danach war die asound.conf weg.
    Wieder neu erstellt mit:
    pcm.!default {
    type hw
    card 0
    device 0
    }
    half auch nichts. Nach jeder Änderung hab ich rebootet.
    Die Rechte stimmen in audio auch noch.
    Beim speaker-test kommt Ton.


    Wie überrede ich yavdr den Ton auszugeben?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • hi ctvdrnoob,


    aplay -l und aplay -L musst du auch als root ausführen :)


    Gruß Micha

  • Das verstehe ich nicht.
    aplay funktioniert doch (siehe letzter Beitrag). Bloß von yavdr wird nichts ausgegeben.
    Hier noch ein paar Ausgaben:

    Code
    1. sudo aplay -Dplughw:0,0 -fcd /usr/share/sounds/alsa/Noise.wav
    2. Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
    3. @VDR1:~$ sudo aplay -Dplughw:0,0 -fcd /usr/share/sounds/alsa/Noise.wav
    4. Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono
    Code
    1. sudo aplay -l
    2. **** Liste der Hardware-Geräte (PLAYBACK) ****
    3. Karte 0: AudioPCI [Ensoniq AudioPCI], Gerät 0: ES1371/1 [ES1371 DAC2/ADC]
    4. Sub-Geräte: 1/1
    5. Sub-Gerät #0: subdevice #0
    6. Karte 0: AudioPCI [Ensoniq AudioPCI], Gerät 1: ES1371/2 [ES1371 DAC1]
    7. Sub-Geräte: 1/1
    8. Sub-Gerät #0: subdevice #0

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von ctvdrnoob ()

  • Ich kenne mich zwar nicht sonderlich aus mit alsa, aber dein aplay statement benutzt plughw, deine asound.conf aber nicht. Um Vergleichbar zu sein müsste das wohl eher so aussehen:

    .
    Du kannst das ja mal ausprobieren.



    Davon mal abgesehen, was hast du eigentlich im Webfrontend eingestellt?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • gda :
    Ich habe deinen Vorschlag ausprobiert. Hat nicht funkioniert.


    Im WF habe ich analog eingestellt. Da der onboard Sound nicht funktionierte, habe ich eine alte Soundkarte eingebaut und wollte erstmal analog den Ton ausgeben. Hat ja auch kurzzeitig (bis zu meiner Spielerei mit spdif) funktioniert.


    Ziel ist aber den onboard Sound über die Grafikkarte an HDMI zu übergeben.


    Ich habe jetzt meine ursprüngliche asound.conf wieder drin. Auf Konsole funktioniert auch das:

    Code
    1. sudo aplay -D hw:0,0 /usr/share/sounds/alsa/Noise.wav
    2. Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono


    edit//: nach Hard-Reset ist jetzt auch der yaVDR Ton wieder auf der Buchse.

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

    Dieser Beitrag wurde bereits 5 Mal editiert, zuletzt von ctvdrnoob ()