Posts by XThunder

    Hi!


    Oje, ich muss gestehen, ich war schon eine Weile nicht mehr hier im Portal aktiv. Bin auch immer noch auf den 0.3 Paketen (läuft alles so schön stabil). Habe die yavdr 0.4 ehrlich gesagt auch noch gar nicht ausprobiert, werde ich aber wohl demnächst mal tun. Da ich vor geraumer Zeit den Patch bereitgestellt habe, sollte ich aber doch vielleicht weiterhelfen können. Schau doch mal in ~/.xbmc/temp/xbmc.log (oder an geeigneter Stelle, keine Ahnung, ob yavdr das log woanders hinpackt) nach XLCDproc Ausgaben. Wenn XBMC deinen Display korrekt erkennt, sollte sowas zu finden sein:


    Code
    1. INFO: XLCDproc::RecognizeAndSetDriver - Driver is: SoundGraph iMON LCD driver


    Dann schauen wir mal weiter.


    (Das Perlskript darf dabei natürlich nicht mitlaufen. Aber ich denke, das versteht sich von selbst.)


    Gruß,
    XThunder

    Hi!


    Warum nicht folgendes machen?


    1. XBMC wird automatisch beim Hochfahren gestartet (in irgendeiner Art von LoopSkript).
    2. Solange, wie XBMC läuft, wird in der VDR shutdown hook das Runterfahren des PCs verhindert.
    3. XBMC hat einen 10 Minuten TimeOut zum BEENDEN, nicht zum Herunterfahren.
    4. XBMC ist jederzeit mittels Fernbedienung wieder zu starten.


    Was man damit erreicht: Bei einem Timer Wake-up ist der Rechner mindestens 10 Minuten am Laufen und verhindert den Shutdown (ist ok, welcher Timer ist schon kürzer). XBMC beendet sich von selbst und VDR kann den Shutdown nach Belieben steuern. Startet bzw. bedient man den XBMC wieder, wird der Shutdown verhindert. Damit ist XBMC nur noch ein Frontend, welches seine Aktivität dem VDR meldet (ok, über Skripte, aber was soll's?!?)


    Das hab ich so seit über einem Jahr am Laufen und der WAF ist auch hoch.


    Gruß,
    XThunder

    Hallo!


    Also bzgl. der eigentlichen Frage: bei mir tut seit über einem Jahr eine MSI G210 stumm und treu ihren Dienst. Kollegen von mir sind damit auch sehr zufrieden. Schau einfach mal in die Signaturen der yavdr Buben! Ich meine, gda hat die auch.


    Gruß,
    XThunder

    Hallo bolzerrr!


    Mmmh, wenn ich diesen Beitrag lese:


    http://forum.xbmc.org/showthread.php?t=48129


    würde ich vermuten, dass der lcdproc deamon zu viele Daten zum Display schickt. Komisch ist, dass er das bei mir nicht macht. XBMC ist bei dir der einzige Client vom LCDproc? Nicht dass der VDR noch was will?!? Oder liegt es vielleicht an dem Scrolldelay? Den habe ich auf 10 gestellt. Probier auch mal eine niedrigere Refreshrate, ich nehme zur Zeit 4Hz, der lcdproc kann wohl auch nur 8Hz. Hier nochmal meine advancedsettings.xml, probier's mal damit.



    Gruß,
    XThunder

    Hi!


    Ich hatte so meine Probleme mit lcdproc 0.5.4. Hatte das eigentlich nur mal ausprobiert, da jemand den Futaba Display mit dem IconPatch ausprobieren wollte. Bei 0.5.4 wurde der imonlcd Treiber geändert, was bewirkt, dass beim ProgressBar-Update durch XBMC die SpinningDisc stehen bleibt. Das sieht wirklich sch...sse aus. Hab's auch mal mit dem 0.5.4 von yavdr ausprobiert, das gleiche Ergebnis. Diese Fehlermeldungen hatte ich damit auch ein paar Mal, hat vielleicht auch was damit zu tun. Daraufhin habe ich die entsprechende Stelle auf 0.5.3 zurückportiert. Mein lcdproc-0.5.4 package enthält diese Portierung des imonlcd Treibers. Ansonsten ist es das Original 0.5.4 mit allen Features (und vielleicht Bugs :-) )


    Ich würde vorschlagen: geh mal auf den lcdproc-0.5.4 aus meinem PPA zurück, schalte auf jeden Fall den Spektrumanalyser in advancedsettings.xml aus und teste nochmal. Feedback bitte hier.


    Ich habe mich gerade mal bei der lcdproc Mailingliste angemeldet und will dort mal einen Bugreport stellen. Mal schauen, ob ich richtig liege.


    Gruß,
    XThunder

    Hallo!


    Ich habe vor einiger Zeit auch vor diesem Problem gestanden. Habe nicht viel Gewese drum gemacht, und die Files einfach umbenannt.


    Code
    1. mv microhttpd.info.gz microhttpd.info.gz.old


    Code
    1. mv libcdio.info.gz libcdio.info.gz.old


    Alternativ kann man auch unter /var/cache/apt/archives mit


    Code
    1. dpkg -i --force-overwrite <paket>


    die Files einfach überbügeln. Da macht man auch nix kaputt. Das sind letztendlich nur Textfiles für info, außerdem kann man sie jederzeit wieder aus einem beliebigen Paket neu installieren.


    Gruß,
    XThunder

    Hi!


    Mmmh, werde ich mal testen. Meinst du, das der LCD zu langsam ist? Oder liegt das am LCDd? Der Absturz ist schon komisch, da der LCDd dann das ganze System blockiert.


    Zum Thema Gedenkminute(n): Ein Kollege von mir benutzt wie ich VNSI/PVR und XBMC als VDR-Frontend. Allerdings hat er den VDR auf einem anderen Rechner laufen, daher höhere Latenzen beim EPG Load während des XBMC Starts. Mein Abfragen auf (!m_bStop) half bei ihm nicht. Daher hat er mal den gdb angeschmissen während der langen Startzeit und sich angeschaut, was die Threads von XBMC so treiben. Der XLCDProc hing in RemoveSpectrumAnalyser(). Daraus haben wir geschlussfolgert, das XBMC scheinbar ILCD::Render() aufruft, obwohl XLCDproc::Initialize() noch nicht durchgelaufen ist. Das sieht man auch an den LCD Debug-Outputs im Logfile. Die Ursache für die ganze Warterei war meiner Meinung nach die for Schleife in RemoveSpectrumAnalyser(), da m_iColumns und m_iRows noch nicht initialisiert waren. Daher initialisiere ich beide nun im Konstruktor von XLCDproc zu Null.


    Patch hängt am TracTicket.


    Gute Nacht,
    XThunder

    Hallo!


    Danke fürs yavdr Howto!


    So, jetzt wieder On-Topic. Habe meinen PPA nochmal aktualisiert, da funzte der SpectrumAnalyser nämlich gar nicht. :unsch


    Ich weiss nicht, wieviele Leute das Zeug hier testen bzw. benutzen, aber mich würde mal interessieren, ob der SpectrumAnalyser bei anderen läuft?!?


    chriss : Ich habe noch einen Bug gefixt, der zu einer Startzeit von 5 Minuten führen konnte, da Variablen für Spalten- und Zeilenanzahl nicht initialisiert waren. Werde den Patch nochmal an das TracTicket hängen, wenn das für dich ok ist?!? Läuft bei dir der SpectrumAnalyser? Bei mir ranzt der LCDd irgendwann mit 99% CPU Last ab und XBMC verabschiedet sich auch. :schiel


    Gruß,
    XThunder

    Mmmh, hört sich für mich doch ganz gut an, da ich der Confluence/SpectrumAnalyser Mehrheit angehöre. :lachen3


    Ok, deswegen funzt bei mir wohl auch ProjectM mit Dharma pvr.


    Danke fürs Feedback,
    XThunder

    Hallo!


    Ist das wieder das Problem mit den Locales? Ich persönlich hatte das Problem noch nicht, aber ein Kollege von mir hatte mit den Dharma PVR Versionen auch kein ProjectM.


    Hilft das:


    http://www.xbmcnerds.com/index.php?page=Thread&threadID=5


    oder das:


    http://forum.xbmc.org/showthread.php?t=51441&page=7


    By the way: Funzt die neue Opdenkamp Version mit VDR/VNSI? Kannste mal deine Eindrücke bzgl. Funktionalität und Stabilität posten?


    Danke,
    XThunder

    Hi!


    Ich habe meine Veris RM200, die bei dem Antec Fusion Remote dabei ist, einfach durch eine Harmony 300i ersetzt. An meiner Lirc, VDR oder XBMC Konfig hab ich dabei nichts geändert, sondern einfach unter myharmony.com die unter Soundgraph Imon hinterlegten Kommandos nach meinem Belieben auf die Tasten verteilt. Ein- und Auschalten funktioniert damit auch perfekt!


    Gruß,
    XThunder

    Ok, das erklärt's dann wohl.


    Der Unterschied zwischen den XBMC Versionen 2:10.5-dharma+pvr~yavdr4 und 2:10.00+pvr-Dharma~xthunder2 besteht eigentlich nur darin, dass meine Version eine modifizierte Variante des Patches von theonlychriss (TracTicket) enthält. Damit hat man auch unter XBMC "volle" Unterstützung des IMON bzw. des Futaba MDM166A Displays, sprich Icons und Bars werden mit dargestellt.


    Mein Build basiert auf dem Mitte-Februar-Stand von https://github.com/opdenkamp/xbmc/tree/Dharma.
    Da die Versionsnummer von Dharma ja scheinbar im Nachhinein auf 10.0 geändert wurde, habe ich diese einfach übernommen.


    Karsten

    Mmmmh, jetzt hast du wieder den yavdr XBMC drauf. Das XBMC aus meinem PPA hat eine niedrigere Versionsnummer (10.0). Du müsstest also entweder den yavdr-xbmc PPA entfernen, oder explizit meine Version auswählen.


    Wenn du meinen PPA korrekt hinzugefügt hast, sollte meine Version verfügbar sein:

    Code
    1. xxx@xxx:~$ apt-cache policy xbmc
    2. xbmc:
    3. Installiert: 2:10.00+pvr-Dharma~xthunder2
    4. Kandidat: 2:10.00+pvr-Dharma~xthunder2
    5. Versions-Tabelle:
    6. *** 2:10.00+pvr-Dharma~xthunder2 0
    7. 500 http://ppa.launchpad.net/xthunder/xbmc-imon/ubuntu/ lucid/main Packages
    8. 100 /var/lib/dpkg/status


    Du könntest dann einfach alle installierten xbmc Pakete entfernen und den XBMC aus meinem PPA installieren:


    Code
    1. sudo apt-get install xbmc=2:10.00+pvr-Dharma~xthunder2


    Mein PPA enthält jetzt übrigens auch den lcdproc-0.5.4 mit mdm166a Treiberunterstützung. Kannst ja mal testen, ob der lcdproc bei dir funktioniert.


    Gruß,
    XThunder