You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

richie_01

Beginner

  • "richie_01" started this thread

Posts: 51

Location: Süddeutschland

Occupation: Dipl. Phys.

  • Send private message

1

Sunday, December 26th 2004, 8:19pm

AC3-Ton defekt beim Bearbeiten mit vdrconvert

Hallo,

Habe ein kleines Problem mit vdrconvert:
Wenn ich eine DVD MIT AC3-Ton erstelle, und dann in einem Stand-Alone-Player abspiele (hab am VDR keinen Audio-Digital-Ausgang) ist die AC3-Spur fehlerhaft, und zwar so, dass das Bild komplett stehenbleibt. Wenn ich im Menü des DVD-Players "Dolby Digital >> PCM" einstelle, dann höre ich Knackser in der Audiospur. Spiele ich nur die mp2-Spur ab, dann ist alles OK. Habe also den starken Verdacht, dass die AC3-Spur korrupt ist! Im Log von vdr2dvd stehen viele Zeilen


WARN: Audio pts for channel 0 moves backwards; please remultiplex input.
WARN: Previous sector: 6989.660 - 6989.724
WARN: Current sector: 6989.692 - 6989.724
WARN: Audio pts for channel 0 moves backwards; please remultiplex input.
WARN: Previous sector: 6989.756 - 6989.820
WARN: Current sector: 6989.788 - 6989.852
WARN: Audio pts for channel 0 moves backwards; please remultiplex input.
WARN: Previous sector: 6991.228 - 6991.324
WARN: Current sector: 6991.292 - 6991.324
STAT: VOBU 14864 at 2645MB, 1 PGCS^MWARN: Audio pts for channel 0 moves backward
s; please remultiplex input.

... und so weiter und so fort.

Können andere User von ähnlichen Problemen berichten? Habe hier im Forum nichts gefunden.

Viele Grüße Richie
Yeong Yang Casper 106 - AMD Sempron 2200+ - 1xTT1.5 - 1xTTBudget - 1x WD 120 GB - 1x Samsung 160 GB - LG DVD+/-R/RAM - Lirc - blaues Grafik-LCD 128x64 - c't vdr 4.5++ (1.3.41 von tobi) - Kernel 2.6.12 - Multipatch

richie_01

Beginner

  • "richie_01" started this thread

Posts: 51

Location: Süddeutschland

Occupation: Dipl. Phys.

  • Send private message

2

Monday, December 27th 2004, 12:13pm

einige weitere "Beobachtungen"

Hallo,

hat denn keiner das gleiche Problem mit dem Ac3-Ton???

Habe jetzt noch einige weitere Beobachtungen gemacht:

DVD mit WinDVD 4.0 unter Win98 abgespielt: (kein Surround-Receiver am Rechner)
-> dasselbe Knacken wie am Standalone-DVD-Player, wenn ich auf "Dolby Digital > PCM" umschalte.

DVD mit Kaffeine (xine) unter Debian/Sarge abgespielt: (gleicher Rechner)
-> ganz normaler Ton, in der Statuszeile wird "dolby digital 2 ch" oder so ähnlich gemeldet, während mein Standalone-Player den Audiostream als 5.1-Surround erkannt hat.

Kann es daran liegen, dass der Player einen 5.1-Stream erwartet? Oder meldet sich der Stream einfach nur falsch beim Player? Andere Dolby Digital 2ch - DVDs (Kauf-DVDs) funktionieren!

Ist vielleicht die mpeg-lib unter Linux sehr viel toleranter als die anderen?

Bin für Antworten (und Beileidsbekundungen) dankbar.

Gruß Richie
Yeong Yang Casper 106 - AMD Sempron 2200+ - 1xTT1.5 - 1xTTBudget - 1x WD 120 GB - 1x Samsung 160 GB - LG DVD+/-R/RAM - Lirc - blaues Grafik-LCD 128x64 - c't vdr 4.5++ (1.3.41 von tobi) - Kernel 2.6.12 - Multipatch

3

Monday, April 4th 2005, 7:31pm

RE: einige weitere "Beobachtungen"

Hast Du inzwischen eine Lösung gefunden?

Bei mir im VDRConvert-Log stehen diesselben Fehlermeldungen, und der AC3-Ton ist nicht synchron beim Abpspielen (es komm aber nicht komplett zum Aussetzen des Bildes, der Ton ist nur versetzt) :(...

4

Monday, April 4th 2005, 7:54pm

RE: AC3-Ton defekt beim Bearbeiten mit vdrconvert

Das Problem tritt auch beim demuxen mit ProjectX auf (ich habe hier im Forum dazu ein Posting verfasst). Es wurden in den letzten Versionen (1.3.xx) vom VDR Änderungen am Dateiformat vorgenommen. Wir müssen uns wohl damit abfinden, dass man im Augenblick nicht in MPEG2 mit AC3 konvertieren kann.

Hier gibt es eine neue Version von vdrconvert, allerdings hat sie mir nicht geholfen:
http://www.vdr-portal.de/board/thread.ph…id=26922&page=5

-Sebastian

This post has been edited 1 times, last edit by "sesc" (Apr 4th 2005, 7:55pm)


5

Thursday, April 7th 2005, 12:14pm

Ich habe das gleiche Problem. Ich benutze ctvdr ( Tobis.Experimental.Sarge). Beim Abspielen im vdr selber sind diese massiven Aussetzer nicht vorhanden. Nur beim Brennen auf DVD mit vdrconvert. Diese Tonspur ist dann definitiv nicht zu gebrauchen.
Grüße, Christian

Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

dimitri

Professional

Posts: 1,137

Location: Frankfurt a.M

Occupation: System Engineer

  • Send private message

6

Thursday, April 7th 2005, 12:49pm

Hi,

sind die probleme beim benutzen von vdrsync3 als demuxer ( CVS update von gestern ) auch noch vorhanden ?

Gruss
Dimitri

7

Thursday, April 7th 2005, 12:53pm

Quoted

Original von dimitri
sind die probleme beim benutzen von vdrsync3 als demuxer ( CVS update von gestern ) auch noch vorhanden ?


Ich bin hier auf die Hilfe von Tobi und seinem Team angewiesen. Ich schicke ihm den Thread. Ich hoffe, sie können es einbauen.
Grüße, Christian

Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

8

Thursday, April 7th 2005, 11:55pm

@kop:

Also ich bekomme mit vdrsync 0.1.3 und vdrconvert 0.1 garnichts mehr konvertiert.

Falls du es selber probieren willst:

Source code

1
2
cd /usr/lib/vdrconvert/bin
wget http://ddimi.homeip.net/cgi-bin/cvsweb.cgi/vdrconvert/bin/vdrsync-0.1.3.pl


Danach muss du in /etc/vdr/vdrconvert/vdrconvert.conf

VDRSYNC=/usr/lib/vdrconvert/bin/vdrsync-0.1.2.2.pl

ändern in:

VDRSYNC=/usr/lib/vdrconvert/bin/vdrsync-0.1.3.pl

@dimitri:

Wie ist der aktuelle Status von vdrconvert 0.2? Bis jetzt gibt es noch keine beta- oder pre-release-Versionen, als nehme ich an, das ganze ist noch stark im Wandel?

Gruß,

Tobias
www.e-tobi.net (Debian-Repositories - Paket-Übersicht: etch; lenny; sid vdrdevel)

dimitri

Professional

Posts: 1,137

Location: Frankfurt a.M

Occupation: System Engineer

  • Send private message

9

Friday, April 8th 2005, 9:44am

Hi,

Quoted

Original von Tobi


@dimitri:

Wie ist der aktuelle Status von vdrconvert 0.2? Bis jetzt gibt es noch keine beta- oder pre-release-Versionen, als nehme ich an, das ganze ist noch stark im Wandel?


ich kann nur empfehlen die Version 0.2 zu benutzen. Im WEBCVS kannst du dir ja ein komplettes tarfile generieren lassen welches sich dann als pre-release versteht. Für eine beta bräuchte ich das OK von Usern die nicht SuSE 9.2 / 9.3 im einsatz haben.

Da ich momentan leider extrem unter Zeitmangel leide wird da auch nichts grossartig gewandelt.

Offen sind noch :
- kapitelauswahl mit animation
- Sprachauswahl
- Untertitel
- setzen von Parameter pro Titel,
- implementierung eines Authoring Plugins.
- bessere NTSC / Hybrid unterstützung

Bugs die mir gemeldet werden werden soweit möglich aber weiterhin gefixt. Da ich aber seit längerem kein feedback bekomme muss ich davon ausgehen das entweder alles einwandfrei funktioniert oder niemand die 0.2 einsetzt.
Als offenen Bug habe ich hier nur das Problem das die DVD nicht auf standalone und Windows Player abspielbar ist wenn die Submenues deaktiviert werden.

Gruss
Dimitri

10

Friday, April 8th 2005, 9:57am

Quoted

Original von Tobi
Also ich bekomme mit vdrsync 0.1.3 und vdrconvert 0.1 garnichts mehr konvertiert.


Ich auch nicht. Ich bekomme bei geschnittenen und ungeschnittenen Aufnahmen:

Quoted


08-04-2005 09:36:23 : Session /usr/lib/vdrconvert/bin/vdr2dvd.sh begin
09:36:24 Start conversion for List :
1) /var/lib/video.00/Last_Samurai_(The_Last_Samurai)/2005-03-28.02.20.99.99.rec

Fr Apr 8 09:36:24 CEST 2005 : Begin conversion /var/lib/video.00/Last_Samurai_(The_Last_Samurai)/2005-03-28.02.20.99.99.rec
EPG Data :
Last Samurai (The Last Samurai) Actionfilm 1876: Der gebrochene US-Kriegsheld Nathan Algren (Tom Cruise) soll der japanischen Armee helfen, den Samurai-Rebellen Katsumoto (Ken Watanabe) zu unterwerfen. Nach einer fatalen Niederlage gerät Algren in die Gewalt seiner Feinde. Fasziniert von deren traditionellem Ehrenkodex findet er seine Selbstachtung wieder und schließt sich den Samurai an. - Wuchtige Schwertschlachten und aufwändige Action: Tom Cruise in einem Abenteuerepos der großen Gefühle. USA 2003. 148 Min. Von Edward Zwick, mit Tom Cruise, Timothy Spall, Ken Watanabe.
09:36:24: Start demux with vdrsync
09:49:12: Create mainmenu
DVDAuthor::spumux, version 0.6.10.
Build options: gnugetopt magick iconv freetype fribidi
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: Locale=de_DE
INFO: Converting filenames to ISO-8859-1
INFO: Picture had 2 colors
INFO: Constructing blank img
INFO: Constructing blank sel
INFO: Autodetect 0 = 60x65-88x93
INFO: Pickbuttongroups, success with 1 groups, useimg=1
INFO: Found EOF in .sub file.
INFO: Max_sub_size=88
WARN: Read 0, expected 4
INFO: 1 subtitles added, 0 subtitles skipped, stream: 32, offset: 0.18

Statistics:
- Processed 0 subtitles.
- The longest display line had -1 characters.
- The maximum number of displayed lines was 0.
- The normal display height of the font arial.ttf was 0.
- The bottom display height of the font arial.ttf was 0.
- The biggest subtitle box had 88 bytes.
ERROR : Keine Audiospuren


vdrsync habe ich von http://ddimi.homeip.net/cgi-bin/cvsweb.c…pe=text%2Fplain und dann chmod 755.
Grüße, Christian

Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

dimitri

Professional

Posts: 1,137

Location: Frankfurt a.M

Occupation: System Engineer

  • Send private message

11

Friday, April 8th 2005, 11:02am

Hi,

Quoted

Original von Tobi

Also ich bekomme mit vdrsync 0.1.3 und vdrconvert 0.1 garnichts mehr konvertiert.


vdrsync3 wird erst ab Revision 1.44 in vdrconvert 0.2 unterstützt.

Gruss
Dimitri

12

Sunday, April 10th 2005, 3:14pm

@dimitri: Ich werd mich dann wohl mal daran machen vdrconvert 0.2cvs in ein Debian-Paket zu packen. Das sollte die Menge der Test-User um einiges erhöhen. Kann aber noch 1-2 Wochen dauern, da noch ein paar andere Dinge anstehen.

Gruß,

Tobias
www.e-tobi.net (Debian-Repositories - Paket-Übersicht: etch; lenny; sid vdrdevel)

13

Saturday, May 14th 2005, 10:35pm

Quoted

Original von Tobi
@dimitri: Ich werd mich dann wohl mal daran machen vdrconvert 0.2cvs in ein Debian-Paket zu packen. Das sollte die Menge der Test-User um einiges erhöhen. Kann aber noch 1-2 Wochen dauern, da noch ein paar andere Dinge anstehen.


Hallo Tobi,
bist du hier schon weitergekommen?
Grüße, Christian

Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

14

Thursday, January 12th 2006, 8:44pm

Hallo,

ist das eigendlich noch aktuell ?

Ich beobachte nach dem letzten Update (e-toby/expermiental) auch diese Meldungen.
Da ich aber "nur" Stereo Ton höre und mit dem ganzen Sound Schnick-Schnack
nix am Hut habe, ist es für mich nur sekundär, solange nicht der Stereo-Ton
betroffen ist.

Auf jeden Fall gibt es die Meldungen heute immer noch:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
WARN: Discontinuity in audio channel 0; please remultiplex input.
WARN: Previous sector: 5282.204 - 5282.204
WARN: Current sector: 5282.236 - 5282.268
WARN: Unknown AC3 sample rate: 3
WARN: Audio pts for channel 0 moves backwards; please remultiplex input.
WARN: Previous sector: 5282.780 - 5282.844
WARN: Current sector: 5282.812 - 5282.844
STAT: VOBU 11008 at 2672MB, 1 PGCS^MWARN: Audio pts for channel 0 moves backwards; please remultiplex input.
WARN: Previous sector: 5285.532 - 5285.628
WARN: Current sector: 5285.596 - 5285.628
WARN: Discontinuity in audio channel 0; please remultiplex input.
WARN: Previous sector: 5285.820 - 5285.852
WARN: Current sector: 5285.884 - 5285.916
WARN: Unknown AC3 sample rate: 3
WARN: Audio pts for channel 0 moves backwards; please remultiplex input.
WARN: Previous sector: 5285.948 - 5286.012


Es ist insofern lästig, da die Meldungen ja dsa logfile geradezu zumüllen.

Gruss,
Bernd
:vdr1 $myVDR

15

Friday, January 20th 2006, 6:34am

Hallo, seid gegrüßt,
ich bin neu im Forum und ziemlich unerfahren was die Interna des VDR betrifft. Seit der Umstellung auf ct_VDR 4.5 habe ich aber das gleiche Problem wie berni123. Dachte schon, ich wäre der einzige. Mich stört es allerdings, dass der AC-3 Ton auf der DVD nicht zu gebrauchen ist.
Gibt es da wirklich keine Lösung oder wird diesem Thread keine Beachtung mehr geschenkt. Die tcmplex-panteltje habe ich übrigens aktualisiert. Lag aber nicht daran. Bitte helft!
Danke
Gruß Norbert :(

rell

Professional

Posts: 790

Location: Bayern

  • Send private message

16

Friday, January 20th 2006, 11:00pm

Hallo zusammen,

auch bei mir tritt das Problem auf.
Nutze vdrconvert0.1 unter linvdr0.7.
Lösungen?

Gruß,
Andreas

Meine VDRs

(Server) --- HW: x86, 2x Sundtek SkyTV Ultimate IV --- SW: Debian Jessie, VDR 2.2.0 mit streamdev, dummydevice, live, vdrmanager,... ---
(Client1) --- HW: Cubieboard 2 -> HDMI:1080i/p@50 --- SW: Debian Jessie, VDR for Sunxi Devices, softhddevice via libvdpau-sunxi ---
(Clients - WIP) --- HW: linux-sunxi.org --- SW: Debian Jessie, VDR for Sunxi Devices, softhddevice via libvdpau-sunxi ---
(Clients - WIP) --- HW: RPi2, WetekPlay

17

Sunday, January 22nd 2006, 12:03pm

Ich fürchte, da wir keine Ahnung haben, vovon wir reden, können wir nicht beutreilen, ob es eine Lösung gibt oder nicht. Andersrum: wenn wir wüssen, worum es geht, wären wir in der Lage eine Lösung zu programmieren, bzw. wüssten, was wir machen müssten, um das Problem abzustellen.

Also bleibt für uns Laien nur: warten auf updates und hoffen ob es sich löst.

Gruss,
Bernd
:vdr1 $myVDR

rell

Professional

Posts: 790

Location: Bayern

  • Send private message

18

Sunday, January 22nd 2006, 2:14pm

Hallo,
Ich denke, dass Problem liegt am Sender -> ARD. Da gabs in letzter Zeit auch irgendeinen Thread über hohe Bitrate etc... Bin aber noch nicht dazugekommen, mich einzulesen.
Aufnahmen von anderen Sendern kann ich erfolgreich umwandeln. Die 2 Testaufnahmen von der ARD funktionierten nicht. Aber da bedarfs noch ein paar Tests...
Mal sehen, vielleicht findet sich ja das Problem.

Gruß,
Andreas

Meine VDRs

(Server) --- HW: x86, 2x Sundtek SkyTV Ultimate IV --- SW: Debian Jessie, VDR 2.2.0 mit streamdev, dummydevice, live, vdrmanager,... ---
(Client1) --- HW: Cubieboard 2 -> HDMI:1080i/p@50 --- SW: Debian Jessie, VDR for Sunxi Devices, softhddevice via libvdpau-sunxi ---
(Clients - WIP) --- HW: linux-sunxi.org --- SW: Debian Jessie, VDR for Sunxi Devices, softhddevice via libvdpau-sunxi ---
(Clients - WIP) --- HW: RPi2, WetekPlay

19

Monday, January 23rd 2006, 5:53am

AC3-Ton defekt beim Bearbeiten mit vdrconvert

Das kann ich nicht bestätigen! - Habe am Wochenende 3 Filme in 5:1 bei PREMIERE 1 aufgenommen (3 Tonspuren - AC3; deutsch; englisch). Bei allen werden problemlos DVD-iso-files erzeugt, wobei wieder jeweils die AC3-Tonspur defekt ist (Tonschnipsel, die zu schnell laufen, dann wieder Aussetzer-nicht zu gebrauchen) Die beiden Stereo-Spuren sind völlig ok.
Ich fürchte, Bernd hat recht, wir Laien müssen uns hier in Geduld üben! Vielleicht hört ja irgendwann mal einer von den Fachleuten unseren Hilferuf. Möglicherweise ist dieser Thread aber auch schon abgeschlossen, so dass ihm keiner von den genannten Personen mehr Beachtung schenkt. Vielleicht sollte man einen neuen Thread aufmachen!?
Gruß Norbert
MSI KT6 Delta; AMD AthlonXP 2500+; 512 MB RAM; WesternDigital WDC 80GB + Maxtor 6Y080L0; Sony DVD-RW DRU-710A; Hauppauge WinTV-Nexus-c; Alpahcrypt 2.03
Kernel 2.6.12-ct-1; VDR 1.3.37 (ct'-VDR 4.5)

20

Monday, January 23rd 2006, 1:07pm

Noch eine Ergänzung: Habe ein bisschen experimentiert. Ergebnis: Die Aufnahmen des VDR sind völlig in Ordnung. Ich habe mir die Dateien 0001.vdr, 002.vdr usw. mal auf einen Windows-Rechner gezogen und mir ProjectX und IfoEdit völlig intakte DVD-Video-Dateien erzeugt (auch die Tonspuren sind alle ok). Wäre erst mal ein workaround, ist aber bestimmt nicht im Sinne des Erfinders.
Während der DVD-Erstellung des VDR habe ich mir dann mal die von vdrsync erzeugten Audio-und Video-Dateien aus /var/lib/video.00/film/tmp/vdr2dvd/VDRSYNC.XXX auf den Windows-Rechner kopiert und daraus mit IfoEdit DVD-Video-Daten erzeugt. Hier tritt der Fehler mit der AC3-Tonspur wieder auf.
Weiter weiss ich nun auch nicht. Das Problem scheint wohl bei vdrsync zu liegen. Was da allerdings genau passiert und welche Programme daran beteiligt sind kann ich als Laie nicht sagen (vielleicht diese tcmplex-panteltje?).
Gruß Norbert
MSI KT6 Delta; AMD AthlonXP 2500+; 512 MB RAM; WesternDigital WDC 80GB + Maxtor 6Y080L0; Sony DVD-RW DRU-710A; Hauppauge WinTV-Nexus-c; Alpahcrypt 2.03
Kernel 2.6.12-ct-1; VDR 1.3.37 (ct'-VDR 4.5)

Immortal Romance Spielautomat