Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

LordJaxom

Meister

  • »LordJaxom« ist der Autor dieses Themas

Beiträge: 2 115

Wohnort: Kind der Kirmes am Kanal

Beruf: System- und Anwendungsprogrammierer

  • Nachricht senden

1

Dienstag, 17. August 2004, 18:16

Wir machen Fortschritte... streamdev-0.3.3-pre3

So...

http://www.magoa.net/linux/contrib/vdr-s…-0.3.3-pre3.tgz

Was ist neu?

- Im Setup kann man nun die einzelnen Server an eine IP (also eine Netzwerkkarte) binden. Standard ist 0.0.0.0 (also alle Interfaces).
- Wenn Ihr den Patch vdr-pluginactivity.diff, der dem Plugin beiliegt auf den VDR des Servers anwendet, wird ein laufender Stream beim Herunterfahren behandelt wie eine laufende Aufnahme. Ohne den Patch ist alles wie gehabt.
- VDR-to-VDR: Section Filter Streaming (normalerweise abgeschaltet) ist jetzt möglich, aber noch nicht wirklich ausgereift. Damit werden die EPG Daten und die Transponderupdates auch auf den Client überspielt. DVB-Subtitles sind damit auch auf dem Client möglich. Wenn Ihr das ausprobieren wollt, schaltet bitte vorher EPG synchronisieren aus. Ich empfehle ausserdem dringend, den Patch vdr-incompletesections.diff auf den Client-VDR anzuwenden, da sonst das Log mit "incomplete section received" Meldungen gefloodet wird.

Was ist anders?

- VDR-to-VDR streamed jetzt wieder über TCP (UDP war'n netter Versuch).
- Die Server sind jetzt defaultmäßig enabled, damit nicht mehr so oft Beschwerden diesbezüglich kommen :-)


Ich hoffe, die ganzen Compilerfehler hab ich jetzt auch alle erwischt.

2

Dienstag, 17. August 2004, 22:05

RE: Wir machen Fortschritte... streamdev-0.3.3-pre3

Hallo,

habe es mal kurz angetestet und es läuft auf den ersten Blick alles prima.

Vielen Dank, vor allen dingen auch für den vdr-pluginactivity Patch !! :]

Gruß,

Frank
Server : MLD 5.1 Headless, Cine S2, DuoFlex S2, 128 SSD, 2 * 4TB SATA
Client1 : Raspberry PI3 : MLD 5.1
Client2 : Raspberry PI3 : MLD 5.1

3

Mittwoch, 18. August 2004, 10:57

RE: Wir machen Fortschritte... streamdev-0.3.3-pre3

Hallo,
bei mir funktioniert (HTTP-Streaming) deutlich besser. Die Startprobleme scheinen wirkllich beseitigt zu sein.

Eine Frage bezüglich des Inactivity-Patches:

Für welche Version ist der Patch. Bei mir unter der Version 1.3.12 läuft er nicht. Er bringt Fehler beim Patchen (include/vdr/plugin.h nicht gefunden) und wenn ich Ihn trotzdem anwende, macht der VDR permanent Restarts.

Vielen Dank schon mal für den Patch:
Genau auf so was habe ich allerdings schon lange gewartet, bisher habe ich mir mit vdrshutdownhook geholfen.


Gruß
Ubuntu 9.10 i386 + s2-liplianin + VDR 1.7.9 + XBMC-PVR-Testing

4

Mittwoch, 18. August 2004, 11:13

RE: Wir machen Fortschritte... streamdev-0.3.3-pre3

Hallo LordJaxom,

die Kompile-Probleme sind jetzt beseitigt. Mit der vanilla vdr-1.2.6 läuft das Plugin auch. Ich habe jedoch normalerweise den VDR mit elchi4d Patch sowie mit dem AC3 Patch am laufen. Hier bekomme ich beim VDR-Start folgende Fehlermeldung und VDR startet nicht:
Aug 18 11:06:17 vdr vdr[3785]: ERROR: ./PLUGINS/lib/libvdr-streamdev-client.so.1.2.6: undefined symbol: __16cMenuWhatsOnItemPC10cEventInfo

Gibts hierfür auch eine Lösung?

Ansonsten großes Lob. VDR - VDR Lösung ist jetzt optimal.

Gruß
mac66
VDR1: Activy 350 mit gen2VDR 1.1
VDR2: Activy 300 mit gen2VDR 1.1
VDR-Server: 1,5 GHz Celeron Mobile, 2 GB Ram, 2x 200 GB HD, 1x Siemens DVB-S 1.3, 2x TT-Nova, SuSE9.3

5

Mittwoch, 18. August 2004, 11:39

was ist den ca. die minimal benötigte bandbreite fürs streaming?

habe mein hausnetzwerk mit powerline adapter aufgebaut und das liegt die bandbreite ca. zw. 3 - 13 mbit... reicht das aus?
EPIA M10000, Technotrend 1.5, 1024Ram, 160Gb

VDR SLAX

BlackKing

Meister

Beiträge: 2 257

Wohnort: Nähe Stuttgart

Beruf: IT-Systemelektroniker

  • Nachricht senden

6

Mittwoch, 18. August 2004, 12:09

je nachdem wie groß die bandbreite des Videosignals ist. Aber ich denke des dürfte gehen. Du kannst ja auch noch den chache ein bissele erhöhen. Und im Notfall kannste ja das signal kleiner machen (128Kbyte/s haben schon leute gemacht dies fürs dsl verkleinert haben)
Aktuelle Systeme:
VDR-Server: MSI KT6A Ultra FISR ; Athlon XP 2200+ ; GrKa Geforce 2 MX; 256MB DDR-SDRam Plugins: streamdev-server, remote
2 x DVB-Budget Karte, Gentoo, Kernel 2.6.8 usw....

7

Mittwoch, 18. August 2004, 12:39

wie kann ich das signal verkleinern? was meinst du damit.
wenn ich von vdr samba auf win rechner daten kopieren dann mit einer geschw. von 190 - 260 k / sek.
EPIA M10000, Technotrend 1.5, 1024Ram, 160Gb

VDR SLAX

8

Mittwoch, 18. August 2004, 14:55

... also zum Streamen braucht man um die 800kB/s, je nachdem mit welcher Bandbreite gerade gesendet wird. Deswegen reicht WLAN 11b gerade nicht zum Streamen.

Den Stream zu verkleinern wäre prima, jedoch habe ich dafür noch keine praktikable Lösung gesehen. Per ffmpeg könnte man z.B. die Auflösung herunter rechnen, oder per requant die Datenrate.

Ich fände es toll, wenn das im Plugin als Option gleich mit drin wäre, habe aber keine Ahnung wie aufwändig das ist. Gerade für requant muß wohl erst der Videostorm vom Audiostrom getrennt werden und danach wieder gemuxt werden. Das braucht natürlich CPU Power und bedeutet wohl auch ein Delay in der Übertragung...


Gruß, Ollo

9

Mittwoch, 18. August 2004, 15:29

gibts da auch ne nicht so rechenintensive lösung für epia boards ?
ich höre raus, dass es eher nicht geht...
EPIA M10000, Technotrend 1.5, 1024Ram, 160Gb

VDR SLAX

10

Mittwoch, 18. August 2004, 15:31

Auf der ML hat jmd via VLC gestreamt und so den Strom erstmal runtergerechnet.

Lars

11

Mittwoch, 18. August 2004, 16:21

Zitat

Original von BlackKing
je nachdem wie groß die bandbreite des Videosignals ist. Aber ich denke des dürfte gehen. Du kannst ja auch noch den chache ein bissele erhöhen. Und im Notfall kannste ja das signal kleiner machen (128Kbyte/s haben schon leute gemacht dies fürs dsl verkleinert haben)


128kbit/s, nicht Kbyte :)

Aber für das Epia könnte man doch mal versuchen, das Bild so zu lassen und nur den Ton mit mp3 mit ffmpeg zu codieren. kA ob der das schafft, oder das reicht...

12

Mittwoch, 18. August 2004, 16:42

welche software soll ich dazu verwenden?
mir fehlt momentan noch der rote faden um damit anzufangen ;)
EPIA M10000, Technotrend 1.5, 1024Ram, 160Gb

VDR SLAX

13

Mittwoch, 18. August 2004, 20:23

ffserver und ffmpeg.

Eine Anleitung findest du hier:

http://www.vdrportal.de/board/thread.php?threadid=7855&sid=

LordJaxom

Meister

  • »LordJaxom« ist der Autor dieses Themas

Beiträge: 2 115

Wohnort: Kind der Kirmes am Kanal

Beruf: System- und Anwendungsprogrammierer

  • Nachricht senden

14

Mittwoch, 18. August 2004, 21:06

RE: Wir machen Fortschritte... streamdev-0.3.3-pre3

Zitat

Original von mac66
die Kompile-Probleme sind jetzt beseitigt. Mit der vanilla vdr-1.2.6 läuft das Plugin auch. Ich habe jedoch normalerweise den VDR mit elchi4d Patch sowie mit dem AC3 Patch am laufen. Hier bekomme ich beim VDR-Start folgende Fehlermeldung und VDR startet nicht:
Aug 18 11:06:17 vdr vdr[3785]: ERROR: ./PLUGINS/lib/libvdr-streamdev-client.so.1.2.6: undefined symbol: __16cMenuWhatsOnItemPC10cEventInfo


Versuch mal folgenden Patch am Plugin, das ist in der nächsten Version drin falls das funzt...
»LordJaxom« hat folgende Datei angehängt:

LordJaxom

Meister

  • »LordJaxom« ist der Autor dieses Themas

Beiträge: 2 115

Wohnort: Kind der Kirmes am Kanal

Beruf: System- und Anwendungsprogrammierer

  • Nachricht senden

15

Mittwoch, 18. August 2004, 21:09

RE: Wir machen Fortschritte... streamdev-0.3.3-pre3

Zitat

Original von diskmemo
Für welche Version ist der Patch. Bei mir unter der Version 1.3.12 läuft er nicht. Er bringt Fehler beim Patchen (include/vdr/plugin.h nicht gefunden) und wenn ich Ihn trotzdem anwende, macht der VDR permanent Restarts.


So sorry, ich hab in dem Patch ne Datei zuviel gepatched.
Übrigens: Nach Anwendung des Patches UNBEDINGT VDR und Plugins neu compilieren!!!

Hier der korrekte, in der nächsten Version auch drin.
»LordJaxom« hat folgende Datei angehängt:

LordJaxom

Meister

  • »LordJaxom« ist der Autor dieses Themas

Beiträge: 2 115

Wohnort: Kind der Kirmes am Kanal

Beruf: System- und Anwendungsprogrammierer

  • Nachricht senden

16

Mittwoch, 18. August 2004, 21:13

Ahh, und sorry an alle, die gerne nen requant in den Stream eingebaut haben möchten... Sorry das ist zur Zeit nicht drin, da das de- und remuxen intern ersma n bissl mehr Arbeit macht als erforderlich :] und ausserdem fürchte ich ganz stark dass anschliessend die A/V-Synchronisation hin ist :)

17

Donnerstag, 19. August 2004, 08:11

RE: Wir machen Fortschritte... streamdev-0.3.3-pre3

Zitat

Original von LordJaxom

Zitat

Original von mac66
die Kompile-Probleme sind jetzt beseitigt. Mit der vanilla vdr-1.2.6 läuft das Plugin auch. Ich habe jedoch normalerweise den VDR mit elchi4d Patch sowie mit dem AC3 Patch am laufen. Hier bekomme ich beim VDR-Start folgende Fehlermeldung und VDR startet nicht:
Aug 18 11:06:17 vdr vdr[3785]: ERROR: ./PLUGINS/lib/libvdr-streamdev-client.so.1.2.6: undefined symbol: __16cMenuWhatsOnItemPC10cEventInfo


Versuch mal folgenden Patch am Plugin, das ist in der nächsten Version drin falls das funzt...


Mit dem Patch funktioniert das Plugin. Ich musste jedoch den Patch per Hand einfügen. patch -p1 hat mir einen Fehler ausgegeben.

Ein Punkt wäre noch die deutsche Übersetzung von Remote Schedule.
Die anderen Menuepunkte haben ja bereits die Übersetzung.

Noch als letzter Punkt:
Wenn man einen Timer mit Remote Schedule auf dem Server setzt, wird der Programmtitel nicht mit übernommen. Es erscheint dann bei den Recordings nur der Kanalname.

Gruß
mac66
VDR1: Activy 350 mit gen2VDR 1.1
VDR2: Activy 300 mit gen2VDR 1.1
VDR-Server: 1,5 GHz Celeron Mobile, 2 GB Ram, 2x 200 GB HD, 1x Siemens DVB-S 1.3, 2x TT-Nova, SuSE9.3

18

Donnerstag, 19. August 2004, 15:38

Zitat

Original von ollo
Ich fände es toll, wenn das im Plugin als Option gleich mit drin wäre, habe aber keine Ahnung wie aufwändig das ist. Gerade für requant muß wohl erst der Videostorm vom Audiostrom getrennt werden und danach wieder gemuxt werden. Das braucht natürlich CPU Power und bedeutet wohl auch ein Delay in der Übertragung...


vamps macht das on-the-fly, indem es kleine Stückchen an requant weiterreicht. Dadurch bleiben zum einen Audio und Video synchron, zum anderen kann man die MPEG-Datei per Pipe weiterreichen.
LinVDR 0.7 (per update)

19

Freitag, 20. August 2004, 15:52

Hi, hab´s jetzt auch mal getestet.

Leider gehöre ich zu denen, die es bisher nicht geschafft haben, das Bild per HTTP-Streaming völlig fehlerfrei auf einen Windows-Rechner zu streamen (gestestet mit VLC und MPlayer, jeweils PES). Immer wieder sind bunte Blöcke usw. zu sehen. Mit VDR 1.3.12 und streamdev-0.3.3-pre3 unter SuSE 9.1 läuft es bei mir auf jeden Fall besser bei mir als mit dem 'alten' VDR 1.2.6 mit streamdev 3.0 unter SuSE 9.0. VDR-Maschine ist ein Duron 1300 mit Asrock K7S8XE+ (SiS-Chipsatz) und 256 MByte RAM, Client ein Athlon 2700 mit Epox-8K9AI (VIA KT400) und 512 MByte RAM.

Heute früh hatte ich Gelegenheit, dass mal auf völlig anderen Rechnern unter SuSE 9.1 mit einer Nova-s und softdevice einzurichten, nämlich 2 Pentium-4-Systemen mit jeweils 512 MByte RAM - und auch in diesem Netzwerk gibt es diese Störungen.

Mir kommt es so vor, als würden die Störungen immer bei schnellen Bewegungen, Schnitten, komplexen Szenen, also vielleicht höherer Bitrate, auftreten. Habe mal einfach im Server-Unterordner im File connection.h die Buffer-Größen verändert (kann auch der völlig falsche Ort gewesen sein :)), aber das hat alles eher verschlimmbessert.

P.S.: Beide Systeme sind 100 MBit-Ethernet-LANs, an der Bandbreite kann es daher IMHO nicht liegen.

Ein weiterer Punkt ist, dass das Pausieren bei einer Softdevice-VDR-Installation anscheinend nicht funktioniert - ich kann auf jeden Fall bei diesem Ein-Karten-System nicht auf einen Kanal schalten, der auf einem anderen Transponder liegt.

Mit freundlichen Grüßen

Jörg
yaVDR 0.5.0a
Intel Core2Duo E6750, Asus P5Q,
Gainward GT 240 512MB GDDR5, Hauppauge HVR-4000 & Nova-S2-HD, 4 GByte RAM
an Panasonic TX-P42GW10 und Onkyo TX-SR508

20

Freitag, 20. August 2004, 16:48

requant

Hallo Heißduscher & LordJaxom,

@Heißduscher,
also vamps ist so leider nicht zu gebrauchen um mit streamdev zusammmenzuarbeiten, oder wie soll das genau funktionieren? Jedoch scheint vamps als Grundlage für eine eventuelle Implementierung in das streamdev Pluging durchaus geeigent!

@LordJaxom, wie sieht's aus? Vielleicht doch ein Feature für 0.3.5?!?

Danke & Gruß, Ollo

Immortal Romance Spielautomat