You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

uwe67

Intermediate

Posts: 190

Occupation: Systemsoftwareentwickler

  • Send private message

21

Tuesday, February 22nd 2005, 8:42pm

Quoted

Original von Dieter
Hallo,
den "i2c_readbytes: i2c read error (addr 0a, err == -121)" habe ich auch. Allerdings mit 2.6.10.

bei mir sieht es so aus:

Source code

1
2
3
4
5
6
7
Feb 21 18:50:19 localhost kernel: ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 16 (level, low) -> IRQ 16
Feb 21 18:50:19 localhost kernel: /usr/local/src/dvb-kernel/build-2.6/skystar2.c: FlexCopII(rev.130) chip found  
Feb 21 18:50:19 localhost kernel: /usr/local/src/dvb-kernel/build-2.6/skystar2.c: the chip has 6 hardware filters 
Feb 21 18:50:19 localhost kernel: driver_initialize MAC address = 00:d0:d7:02:99:b1:00:00  
Feb 21 18:50:19 localhost kernel: DVB: registering new adapter (SkyStar2).  
Feb 21 18:50:19 localhost kernel: i2c_readbytes: i2c read error (addr 0a, err == -121)  
Feb 21 18:50:19 localhost kernel: DVB: registering frontend 1 (ST STV0299 DVB-S)...  


der "i2c_readbytes: i2c read error (addr 0a, err == -121)" kommt wenn der falsche treiber geladen wurde ! hatte ich auch. den treiber mt312 also nicht mehr mit modprobe starten.

die skystar2 braucht für vdr nur den dvb-treiber "skystar2" und das "stv0299"-frontend.

gruß uwe
Multiroom-System:
Server: Suse 13.1, 12TB HD, Cine S2 (4Tuner), vdr2.1.5, streamdev-server, xineliboutput
FullHD-Client1: Zotac ZBOX HD-ND22, Suse 12.2, vdr2.1.5, xineliboutput, IR-Empfänger/Sender/Einschalter yaUsbIR V3
FullHD-Client2: Zotac ZBOX HD-ND22, Suse 12.2, vdr2.1.5, streamdev-client, softhddevice, IR-Empfänger/Sender/Einschalter yaUsbIR V3
AudioClient Bad: alter PocketPC über WLAN, Touchbedienung
TestClient: Asus M3N78-VM, Suse 13.1, vdr2.1.5, IR-Empfänger/Sender/Einschalter yaUsbIR V3.5, softhddevice

22

Wednesday, February 23rd 2005, 8:52am

Quoted

Original von uwe67
[...]

der "i2c_readbytes: i2c read error (addr 0a, err == -121)" kommt wenn der falsche treiber geladen wurde ! hatte ich auch. den treiber mt312 also nicht mehr mit modprobe starten.

die skystar2 braucht für vdr nur den dvb-treiber "skystar2" und das "stv0299"-frontend.

gruß uwe
Das ist ja lieb, dass du helfen möchtest, aber manchmal frage ich mich, ob manche Leute hier auch mal den Thread lesen, bevor sie antworten. Deine Erklärung ist zwar prinzipiell richtig, aber:

1. Hatte ich das schon vorher geschrieben.
2. Ist das keine Erklärung für das Phänomen der "einschlafenden Karte". Es ist nämlich völlig egal, wieviele Extra-Frontend-Treiber man dazulädt, solange nur der richtige darunter ist.
3. Ist der Satz "die skystar2 braucht für vdr nur den dvb-treiber "skystar2" und das "stv0299"-frontend" falsch. Die Skystar2 rev2.6 braucht nur die genannten Treiber, hat man aber eine rev2.3-Karte, so braucht man sehr wohl das mt312. Ganz zu schweigen von der Airstar (mt352).
4. Kann man mit den aktuellen CVS (oder Kernel 2.6) Treibern gar nicht verhindern, dass der skystar2-Treiber alle zu ihm gehörigen Frontends automatisch nachlädt. Auch das hatte ich schon erklärt.
Godzilla [Low Budget Record-Only]: AMD K6/2(400), Gigabyte GA-5AX, 192MB, ATI RagePro (Mach64GT) mit TV-Out, Technisat Skystar2 rev 2.6b, IBM DTLA 40GB, Ensoniq ESS-Solo1 (es1935), Pioneer DVR 108

This post has been edited 1 times, last edit by "metahawk" (Feb 23rd 2005, 8:55am)


skiller2k1

Moderator

  • "skiller2k1" started this thread

Posts: 2,361

Location: Karlsruhe

Occupation: Freiberuflicher Webdesigner

  • Send private message

23

Wednesday, February 23rd 2005, 4:00pm

Aaaaaaalso. Habe aufgrund Tipps von arghgra im Chat mal den EPG Scan abgeschaltet. Dieses hatte ich mit dem 1.3.21 noch nicht probiert. Der VDR läuft nun seit gestern abend 20:45 Uhr und nimmt auch noch auf. :D Von daher sieht es schonmal gut aus.

Muss jetzt erstmal weiter testen, ob das auf die Dauer auch funktioniert, gebe dann Rückmeldung.

Erstmal danke an alle, die mir Tipps gegeben haben!

Gruss

Michi
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Intermediate

Posts: 246

Location: gebürtig ganz im Norden, Wohnort in Spanien

Occupation: Informatiker

  • Send private message

24

Monday, February 28th 2005, 11:54am

Quoted

Original von skiller2k1
... mal den EPG Scan abgeschaltet. ...


Obwohl mich das Problem mit der pennenden Skystar nur randständig interessiert, weil ich außer ca. 47 sekunden am beginn der Aufnahme keine Probleme habe, hatte ich mich erwartungsfroh daran gemacht den "femon Tipp" von uwe67 oder auch SledgeHammer in eine Form zu bringen, die noch ein paar sinnvolle Infos auf den Schirm (>tty8<) zaubert...

...UND DANN - funktioniert es garnicht :gemein

...sind denn einige einer Problemlösung nahe?

Das Ding wird nämlich hier und hier ebenfalls abgehandelt...vielleicht bündeln wir mal die Kräfte

Gruß
Rudibert........wenn doch nur alles so zuverlässig liefe, wie der VDR...
Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)

skiller2k1

Moderator

  • "skiller2k1" started this thread

Posts: 2,361

Location: Karlsruhe

Occupation: Freiberuflicher Webdesigner

  • Send private message

25

Wednesday, March 2nd 2005, 12:23pm

Aaaaaalso, nach 7 Tagen Dauertest kann ich nun sagen, das das Abschalten des EPG-Scans es gebracht hat. Die Karte läuft durch und nimmt immer auf.

Nun geht halt die endlose Diskussion und Rätselerei weiter, warum Budgetkarten ein Problem mit dem EPGScan haben.
Aber ich bin guter Dinge, das wir das noch rauskriegen werden ;)

Liebe Grüsse

Michi
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Intermediate

Posts: 246

Location: gebürtig ganz im Norden, Wohnort in Spanien

Occupation: Informatiker

  • Send private message

26

Wednesday, March 2nd 2005, 12:28pm

@michi

da sind wir 2 ;)
Rudibert........wenn doch nur alles so zuverlässig liefe, wie der VDR...
Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)

skiller2k1

Moderator

  • "skiller2k1" started this thread

Posts: 2,361

Location: Karlsruhe

Occupation: Freiberuflicher Webdesigner

  • Send private message

27

Wednesday, March 2nd 2005, 2:39pm

Quoted

Original von rudibert
da sind wir 2 ;)

Hehe. Gut zu hören.
Dieser Thread von Metahawk scheint auch interessant zu sein: Hier

Ist halt nur die Frage, welche der Methoden am schnellsten umzusetzen währe.
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Intermediate

Posts: 246

Location: gebürtig ganz im Norden, Wohnort in Spanien

Occupation: Informatiker

  • Send private message

28

Wednesday, March 2nd 2005, 5:05pm

..tja...skiller die Seeelenverwandtschaft ist ja schon am Avatar ablesbar:rofl :lol1 :lachen3
Rudibert........wenn doch nur alles so zuverlässig liefe, wie der VDR...
Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)

This post has been edited 1 times, last edit by "rudibert" (Mar 2nd 2005, 6:10pm)


skiller2k1

Moderator

  • "skiller2k1" started this thread

Posts: 2,361

Location: Karlsruhe

Occupation: Freiberuflicher Webdesigner

  • Send private message

29

Wednesday, March 2nd 2005, 6:09pm

Quoted

Original von rudibert
..tja...die Seeelenverwandtschaft ist ja schon am Avatar ablesbar:rofl :lol1 :lachen3

Meinst du jetzt damit mich oder Metahawk? ;)

Also ich habs nun getestet und siehe da. 0byte Files. Also bei mir hats nicht funktioniert. Jedenfalls nicht über die runvdr ;(

Werde den EPGScan wieder abschalten.. (Und den Rechner neustarten, grml)
Trotzdem mal danke an Metahawk. Vielleicht ergeben sich ja mit den andern beiden Methoden bessere Ergebnisse...

Gruss

Michi
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Intermediate

Posts: 246

Location: gebürtig ganz im Norden, Wohnort in Spanien

Occupation: Informatiker

  • Send private message

30

Wednesday, March 16th 2005, 11:35am

@skiller
hast du nach dem Eintragen von <enable_hw_filters> eine Meldung übers Abschalten der Filter bekommen (The card has 6 hardware filters 0 Filters used because off...)?
Rudibert........wenn doch nur alles so zuverlässig liefe, wie der VDR...
Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)

Stefan_T

Trainee

Posts: 175

Location: Salzburg

  • Send private message

31

Friday, March 18th 2005, 7:43am

Also ich habe da so eine Idee (kann sie aber mangels Skystar Karte nicht testen).

Wenn die Skystar durch EPG Scan und durch schnelles manuelles Zappen sich
verklemmt, warum dann nicht einfach beim EPG Scan zwischen den Scan Schritten
einen Sleep einbauen?

Wie gesagt, ich hab keine Skystar, bisher.
Produktiv: Kubuntu Breezy, Sempron 64 2800+ im 64bit Modus, 1GB, 2x200GB+120GB Seagate, DVB-S: Nexus 2.6 und Nova
Test: Kubuntu Breezy, AMD64 3200+ im 64bit Modus, 2GB, 250GB Seagate SATA, DVB-S: Nova Plus

rudibert

Intermediate

Posts: 246

Location: gebürtig ganz im Norden, Wohnort in Spanien

Occupation: Informatiker

  • Send private message

32

Friday, March 18th 2005, 12:58pm

Quoted

Original von Stefan_T
[...]
Wenn die Skystar durch EPG Scan und durch schnelles manuelles Zappen sich
verklemmt, warum dann nicht einfach beim EPG Scan zwischen den Scan Schritten
einen Sleep einbauen?
[...]
..das Problem ist leider das Gegenteil:
Inaktivität killt die Anspechbarkeit und die SkyStar2 startet nach einigen Sekunden neu (was dann eben die Unterbrechungen im Livebild der FF-Karte verursacht, weil alle Treiber entladen werden.) X(
Rudibert........wenn doch nur alles so zuverlässig liefe, wie der VDR...
Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)

Stefan_T

Trainee

Posts: 175

Location: Salzburg

  • Send private message

33

Friday, March 18th 2005, 1:04pm

Rudibert, da wird aber hier von sdu etwas anderes gesagt:

http://www.vdrportal.de/board/thread.php?threadid=31464

Das mit der Inaktivität.... könnte es sein daß da der Treiber entladen
wird und es dadurch entsteht?

Ich kann mich so vage daran erinnern daß die DVB Treiber vom Kernel
entladen werden damit die Karten nicht so viel Strom brauchen.
So irgendwie.
Produktiv: Kubuntu Breezy, Sempron 64 2800+ im 64bit Modus, 1GB, 2x200GB+120GB Seagate, DVB-S: Nexus 2.6 und Nova
Test: Kubuntu Breezy, AMD64 3200+ im 64bit Modus, 2GB, 250GB Seagate SATA, DVB-S: Nova Plus

This post has been edited 1 times, last edit by "Stefan_T" (Mar 18th 2005, 1:07pm)


rudibert

Intermediate

Posts: 246

Location: gebürtig ganz im Norden, Wohnort in Spanien

Occupation: Informatiker

  • Send private message

34

Friday, March 18th 2005, 1:31pm

hmm...vielleicht zappe ich nicht so heftig ;D

Mein Problem wird eher hier behandelt: Möglicher Workaround
Rudibert........wenn doch nur alles so zuverlässig liefe, wie der VDR...
Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)

Immortal Romance Spielautomat