Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

uwe67

Fortgeschrittener

Beiträge: 191

Beruf: Systemsoftwareentwickler

  • Nachricht senden

21

Dienstag, 22. Februar 2005, 20:42

Zitat

Original von Dieter
Hallo,
den "i2c_readbytes: i2c read error (addr 0a, err == -121)" habe ich auch. Allerdings mit 2.6.10.

bei mir sieht es so aus:

Quellcode

1
2
3
4
5
6
7
Feb 21 18:50:19 localhost kernel: ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 16 (level, low) -> IRQ 16
Feb 21 18:50:19 localhost kernel: /usr/local/src/dvb-kernel/build-2.6/skystar2.c: FlexCopII(rev.130) chip found  
Feb 21 18:50:19 localhost kernel: /usr/local/src/dvb-kernel/build-2.6/skystar2.c: the chip has 6 hardware filters 
Feb 21 18:50:19 localhost kernel: driver_initialize MAC address = 00:d0:d7:02:99:b1:00:00  
Feb 21 18:50:19 localhost kernel: DVB: registering new adapter (SkyStar2).  
Feb 21 18:50:19 localhost kernel: i2c_readbytes: i2c read error (addr 0a, err == -121)  
Feb 21 18:50:19 localhost kernel: DVB: registering frontend 1 (ST STV0299 DVB-S)...  


der "i2c_readbytes: i2c read error (addr 0a, err == -121)" kommt wenn der falsche treiber geladen wurde ! hatte ich auch. den treiber mt312 also nicht mehr mit modprobe starten.

die skystar2 braucht für vdr nur den dvb-treiber "skystar2" und das "stv0299"-frontend.

gruß uwe
Multiroom-System:
Server: Suse 13.1, 12TB HD, Cine S2 (4Tuner), vdr2.1.5, streamdev-server, xineliboutput
FullHD-Client1: Zotac ZBOX HD-ND22, Suse 12.2, vdr2.1.5, xineliboutput, IR-Empfänger/Sender/Einschalter yaUsbIR V3
FullHD-Client2: Zotac ZBOX HD-ND22, Suse 12.2, vdr2.1.5, streamdev-client, softhddevice, IR-Empfänger/Sender/Einschalter yaUsbIR V3
AudioClient Bad: alter PocketPC über WLAN, Touchbedienung
TestClient: Asus M3N78-VM, Suse 13.1, vdr2.1.5, IR-Empfänger/Sender/Einschalter yaUsbIR V3.5, softhddevice

22

Mittwoch, 23. Februar 2005, 08:52

Zitat

Original von uwe67
[...]

der "i2c_readbytes: i2c read error (addr 0a, err == -121)" kommt wenn der falsche treiber geladen wurde ! hatte ich auch. den treiber mt312 also nicht mehr mit modprobe starten.

die skystar2 braucht für vdr nur den dvb-treiber "skystar2" und das "stv0299"-frontend.

gruß uwe
Das ist ja lieb, dass du helfen möchtest, aber manchmal frage ich mich, ob manche Leute hier auch mal den Thread lesen, bevor sie antworten. Deine Erklärung ist zwar prinzipiell richtig, aber:

1. Hatte ich das schon vorher geschrieben.
2. Ist das keine Erklärung für das Phänomen der "einschlafenden Karte". Es ist nämlich völlig egal, wieviele Extra-Frontend-Treiber man dazulädt, solange nur der richtige darunter ist.
3. Ist der Satz "die skystar2 braucht für vdr nur den dvb-treiber "skystar2" und das "stv0299"-frontend" falsch. Die Skystar2 rev2.6 braucht nur die genannten Treiber, hat man aber eine rev2.3-Karte, so braucht man sehr wohl das mt312. Ganz zu schweigen von der Airstar (mt352).
4. Kann man mit den aktuellen CVS (oder Kernel 2.6) Treibern gar nicht verhindern, dass der skystar2-Treiber alle zu ihm gehörigen Frontends automatisch nachlädt. Auch das hatte ich schon erklärt.
Godzilla [Low Budget Record-Only]: AMD K6/2(400), Gigabyte GA-5AX, 192MB, ATI RagePro (Mach64GT) mit TV-Out, Technisat Skystar2 rev 2.6b, IBM DTLA 40GB, Ensoniq ESS-Solo1 (es1935), Pioneer DVR 108

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »metahawk« (23. Februar 2005, 08:55)


skiller2k1

Moderator

  • »skiller2k1« ist der Autor dieses Themas

Beiträge: 2 361

Wohnort: Karlsruhe

Beruf: Freiberuflicher Webdesigner

  • Nachricht senden

23

Mittwoch, 23. Februar 2005, 16:00

Aaaaaaalso. Habe aufgrund Tipps von arghgra im Chat mal den EPG Scan abgeschaltet. Dieses hatte ich mit dem 1.3.21 noch nicht probiert. Der VDR läuft nun seit gestern abend 20:45 Uhr und nimmt auch noch auf. :D Von daher sieht es schonmal gut aus.

Muss jetzt erstmal weiter testen, ob das auf die Dauer auch funktioniert, gebe dann Rückmeldung.

Erstmal danke an alle, die mir Tipps gegeben haben!

Gruss

Michi
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

24

Montag, 28. Februar 2005, 11:54

Zitat

Original von skiller2k1
... mal den EPG Scan abgeschaltet. ...


Obwohl mich das Problem mit der pennenden Skystar nur randständig interessiert, weil ich außer ca. 47 sekunden am beginn der Aufnahme keine Probleme habe, hatte ich mich erwartungsfroh daran gemacht den "femon Tipp" von uwe67 oder auch SledgeHammer in eine Form zu bringen, die noch ein paar sinnvolle Infos auf den Schirm (>tty8<) zaubert...

...UND DANN - funktioniert es garnicht :gemein

...sind denn einige einer Problemlösung nahe?

Das Ding wird nämlich hier und hier ebenfalls abgehandelt...vielleicht bündeln wir mal die Kräfte

Gruß

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

skiller2k1

Moderator

  • »skiller2k1« ist der Autor dieses Themas

Beiträge: 2 361

Wohnort: Karlsruhe

Beruf: Freiberuflicher Webdesigner

  • Nachricht senden

25

Mittwoch, 2. März 2005, 12:23

Aaaaaalso, nach 7 Tagen Dauertest kann ich nun sagen, das das Abschalten des EPG-Scans es gebracht hat. Die Karte läuft durch und nimmt immer auf.

Nun geht halt die endlose Diskussion und Rätselerei weiter, warum Budgetkarten ein Problem mit dem EPGScan haben.
Aber ich bin guter Dinge, das wir das noch rauskriegen werden ;)

Liebe Grüsse

Michi
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

26

Mittwoch, 2. März 2005, 12:28

@michi

da sind wir 2 ;)

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

skiller2k1

Moderator

  • »skiller2k1« ist der Autor dieses Themas

Beiträge: 2 361

Wohnort: Karlsruhe

Beruf: Freiberuflicher Webdesigner

  • Nachricht senden

27

Mittwoch, 2. März 2005, 14:39

Zitat

Original von rudibert
da sind wir 2 ;)

Hehe. Gut zu hören.
Dieser Thread von Metahawk scheint auch interessant zu sein: Hier

Ist halt nur die Frage, welche der Methoden am schnellsten umzusetzen währe.
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

28

Mittwoch, 2. März 2005, 17:05

..tja...skiller die Seeelenverwandtschaft ist ja schon am Avatar ablesbar:rofl :lol1 :lachen3

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »rudibert« (2. März 2005, 18:10)


skiller2k1

Moderator

  • »skiller2k1« ist der Autor dieses Themas

Beiträge: 2 361

Wohnort: Karlsruhe

Beruf: Freiberuflicher Webdesigner

  • Nachricht senden

29

Mittwoch, 2. März 2005, 18:09

Zitat

Original von rudibert
..tja...die Seeelenverwandtschaft ist ja schon am Avatar ablesbar:rofl :lol1 :lachen3

Meinst du jetzt damit mich oder Metahawk? ;)

Also ich habs nun getestet und siehe da. 0byte Files. Also bei mir hats nicht funktioniert. Jedenfalls nicht über die runvdr ;(

Werde den EPGScan wieder abschalten.. (Und den Rechner neustarten, grml)
Trotzdem mal danke an Metahawk. Vielleicht ergeben sich ja mit den andern beiden Methoden bessere Ergebnisse...

Gruss

Michi
Wohnzimmer: Techsolo TC-400 :: ASUS P5N7A-VM :: Intel Core 2 Duo E7400 :: GeForce 9300 onboard :: vdr 1.7.15 e-tobi ::
In Rente: Pimped Scenic 600 (Bilder und Aufbau) :: PIII 600Mhz :: Hauppauge Nexus-S 2.1 4MB :: vdr 1.5.2 e-tobi ::

"Wer denkt, dass Volksvertreter das Volk vertreten, der glaubt auch, dass Zitronenfalter Zitronen falten." Zeit zum ändern!

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

30

Mittwoch, 16. März 2005, 11:35

@skiller
hast du nach dem Eintragen von <enable_hw_filters> eine Meldung übers Abschalten der Filter bekommen (The card has 6 hardware filters 0 Filters used because off...)?

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

31

Freitag, 18. März 2005, 07:43

Also ich habe da so eine Idee (kann sie aber mangels Skystar Karte nicht testen).

Wenn die Skystar durch EPG Scan und durch schnelles manuelles Zappen sich
verklemmt, warum dann nicht einfach beim EPG Scan zwischen den Scan Schritten
einen Sleep einbauen?

Wie gesagt, ich hab keine Skystar, bisher.
Produktiv: Kubuntu Breezy, Sempron 64 2800+ im 64bit Modus, 1GB, 2x200GB+120GB Seagate, DVB-S: Nexus 2.6 und Nova
Test: Kubuntu Breezy, AMD64 3200+ im 64bit Modus, 2GB, 250GB Seagate SATA, DVB-S: Nova Plus

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

32

Freitag, 18. März 2005, 12:58

Zitat

Original von Stefan_T
[...]
Wenn die Skystar durch EPG Scan und durch schnelles manuelles Zappen sich
verklemmt, warum dann nicht einfach beim EPG Scan zwischen den Scan Schritten
einen Sleep einbauen?
[...]
..das Problem ist leider das Gegenteil:
Inaktivität killt die Anspechbarkeit und die SkyStar2 startet nach einigen Sekunden neu (was dann eben die Unterbrechungen im Livebild der FF-Karte verursacht, weil alle Treiber entladen werden.) X(

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

33

Freitag, 18. März 2005, 13:04

Rudibert, da wird aber hier von sdu etwas anderes gesagt:

http://www.vdrportal.de/board/thread.php?threadid=31464

Das mit der Inaktivität.... könnte es sein daß da der Treiber entladen
wird und es dadurch entsteht?

Ich kann mich so vage daran erinnern daß die DVB Treiber vom Kernel
entladen werden damit die Karten nicht so viel Strom brauchen.
So irgendwie.
Produktiv: Kubuntu Breezy, Sempron 64 2800+ im 64bit Modus, 1GB, 2x200GB+120GB Seagate, DVB-S: Nexus 2.6 und Nova
Test: Kubuntu Breezy, AMD64 3200+ im 64bit Modus, 2GB, 250GB Seagate SATA, DVB-S: Nova Plus

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Stefan_T« (18. März 2005, 13:07)


rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

34

Freitag, 18. März 2005, 13:31

hmm...vielleicht zappe ich nicht so heftig ;D

Mein Problem wird eher hier behandelt: Möglicher Workaround

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

Immortal Romance Spielautomat