Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 16. Januar 2009, 22:24

irtrans Problem

Hallo Alle

Ich habe ein Problem mit dem irtans Server. Installation und Anlernung der FB haben funktioniert (Danke an die vielen Threads dazu), aber wenn ich ein Taste auf der FB drücke, wird das Kommando zweimal an den VDR übermittelt. Macht die Bedienung reichlich umständlich. :-(

'irw' zeigt pro FB-Tastendruck nur ein Kommando an.

7000001000000000 00 2 one4all

Als Software läuft der c't vdr Version 6.2.

Hat jemand einen Tipp oder eine Idee?

Grüße,
Robert

netvista-fan

Erleuchteter

Beiträge: 3 490

Wohnort: mitten im Ruhrgebiet

Beruf: Dipl. Ing.

  • Nachricht senden

2

Samstag, 17. Januar 2009, 15:53

RE: irtrans Problem

Du nutzt vdr-sxfe oder ne FF?
bei vdr-sxfe mit lirc und nochmal vdr der standardmässig auch lirc nutzt wär das Problem normal und leicht zu beheben.

3

Samstag, 17. Januar 2009, 17:44

RE: irtrans Problem

Sowohl als auch. :-)

Ich habe vor einer Woche das Motherboard gewechselt, weil das alte mit H.264-Mpegs nicht mehr klar kam. Prompt ist zwei Tage danach die Platte abgeraucht ...

Auf dem Board ist eine ATI (Radeon™ HD 2100). Die läßt sich mit vdr-sxfe auch in Betrieb nehmen, allerdings ist die Qualität sehr schlecht (extrem viele Streifen beim Interlacing, auch diverse Optimierungen bringen nichts).

Daher habe ich im Moment noch meine alte FF-Karte (SAA7146) in Betrieb.

Das Problem tritt aber in beiden Fällen auf. Die alte Installation war eine c't vdr 6.1, da ging es ohne Probleme.

Grüße,
Robert

netvista-fan

Erleuchteter

Beiträge: 3 490

Wohnort: mitten im Ruhrgebiet

Beruf: Dipl. Ing.

  • Nachricht senden

4

Samstag, 17. Januar 2009, 18:58

RE: irtrans Problem

Also, wenn nur die FF ohne xine genutzt wird sollte es nicht sein...
da bin ich erstmal ratlos.
ggf. mal die remote.conf überprüfen oder neu anlernen.

5

Samstag, 17. Januar 2009, 19:54

RE: irtrans Problem

Hi


Ich schwanke noch zwischen beiden Methoden.

Hiermit bekomme ich eine halbwegs vernünftige Anzeige hin.

Quellcode

1
2
vdr-sxfe --daemon --video=xshm --post \
tvtime:method=Greedy2Frame,enabled=1,framerate_mode=full,chroma_filter=1,cheap_mode=1 xvdr://localhost


Loadavaerage liegt zwar bei 0.5 und durch das fehlerhafte Interlacing sieht das OSD immer noch grauslich aus.

Was würdest du denn im Fall vdr-sxfe vorschlagen? vdr-sxfe ist doch imho nur ein Frontend und die Steuerung über den irtrans sollte davon unabhängig davon sein?

Ich probiere jetzt nochmal das Neuanlernen ... ;-)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »rom770« (17. Januar 2009, 20:42)


6

Samstag, 17. Januar 2009, 20:41

RE: irtrans Problem

Ich habe jetzt /var/lib/vdr/remote.conf gelöscht und die FB neu angelernt - ohne Besserung. :-(

netvista-fan

Erleuchteter

Beiträge: 3 490

Wohnort: mitten im Ruhrgebiet

Beruf: Dipl. Ing.

  • Nachricht senden

7

Samstag, 17. Januar 2009, 22:49

RE: irtrans Problem

Die sache ist halt das der vdr an sich auf lirc hört, und ggf. vdr-sxfe auch noch auf lirc hört wenn er mit der lirc option gestartet wird.
Dann kommt halt 1x die Taste direkt am vdr an und noch 1x über das vdr-sxfe Frontend.
Abhilfe wär da halt für vdr lirc auf /dev/null zu setzen und nur über vdr-sxfe zu gehen.

Wenn zur Ausgabe nur die FF genutzt wird ohne xineplugin sollte jedoch nur 1x der Tastendruck durchkommen.

Scheint bei dir halt anders zu sein... irgendwo scheint sich der event zu verdoppeln.

8

Sonntag, 18. Januar 2009, 17:23

RE: irtrans Problem

Hi

Das vdr-sxfe wird ohne lirc-Option gestartet. Daran liegt es also nicht.

Aber es gibt eine Neuigkeit: Vor 5 Minuten habe ich mal das vdr-plugin-remote in der Version 0.3.8-3 installiert.

Damit funktioniert es ohne Probleme! :]

Scheint also ein Software-Problem des Plugins zu sein.

Grüße,
Robert

netvista-fan

Erleuchteter

Beiträge: 3 490

Wohnort: mitten im Ruhrgebiet

Beruf: Dipl. Ing.

  • Nachricht senden

9

Sonntag, 18. Januar 2009, 17:29

RE: irtrans Problem

Äh, das remote-plugin ist nur für den empfänger an der FF Karte!!!
Wenn Du den nicht nutzt sondern über lirc gehst solltest Du das plugin entfernen.
Wenn der FF Empfänger auch noch dran hängt kann natürlich ein event vom remote-plugin und einer von lirc kommen was deine 2 Tastendrücke erklären würde...

10

Sonntag, 18. Januar 2009, 18:59

RE: irtrans Problem

?

Irgendwie reden wir aneinander vorbei ...

Der VDR läuft in einem DIGN5-Gehäuse. Da ist vorn ein IR-Sensor eingebaut, der sich über /dev/USB0 abfragen lässt. Da hängt der 'irserver' dran, der die erkannten Signale über das lirc-Socket-Interface ausgibt.

Sprich: lirc ist installiert, aber der Daemon läuft nicht (sonst wäre es ja wirklich doppelt) und in vdr.remote.conf ist -l lircd definiert. Das lirc-Paket brauche ich, da sonst /dev/lircd nicht existiert.

Den IR-Empfänger an der FF-Karte habe ich nicht angeschlossen, da schon einer im Gehäuse ist.

Mit der vdr-plugin-remote Version 0.3.8-3 funktioniert es ohne Probleme, nur mit der Version 0.4 kommt jeder jedes Kommando doppelt an.

Sieht für mich wie ein Problem in vdr-plugin-remote aus, oder?

Grüße,
Robert

netvista-fan

Erleuchteter

Beiträge: 3 490

Wohnort: mitten im Ruhrgebiet

Beruf: Dipl. Ing.

  • Nachricht senden

11

Sonntag, 18. Januar 2009, 19:29

RE: irtrans Problem

Wenn Du lirc nutzt benötigst Du nicht das remote-plugin, denn das ist im groben für den Empfänger der FF zuständig.
Und wenn Du nur ne budget hättest würde evtl. der vdr auch nicht starten weil das plugin keinen Empfänger finden würde.

Also wie wärs denn mal mit dem deinstallieren des Plugins?
Könnte evtl. dein Problem lösen, brauchen wirst Du es jedenfalls nicht.

Im groben gibts mittlerweile auch alternative Hardware die davon unterstützt wird, u.a. auch lirc, aber wenn Du über das Plugin gehen möchtest muss halt evtl. lirc im VDR abgeschaltet werden, sonst kommen die Tasten unter umständen 2x an.

Also entweder - oder...

Und bei der neuen Version könnte durchaus die lirc unterstützung das Feature sein das für die doppelten Tasten zuständig ist, welche im älteren evtl. noch nicht drin ist.

Wobei ich grad sehe ... kein lircd ... ähöm... von wo kommen dann die events?
sicher das da wirklich nirgends lirc läuft, imho wird das device erst durch diesen angelegt, kann mich natürlich auch irren.

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »netvista-fan« (18. Januar 2009, 19:36)


12

Sonntag, 18. Januar 2009, 23:16

RE: irtrans Problem

Hi

Na die Events kommen vom irserver, wie gesagt. Der liest /dev/ttyUSB0 (da hängt der IR-Sensor dran) und schreibt die erkannten Kommandos nach /dev/lircd. Ich denke, dort holt sich das vdr-remote-plugin die Kommandos ab and steuert den VDR (genauer: der VDR benutzt libvdr-remote.so, um /dev/lircd auszulesen).

Zu /dev/lircd: Das wird (imho) durch die Installation des lirc-Packages angelegt. Beim Booten des Rechners wird auf der im Package enthaltene lircd gestartet, der aber keine Konfiguration findet und sich beendet. Den brauche ich auch nicht, das übernimmt ja der irserver.

Habe das gerade zur Sicherheit mit einem ps -efa geprüft - es läuft definitiv kein lircd.

Da es mit der Vorgänger-Version des vdr-plugin-remote läuft, habe ich für mich das Problem als gelöst verbucht. Wenn sich jemand aber verantwortlich fühlt, der Sache genauer auf den Grund zu gehen, unterstütze ich ihn gerne. :)

Wenn ich das vdr-plugin-remote auch rauswerfe: Wo sage ich dann dem VDR, dass er /dev/lircd lesen soll?

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »rom770« (18. Januar 2009, 23:32)


SHF

Erleuchteter

Beiträge: 3 962

Wohnort: hessische Bergstrasse

  • Nachricht senden

13

Montag, 19. Januar 2009, 01:04

Zitat

Original von rom770
Habe das gerade zur Sicherheit mit einem ps -efa geprüft - es läuft definitiv kein lircd.
Eigentlich aber doch, der irserver ist nämlich eigentlich nur ein modifizierter LIRCd.

Zitat

Wenn ich das vdr-plugin-remote auch rauswerfe: Wo sage ich dann dem VDR, dass er /dev/lircd lesen soll?
Das macht er normalerweise selbstständig.
Wirf doch einfach das Remote-Plugin raus und schau, was passiert.
Gruss
SHF


Mein (neuer) VDR:

Software:
Debian Wheezy mit Kernel 3.14
VDR 2.0.7 & div. Plugins aus YaVDR-Paketen
noad 0.8.6

Hardware:
MSI C847MS-E33, onboard 2x1,1GHz Sandybridge Celeron 847, 4GiB RAM
32GB SSD (System), 4TB 3,5" WD-Red HDD (Video)
TT FF DVB-S 1.5 FullTS-Mod PWM-Vreg-Mod, DVB-Sky 852 Dual DVB-S2
Das ganze im alten HP Vectra VLi8-Gehäuse versorgt von:
PicoPSU-160-XT und Meanwell EPP-150 im ATX-NT-Gehäuse

netvista-fan

Erleuchteter

Beiträge: 3 490

Wohnort: mitten im Ruhrgebiet

Beruf: Dipl. Ing.

  • Nachricht senden

14

Montag, 19. Januar 2009, 02:11

Und wenn man in der /etc/default/vdr
OPTIONS="-w 60" auf "-w60 --lirc=/dev/null" erweitert,
läuft der vdr ohne lirc und nutzt nur das remote-plugin.
Dann kannst Du mal schauen wer wo die lirc events empfängt.

Das der irserver quasi auch ein lircd ist war mir nicht ganz bekannt,
aber damit ist ja alles klar...

15

Montag, 19. Januar 2009, 02:18

ich benutze ebenfalls den irserver, allerdings ohne das remote-plugin. Vdr-sxfe starte ich mit --lirc,
ich sage dem vdr explizit, dass er nicht auf /dev/lircd lauschen soll. Solange ich das nicht machte,
gab es doppelte Aktionen. Das Ganze funktioniert völlig problemlos mit dem neuen Motherboard.
Mit dem Alten passierte es öfter, dass nach dem resume aus suspend2ram der USB-Port in einem
undefinierten Zustand fest hing.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
Samsung UE55H6470

16

Dienstag, 20. Januar 2009, 11:06

Ich habe jetzt vdr-plugin-remote kompett rausgeworfen und in vdr.conf unter OPTIONS "-w 60 --lirc=/dev/lircd" eingetragen.

Damit funktioniert sowohl vdr über FF als auch über vdr-sxfe. :)

Wenn ich heute abend Zeit habe, werde ich auch mal die Variante "lirc=/dev/null" mit remote-Plugin ausprobieren und die Ergebnisse berichten.

Suspend2ram habe ich noch nicht ausprobiert.

17

Dienstag, 20. Januar 2009, 20:59

Hi

Also, jetzt habe ich OPTIONS "-w 60 --lirc=/dev/null" gesetzt mit folgenden Ergebnissen:
  1. mit vdr-plugin-remote 0.4 und "-i autodetect" wird die FB nicht erkannt
  2. mit vdr-plugin-remote 0.4 und "-l /dev/lircd" funktionieren vdr und vdr-sxfe
  3. mit vdr-plugin-remote 0.3.8 und "-l /dev/lircd" funktionieren vdr und vdr-sxfe nicht ?(
    [/list=1]
    1 habe ich so erwartet, aber 2 und 3 sind in der Kombination schon etwas seltsam.

    Ich habe jetzt das Plugin wieder rausgeworfen und OPTIONS "-w 60 --lirc=/dev/lircd" restauriert - keep it simple ...

netvista-fan

Erleuchteter

Beiträge: 3 490

Wohnort: mitten im Ruhrgebiet

Beruf: Dipl. Ing.

  • Nachricht senden

18

Mittwoch, 21. Januar 2009, 14:39

Da der vdr in der standard config eh auf lirc hört, dürfte
OPTIONS "-w 60 --lirc=/dev/lircd"
das selbe sein als wenn man den lirc teil weg lässt...
Mit /dev/null stellt man es halt einfach nur ab.

Und so seltsam finde ich die "getesteten" varianten nicht,
Bei 1 wird wohl einfach das lirc device nicht per autodetect gefunden,
bei 2 klappte es ja auch vorher, nur hattest Du noch die events über den vdr lirc (also 2x)
bei 3 hatte es wohl auch vorher nicht über das plugin funktioniert und Du hattest eh nur die events über den vdr lirc teil, da der jetzt aus ist kommt halt gar nichts mehr.

Somit ist dir jetzt wohl klar das Du nicht übers remote Plugin gehen musst da der vdr von sich aus schon die Signale empfängt.

Wenn Du noch vdr-sxfe mit lirc startest würdest Du auch wieder alle signale 2x bekommen... mit passendem remote-plugin sogar 3x.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »netvista-fan« (21. Januar 2009, 14:42)


19

Mittwoch, 21. Januar 2009, 17:02

Zitat

Original von netvista-fan
Somit ist dir jetzt wohl klar das Du nicht übers remote Plugin gehen musst da der vdr von sich aus schon die Signale empfängt.


Jup. Danke nochmal an alle für die Ratschläge. :)

Zitat


Wenn Du noch vdr-sxfe mit lirc startest würdest Du auch wieder alle signale 2x bekommen... mit passendem remote-plugin sogar 3x.


Wahrscheinlich, werde ich aber nicht ausprobieren. :lol2

Immortal Romance Spielautomat