Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 805

Wohnort: Österreich/Tirol

Beruf: Gasmann-Assistent

  • Nachricht senden

301

Samstag, 4. September 2010, 21:34

So, nächstes Problem.

Ich starte den Installer mit ./VdrAssistant-0.1.227.run
Dann kommt die Sprachauswahl und anschließend erhalte ich folgende Fehlermeldung:

Quellcode

1
Die Systemvariable JAVA_HOME wurde nicht gesetzt. Sie sollte den Pfad zu  einer gültigen JDK-Installation enthalten.


Dann ich so:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
albert@prefect:~/vdrass$ cd $JAVA_HOME 
albert@prefect:/usr/lib/jvm/java-6-sun$ ls -al 
insgesamt 68 
drwxr-xr-x 8 root root  4096  1. Aug 11:50 . 
drwxr-xr-x 6 root root  4096  1. Aug 11:57 .. 
drwxr-xr-x 3 root root  4096  1. Aug 11:50 bin 
lrwxrwxrwx 1 root root    13  1. Aug 11:50 COPYRIGHT -> jre/COPYRIGHT 
drwxr-xr-x 2 root root  4096 28. Jul 14:56 ext 
drwxr-xr-x 3 root root  4096  1. Aug 11:50 include 
drwxr-xr-x 7 root root  4096  1. Aug 11:50 jre 
drwxr-xr-x 3 root root  4096  1. Aug 11:50 lib 
lrwxrwxrwx 1 root root    11  1. Aug 11:50 LICENSE -> jre/LICENSE 
drwxr-xr-x 4 root root  4096  1. Aug 11:49 man 
-rw-r--r-- 1 root root 33526  7. Dez 2006  README.html 
lrwxrwxrwx 1 root root    10  1. Aug 11:49 .systemPrefs -> /etc/.java 
lrwxrwxrwx 1 root root    31  1. Aug 11:50 THIRDPARTYLICENSEREADME.txt -> jre/THIRDPARTYLICENSEREADME.txt 
albert@prefect:/usr/lib/jvm/java-6-sun$ pwd -P 
/usr/lib/jvm/java-6-sun-1.6.0.21 
albert@prefect:/usr/lib/jvm/java-6-sun$ ls -al /etc/alternatives/java 
lrwxrwxrwx 1 root root 36  9. Jän 2010  /etc/alternatives/java -> /usr/lib/jvm/java-6-sun/jre/bin/java


Sieht alles richtig aus, geht aber nicht :(
Vorschläge?

mfG,
f.
VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric v5, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

302

Samstag, 4. September 2010, 21:47

Hi,
das ist eine Umgebungsvariable. Die setzt Du einfach mit

Quellcode

1
export JAVA_HOME=/usr/lib/jvm/java-6-sun


Das hält jetzt bis zum nächsten Neustart. Wie man das dauerhaft einrichtet beschreibt Gero hervorragend auf seinen Seiten... ;)

Gruß
Stefan
Mein VDR: link :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »stmeyer« (5. September 2010, 12:19)


303

Samstag, 4. September 2010, 22:02

@Stefan

Da passiert leider nichts. Habe ich schon mehrfach probiert. Bekomme aber auch nirgends eine Fehlermeldung.

Hier mal wieder Screens:


Dienste auf "hera-server" scheinen ja alle zu laufen.

Und mehr passiert einfach nicht:


Irgendwie habe ich den Verdacht das Laptop und Server laufen aber auf dem easyvdr etwas nicht stimmt. Von da kommen scheinbar keine Daten. Ich habe aber auch gerade keinen anderen vdr am laufen um das mal gegentesten zu koennen.

Gruss!
easyVDR 2.1 stable, Gigabyte GA-Z87M-D3H, Intel Core i3-4130, 16 GB, Nvidia GT 630 Rev. 2, Samsung 840EVO 120GB SSD System, 16TB-NAS als zentraler Speicherplatz (Raid-Z2), DD Cine S2 v6.5 Dual DVB-S2, Antec Fusion V2 Silver

304

Samstag, 4. September 2010, 22:13

Hi,
passt Dein Port? Gero war nämlich bei seinen Standardwerten, die er bei der Konfiguration angibt nicht konsistent. Er nutzt da einmal 7936 und dann wieder 7937.

Bei mir tut's:

Gruß
Stefan
»stmeyer« hat folgende Datei angehängt:
  • epg.png (103,99 kB - 326 mal heruntergeladen - zuletzt: 31. März 2013, 09:42)
Mein VDR: link :D

305

Samstag, 4. September 2010, 22:20

So, ich habe nun unter Ubuntu auch keine Probleme mit der Installation als User gehabt. :)

Allerdings habe ich exakt das gleiche Verhalten, wie vorher unter Debian:
- mkv lassen wir mal aussen vor, das tut wohl nicht mit der 227
- Aufnahme ausgewählt, Tonspur kontrolliert. Steht wie unter debian schon abgespeichert da, also 1 Spur bezeichnet und markiert.
- Jobverwalter ausgewählt, neuer job, Name eingegeben, Theme gewählt und unter Aufnahmen den Film ausgewählt.
- es kommt wieder die Meldung, dass die Aufnahme unvollständige Tondaten hat.
- in dem Verzeichnis vdrassistant/ext gibt keine ...prozess.jar -Files und es wird auch nix konvertiert...

siehe Screenshots

Gruß
Stefan
»stmeyer« hat folgende Dateien angehängt:
  • Details.png (104,12 kB - 323 mal heruntergeladen - zuletzt: 31. März 2013, 15:06)
  • Tonspur.png (58,73 kB - 316 mal heruntergeladen - zuletzt: 31. März 2013, 14:18)
  • job.png (85,07 kB - 315 mal heruntergeladen - zuletzt: 31. März 2013, 08:13)
Mein VDR: link :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »stmeyer« (4. September 2010, 22:32)


306

Samstag, 4. September 2010, 22:45

so und nun habe ich kapiert, wo ich die ...process-Files suchen muß. Ich habe da dauernd auf dem Desktop gesucht.
Auf dem Arbeitstier sind die vorhanden
"SRDVDCnvProcess.jar SRMKVCnvProcess.jar SRThemeDVDStd.jar"

Sorry, es sind für mich scheinbar zuviele Rechner im Spiel... :versteck


Und zwischendurch habe ich auch mal Deinen Tip ausprobiert, eine ältere .run-Installation auf dem Arbeitstier durchzuführen, in Verbindung mit dem 227er Desktop. Da konvertiert bei mir auch nix. :(

Für heute mach ich Schluß...

Gruß
Stefan
Mein VDR: link :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »stmeyer« (4. September 2010, 22:59)


307

Samstag, 4. September 2010, 22:52

Jetzt muss ich nochmal ganz bloed fragen:

Wer soll denn der epg-Host sein der bei der Installation des vdrproxy auf dem vdr abgefragt wird?

Soll das dann das Arbeitstier oder der Desktop sein? Habe schon beider Versionen versucht.

Den Port habe ich nun auch ueberall auf 7937 gestellt. War wirklich verschieden. Leider ohne Erfolg bisher.

Gruss!
easyVDR 2.1 stable, Gigabyte GA-Z87M-D3H, Intel Core i3-4130, 16 GB, Nvidia GT 630 Rev. 2, Samsung 840EVO 120GB SSD System, 16TB-NAS als zentraler Speicherplatz (Raid-Z2), DD Cine S2 v6.5 Dual DVB-S2, Antec Fusion V2 Silver

308

Samstag, 4. September 2010, 23:03

Hi Hera,
die Frage habe ich auch schon gestellt. Gero hat die Frage 2 Seiten vorher beantwortet.
Ich habe hier das Arbeitstier eingetragen.

Blöde Frage: Du hast den vdrproxy auf dem VDR aber schon gestartet?
Wenn Du das als User machst solltest Du folgende Meldung bekommen

Quellcode

1
2
3
stmeyer@vdr:~$ vdrproxy.pl &
[1] 7633
stmeyer@vdr:~$ /sbin/vdrproxy.pl 7633: Server accepting clients at port #7937


Gruß
Stefan
Mein VDR: link :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »stmeyer« (5. September 2010, 00:52)


Beiträge: 805

Wohnort: Österreich/Tirol

Beruf: Gasmann-Assistent

  • Nachricht senden

309

Samstag, 4. September 2010, 23:19

Zitat

Original von stmeyer
Hi,
das ist eine Umgebungsvariable. Die setzt Du einfach mit

Quellcode

1
2
JAVA_HOME=/usr/lib/jvm/java-6-sun
export=JAVA_HOME


Das hält jetzt bis zum nächsten Neustart. Wie man das dauerhaft einrichtet beschreibt Gero hervorragend auf seinen Seiten... ;)


Ja, das ist mir schon klar. Ich habe auch in VdrAssistant (Pes, Pes-HD, TS und TS-HD Aufnahmen verwalten und "offline" konvertieren) geschrieben, dass ich die Variable in der /etc/profile gesetzt habe. Auch wenn ich vor oder nach dem Aufruf von VdrAssistant-0.1.227.run überprüfe ob die Variable gesetzt ist schaut alles normal aus (siehe voriger Post von mir, der lange Teil).

Ich steh momentan auf der Leitung.

mfG,
f.
VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric v5, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

310

Sonntag, 5. September 2010, 11:18

Hallo zusammen,

langsam kommt Leben auf :)

Zitat

unter Bearbeiten/Einstellungen wird mir im Abschnitt "DataSource" unter "Verzeichnis der Aufnahmen" als Directory "/media/video" angezeigt.
Wenn damit das eigentliche vdr-video-Verzeichnis gemeint ist, so sollte da bei mir "/media/video0" stehen.

Hm, weiß ja nicht, wie Du installiert hast, aber es macht durchaus Sinn, sich alle Einstellungen im Installer anzuschauen und sie zu überprüfen. Wenn ein Punkt unklar ist, gibt es die Hilfefunktion.
Ich habe die Texte nicht aus lauter Langeweile verfasst ;)

Also ganz konkret: bei der Installation mit dem Bash-Installer auf dem Arbeitstier interessiert nicht, wo die Aufnahmen auf dem VDR liegen, sondern wo die Aufnahmen im Verzeichnisbaum des Arbeitstieres eingebunden/zu finden sind.

Wenn der Aufnahme-Verwaltungs-Dienst keine Aufnahmen findet, tut er auch nix.
Logdatei ist /var/log/srvRecManager0-0.log

Zitat

Bei mir fehlen ja die für die Umwandlung nötigen ...prozess.jar-Files.

ist für die nächste Version behoben.

Zitat

KANN ICH IRGENDWIE PRUEFEN OB DER VDRPROXY RICHTIG FUNKTIONIERT?

Aua - schrei doch bitte nicht so laut.
Der Proxy schreibt seine Meldungen entweder nach /var/log/messages, /var/log/syslog oder in den Ringpuffer, der per logread auszulesen ist - je nach Installation.

Zitat

Nun scheitere ich aber an der Ramdisk.

Sorry, werde die Online-Doku baldmöglichst aktualisieren. Aber wie ich lesen konnte, hast Du den richtigen Faden ja gefunden ;)

Zitat

Die setzt Du einfach mit

Quellcode

1
2
JAVA_HOME=/usr/lib/jvm/java-6-sun
export=JAVA_HOME

Das war leider nix!
Wer das so abtippt, erhält eine Variable export im Environment, aber JAVA_HOME wird nicht bekannt gemacht. Kommpiuter sind ja so pedantisch :schiel

export ist ein Befehl und kein Variablenbezeichner, deshalb darf nach export kein Gleichheitszeichen kommen. Besser also so

Quellcode

1
export JAVA_HOME=/usr/lib/jvm/java-6-sun


Zitat

Gero war nämlich bei seinen Standardwerten, die er bei der Konfiguration angibt nicht konsistent.

Sorry, wird für die nächste Version behoben.

Zitat

- es kommt wieder die Meldung, dass die Aufnahme unvollständige Tondaten hat.
- in dem Verzeichnis vdrassistant/ext gibt keine ...prozess.jar -Files und es wird auch nix konvertiert...

Ich habe die Warn-Hinweise und die Verarbeitung dahingehend überarbeitet, dass alles etwas fehlertoleranter ist/wird. Wird in Zukunft so sein, dass ein Warnhinweis kommt, wenn mehrere Tonspuren für eine Aufnahme verwendet werden sollen und die nicht bearbeitet wurden.
Wer die ignoriert und die Verarbeitung trotzdem anstößt erhält eben ein Sprachmenü mit nichtssagenden Texten.

Zitat

Blöde Frage: Du hast den vdrproxy auf dem VDR aber schon gestartet?
Wenn Du das als User machst solltest Du folgende Meldung bekommen

Hm, der Installer für vdrproxy erzeugt extra ein Startscript in /etc/init.d - mit dem sollte der proxy gestartet werden. Also beispielsweise so:

Quellcode

1
sudo /etc/init.d/vdrproxy start
Wer meint, den proxy unbedingt selbst starten zu wollen/müssen, sollte dann wenigstens "nohup" und "nice" verwenden, also z.B. so:

Quellcode

1
nohup nice -19 vdrproxy.pl &
Die neue Version ist derzeit im Test. Dauert noch etwas.
Ich danke Euch allen für Eure Geduld und Eure Rückmeldungen!

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

Beiträge: 805

Wohnort: Österreich/Tirol

Beruf: Gasmann-Assistent

  • Nachricht senden

311

Sonntag, 5. September 2010, 11:49

Zitat

Original von geronimo

Zitat

Nun scheitere ich aber an der Ramdisk.

Sorry, werde die Online-Doku baldmöglichst aktualisieren. Aber wie ich lesen konnte, hast Du den richtigen Faden ja gefunden ;)
Ja, schaut so aus :)

Zitat


Quellcode

1
export JAVA_HOME=/usr/lib/jvm/java-6-sun


Seltsam, genau so steht es in der /etc/profile, echo $JAVA_HOME gibt auch das richtige aus.
Wenn ich die Variable dann vor der Installation manuell setze funktioniert es.
[/quote]

Nun das nächste Problem: Im VdrAssistant-0.1.227.jar werde ich nach einem Datenbankpasswort gefragt (siehe Screenshot). Was muss ich denn da eintragen?

mfG,
f.
»fatzgenfatz« hat folgende Datei angehängt:
  • screen.png (84,78 kB - 259 mal heruntergeladen - zuletzt: 31. März 2013, 21:32)
VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric v5, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »fatzgenfatz« (5. September 2010, 11:50)


312

Sonntag, 5. September 2010, 12:17

Hi Gero,

Zitat

Hm, der Installer für vdrproxy erzeugt extra ein Startscript in /etc/init.d - mit dem sollte der proxy gestartet werden.

Danke für den Hinweis, das habe ich noch gar nicht gesehen. Alledings läuft bei mir der VDR unter Ubuntu, wenn ich es richtig machen will, brauche ich für den automatischen Start ein upstart-Skript.
Und zum Test hab ich das halt immer von Hand gestartet. Nice war mir für den Test nicht wichtig. ;)
Wenn mal alles funktioniert kümmer ich mich darum, alles auch automatisch starten zu lassen...

Zitat

Hm, der Installer für vdrproxy erzeugt extra ein Startscript in /etc/init.d - mit dem sollte der proxy gestartet werden.

Da war's wohl gestern schon zu spät, Du hast natürlich völlig recht. Ich korrigier das oben...

Zitat

Zitat

Bei mir fehlen ja die für die Umwandlung nötigen ...prozess.jar-Files.


ist für die nächste Version behoben.

Das heißt, die werden auch auf dem Desktop gebraucht? Ich schrieb oben ja nochmal, dass ich die mittlerweile auf dem Arbeitstier gefunden habe...

@fatzgenfatz: Dein Datenbank-User und das Datenbank-Passwort sind das, was Du bei der Einrichtung der Datenbank gesetzt hast. Wenn Du die Vorgaben des Installateurs und das createDB-Skript von Gero benutzt hast, dann ist der Dabenbank-User "vaUser" und das Passwort "secret". Jeweils natürlich ohne Anführungszeichen.

Gruß
Stefan
Mein VDR: link :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »stmeyer« (5. September 2010, 12:18)


313

Sonntag, 5. September 2010, 12:47

Hallo!

Ich denke den Fehler auf dem vdr gefunden zu haben. Nach dem Aufruf des vdrproxy.pl so wie Gero es vorhin beschrieben hat bekomme ich in der nohup.out folgende Eintraege:

Quellcode

1
2
3
4
5
6
7
8
9
10
/sbin/vdrproxy.pl 7348: Server accepting clients at port #7937
/sbin/vdrproxy.pl 7348: Connect from hera-server
/sbin/vdrproxy.pl 7348: hera-server tried to connect, but is not allowed by "knownHosts"
/sbin/vdrproxy.pl 7348: reaped 7354 with exit 256
/sbin/vdrproxy.pl 7348: Oups, server closed without intention. Gonna restart... (Keine Kind-Prozesse)
/sbin/vdrproxy.pl 7348: could NOT start server: Die Adresse wird bereits verwendet
/sbin/vdrproxy.pl 7348: start cleanup ...
/sbin/vdrproxy.pl 7348: gonna kill child: #7354
/sbin/vdrproxy.pl 7348: Server accepting clients at port #7937
...


Das ist nun wieder Neuland fuer mich. Wie bekomme ich denn den hera-server in die known_hosts?
Es gibt uebrigens im Verzeichnis ./.ssh/ eine known_hosts und eine known_hosts_hera.
Kann ja nicht mehr viel fehlen bis wenigstens mal die EPG-Daten angezeigt werden. Der Server will ja staendig ;)

Gruss!
easyVDR 2.1 stable, Gigabyte GA-Z87M-D3H, Intel Core i3-4130, 16 GB, Nvidia GT 630 Rev. 2, Samsung 840EVO 120GB SSD System, 16TB-NAS als zentraler Speicherplatz (Raid-Z2), DD Cine S2 v6.5 Dual DVB-S2, Antec Fusion V2 Silver

Beiträge: 805

Wohnort: Österreich/Tirol

Beruf: Gasmann-Assistent

  • Nachricht senden

314

Sonntag, 5. September 2010, 13:06

Zitat

Original von stmeyer
@fatzgenfatz: Dein Datenbank-User und das Datenbank-Passwort sind das, was Du bei der Einrichtung der Datenbank gesetzt hast. Wenn Du die Vorgaben des Installateurs und das createDB-Skript von Gero benutzt hast, dann ist der Dabenbank-User "vaUser" und das Passwort "secret". Jeweils natürlich ohne Anführungszeichen.


Hmm, bei der Installation habe ich alle Vorgaben unverändert gelassen. Aber vaUser und secret nimmt er nicht :(
VDR1: HW: Asrock Q1900M, Celeron J1900, Zotac GT 630 Zone Edition, DigitalDevices Cine C2/T2, Sundtek MediaTV Pro USB-Stick, Sundtek MediaTV Digital Home, IR-Empfänger: Atric v5, Gehäuse: MC-1200. FB: HarmonyHub . SW: yavdr 0.6x
VDR2: yavdr 0.6, Intel Pentium E5300, MS-Tech MC-1200, ASUS P5G41C-M LX, G41,MSI VN210-MD512H (NVIDIA GeForce 210), Atric, Sundtek MediaTV Digital Home, FB: Harmony 300, USB-Sound: Terratec Aureon Dual USB
VDR3: Raspberry Pi2 als Streaming Client, MLD 5.1

315

Sonntag, 5. September 2010, 13:32

Zitat

Nun das nächste Problem: Im VdrAssistant-0.1.227.jar werde ich nach einem Datenbankpasswort gefragt (siehe Screenshot). Was muss ich denn da eintragen?

Na, Du hast doch zuerst mit dem Bash-Installer die Datenbank angelegt?!?
Dabei musst Du doch Benutzer und Kennwort angeben - und genau die Werte, die Du dort verwendet hast, solltest Du hier eintragen.
Sobald die Werte richtig eingegeben sind, verschwindet die Fehlermeldung.

Zitat

... wenn ich es richtig machen will, brauche ich für den automatischen Start ein upstart-Skript.

Hast Du es denn probiert?
Das Startscript sollte upstart-fähig sein.

Zitat

Da war's wohl gestern schon zu spät, ...

Lach - es gibt auch ein Leben ohne Rechner :)

Zitat

Das heißt, die werden auch auf dem Desktop gebraucht?

Naja - von den JAR-Dateien ermittelt der Jobeditor sich die möglichen Ziele für eine Umwandlung.
Auf diese Weise kann man auch eigene Umwandlungen hinzufügen. Einfach eine passende JAR-Datei auf Desktop und Arbeitstier kopieren und eine neue Umwandlung steht zur Verfügung :)

Zitat

Wie bekomme ich denn den hera-server in die known_hosts?

Hast Du den Installer von vdrproxy ausgeführt?
Der fragt doch nach dem Rechnernamen des EPG-hosts.

Zitat

Hmm, bei der Installation habe ich alle Vorgaben unverändert gelassen. Aber vaUser und secret nimmt er nicht

Hm, wenn das stimmt, dann kann höchstens noch sein, dass Du nach den Änderungen in /etc/hosts oder my.cnf vergessen hast, den Rechner neu zu starten.

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

316

Sonntag, 5. September 2010, 13:59

Hallo!

Nun habe ich endlich die EPG-Daten - super!!
Hatte sich doch ein kleiner Vertipper bei der Installation des vdrproxy ergeben. Servernamen falsch geschrieben ;)

Nun geht es an die Aufnahmen.

Gruss!

Freue mich wie ein kleines Kind - es geht voran :)
easyVDR 2.1 stable, Gigabyte GA-Z87M-D3H, Intel Core i3-4130, 16 GB, Nvidia GT 630 Rev. 2, Samsung 840EVO 120GB SSD System, 16TB-NAS als zentraler Speicherplatz (Raid-Z2), DD Cine S2 v6.5 Dual DVB-S2, Antec Fusion V2 Silver

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hera« (5. September 2010, 15:13)


317

Sonntag, 5. September 2010, 17:47

Hallo,

Ihr habt mich ganz schön auf's Glatteis geführt mit dem "target directory"-Fehler ...

Nach etlichen Tests stellte sich heraus, dass es doch wieder ein Anwendungsfehler war, denn Ursache dafür war der fehlende Eintrag in /etc/sudoers. Im Gegensatz zu Ubuntu ist bei Debian der Benutzer nicht automatisch für die Verwendung von sudo berechtigt! - und ich finde das auch gut so.

Also hier ein Protokoll einer Desktop-Installation unter Debian-testing (nach der Systeminstallation):
  • vi /etc/apt/sources.list - zufügen von "distrib" und "non-free"
  • apt-get update
  • apt-get install sun-java6-jdk galternatives
  • galternatives und bei "java" die sun-Variante aktivieren
  • vi /etc/hosts eigene IP-Adresse eintragen und IP + Name des DB-Servers eintragen
  • vi /etc/sudoers - eigenen Benutzer zur Verwendung von sudo zulassen
  • java -jar VdrAssistant-0.1.227.jar - bei der Meldung, dass für das ISO-Verzeichnis keine Schreibberechtigung vorliegt, diese erteilen
  • sudo für Konfigurationsdaten verwenden auswählen
  • Installation starten
Installation läuft ohne Fehler durch und VdrAssistant kann gestartet werden.

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

318

Sonntag, 5. September 2010, 19:03

Hi,

also jetzt bitte nicht hauen wenn ich mal so ganz direkt frage was ich bisher scheinbar nicht begriffen habe:

Die EPG-Daten werden hier geladen. Das ist alles ok und funzt. Ich bekomme aber keine Aufnahmen angezeigt. Hier mal kurz mein Vorgehen um Fehler zu erkennen:

1. vdrproxy laeuft (7937) und dort ist das lokale /media/video0 angegeben

2. auf dem Server habe ich die neue Versin 228 installiert und dabei Port auf 7937 und als Aufnahmebasis "/home/hera/videos" (da liegen lokal auf dem Server Kopien vom vdr zum codieren) angegeben - Installation laeuft fehlerfrei durch

3. SRServiceManager auf dem Server gestartet - Status ergibt auch "running"

4. auf dem Laptop den 228er-Java-Installateur laufen lassen und wieder Port auf 7937 gestellt, als ISO-Dir habe ich "/home/hera/iso" gewaehlt (scheinbar lokal auf dem Laptop??) -> Installer laeuft fehlerfrei duch

5. VdrAssistant auf Laptop gestartet -> in den Einstellungen bei Datenquelle steht bei "Verzeichnis der Aufnahmen" jetzt wieder "/media/video" und nicht "/home/hera/videos" wie es auf dem Server ist
Auswaehlen kann ich bei dieser Option ja scheinbar nur lokale Verzeichnisse.

Liegt hier der Fehler?

Wenn ich jedenfalls die Aufnahmen einlesen lassen will passiert nichts.

Ich sehe scheinbar nach den vielen Tests den Wald vor lauter Baeumen nicht mehr.

Hoffe auf Eure Hilfe ;)

Gruss!
easyVDR 2.1 stable, Gigabyte GA-Z87M-D3H, Intel Core i3-4130, 16 GB, Nvidia GT 630 Rev. 2, Samsung 840EVO 120GB SSD System, 16TB-NAS als zentraler Speicherplatz (Raid-Z2), DD Cine S2 v6.5 Dual DVB-S2, Antec Fusion V2 Silver

319

Sonntag, 5. September 2010, 19:27

Hi Gero,

Zitat

Ihr habt mich ganz schön auf's Glatteis geführt mit dem "target directory"-Fehler ...

Nach etlichen Tests stellte sich heraus, dass es doch wieder ein Anwendungsfehler war, denn Ursache dafür war der fehlende Eintrag in /etc/sudoers

bei mir kann das in der Tat vergessen worden sein (kann nicht mehr nachschauen, da es die Inst. nicht mehr gibt), Hera schreibt aber 2 Seiten vorher explizit, dass sein User in der sudoers stand.

Ich habe nun auch auf dem Arbeitstier und dem Desktop die 228 installiert. Jetzt kommt kein Fehler mehr, wenn ich eine Aufnahme in mkv konvertieren will. Im Job-Verwalter steht der Job mit Status freigegeben.

Konvertierung startet keine. Was habe ich vergessen?

Hier das log (srvJobProfessor0-0.log):

@Hera: Ich habe keine Idee :( Wenn Deine Pfade stimmen sollte das doch tun...

Gruß
Stefan
»stmeyer« hat folgende Datei angehängt:
Mein VDR: link :D

320

Sonntag, 5. September 2010, 19:39

Kommando zurück: Nachdem ich den Desktop-Installer beendet habe läuft hier auf dem Server nun tatsächlich eine Konvertierung. :cool1

Muß man wirklich erst die Desktop-Anwendung schliessen bis der startet oder hätte ich einfach ein paar min. länger warten müssen???

so geeeeeeil... :)

Gruß
Stefan
Mein VDR: link :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »stmeyer« (5. September 2010, 19:41)


Immortal Romance Spielautomat