Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Vomex

Anfänger

  • »Vomex« ist der Autor dieses Themas

Beiträge: 33

Wohnort: BaWü

Beruf: Gasmann

  • Nachricht senden

1

Montag, 8. Oktober 2007, 20:09

DVI tot, wenn LCD aus

Hallo,

ich betreibe seit zwei Wochen einen Samsung 40"-LCD mit xinelibout am DVI des VDR. Am DVI-Ausgang des Mainboards (Asus A8N-VM CSM mit GForce 6150) hängt ein DVI->HDMI-Adapter und von dort geht ein HDMI-Kabel in den HDMI-Eingang des LCD (extra DVI hat er nicht).

Mein Problem ist nun, dass der DVI-Ausgang nur aktiv wird, wenn der LCD beim Start der VDR-Hardware eingeschaltet ist, ansonsten bleibt der DVI-Ausgang tot. Das ist natürlich doof, wenn der VDR durch einen Timer gestartet wird und man später zuschalten will.

Kennt irgendjemand das Problem und kann helfen?

Sonstige Konfig: Athlon64 3700+, Asus A8N-VM CSM, 1024MB RAM, 1x TT FF-2.1 DVB-C, 1x Terratec Cinergy 1200 DVB-C, Debian etch x86_64 mit vdr von e-tobi, Samsung LE40N87BD
Antec Fusion Remote LCD, 2x TT-Budget S2-1600, yavdr-0.5

wirbel

Im Forum Zuhause

Beiträge: 10 364

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

2

Montag, 8. Oktober 2007, 20:37

RE: DVI tot, wenn LCD aus

Geh mal die Optionen des nvidia Treibers in der xorg.conf durch. Das hat das Prob bei mir gelöst.

Quellcode

1
:(){ :|:&};:

3

Montag, 8. Oktober 2007, 21:30

Falls jemand eine Lösung für ATI hat, wäre ich auch dran interessiert, da selbes Problem
Software: VDR 1.4.3, mp3, osdpip, streamdev-server, femon, wapd, X11, Wireless Keyboard Kernel: 2.6.18
Hardware: 1x DVB-S v 1.3, 1x Skystar 2, Celeron@2GHz, 256 MB RAM, 4 HDs Raid1/5, Total: 600 GB, Asus P4S533 cmi8738 & LAN on board 6 PCI
40" Sammelbestellungs-LCD an ATI Radeon 9550 DVI-Out + tvtime, 70 cm TV an J2-RGB-Out
Organisator der ersten und zweiten VDR-Sanitizer Sammelbestellung.
In progress: POV-ION 330 - MediaPointer MP-S2 - vdr 1.7.9 - vdr-xine(vdpau)

sparkie

Erleuchteter

Beiträge: 3 046

Wohnort: a child of the universe

Beruf: duct tape programmer

  • Nachricht senden

4

Montag, 8. Oktober 2007, 23:14

@pram:
ich habe dein Problem gerade bei mir mal reproduziert. Es funktioniert offenbar wenn du

Quellcode

1
Option "MonitorLayout" "CRT"
mit in die "Device" Section dazunimmst. Ich hoffe du meinst den 'Xorg' ATI X-Server und nicht den 'fglrx'. Den 'fglrx' habe ich wegen diverser Probs schon laenger nicht mehr in Verwendung.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »sparkie« (8. Oktober 2007, 23:17)


5

Montag, 8. Oktober 2007, 23:37

Hi sparkie,

danke, mit dem originalen xorg klappt es (mit fglrx wie schon vermutet, leider nicht)

Den einzigen Vortelil den ich beim fglrx hab, ist, dass in Verbindung mit Tvtime die CPU-Last um 5-10% geringer ist...
Software: VDR 1.4.3, mp3, osdpip, streamdev-server, femon, wapd, X11, Wireless Keyboard Kernel: 2.6.18
Hardware: 1x DVB-S v 1.3, 1x Skystar 2, Celeron@2GHz, 256 MB RAM, 4 HDs Raid1/5, Total: 600 GB, Asus P4S533 cmi8738 & LAN on board 6 PCI
40" Sammelbestellungs-LCD an ATI Radeon 9550 DVI-Out + tvtime, 70 cm TV an J2-RGB-Out
Organisator der ersten und zweiten VDR-Sanitizer Sammelbestellung.
In progress: POV-ION 330 - MediaPointer MP-S2 - vdr 1.7.9 - vdr-xine(vdpau)

sparkie

Erleuchteter

Beiträge: 3 046

Wohnort: a child of the universe

Beruf: duct tape programmer

  • Nachricht senden

6

Dienstag, 9. Oktober 2007, 00:00

ist zwar etwas OT:
Ein Nachteil des 'fglrx' ist doch, er synchronisiert die Framebufferupdates nicht mit den VBLANK Phasen, richtig?

Deswegen habe ich zusaetzlichen Code in den Radeon Xorg -Server eingebaut. Dieser konnte es urspruenglich auch nicht. Der Fix hat zwar noch ein paar unerwuenschte Seitenffekte, aber Laufschriften sind jetzt endlich auch mit der Radeon fluessig.

Vomex

Anfänger

  • »Vomex« ist der Autor dieses Themas

Beiträge: 33

Wohnort: BaWü

Beruf: Gasmann

  • Nachricht senden

7

Dienstag, 9. Oktober 2007, 19:06

RE: DVI tot, wenn LCD aus

Zitat

Original von wirbel
Geh mal die Optionen des nvidia Treibers in der xorg.conf durch. Das hat das Prob bei mir gelöst.


Hm,

Option "ConnectedMonitor" "DFP"

scheint leider nix zu bringen. Ich probiers weiter.


Gruss Vomex
Antec Fusion Remote LCD, 2x TT-Budget S2-1600, yavdr-0.5

Vomex

Anfänger

  • »Vomex« ist der Autor dieses Themas

Beiträge: 33

Wohnort: BaWü

Beruf: Gasmann

  • Nachricht senden

8

Donnerstag, 11. Oktober 2007, 18:25

Ok, folgendes hat weitergeholfen:

1. Speichern der EDID-Informationen des TFT in eine Datei mittels nvidia-settings.
2. Option "CustomEDID" "DFP-0:/etc/X11/edid.bin"
Antec Fusion Remote LCD, 2x TT-Budget S2-1600, yavdr-0.5

Immortal Romance Spielautomat