[yavdr 0.2] meine Röhre lebt

  • Epilog: Ich hasse VDR und ich hasse Linux, Debian, Ubuntu und den .deb Kram sowieso.
    Soviel Zeit wie ich schon mit testen, basteln, compilieren und löten verbracht habe frage ich mich immer
    wieder, woher die 2 Kinder in unserem Haus kommen. Wenn meine Frau fragt, wo die Kohle hin ist, kommt
    ein: "Ich gehe nicht in die Kneipe und auch nicht zu Nutten. Ich investiere in RAM und Nvidia Chips".
    Für mich ist VDR Basteln ein sehr schönes Hobby. Aber was soll ich jetzt machen.
    Dieses YAVDR Dings rennt und ist seit gestern im Produktiven Einsatz.



    So nun ist es doch noch soweit gekommen. Mein erster .deb Client ist am Start, per VGA2SCART
    Kabel an meiner 1997 gekauften Sony Trinitron 16:9 Röhre (persönlich finde ich das Bild um ein
    vielfaches besser, als das was in so manchen Märkten sieht).


    Angetrieben wird die Röhre von einem Point of View ION-CS330-1 mit folgender Ausstattung:
    - Intel Atom N330 1.6GHz,
    - 2GB RAM
    - 320GB HDD
    - nVidia ION
    - DVD-RW
    - Pollin X10 Funk (per intern angeschlossenem Empfänger)
    - DVBs2 TT-3200


    Am 03.April habe ich mir, sehr kurz entschlossen das o.g. ION System über amazon.de gekauft.
    Da ich bisher keine nvidia Grafikkarte hatte und auch keine Zeit und Lust auf großen Gehäusebau hatte,
    habe ich mich für diesen kompakten Typen entschieden. Mir war wichtig, das ich auch eine Platte
    einbauen konnte damit ich einfach mal TimeShift Lokal habe (die Kinderfilme sollten auch lokal liegen)
    und meine PCI DVB-S2 Karte rein passte.


    Nach ca. 8 Wochen hatte ich schon an einen Fehlkauf gedacht. Getestet hatte ich mit
    Lenny, Squeeze, Ubuntu 9.10, yavdr 0.1, yavdr 0.1.1. Alles Mist, nicht nur das es instabil war sondern
    es war auch einfach kein flüssiges Bild aus der Büchse zu bekommen. Nun sei hier noch gesagt,
    das in meinem Bastelkeller ein FullHD Samsung Monitor steht, dem 5 TB MKVs und 5 HD Sender
    befüttern sollten. Und alles was Mann zu sehen bekam, waren SCHARFE aber ruckelnde Bilder.


    Mehr durch einen dummen Zufall, bin ich dann über einen Artikel zu dem o.g. ION gestolpert.
    Dort war ein Bild von den Innereien, wo man das Motherboard von der Seite sehen konnte.
    Wieso waren denn da 2 RAM Riegel drin!?! Also wieder zu amazon.de und 2x1GB RAM bestellt.


    Nach endlosen 2 Tagen des Wartens musste der eine 2GB Riegel weichen. 2 mal 1GB rein und Boot.


    Muss ich noch was sagen. Natürlich nicht, das weiß man ja, das man immer 2 x 1 GB 800 Mhz Riegel
    braucht.


    Das Bild lief flüssig und sah einfach fantastisch aus.


    Wie wacht die Büchse auf: ACPI läuft out of the Box.


    Nun noch an die Pollin X10, die zum Verrecken nicht laufen wollte. Da ich ja einen der YAVDR Devs
    als Knecht zur Verfügung habe (derjenige welche weiß wie ich es meine) wurde der Fehler auch noch
    gefixt.


    Ein verdammt Großes Lob und einen noch größeren Dank an das gesamte YAVDR Team.


    Gruß vdr-box

    Dieser Beitrag wurde bereits 5 Mal editiert, zuletzt von vdr-box ()

  • hier kommen noch ein paar Erklärungen rein:


    2010-07-19: Fix für die Pollin X10:

    Code
    1. nano /usr/share/yavdr/events/actions/change-lirc-hardware

    Zeile 53 fehlen die Anführungszeichen

    Code
    1. if [ -n "$BLACKLIST" ]; then


    2010-07-19: ACPI WakeUp

    Code
    1. nano /etc/vdr/vdr-addon-acpiwakeup.conf
    Code
    1. ACPI_ENABLED=yes

    Natürlich dann noch im Webfrontend unter "VDR Shutdown - wählen" shutdown aktivieren.


    2010-07-20: Als VGA2Scart Kabel benutze ich eins von Dr. Jones hier aus dem Forum




    vdr-box

    Dieser Beitrag wurde bereits 6 Mal editiert, zuletzt von vdr-box ()

  • Zitat

    Original von vdr-box
    per VGA2SCART
    Kabel an meiner 1997 gekauften Sony Trinitron 16:9 Röhre


    welches Kabel verwendest Du bzw. wo hast Du es her?


    kannst Du dieses Problem nachvollziehen oder hast eine Lösung gefunden?

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • XBMC und die Pollin


    Viel wird geschrieben und noch mehr wurde gelesen. Hier kommt noch die Doku der FB rein


    vdr-box

  • da pfuscht sich doch der Dr. Seltsam dazwischen. :-)


    Derzeit läuft die Ausgabe über ein 3m VGA2Scart Kabel hier aus dem Forum. Ich habe keine
    16:9 Schaltspannung anliegen.


    Der Sony steht auf 16:9 fix. Eigentlich schon immer, auch unter meiner FF Karte.
    Der VDR steht unter DVB auch auf 16:9.


    Derzeit sehe ich:
    - ARD 16:9 Vollbild
    - ZDF 16:9 "Casanova" oben und unten Balken, Köpfe perfekt.
    - VOX 4:3 "Bosten Legal" rechts und links schwarze Balken. (Gerade schaltet die Werbung in 16:9 Vollbild, funkt auch)


    Meiner Meinung nach alles Bestens.


    vdr-box

  • poste doch mal bitte aus der setup.conf die Einstellungen des xineliboutput-Plugins.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Dr. Seltsam :


    Habe gerade nochmal den Keller VDR mit meiner FF Karte angemacht. Ist per S-Video angeschlossen.
    Da ich ja die Röhre auf 16:9 stehen habe musste ich nur die Röhre bei VOX - Bosten Legal auf 4:3 schalten.
    Ansonsten alles wie oben angegeben, also die gleiche Ausgabe. Nur das Bild ist per
    VGA2Scart verdammt viel besser.


    der Videoteil sollte reichen

    vdr-box

  • Merci. Und bitte auch nochmal Deine xorg.conf.yavdr


    Wieso musst Du bei Ausgabe über die FF-Karte das Bildformat bei der Röhre umschalten? Das sollte eigentlich über die wss-bits im Videosignal automatisch geschehen.

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Zitat

    Original von Dr. Seltsam
    Wieso musst Du bei Ausgabe über die FF-Karte das Bildformat bei der Röhre umschalten? Das sollte eigentlich über die wss-bits im Videosignal automatisch geschehen.


    Aha, man kennt sich aus. :lachen1


    Richtig, aber ich habe das bei mir abgeschaltet. Die Autoerkennung der Röhre hat bei meine 1.6er FF Karte
    immer hin und her geschaltet.
    Und was schaue ich schon in 4:3

    Code
    1. nano /etc/X11/xorg.conf.yavdr



    vdr-box

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von vdr-box ()

  • mich wundert, dass Du ohne die


    # Set for 16:9 display
    DisplaySize 400 225


    und ohne


    Modes "720x576"



    auskommst, die ich in meiner xorg.conf drin habe.


    Welche Auflösung hat der x-server denn bei Dir effektiv?

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Zitat

    Original von Dr. SeltsamWelche Auflösung hat der x-server denn bei Dir effektiv?


    wenn du mir sagst, wie ich das heraus finde?


    vdr-box

  • Zitat

    Originally posted by Dr. Seltsam
    Welche Auflösung hat der x-server denn bei Dir effektiv?


    nach obiger Modeline hat der effektiv 1024x576. Somit weiss Xine, dass es sich um ein 16:9 TV-Geraet handelt. Ohne dass Verrenkungen mit der 'AspectRatio' Angabe in setup.conf noetig waeren. Es wird das Seitenverhaeltnis also automatisch richtig dargestellt.


    Zitat

    Originally posted by vdr-box
    Ich habe keine 16:9 Schaltspannung anliegen.


    Der Sony steht auf 16:9 fix.


    genau so ist es richtig. Die Skalierung uebernimmt die Grafik. Das Videotiming zwischen Grafik und TV bleibt immer konstant.


    Ausserdem gibt es so kein Gezappel mehr am Display, das durch eine sich aendernde Schaltspannung verursacht werden koennte.


    - sparkie

  • Zitat

    Original von sparkie
    nach obiger Modeline hat der effektiv 1024x576. Somit weiss Xine, dass es sich um ein 16:9 TV-Geraet handelt. Ohne dass Verrenkungen mit der 'AspectRatio' Angabe in setup.conf noetig waeren. Es wird das Seitenverhaeltnis also automatisch richtig dargestellt.


    Richtig, zeigt auch ein TFT Monitor an, der natürlich diesen Modus nicht kann.


    Zitat

    Originally posted by vdr-box
    genau so ist es richtig. Die Skalierung uebernimmt die Grafik. Das Videotiming zwischen Grafik und TV bleibt immer konstant.


    Ausserdem gibt es so kein Gezappel mehr am Display, das durch eine sich aendernde Schaltspannung verursacht werden koennte.
    - sparkie


    So ist es und es läuft wirklich prima.


    vdr-box


  • Muhahaha, einen kleinen Unterschied gibt es noch... bei m ir ist das 2. Kind gerade unterwegs. :)

    Umgestiegen auf Dreambox 7020HD und 800HDse. Einfach genial!
    Vielen Dank an das yaVDR-Team für die tollen Releases!


    Zu verkaufen:
    System 1: yaVDR 0.3 - M4N78-VM - 2GB - 8200 Onboard - CPU 5050e - 2 x TeVii S464
    System 2: yaVDR 0.3 - K10N78M Pro - AMD Athlon(tm) 64 3200+ - 8200 Onboard - TT s-1600

  • Zitat

    Original von sys64738
    Muhahaha, einen kleinen Unterschied gibt es noch... bei m ir ist das 2. Kind gerade unterwegs. :)


    Wenn du bisher dachtest, du hast wenig Zeit, dann warte erst mal ab, wenn das zweite da ist. :strike1


    vdr-box