Asus AT3N7A-I will nicht aufwachen :O

  • Hallo,


    habe gerade das neue Board provisorisch zusammen gestöpselt und dachte - bevor ich mich weiter rein hänge, sollte auf jeden Fall das Aufwachen funzen.


    Egal ob ich im BIOS wakeon rtc ein oder ausschalte - der Effekt ist derselbe. Nämlich keiner.
    Es macht auch keinen Unterschied, ob ich erst ne 0 rausschicke oder gleich ne neue Sekunden-Anzahl.
    alarm_IRQ geht auf yes und in der Zeit sind keine Sternchen - und doch wacht das Board nicht auf.


    Ich erinnere mich, dass ich vor dem Kauf gelesen habe, dass das Board problemlos aufwachen tun täte - vielleicht kann mir ja jemand einen Tip geben.
    Langsam weiß ich nicht, was ich noch probieren soll :(


    Ach ja: in /etc/defaults/rcS habe ich HWCLOCKACCESS=no zugefügt.

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Quote

    Original von geronimo
    Ich erinnere mich, dass ich vor dem Kauf gelesen habe, dass das Board problemlos aufwachen tun täte - vielleicht kann mir ja jemand einen Tip geben.
    Langsam weiß ich nicht, was ich noch probieren soll :(


    Probleme mit UTC kannst du ausschließen? Also auch mal statt meinetwegen 5 Minuten in die Zukunft zugehen, mal 1 Stunde und 5 Minuten ausprobiert?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Hallo,


    danke Dir für Deine Antwort!


    Quote

    Probleme mit UTC kannst du ausschließen?


    Also ausschließen kann ich garnix - und schon garnicht, dass das Problem evtl vor der Tastatur zu finden ist ;)


    Kiste läuft auf UTC.
    Ich bin davon ausgegangen, dass date %s auch utc liefert.


    Aba gut. Werde ich ausprobieren.
    Ist nur dann doof, wenn ich die Zeiten selber umrechnen soll/muss. Das wollte ich gern vermeiden.


    Melde mich später wieder.

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Das Board wacht hier bei mir auf jeden Fall absolut zuverlässig auf. Wichtig: Zurückspeichern der Uhrzeit beim Herunterfahren abschalten (siehe VDR-Wiki). Die Uhr läuft bei mir auch auf UTC.


    Grüße,
    Holger

    VDR 1-3: Zotac ZBox HD-ID42, yavdr-0.5
    VDR 4: AMD5900/Asus M3N-78, yavdr-0.5
    DVB-Empfang: Netceiver
    Storage: via NFS von separatem Fileserver

    [size=10]

    The post was edited 1 time, last by hsteinhaus ().

  • Hallo Holger,


    danke Dir für die Bestätigung, dass es funzen sollte. Das ist doch schon mal ne Beruhigung :)


    Könntest Du mir vielleicht Deine BIOS-Einstellungen verraten?


    Ich habe im VDR-Wiki jetzt nix zum Vermeiden des Zurückspeicherns der Zeit gefunden.
    In einem anderen Wiki las ich von dem Tip, dass man die Datei /etc/defaults/rcS erweitern müsse.
    Das habe ich getan.


    Wie sieht das bei Dich aus? - Musst Du die Zeit zweimal schreiben?
    Fährst Du den Rechner mit poweroff runter oder schickst Du ihn in einen Schlafmodus?


    Gruß Geronimo

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Ich sehe gerade, Du hast HWCLOCKACCESS schon gefunden - das meinte ich mit dem Zurückschreiben der Uhrzeit.


    Ich schicke ihn nur in den S3-Mode. Wenn ich mich recht erinnere, ging power-Off aber auch. Werde ich heute Nacht mal probieren. Bei den BIOS-Einstellungen steht das automatische Wakeup auf off, der Rest auf on. Ansonsten brauche ich noch den Kernel-Parameter "usbcore.autosuspend=-1", anderenfalls habe ich das gegenteilige Problem in Verbindung mit neueren NVidia-Treibern - der Rechner wacht ständig von selbst auf nach dem Suspend. Ich schreibe die Zeit aus Kompatibilitätsgründen doppelt.


    Ich nehme an, Du probierst erst mal an der Console? Denn VDR hat noch ein paar ganz spezielle Fußangeln, um das Testen auch recht schwierig zu machen ("Brückenzeit").


    Grüße,
    Holger

    VDR 1-3: Zotac ZBox HD-ID42, yavdr-0.5
    VDR 4: AMD5900/Asus M3N-78, yavdr-0.5
    DVB-Empfang: Netceiver
    Storage: via NFS von separatem Fileserver

    [size=10]

  • OK, also wakeup habe ich aus, dann werde ich die anderen Parameter mal durchprobieren.
    Mit usb habe ich im Moment noch nix am Hut - habe nur zum Installieren einen Stick statt CD verwendet.
    Jetzt liegt USB wieder brach.
    Den blauen Zahn habe ich auch deaktiviert. Vielleicht spart es ja etwas Strom, wenn ich es nicht brauche - aber auf jeden Fall reduziert es den Elektrosmog. Bekomme auch so genug heiße Ohren ...


    Quote

    Ich schreibe die Zeit aus Kompatibilitätsgründen doppelt.


    Könntest Du mir bitte erklären wie das geht?
    Sobald ich einen zweiten Schreibbefehl absetze (egal ob identisch oder nicht) bekomme ich Schreibrechte-Fehler.


    Quote

    Ich nehme an, Du probierst erst mal an der Console? Denn VDR hat noch ein paar ganz spezielle Fußangeln, um das Testen auch recht schwierig zu machen ("Brückenzeit").


    Yepp. Im Moment arbeite ich nur an der Console. Bissle noch mit perl, weil ich ne faule Natur bin ...
    Die VDR-Skripte kenne ich soweit. Habe für LinVDR einige Scripte geschrieben und auch mal das poweroff angepasst. Denke nicht dass ich dort auf Probleme stoßen werde.


    Das wakeup ist für mich erst mal der schlimmste Brocken - eben weil soviel Glückssache bzw. Magie dabei ist :D


    Im Augenblick ist der Kleine völlig mit Kernelbau ausgelastet ;)
    Das hat mich auch überrascht. Ich hatte es so im Kopf gehabt, dass die Kernelorgie ein Test dafür wäre, wie gut die unterschiedlichen Prozessoren angesteuert werden ...
    Wenn das stimmt, dann schneidet das Board sehr schlecht ab.
    Habe es eine Weile mit top beobachtet - und die meiste Zeit schafft nur einer. Die anderen Professoren huldigen der modernen Team-Arbeit (Toll ein anderer machst).


    Gruß Geronimo

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Quote

    Original von geronimo
    Im Augenblick ist der Kleine völlig mit Kernelbau ausgelastet ;)
    Das hat mich auch überrascht. Ich hatte es so im Kopf gehabt, dass die Kernelorgie ein Test dafür wäre, wie gut die unterschiedlichen Prozessoren angesteuert werden ...
    Wenn das stimmt, dann schneidet das Board sehr schlecht ab.
    Habe es eine Weile mit top beobachtet - und die meiste Zeit schafft nur einer. Die anderen Professoren huldigen der modernen Team-Arbeit (Toll ein anderer machst).


    Dann gib ihnen doch etwas zu tun:

    Code
    1. make -j 4


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Quote

    Dann gib ihnen doch etwas zu tun


    ... und schon ist wieder der Projektleiter schuld :O


    P.S. Danke für den Tip! - nachdem ich wusste, dass es an mir liegt, habe ich auch den Parameter für make-kpkg gefunden :)

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

    The post was edited 1 time, last by geronimo ().

  • Moin,


    ich dachte ich probiers nomml mit dem Aufwachen ...


    BIOS:
    Suspend Mode [auto]
    ACPI 2.0 [Enabled]
    ACPI APIC [Enabled]


    Restore on power loss [Power on]


    wake von PCI(E) [Enabled]
    wake von PS/2 [Disabled]
    wake von RTC [Disabled]


    unter linux sieht das dann so aus (times.pl gibt die rtc aus, wenn ich keinen Parameter angebe, ansonsten wird ein Timer gesetzt):


    Code
    1. vnbox:/usr/local/src/times# date
    2. Fr 11. Dez 06:35:27 CET 2009



    ... und hier noch die rcS:


    Ich wäre auch für Tips dankbar, die mir aufzeigen, an welcher Ecke ich nach dem Problem suchen könnte. Bin an der Ecke völlig unterbelichtet.


    Gruß Geronimo

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Hallo,


    ich habe die Sache vorhin mal probiert - Wakeup funkcitoniert aus aus dem Soft Off. Dabei habe ich folgende Schritte durchgeführt:


    Um 11:01:04 fanden sich dann die ersten Einträge im syslog, der Rechner war also wieder wach.


    Die Bios-Einstellungen müssten Deinen entsprechen, verwendete Distribution ist Ubuntu 9.10. Lad Dir eventuell mal eine Live-CD runter und probiere es damit mal. Das BIOS ist die Version 0215 vom 04.09.09


    Grüße,
    Holger

    VDR 1-3: Zotac ZBox HD-ID42, yavdr-0.5
    VDR 4: AMD5900/Asus M3N-78, yavdr-0.5
    DVB-Empfang: Netceiver
    Storage: via NFS von separatem Fileserver

    [size=10]

    The post was edited 2 times, last by hsteinhaus ().

  • Hallo Holger,


    danke für Deine Geduld!


    Habe mir das image der neuen Ubuntu runter geladen, aber daraus einen bootbaren Stick zu basteln hat leider nicht geklappt. Ich hatte ein einfache Rezept, mit dem ich problemlos aus einem Stick eine Installations-CD machen konnte - aber bei ubuntu war es so, dass letzteres die iso-Datei nicht kopieren konnte.


    Wenn ich die CD-Emulation für den Stick aktiviere, kann das Teil nimmer davon booten :(


    Könntest Du mir vielleicht eine kernel-config posten?


    Wenn alle Stricke reißen muss ich eben mein HW-Wakeup Projekt vorziehen.
    Ärgern tut es mich aber schon. Extra das Teil gekauft, weil es tun sollte ...



    Gruß Geronimo

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

  • Servus,


    wenn ich mir das hier so ansehe,


    Quote

    Original von geronimo
    ...
    unter linux sieht das dann so aus (times.pl gibt die rtc aus, wenn ich keinen Parameter angebe, ansonsten wird ein Timer gesetzt):




    dann fällt mir auf, das Dein Script alles schön ausliest, auch das das 'Alarm Date' auf 12 steht, was dem Wert nach eigentlich der Monat wäre ;) Vielleicht wacht das Board ja morgen am 12.Dez. auf.
    Nur so'ne Idee. Wenn Du es heute schon probieren willst, solltest Du in Deinem Script mal Monat und Tag vertauschen, oder überprüfen, wie Du die Werte den Variablen zuweist, vielleicht ist da ja ein Dreher drinnen.


    Noch eine Möglichkeit wäre es, das BIOS einmal selbst das Board aufzuwecken, mit Datum und Uhrzeit Angabe. Danach WakeOnRTC wieder auf 'Disabled' und noch ma' probieren.


    Gruß
    OS/2

    Hardware: Asus Pundit, Celeron 2,4GHz, 1 x TT 1.5, 1 x Skystar2 2.6c, B&O Beolink 5000 an LIRC
    Software: verpanschtes LinVDR 0.7 mit mt20050414 Edition

  • Moin moin,


    ich sach nur KRASS, oder auch Crank III


    Habe heute morgen einen BIOS-reset durch geführt und wie gehabt: es klappt nicht.
    Dann habe ich mir ergurgelt, wie man Linux ein Suspensorium verpasst und ...
    ... siehe da: er wacht auf.


    Was ich aber am schärfsten finde, ist die Ausgabe von rtc nach dem wakeup:

    Ach ja, noch was crankes:
    Beim Einschlafen von dem Kleinen hängt sich die ssh-Session auf.
    Dachte ich zumindest, denn nach dem Aufwachen konnte ich weiter arbeiten, als wären wir nie getrennt gewesen. Puh - weiß nocht nicht, ob mir das gefällt :O


    Aber wenigstens klappt das Aufwachen jetzt. Muss ich mir nur das "halt" anders verlinken ...


    Eckdaten:
    Kernel: 2.6.32
    Weckzeit setzen: echo "Aufwachzeit in Sekunden" > /sys/class/rtc/rtc0/wakealarm
    schlafen legen: acpitool -S


    Dann kann ich ja mal anfangen, den VDR aufzusetzen ... :)


    Gruß Geronimo

    Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!