keni WakeUp bei Timer

  • Parameter dranhängen.
    Aber als Kurztest kannst Du den Link aus rc0.d auch erst einmal rausnehmen (verschieben in z.B. /root, dann kannst Du den Link später wieder reinschieben).
    So kannst Du erst einmal testen, ob Dein Problem etwas mit dem hwclock Aufruf zu tun hat.


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Gerade sehe ich Dein Script: Ist schon drin.


    Was mir noch einfällt. Fahr mal den vdr runter und boote mit Knoppix. Dann schaust Du, ob die Datei /var/cache/vdr/acpiwakeup.time vorhanden ist.


    Dann siehst Du zumindest, ob er überhaupt diese Datei erzeugt. Wenn nein, existiert das Problem schon beim vdr powerdown.

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

    The post was edited 1 time, last by beagle ().

  • Hat sich wohl überschnitten. Script ist OK soweit?


    Wenn ich die Verküpfung aus rc0.d lösche, und den VDR stoppe, wie oben beschrieben, ist /proc/acpi/alarm immer noch nicht korrekt beschrieben worden.


    Bzgl. Knoppix schaue ich morgen weiter. Vielen Dank erstmal für Deine Hilfe!

  • Ich habe doch vorhin schon erwähnt, daß das stoppen des vdr diesen Script nicht auslöst. Das macht erst der powerdown script, der aus vdr heraus aufgerufen wird.

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • moin moin,
    ich habe gerade mal bei nachgeschaut:
    Die /var/vache/vdr/acpiwakeup.time wird bei mir erzeugt, allerdings vom init script vdr-addon-acpiwakeup wieder gelöscht.
    Du kannst jetzt:
    a) mit knoppix booten
    b) im vdr-addon-acpiwakeup das löschen der datei acpiwakeup.time ausknipen
    (rm -f $wakeupfile.... auskommentieren)


    und schauen, ob diese Datei vdr-addon-acpiwakeup (bei b) nach dem nächsten booten) da ist:


    Dann kann man mal weiterschauen, in welche Richtunng Du suchen mußt.


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • So, da bin ich wieder.


    Ich habe die /etc/init.d/vdr-addon-acpiwakeup soweit modifiziert, dass ich die vorletzte Zeile (siehe unten)


    Code
    1. reset_wakeup_time()
    2. {
    3. echo "$NAME: Resetting wakeup time"
    4. # rm -f $WAKEUP_FILE >/dev/null 2>&1
    5. }


    auskommentiert habe. Dann habe ich auf der Konsole "poweroff" eingegeben, den Rechner danach wieder gestartet. Die Datei /var/cache/vdr/acpiwakeup.time ist nach dem Neustart nicht vorhanden.


    Knoppix lade ich gerade runter, dauert allerdings ein wenig. Das werde ich danach auch noch mal testen.


    Gruß,
    Christoph

  • Um dies zu testen, muss der vdr sich selbst oder über das osd heruntergefahren werden. Sonst wird der Powerdown script nicht aufgerufen. Dann kannst Du lange warten, bis er wieder aufwacht.
    Nur so funktionert das schreiben der Zeiten in ACPI.


    Gruss
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • das ist der /usr/bin/poweroffvdr.
    Dieser wird vom vdr selbst aufgerufen. Nur vdr kennt die Aufweckzeit und kann die entsprechenden Parameter auch übergeben.
    Wenn Du die Kiste also anders herunterfährst, wacht er natürlich auch nicht auf.
    Guck mal hier:
    http://www.vdr-wiki.de/wiki/index.php/SVDRP
    auf diesem Weg kannst Du ihn regulär herunterfahren. Notfalls halt mit: "HITK Power" oder so ähnlich


    Gruss
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Hervorragend! Wenn ich ihn so herunterfahre, existiert die acpiwakeup.time. Ob er dann auch anspringt, habe ich noch nicht getestet, das folgt im Laufe des Abends.


    Die Mahlzeit-Distribution konnte ich mit "poweroff" herunterfahren und der PC ist dann wieder ordnungsgemäß aufgewacht. Die c't Distribution muss anscheinend mit poweroffvdr heruntergefahren werden...


    Jetzt bin ich mal gespannt, ob er nach der Aufnahme auch wieder ausgeht.


    Vielen Dank beagle für Deine Hilfe!


    Gruß,
    Christoph