nvram wakeup version 0.96

  • Ich habe nvram-wakeup (Version 0.96) eingerichtet.
    Das Setzen der Uhrzeiten in nvram manuelle (nvram-wakeup -C /etc/nvram-wakeup.conf --directisa -s $((.....)) und das Hochlaufen
    mit der dadurch gesetzten Uhrzeit funktioniert hervorragend.


    Allerdlings zeigt ein Aufnahmetimer in Bezug auf nvram-wakeup keine Reaktion.
    make install, make clean, make install durchgeführt.
    Reboot Probelmatik ausgeschlossen.


    Wo liegt daas Problem?

  • Hi,


    Ich sage mal: Ein recht unglücklicher erster Beitrag...
    Der Newsbereich ist sicher nicht der richtige Ort, sowas zu Posten... Das könnte eher in die NVRam Sektion gehören... ;)


    Wichtig ist, dass beim Herunterfahren des VDRs auch der NVRam aufgerufen wird. Dafür sind Änderungen im Shutdown-Script nötig... Wie das geht steht allles genau in den Dokus von NVRam-Wakeup...


    Such einfach mal hier im Forum...


    MG-f


    Robsta


    Hardware: Antec Fusion Remote Black, Asus P5N7A-VM, E5200, Mystique SaTiX-S2 Dual V2, Stereo-Atmo
    TV: Samsung UE32B6000, BenQ W1070
    Software: yaVDR


  • Vielen Dank für die prompte Antwort.
    Ich habe inzwischen festgestellt, daß in der Varaiblen $1 von $NVRAMCMD ($NVRAAMCMD -ls $1 nichts drin steht, deshalb gibt es bei Ausführung des vdrshutdownskripts eine Fehlermeldung: fehlender Paramete -s. Ich denke, daß in $1 der Timerwert stehen müsste.


    Was ist die Ursache?


    Mein Board Asus Cusl2c funktioniert nur mit RTC= ON in der nvram-wakeup.conf. Es müssen (können) keine Adresswerte angegeben werden.

  • hi,


    ich glaube ich erkär mal was eigentlich passieren soll


    du startest vdr mir dem parameter -s (ver such mal 'man vdr' auf der konsole), damit weis vdr das wenn auf der remote powerdown gedrückt wird (oder inaktivity timeout erreicht ist) es dieses script aufrufen soll, wenn vdr das macht übergibt es die zeit des nächsten timers als parameter an das script


    hier endet die funktion/aufgabe von vdr in diesem zusammenhang


    in dem script wird dann mit nvramwakeup die startzeit gesetzt und der rechner mittels shutdown heruntergefahren

  • Hallo,


    das geht ja furchtbar schnell.
    Die Option -s ist bereits eingerichtet. Allerdings fruchtet shutdown nicht, da die Fehlermeldung "settime benötigt Parameter" (in $nvramcmd --settime $1 -- syslog .....) erscheint. Es sieht so aus, daß hier nichts übergeben wird
    Keine Ahnung was hier falsch ist.

  • Das Problem ist gelöst. Ich habe im vdrshutdown-skript den Verweis auf die nvram-wakeup.conf eingetragen und den Rechner über die Fernbedienung des vdr-rekorders ausgeschaltet. Die Timer-Daten wurden so in das NVRAM eingetragen. Die Hinweise im Forum haben mich auf den richtigen Weg gebracht. Danke!


    Ich füge diesem Beitrag die nvram-wakeup.conf für ein Asus Board CUSL2-C bei.

  • Quote

    Original von scharteli


    Ich füge diesem Beitrag die nvram-wakeup.conf für ein Asus Board CUSL2-C bei.


    und das funktioniert? Ich haette erwartet, dass nach dem aendern des Status das BIOS
    auf defaultwerte zurueckgesetzt werden wuerde.


    und das ist meiner meinung nach die richtige Konfiguration:

    Code
    rtc_time         = ON
    addr_stat        = 0x56
    shift_stat       = 4
    rtc_day          = 0x7F
    reset_day        = ON
    addr_chk_h       = 0x6C
    addr_chk_l       = 0x6D

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!