Ansible - Fernbedienung funktioniert nicht nach jedem Neustart ...

  • Obwohl yaVDR-Ansible ansonsten anstandslos seinen Dienst versieht, kommt es immer mal wieder vor, dass nach dem Einschalten die Fernbedienung nicht funktioniert.

    Ich poste mal einen Auszug aus /var/log/syslog.


    Das Einschalten beginnt in Zeile Oct 27 20:17:16 localhost systemd-modules-load[384]: Inserted module 'iscsi_tcp'

    https://pastebin.com/736LYg3V

    Dann haben wir festgestellt, dass die FB nicht funktioniert und den Hardware-Reset-Button gedrücktOct 27 20:18:09 localhost systemd-modules-load[384]: Inserted module 'iscsi_tcp'

    Danach funktioniert die FB wie gewohnt.

    https://pastebin.com/UnzdDXEH


    Woran kann das liegen?

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Kann es sein, dass du da lircd nicht deaktiviert hast?

    Was liefert

    Code
    1. systemctl status lircd.service lircd.socket
    2. ps aux | grep lirc

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Code
    1. systemctl status lircd.service lircd.socket
    2. ● lircd.service
    3. Loaded: masked (/dev/null; bad)
    4. Active: inactive (dead)
    5. ● lircd.socket
    6. Loaded: masked (/dev/null; bad)
    7. Active: inactive (dead)


    Code
    1. ps aux | grep lirc
    2. root 836 0.0 0.0 20352 1992 ? Ss 18:40 0:00 /usr/bin/irexec /etc/lirc/irexec.lircrc
    3. root 854 0.0 0.0 11144 2204 ? Ss 18:40 0:00 /usr/sbin/eventlircd -f --socket=/var/run/lirc/lircd
    4. vdr 2101 0.0 0.0 20352 2040 ? Ss 18:40 0:00 /usr/bin/irexec /var/lib/vdr/.lircrc
    5. davie2000 3276 0.0 0.0 14780 1004 pts/1 S+ 18:41 0:00 grep --color=auto lirc

    Service ist inaktiv, Prozess läuft aber trotzdem???


    Ich habe bzgl. LIRC bisher überhaupt gar nichts bewusst gemacht oder umgestellt.

    Außer, dass ich in /yavdr-ansible/roles/yavdr-desktop/templates die Datei .lircrc.j2 geändert und KEY_HOME durch KEY_PROG2 ersetzt habe, nach deiner tatkräftigen Unterstützung damals.

    Achja: und ich verwende eine eigene Keymap in /yavdr-ansible/roles/yavdr-remote/templates/rc_maps.cfg.j2.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Darf ich das Thema bitte nochmal in Erinnerung rufen? Das Problem besteht nämlich nach wie vor.


    Sollte ich den lircd überhaupt deaktivieren?

    Warum hat das Ansible dann nicht gemacht?

    Bzw. warum ist lircd überhaupt aktiv?

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD