Skin nopacity träge

  • Ich habe gerade mal meinen Test-VDR in Richtung nutzbar getrieben, damit ich meine alten VDR zum Testen nutzen kann.

    Ich wollte es ein wenig hübscher haben und habe mal wieder das nopacity Skin probiert, Probleme hatte ich damit schon immer.

    Der VDR stürzte ab (vdr-sxfe) z.B:


    Code
    1. Jan 27 11:47:51 vdr kernel: [42521.183066] vdr-sxfe[11904]: segfault at 7f271a179e08 ip 00007f273053b3c0 sp 00007f272b563a58 error 4 in libc-2.19.so[7f273040c000+1a1000] Jan 27 11:47:51 vdr vdr: [11894] [xine..put] Client connection 0 closed


    Gerade läuft alles "gut", wenn ich aber das Menu öffne, dann erscheint das Menu mal länger, mal kürzer und wird dann unsichtbar (Kann auch beim Scrollen passieren und ist nicht das verschwinden nach einer Minute nichts tun! ;) ) Wenn ich dann runter scrolle erscheinen die Menupunkte.

    CPU Auslastung bei 0,7%, vdpau hilft da vermutlich kräftig mit!?

    Meine Suche hat bis jetzt keine Ergebnisse geliefert.

    Plugin Version ist 1.1.3, e-tobi Quellen, Windowmanager ist icewm-lite

    Hat jemand einen Hinweis wo ich drehen kann?

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

  • Lustige Sache! Als ich vor 9h den Post los schickte war alles in Ordnung, bis auf das Problem mit dem Skin. Dann bin ich zu einer Feier...

    Als ich wiederkam machte Skinelchi(?) einen Segfault, obwohl nopacity aktiv.

    Programm vdr Neustart mittels "service vdr start / stop" keine Besserung, Rechner Neustart keine Besserung. Skinelchi deinstalliert, keine Besserung. Skinnopacity deinstalliert, vdr läuft. Allerdings wird mir garkein OSD mehr angezeigt. Im log erscheint allerdings eine Bandbreitenmeldung für das OSD.

    VDPAU findet auch kein Device mehr. Ich bin mir Sicher das ich vorhin, nach dem Neustart, nichts geändert hatte.


    Die Suche geht weiter, wenigsten geht das live Plugin noch!

    Hier was unmittelbar passierte:

    Code
    1. an 27 18:46:54 vdr vdr: [4794] starting plugin: skinenigmang
    2. Jan 27 18:46:54 vdr vdr: [4794] starting plugin: skinnopacity
    3. Jan 27 18:46:54 vdr rsyslogd-2177: imuxsock begins to drop messages from pid 4794 due to rate-limiting
    4. Jan 27 18:46:56 vdr recordingaction: executing /usr/share/vdr/recording-hooks/R90.custom before recording /var/lib/video/BBC_Exclusiv/Hunde_-_Eine_faszinierende_Tierfamilie/2018-01-27.18.03.312-0.rec a
    5. s shell script
    6. Jan 27 18:46:56 vdr kernel: [ 209.252580] vdr[4794]: segfault at 28 ip 00007f8ff4f40bcc sp 00007fffd5932c20 error 4 in libvdr-skinelchi.so.2.2.0[7f8ff4ee9000+6d000]
    7. Jan 27 18:46:57 vdr runvdr: restarting VDR

    Kleiner Erfolg, OSD ist wieder da, alte Config eingespielt, ich vermute das die Farbtiefe mit "True Color" nicht mehr passte.

    Vdpau geht nun auch wieder. libvdpau1 (1.1-1) anstelle von (0.8*) und alles ist gut. Jetzt werde ich noch mutig und spiele die elchi und nopacity wieder ein und gucke was passiert.

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

    The post was edited 2 times, last by hurtme ().