[gelöst] Kein ACPI wakeup nach Neuinstallation auf Debian Stretch

  • Hallo, liebes Forum,


    vielleicht (bestimmt) könnt Ihr mir wieder mal helfen. Ich habe ca 2. Jahre einen VDR auf einem Elitegroup A780GM-A laufen. Jetzt habe ich den vdr neu aufgesetzt mit Debian Stretch mit systemd. Die alte Installation steht noch zur Verfügung als Referenz.

    Mit der alten Installation wacht das Board


    Code
    1. echo 0 > /sys/class/rtc/rtc0/wakealarm
    2. echo 1514806200 > /sys/class/rtc/rtc0/wakealarm

    wie gewünscht auf. Bei der Neuen tut sich schlicht nichts. Debian läuft auf UTC, Bios-Uhr ist eine Stunde zurück. Heruntergefahren habe ich das Board mit


    Code
    1. shutdown -h now und
    2. systemctl hibernate oder
    3. systemctl suspend (jeweils testweise)


    Hat jemand eine Idee?

    Danke schon mal im Voraus.

  • Debian läuft auf UTC, Bios-Uhr ist eine Stunde zurück.

    Das BIOS sollte immer mit UTC laufen.


    Aber nehmen wir mal an, das wäre der Fall:

    Dann wäre deine Systemzeit jetzt z.B. 11:52:00 und dein BIOS wäre bei 10:52:00 - dann musst du noch warten, damit das um 12:30 Uhr aufwacht...

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Vielen Dank, seahawk1986,


    ich habe brav noch eine Stunde gewartet, aber er wacht nicht auf. Meines Wissens unterscheidet sich aber auch die Systemzeit von der Bioszeit, da ja UTC die allgemeine Zeit ist.


    Nichts desdo trotz gibt ein


    und das ist so ziemlich das gleiche wie bei der alten Installation. :(

    Noch irgendjemand eine Idee?

  • Meines Wissens unterscheidet sich aber auch die Systemzeit von der Bioszeit, da ja UTC die allgemeine Zeit ist.

    Also normalerweise sollte das so aussehen:

    Die RTC läuft in UTC, das System nutzt für die Anzeige die eingestellte Zeitzone - das wäre hierzulande im Winter CET aka MEZ, wie einem z.B. date verrät:

    Code
    1. $ date
    2. Mo 1. Jan 14:18:32 CET 2018
    3. $ date -u
    4. Mo 1. Jan 13:18:35 UTC 2018
    5. $ date +%s
    6. 1514812723


    Probier es mal mit relativen Zeitangaben:

    Code
    1. echo 0 > /sys/class/rtc/rtc0/wakealarm
    2. echo $(date -d "now +10 min" +%s) > /sys/class/rtc/rtc0/wakealarm
    3. poweroff

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich habe den Fehler gefunden: Kernel Parameter!

    Die waren vom System wie folgt gesetzt:


    Code
    1. GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    2. GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi=noirq"

    und ich habe diese abgeändert in:


    Code
    1. GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    2. GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    3. GRUB_CMDLINE_LINUX="hpet=disable"

    danach lief es dann. Ich hätte nur in meiner alten Installation nachschauen müssen. Aber man muss ja erst mal drauf kommen, das es an den Kernelparametern liegt.

    Vielen Dank, seahawk1986, für deine Antwort.

  • Ja, aber "hpet" ist schon lange bekannt als ACPI Wakeup "Killer" ...

    HowTo: APT pinning