[gelöst] Fernbedienung geht nicht mehr auf Openelec XBMC 3.2.1 Frontend auf Raspberry

  • Hallo!
    Ich suche kompetente und verständliche Hilfe bei euch zum Thema wie ich meine IR Fernbedienung am Raspberry OpeneElec XBMC 3.2.1 wieder zum laufen bringe.
    Mir ist klar dass es google gibt, und sehr viele Foren, aber ich bitte hier um eine Erklärung als wenn Ihr neben mir sitzen würdet. Ich blick einfach nicht mehr durch was ich in welcher Reihenfolge zu tun habe.


    Ich verwende einen Zotac Rechner als Backend und einen Raspberry mit Openelec 3.2.1 als Frontend (xvdr) - da ich keinen Flatscreen mit HDMI oder ähnlichem habe


    Seit den letzten beiden upgrades von openelec geht Fernbedienungsmäßig gar nichts mehr (habe diesen Technotrend USB Empfänger) - hat aber schon mal funktioniert.


    Der Empfänger wird in Openelec 3.2.1 erkannt. An dem liegts also nicht. Komisch ist dass ich lirc0 UND lirc1 als devices habe .... keine Ahnung ob das vorher auch so war.


    Um was ich zu allererst bitte ist mal eine zeitliche Abfolge, was ich wann tun oder nachsehen sollte, denn ehrlich gesagt weis ich nicht mehr wie ich die Fernbedienung zuvor zum laufen gebracht habe. Ich weis nur irw und irrecord haben mal funktioniert - jetzt bleiben beide ergebnislos.
    in vielen Foren steht leider nur etwas von XBMC auf einem normalen Rechner und nicht am Raspberry, drum ist das auch wieder recht unbrauchbar, da manche configfiles am Raspberry gar nicht exisiterien.


    Wäre super wenn sich der ein oder andere die Zeit nehmen könnte mit dem ich das Problem lösen könnte.


    Vielen Dank und lG
    FTF

    YAVDR 0.5


    Linux tvserver 3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


    DVB-C (Technotrend TT-connect CT-3650); DVB-T (Realtek RTL2832U); DVB-S2 (DVBSky S960)


    vdr (2.0.3/2.0.0); epgfixer (0.3.1); dummydevice (1.0.3); graphtftng (0.4.1); dynamite (0.1.5); quickepgsearch (0.0.1); skinpearlhd (0.0.1); xine (0.9.4); dvbhddevice (2.0.2); vdrmanager (0.9); xvdr (0.9.9); pvr350 (1.7.4); dvbsddevice (2.0.1); epgsearchonly (0.0.1); xineliboutput (1.0.90-cvs); channellists (0.0.5); iptv (2.0.0); live (0.3.0); softhddevice (0.6.1rc1); restfulapi (0.1.2); streamdev-server (0.6.0-git); autostart (0.9.3); extrecmenu (1.2.3-git); vnsiserver3 (0.9.1); text2skin (1.3.2+git); conflictcheckonly(0.0.1);
    menuorg (0.5.1); wirbelscan (0.0.7); femon (2.0.0); epgsearch (1.0.1.beta5); markad (0.1.5pre); dbus2vdr (17)

    The post was edited 1 time, last by FTF ().

  • Und was sagen die Entwickler im OpenElec-Forum?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • dort hab ich auch grade gepostet.


    Dachte ich frag hier mal - vielleicht hat jemand das selbe Problem.
    Sollte ich was brauchbares erfahren poste ich es hier selbstverständlich. Aber vielleicht ist jemand anderer schneller ;-)

    YAVDR 0.5


    Linux tvserver 3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


    DVB-C (Technotrend TT-connect CT-3650); DVB-T (Realtek RTL2832U); DVB-S2 (DVBSky S960)


    vdr (2.0.3/2.0.0); epgfixer (0.3.1); dummydevice (1.0.3); graphtftng (0.4.1); dynamite (0.1.5); quickepgsearch (0.0.1); skinpearlhd (0.0.1); xine (0.9.4); dvbhddevice (2.0.2); vdrmanager (0.9); xvdr (0.9.9); pvr350 (1.7.4); dvbsddevice (2.0.1); epgsearchonly (0.0.1); xineliboutput (1.0.90-cvs); channellists (0.0.5); iptv (2.0.0); live (0.3.0); softhddevice (0.6.1rc1); restfulapi (0.1.2); streamdev-server (0.6.0-git); autostart (0.9.3); extrecmenu (1.2.3-git); vnsiserver3 (0.9.1); text2skin (1.3.2+git); conflictcheckonly(0.0.1);
    menuorg (0.5.1); wirbelscan (0.0.7); femon (2.0.0); epgsearch (1.0.1.beta5); markad (0.1.5pre); dbus2vdr (17)

  • dort hab ich auch grade gepostet.


    Cross postings mag ich gar nicht. Beantworte dort doch erstmal die Fragen.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Hallo,
    wie versprochen melde ich die Lösung meines Problems.
    Aus meiner Erfahrung empfehle ich eine komplette Neuinstallation und kein upgrade des Openelec XBMC für Raspberry.
    Es schein dass beim update einiges an nicht mehr verwendeten Dateien über bleiben die stören könnten.


    Da es sich bei mir um einen USB TechnoTrend IR Receiver handelt, bei dem sowohl der USB Empfänger als auch eine Fernbedienung dabei war, glaube ich dass mir das bei der Lösungsfindung zu Gute kam.
    Der Empfänger wurde stets sofort erkannt und installiert.
    Das Registered IR keymap war auch immer "rc-tt-1500"
    Nur die Fernbedienung selbst löste keine Reaktion im Openelec XBMC aus.


    Beim troubleshooten bin ich draufgekommen, dass kein Protokoll im Keytable geladen wurde.

    Code
    1. ir-keytable
    2. Found /sys/class/rc/rc0/ (/dev/input/event0) with:
    3. Driver ttusbir, table rc-tt-1500
    4. Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC other
    5. Enabled protocols:
    6. Repeat delay = 1000 ms, repeat period = 125 ms


    Das fand ich bereits raus als ich noch auf der upgedateten Installation den Fehler suchte.


    Auf der neu installierten Version hab ich jedoch ebenfalls gesehen, dass hinter der keytable kein aktiviertes Protokoll gab.


    Als ich dies mal beheben wollte, nämlich mit dem folgenden Kommando

    Code
    1. ir-keytable -pRC-5


    nur um mal alle möglichen Protokolle durchzugehen und zu sehen ob es einen Output bei einem der Protokolle gibt,
    funktionierte plötzlich alles ohne weiter konfig von remote.xml oder lirc.conf oder oder oder...


    Das einzige was ich erstellte war eine autostart.sh im Verzeichnis /storage/.config um eben die aktivierung des Protokolls beim booten zu erledigen:

    Code
    1. ir-keytable -pRC-5


    Fazit: Fernbedienung läuft super, ohne Tastenprellen oder sonstige Effekte.


    Leider ist das ganze Zusammenspiel von Config Dateien und Übersetzungsdateien noch dazu mit der Info wann man was braucht und wie editieren muss,
    leider nicht nachvollziehbar dokumentiert.


    Ich hoffe diese Meldung hilft dem ein oder anderen


    herzlichen gruß
    FTF

    YAVDR 0.5


    Linux tvserver 3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


    DVB-C (Technotrend TT-connect CT-3650); DVB-T (Realtek RTL2832U); DVB-S2 (DVBSky S960)


    vdr (2.0.3/2.0.0); epgfixer (0.3.1); dummydevice (1.0.3); graphtftng (0.4.1); dynamite (0.1.5); quickepgsearch (0.0.1); skinpearlhd (0.0.1); xine (0.9.4); dvbhddevice (2.0.2); vdrmanager (0.9); xvdr (0.9.9); pvr350 (1.7.4); dvbsddevice (2.0.1); epgsearchonly (0.0.1); xineliboutput (1.0.90-cvs); channellists (0.0.5); iptv (2.0.0); live (0.3.0); softhddevice (0.6.1rc1); restfulapi (0.1.2); streamdev-server (0.6.0-git); autostart (0.9.3); extrecmenu (1.2.3-git); vnsiserver3 (0.9.1); text2skin (1.3.2+git); conflictcheckonly(0.0.1);
    menuorg (0.5.1); wirbelscan (0.0.7); femon (2.0.0); epgsearch (1.0.1.beta5); markad (0.1.5pre); dbus2vdr (17)