Posts by FTF

    Hallo Leute,
    ich komm erst jetzt dazu euch zu antworten.
    Vielen Dank für eure Hinweise und Tipps.
    Wie von mir schon angenommen hat meine Anfrage kein technisches Problem als Grundlage sondern eher wie ich den VDR am geschicktesten konfiguriere.
    Ich muss mich mal mit den Kanalgruppen beschäftigen, da es mir scheint, der Beste Weg zu sein um Aufnahmen zu steuern.
    Was ich heute schon mache ist, die mehrfachen Timer einer Sendung zu deaktivieren, anstatt diese zu löschen. Das hilft in jedem Fall einen kleinen Schritt weiter.
    Ich denke meine Anfrage ist somit beantwortet und ich werd mal grübeln und testen wie ich die channels.conf sortiere und grupiere.
    vielen Dank für die Inputs, ich setze den Beitrag auf gelöst.

    Hallo Hepi,
    Danke erstmal für Deine Gedankenstütze!
    Es leuctet mir ein, dass eine Sendung mit dem gleichen Inhalt (Titel) auf zwei unterschiedlichen Kanälen, für den VDR unabhängig sind.
    AAABER: Ich programmiere nicht selbst sondern lasse, anhand von Schauspielernamen mittels EPG Search, die Timer automatisch setzen.
    Wenn nun ein Adapter belegt ist - gut. dann würde auch kein Timer gesetzt werden - so meine Annahme.


    Wenn nun aber im nächsten EPG Suchlauf aufscheint, dass auf einem anderen Adapter, der frei ist, ein EPG Treffer (müßte ja sein, da die gleiche Sendung, mit den gleichen Schauspielernamen) vorhanden ist, dachte ich, dass ein Timer gesetzt wird.

    Liebe Forenmitglieder,
    Da ich weder mit google noch in diesem Forum zu meinem Thema fündig geworden bin, habe ich mich doch entschlossen nachzufragen.
    Mein System (YAVDR auf aktuellem Stand - ohne experimentellen Paketen oder selbst gestrickten Dingen) läuft mit 4 USB DVB Adaptern.


    Einem Tevii S660 DVB-S2 USB Adapter
    Einem DVBSky S960 DVB-S2 USB Adapter
    Einem Technotrend TT-3650CI DVB-C USB Adapter
    und einem Cynergy DVB-T USB Stick


    Ich betreibe YAVDR im Headless Betrieb und als Streaming Client verwende ich einen Raspberry PI und der aktuellen OpenElec Version mit XBMC
    Alles funktioniert so weit gut, ausser das ich ich hie und da den VDR Rebooten muss da kein Stream am XBMC "ankommt".


    Meine Frage bezieht sich jedoch darauf, wie ich dem VDR beibringen kann, dass er bei Sendungen die zeitgleich auf unterschiedlichen Sendern laufen, und aufgenommen werden sollen, nicht den selben Adapter nimmt (somit ist entweder eine Sendung aufgenommen und eine nicht oder es sind beide mit "0" Minuten in der Liste der aufgenommenen Sendungen) - sondern einen anderen, freien Adapter, auf dem die selbe Sendung zu empfangen ist. Da ich 4 Adapter habe und minimum auf 3, maximum auf 4 Adaptern die selben Sender empfangen werden, hätte der VDR genügend Auswahl.


    Ich hoffe dass ich meine Frage verständlich formuliert habe und hoffe weiters auf gute Tipps von euch.
    lG
    FTF

    Hallo,
    Ich habe durch Zufall ein merkwürdiges Phänomen.
    Bei mir hängen an einer Dual LNB SelfSat H30D2 einmal ein HD Reveiver und einmal die USB DVB-S2 Box (siehe Signature) am VDR.
    Das Phänomen äussert sich so, dass der HD Receiver läuft und sobald die USB-DVB-S2 Box aktiv wird (nach reboot zum Beispiel), habe ich weder am HD Receiver noch am VDR ein Bild.
    Dreh ich den VDR ab, starte den HD Receiver neu - Bild am Receiver wieder ok
    Dreh ich den Receiver ab und starte den VDR neu - Bild über den VDr wieder ok


    Nur beide zusammen gehen nicht....
    Die Antenne hat 2 vollwertige LNB Anschlüsse .... dachte ich???


    Kennt das jemand?


    Danke für Hinweise


    lG FTF

    Hallo Hepi,
    Ich hab grad den Thread gefunden un auf ein super interessantes Kommentar von Dir gestoßen:


    3) Wir bieten bestmöglichen Kerneltreiber-Umfang. Mit yaVDR 0.5 kann man
    sich aussuchen, ob man Kernel 3.2, 3.5 oder 3.8 nutzt. Zudem kann man
    sich entscheiden, Kernel 3.2 mit linux-media-dkms aufzubohren oder
    Kernel 3.2 mit media-build-experimental. Das ist eine sehr große
    Vielfalt an Optionen. Wenn Du Dir trotzdem eine Karte kaufst, die mit
    diesen Optionen nicht unterstützt wirst, bist Du auf Dich allein
    gestellt.


    Bitte sei so nett und erklär mir kurz wie ich die unterschiedlichen Kernels aussuchen kann? (oder ist es eh mit sudo apt-get install "kernel 3.8")
    was meinst Du mit "media-dkms aufbohren"? Was bringt das und wie mach ich das?
    deto meine frage wie ich das mache mit "Kernel 3.2 mit media-build-experimental"


    vielen lieben Dank wenn DU mir das ausführen könntest!


    Danke und lG
    FTF

    Hallo,
    Mein Setup (in der Signature) läuft mit YaVDR 0.5 - der aktuellen Version.
    Nun habe ich das Problem dass immer wieder eine Quelle (habe 3 - DVB-S, DVB-T und DVB-C) nicht -richtig - funktioniert (sprich kein Bild und kein Ton) aber EPG schon.


    Die Installation läuft bei mir so ab, dass ich YaVDR ganz normal installiere.
    Damit läuft dann mal die TechnoTrend TT-connect CT-3650 CI für DVB-C (wird vom 3.2er Kernel plug and play unterstützt)
    Treiber ist dann entweder dvb-ttusb-budget oder tt-dvb-usb2 (weis ich jetzt nicht genau auswendig)


    für den DVB-T USB Stick installiere ich dann den Kernel 3.8 (sudo apt-get install linux-image-3.8.0-31-generic).
    Der funktioniert dann auch nach dem reboot


    Nun habe ich jedoch 2 DVB-S2 USB devices (die (noch) nicht gleichzeitig an dem YaVDR hängen) die ich aber folgendermaßen installieren muss


    1. Tevii DVB-S2 USB Box (S660)
    Download Firmware und in /lib/firmware kopieren - ok
    Download Demod Firmware und in /lib/firmware kopieren - ok
    lediglich die "dvb-fe-ds3000.fw" wird nicht zusätzlich von der Tevii Box geladen wird (obwohl in /lib/firmware vorhanden) - schein aber nicht zu stören
    Treiber - ist ein Link auf s2-liplianin-v39 (installiert sich wie das media-build v4l) - ist auch ok, und DVB-S funktioniert dann auch


    2. DVBSKy S960 DVB-S/S2 USB
    Download Firmware und in /lib/firmware kopieren - ok
    Treiber - ist ein Link auf die DVBSky Seite und man lädt das v4l media_build-bst-130806 runter - ist auch ok und DVB-S funktioniert dann auch


    Das Problem bei der ganzen Sache ist, dass sobal ich mit den media-bilds anfange die DVB-C Box Treiber (dvb-ttusb-budget oder tt-dvb-usb2) offenbar gelöscht werden und ausserdem meine ich, dass ich durch die unterschiedlichen Media Build versionen einmal die eine DVB-S und dann wieder die andere in Ihrem Treiber negativ beeinflusse (sprich verändere) - Anmerkung hier (die Adapter sind alle 3 vorhanden und werden auch geladen


    Könnt Ihr mir helfen eine Methodik zu finden wie ich alle Geräte gemeinsam und gleichzeitig - mit den richtigen Treibern - betreiben kann??
    Mach ich irgendwas falsch in der ganzen Installations Prozedur?


    Danke und lG
    FTF

    Hallo!
    Ich habe aktuell (unter anderem) das Problem dass DVB-S2 Kanäle nur kurz nach einem YaVDR Reboot am Streaming Client angezeigt werden. Nach gefühlten 15-20 minuten klappt es gar nicht mehr.
    Mein Setup ist in der Signatur.


    Das logging zeigt einen Kanal auf DVB-S2 der am TV jedoch nicht angezeigt wird - danach wird auf DVB-T umgeschalten mit Bild und Ton - danach wieder zurück auf DVB-S2 wieder ohne Bild und Ton



    hat jemand Ansatzpunkte wo ich troubleshooten kann?


    Danke und herzliche Grüße
    FTF

    Hallo!
    Ein merkwürdiges Phänomen plagt mich aktuell.
    Zu aller erst mein Setup:


    Mein YaVDR läuft im headless mode. ich streame auf einen Raspberry mit openelec XBMC version 3.2.3 (mittels xvdr pvr plugin)


    OS:

    Code
    Linux tvserver 3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


    DVB-C (Technotrend TT-connect CT-3650)
    DVB-T (Realtek RTL2832U)
    DVB-S2 (DVBSky S960)


    SW Versionen:
    vdr (2.0.3/2.0.0) - The Video Disk Recorder
    epgfixer (0.3.1) - Fix bugs in EPG
    dummydevice (1.0.3) - Output device that does nothing
    graphtftng (0.4.1) - VDR OSD on TFT
    dynamite (0.1.5) - attach/detach devices on the fly
    quickepgsearch (0.0.1) - Quick search for broadcasts
    skinpearlhd (0.0.1) - PearlHD Skin
    xine (0.9.4) - Software based playback using xine
    dvbhddevice (2.0.2) - HD Full Featured DVB device
    vdrmanager (0.9) - VDR-Manager support plugin
    xvdr (0.9.9) - XVDR Server
    pvr350 (1.7.4) - PVR350 as output device
    dvbsddevice (2.0.1) - SD Full Featured DVB device
    epgsearchonly (0.0.1) - Direct access to epgsearch's search menu
    xineliboutput (1.0.90-cvs) - X11/xine-lib output plugin
    channellists (0.0.5) - Manage your channellists
    iptv (2.0.0) - Experience the IPTV
    live (0.3.0) - Live Interactive VDR Environment
    softhddevice (0.6.1rc1) - A software and GPU emulated HD device
    restfulapi (0.1.2) - Offers a RESTful-API to retrieve data from VDR
    streamdev-server (0.6.0-git) - VDR Streaming Server
    autostart (0.9.3) - Start a plugin automatically
    extrecmenu (1.2.3-git) - Extended recordings menu
    vnsiserver3 (0.9.1) - VDR-Network-Streaming-Interface (VNSI) Server
    text2skin (1.3.2+git) - Loader for text-based skins
    conflictcheckonly (0.0.1) - Direct access to epgsearch's conflict check menu
    menuorg (0.5.1) - Reorganizes the main menu
    wirbelscan (0.0.7) - DVB and pvrinput channel scan for VDR
    femon (2.0.0) - DVB Signal Information Monitor (OSD)
    epgsearch (1.0.1.beta5) - search the EPG for repeats and more
    markad (0.1.5pre) - Mark advertisements
    dbus2vdr (17) - control vdr via D-Bus


    Nun zum Thema:
    An sich läuft 90% gut, leider gibt es 2 Probleme bei denen ich mich aktuell ausser Stande sehe diese zu lösen (auch mit intensivem googlen)
    dies ist der thread zum ersten Problem.


    Das erste Problem ist eine Fehlermeldung

    Code
    imuxsock begins to drop messages from pid 1196 due to rate-limiting


    diese erscheint wenn ich den ersten Kanal des YaVDR anwähle - ohne Bild und ohne Ton. Schalte ich weiter auf den zweiten, kommt normal das Bild.
    Empfangsstärke kann es nicht sein, da die ersten Sender per DVB-C kommen.
    Bzgl Transponder kann ich auch gleich sagen, da die ersten Sender am selben Transponder liegen


    Code
    ORF1;ORF:306000:M256:C:6900:160=2:161=deu@3;163=deu@106:165:0:13001:1:1117:0
    ORF2;ORF:306000:M256:C:6900:500=2:501=deu@3;503=deu@106:505:0:13002:1:1117:0
    ORF2 W;ORF:306000:M256:C:6900:500=2:501=deu@3;503=deu@106:505:0:13003:1:1117:0
    ORF2 N;ORF:306000:M256:C:6900:500=2:501=deu@3;503=deu@106:505:0:13004:1:1117:0


    Das gesamte logging sieht dabei so aus (syslog)



    umschalten auf den zweiten Kanal (selber DVB-C Transponder)




    hat jemand von euch einen hinweis wonach ich ausschau halten soll in welchem logging?


    Danke FTF

    Hallo Doktor und Mini!
    Bei genau dem Link hab ich gestern kehrt gemacht und mich für die "rename" variante entschieden...
    Ich bin zwar kein Scripter/Programmierer aber bei dem Befehl

    Code
    ACTION=="add", SUBSYSTEM=="dvb", ENV{DVB_DEVICE_TYPE}=="frontend", ENV{DVB_DEVICE_NUM}=="1", ATTRS{serial}=="LHKEBJ", ENV{dynamite_attach}="no"


    fehlt mir eben die Abbildung dass ich den Adapter0 am Frontend1 ansprechen möchte.


    Da ich nicht wußte wie ich die Adapternummer UND die Frontend Nummer in ein Kommando bekomme hab ich mich für die andere Variante entschieden.


    FTF

    Spät aber doch ein update hier.
    Der vorgeschlagene Thread von Dr. Seltsam war im ersten Schritt eine Hilfe, jedoch leider nicht die Lösung.
    Mit der Methodik des alten Threads hab ich feststellen müssen, dass beide Frontends, also DVB-C und DVB-T die selbe Seiennummer haben. Alles ist gleich.
    Da ich mich selbst mit den udev Geschichten nicht auskenn, welche Parameter man wie ansprechen kann, und da eben beide Frontends, nach den im Thread angegebenen Parametern nicht unterscheidbar waren, habe ich weiter gesucht und eine Methode gefunden die total einfach aber effektiv ist. DIe Methodik ist sogar im VDR Wiki beschrieben - Link dorthin
    kurz hier nochmal zusammengefasst:


    Code
    nano /usr/bin/renamefrontend00

    angelegt


    Darin den folgenden Code

    Code
    mv /dev/dvb/adapter0/frontend1 /dev/dvb/adapter0/frontend1.disabled


    Eine udev Regel erzeugt mit

    Code
    nano /etc/udev/rules.d/44-dvbrename.rules


    und darin den folgenden Code

    Code
    ACTION=="add", KERNEL=="dvb0.frontend1", RUN+="/usr/bin/renamefrontend00"


    damit bekomme ich mit

    Code
    ls /dev/dvb/adapter0/


    zwar wieder 2 Frontends, aber nur ein verwendbares - nämlich das frontend0
    Das frontend1 heißt nun frontend1.disabled und wird somit nicht mehr angesprochen


    ein anschließendes DVB-T w_scan ohne Angabe eines Adapters und Frontends wurde vom DVB-T Stick durchgeführt und nicht vom DVB-T Teil der CT-3650 Box.


    Funktioniert somit für mich und bedanke mich für die Hinweise und Hilfe!!!


    lG FTF

    Hallo Seahawk,
    Vielen Dank für Deine super rasche Antwort! So einfach kann es manchmal gehen. Hast mir ja schon ein paar mal geholfen ;)


    Eines was mir dazu noch einfällt, weil auch demnächst ein DVB-S USB Empfänger dazu kommt.


    Wenn ich den Adapter beim w_scan angebe dann sollten die Adapter immer in der selben Reihenfolge beim booten installiert werden?
    Muss ich hier etwas beachten, sprich manuell festlegen, oder ist es automatisch immer die selbe Reihenfolge?
    Oder spielt die Reihenfolge gar keine Rolle?


    Danke nochmals


    lG
    FTF

    Hallo,
    Leider habe ich nichts im Forum oder Internet gefunden dass mich einer Lösung näher bringt.
    Folgende Konfiguration habe ich.
    Einen YAVDR 0.5 auf Letztstand.
    Dran hängt ein USB TT-connect CT-3650 CI (ein DVB-C und ein DVB-T Receiver in einer Box - allerdings kann immer nur einer der Beiden verwendet werden)
    Diese USB Box verwende ich für DVB-C Empfang.
    Nun möchte ich einen DVB-T USB Stick noch dazu verwenden, da ich den DVB-T Teil des CT-3650 CI nicht verwenden kann.
    Wenn ich beide Empfänger anstecke dann habe ich 3 Adapter registriert - einen DVB-C und zwei DVB-T.
    Soweit so gut.


    Ich erstelle meine channels.conf mit "w_scan" und das funktioniert auch wenn ich einen DVB-C scan mache.
    Wenn ich allerdings einen DVB-T scan mache, dann wird das mit dem DVB-T tuner des CT-3650 CI gemacht und nicht mit dem zweiten DVB-T Stick - was ich verstehen kann da es ein Adapter ist.


    Meine Frage allerdings ist, wie ich ein w_scan mit dem zweiten DVB-T Stick machen kann und dass die damit gefundenen Sender auch über diesen Stick dann später empfangen werden - und nicht über den DVB-T tuner des CT-3650 CI.


    Vielen Dank für eure Tipps!!!


    lG FTF

    Hallo,
    wie versprochen melde ich die Lösung meines Problems.
    Aus meiner Erfahrung empfehle ich eine komplette Neuinstallation und kein upgrade des Openelec XBMC für Raspberry.
    Es schein dass beim update einiges an nicht mehr verwendeten Dateien über bleiben die stören könnten.


    Da es sich bei mir um einen USB TechnoTrend IR Receiver handelt, bei dem sowohl der USB Empfänger als auch eine Fernbedienung dabei war, glaube ich dass mir das bei der Lösungsfindung zu Gute kam.
    Der Empfänger wurde stets sofort erkannt und installiert.
    Das Registered IR keymap war auch immer "rc-tt-1500"
    Nur die Fernbedienung selbst löste keine Reaktion im Openelec XBMC aus.


    Beim troubleshooten bin ich draufgekommen, dass kein Protokoll im Keytable geladen wurde.

    Code
    ir-keytable
    Found /sys/class/rc/rc0/ (/dev/input/event0) with:
            Driver ttusbir, table rc-tt-1500
            Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC other
            Enabled protocols: 
            Repeat delay = 1000 ms, repeat period = 125 ms


    Das fand ich bereits raus als ich noch auf der upgedateten Installation den Fehler suchte.


    Auf der neu installierten Version hab ich jedoch ebenfalls gesehen, dass hinter der keytable kein aktiviertes Protokoll gab.


    Als ich dies mal beheben wollte, nämlich mit dem folgenden Kommando

    Code
    ir-keytable -pRC-5


    nur um mal alle möglichen Protokolle durchzugehen und zu sehen ob es einen Output bei einem der Protokolle gibt,
    funktionierte plötzlich alles ohne weiter konfig von remote.xml oder lirc.conf oder oder oder...


    Das einzige was ich erstellte war eine autostart.sh im Verzeichnis /storage/.config um eben die aktivierung des Protokolls beim booten zu erledigen:

    Code
    ir-keytable -pRC-5


    Fazit: Fernbedienung läuft super, ohne Tastenprellen oder sonstige Effekte.


    Leider ist das ganze Zusammenspiel von Config Dateien und Übersetzungsdateien noch dazu mit der Info wann man was braucht und wie editieren muss,
    leider nicht nachvollziehbar dokumentiert.


    Ich hoffe diese Meldung hilft dem ein oder anderen


    herzlichen gruß
    FTF

    Hallo!
    Ich suche kompetente und verständliche Hilfe bei euch zum Thema wie ich meine IR Fernbedienung am Raspberry OpeneElec XBMC 3.2.1 wieder zum laufen bringe.
    Mir ist klar dass es google gibt, und sehr viele Foren, aber ich bitte hier um eine Erklärung als wenn Ihr neben mir sitzen würdet. Ich blick einfach nicht mehr durch was ich in welcher Reihenfolge zu tun habe.


    Ich verwende einen Zotac Rechner als Backend und einen Raspberry mit Openelec 3.2.1 als Frontend (xvdr) - da ich keinen Flatscreen mit HDMI oder ähnlichem habe


    Seit den letzten beiden upgrades von openelec geht Fernbedienungsmäßig gar nichts mehr (habe diesen Technotrend USB Empfänger) - hat aber schon mal funktioniert.


    Der Empfänger wird in Openelec 3.2.1 erkannt. An dem liegts also nicht. Komisch ist dass ich lirc0 UND lirc1 als devices habe .... keine Ahnung ob das vorher auch so war.


    Um was ich zu allererst bitte ist mal eine zeitliche Abfolge, was ich wann tun oder nachsehen sollte, denn ehrlich gesagt weis ich nicht mehr wie ich die Fernbedienung zuvor zum laufen gebracht habe. Ich weis nur irw und irrecord haben mal funktioniert - jetzt bleiben beide ergebnislos.
    in vielen Foren steht leider nur etwas von XBMC auf einem normalen Rechner und nicht am Raspberry, drum ist das auch wieder recht unbrauchbar, da manche configfiles am Raspberry gar nicht exisiterien.


    Wäre super wenn sich der ein oder andere die Zeit nehmen könnte mit dem ich das Problem lösen könnte.


    Vielen Dank und lG
    FTF

    Hallo Community,
    Bei mir läuft OpeneElec XBMC (OpenELEC-RPi.arm-2.99.5 - von Mitte März 2013) auf einem RaspBerry Typ B als Frontend zu einem VDR.
    Läuft an sich alles super - Perfekt wäre wenn ich das XBMC noch mit einer normalen, bereits existierenden, Fernbedienung steuern könnte.
    Ich habe einen USB UIRT Adapter an den Raspberry angeschlossen, leider tut sich gar nix.


    Ich finde weder eine

    Code
    /etc/lirc/hardware.conf


    noch tut sich etwas bei

    Code
    irw


    Auch das Modul

    Code
    uirt2_raw

    steht offenbar nicht zur Verfügung.


    Das einzige was ich finde ist im /etc/lirc/ Verzeichnis, ein template für eine xbox Fernbedienung


    Hat von euch jemand eine Idee wie ich weiter machen kann?


    Danke und viele Grüße


    FTF