Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 20. April 2003, 13:02

Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Hallo zusammen,

mein erstes Posting in diesem Forum - ich hoffe es geht nix schief. Wenn doch, bitte um Nachsicht.

Erstmal Lob an Michael "MrSputnik": Der Client war für mich der endgültige Grund, auf die vdr-Entwicklerversion upzudaten. Schöne Sache!

Leider habe ich ein Problem. Wenn ich meine vdr-Box mit einer DVB-Karte laufen lasse, funktioniert das Streaming einwandfrei. Aktiviere ich aber beide DVB-Karten (Primary: Siemens DVB-S, Device 1; Secondary: Haup. WinTV-NOVA-S, Device 2) bekomme ich folgende Meldung in /var/log/messages:

...
connect from 192.168.0.2, port 1028 - accepted
SVDRP message: 'VDR Streamplayer connected!'
info: VDR Streamplayer connected!
stream: broadcasting channel 15, Vpid = 2401, Apid = 2402
streaming transceiver thread started (pid=1184)
receiver thread started on device 2 (pid=1185)
ERROR: video data stream broken on device 2
initiating emergency exit
emergency exit requested - shutting down
closing SVDRP connection
...

Kein Wunder, dass ich keinen Stream sehen kann ...
Meine Interpretation: Das Stream-Plugin versucht Device 2 (Hauppauge-Karte) als Receiver zu nutzen. Wäre prinzipiell eine feine Sache, weil dann unter Win und auf der vdr-Box unabhängig ferngesehen werden könnte (einer schaut ARD mit Device 1 auf vdr, der andere Pro7 mit Device 2 als Stream unter Win). Nur leider scheints nicht zu klappen.

Was mich etwas irritiert: In den Postings wird dieses "Feature" gar nicht erwähnt. Im Gegenteil: Hier scheint die vdr-Box immer dem gestreamten Kanal zu folgen.

Frage 1: Stimmt meine Interpretation?
Frage 2: Warum bricht bei mir der Stream zusammen?

Danx und bis später (hoffentlich),

Dominik
F-S Multitainer, Cel. 1100, 256 MB RAM, 120 GB HD Samsung SV1204H, F-S DVB-S Rev 1.3, Haup. WinTV-NOVA-S; SuSE 8.0 Pro, LIRC 0.0.6, DVB 1.0.0-pre2, VDR 1.1.27, MPlayer 0.90; Plugins: VCD 0.0.4f, DVD 0.3.1, MP3 0.7.12, MLCD 0.0.2, Stream 0.1.1

Boergen

Meister

Beiträge: 2 125

Wohnort: Warendorf, NRW

Beruf: Chemiker

  • Nachricht senden

2

Sonntag, 20. April 2003, 15:32

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Hi !

Hab dasselbe Problem. Komischerweise bekomme ich auch zwischendurch folgende Meldung:

connect from 192.168.100.15, port 1043 - DENIED

Die IP ist die meines Windows-Rechner, von dem aus ich per WinClient-Software auf den Stream zugreifen will. Aber diesen merkwürdigen Port habe ich niemals eingestellt.

Sehr seltsam, das. :§$%
VDR1: Athlon XP@1200+, DVB-S FF1.6 + Nova, 112W Netzteil, Atric IR Einschalter
VDR2: Celeron 533, DXR3, 2 x Skystar, Atric IR Einschalter
jeweils Mahlzeit 3.2 + Toxic 1.4.7 (Extp. 34)
...seit vdr-1.0.3 dabei. Boah ist das geil geworden. :D

somebody101

Fortgeschrittener

Beiträge: 454

Wohnort: Weiterstadt, nähe Frankfurt

  • Nachricht senden

3

Freitag, 9. Mai 2003, 06:45

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Hallo,

ich habe ebenfalls oben beschriebenes Problem. Bei mir sind 2 DVBS (rev 1.3) eingebaut.
die 2. karte verrichtet z.B. beim Aufnehmen problemlos ihren dienst. beim stream-plugin kommt die meldung bezüglich broken stream (siehe oben)

gibt es hierfür bisher noch keine lösung ??


gruß
rob.
VDR1: HP-Microserver N40L mit mit yavdr 0.6 (headless) und 3 USB Empfängern (pctv 461e)
VDR2: MacMini mit yavdr 0.6 und TT-3600 (USB)
VDR3 - VDR5: Raspberry Pi3 mit USB Empfänger (pctv461e) und MLD

4

Freitag, 9. Mai 2003, 10:21

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Hallo,

welche version vom Plugin/VDR nutzt ihr ?

Ich habe auch 2 DVB karten und es läuft nicht :(

Seit VDR 1.1.27 hab ich es nicht mehr probiert.

Gruß
Viking
04.07.2007 Sharemarks 0.1.4pre6
AutoCutter 0.3.1
LC17

Bin dabei auf LinuxMCE umzustellen.
System : Viking LinuxMCE

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »viking« (9. Mai 2003, 10:31)


somebody101

Fortgeschrittener

Beiträge: 454

Wohnort: Weiterstadt, nähe Frankfurt

  • Nachricht senden

5

Freitag, 9. Mai 2003, 11:30

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

hi viking,

ich hab das stream plugin 0.1.1 unter vdr version 1.1.28 und 1.1.30 probiert.
bei beiden der gleiche fehler.


gruß
rob.
VDR1: HP-Microserver N40L mit mit yavdr 0.6 (headless) und 3 USB Empfängern (pctv 461e)
VDR2: MacMini mit yavdr 0.6 und TT-3600 (USB)
VDR3 - VDR5: Raspberry Pi3 mit USB Empfänger (pctv461e) und MLD

Django

Meister

Beiträge: 1 963

Wohnort: Pliening

Beruf: BOfH

  • Nachricht senden

6

Freitag, 9. Mai 2003, 11:44

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Griasdebua!

Zitat

Original von gigabit
Erstmal Lob an Michael "MrSputnik": Der Client war für mich der endgültige Grund, auf die vdr-Entwicklerversion upzudaten. Schöne Sache!

Welcher client? für LINUX oder M$?

Zitat

Leider habe ich ein Problem. Wenn ich meine vdr-Box mit einer DVB-Karte laufen lasse, funktioniert das Streaming einwandfrei.

Nun das habe ich (noch) nicht ausprobiert, was die Kiste macht, wenn ich Karte 2, 3 und 4 deaktiviere. Sind alles Budget-Karten.

Zitat

Frage 1: Stimmt meine Interpretation?

Sehe ich auch so, daß zum Streamen bei Dir das 2te device verwendet wird. Bei mir ist es device 3:

Quellcode

1
2
3
4
5
6
7
8
May  9 10:52:07 vdr in.telnetd[2093]: connect from 192.168.10.50 (192.168.10.50)
May  9 10:52:28 vdr vdr[578]: stream: broadcasting channel 11, Vpid = 201, Apid = 202
May  9 10:52:28 vdr vdr[2113]: streaming transceiver thread started (pid=2113)
May  9 10:52:28 vdr vdr[2114]: receiver thread started on device 3 (pid=2114)
May  9 10:52:35 vdr vdr[2113]: stream: connect nr. 0 from 192.168.10.50, port 32796 accepted
May  9 10:52:59 vdr vdr[2114]: ERROR: video data stream broken on device 3
May  9 10:52:59 vdr vdr[2114]: initiating emergency exit
May  9 10:52:59 vdr vdr[578]: emergency exit requested - shutting down
Wie nun das Plugin diese Zuordnung trifft, weiß ich allerdings auch nicht. Ob das per Zufall geschieht, oder ob es da eine feste Zuordnung gibt: Absolut keine Ahnung, leider ...

Zitat

Frage 2: Warum bricht bei mir der Stream zusammen?
Ich hatte früher mal ähnliche Fehlermeldungen; so ist z.B. speziell beim BR3 immer der Video Daten Stream abgebrochen. Ursache war eine "falsche" PID für den Videotext. Ich vermute daher, dass es irgendwie damit zusammen hängt. Genau weiss ich es aber auch (noch) nicht, aber ich weiter am Testen mit verschiedenen DVB-Treibern und verschiedenen VDR-Versionen.

Pfiade,
Django

:evil: Nichts ist wahr, alles ist erlaubt! :evil:

VDR-Server: ASUS A7V8X, Duron 1.300, 256 MB, 3x 120 GB Maxtor HD, PIONEER DVR-106, Design Tower AIR Black, 40x4 LCD,
1x TT-DVB-S V1.6, 3x DVB-S Nova, URC-7562, CentOS 5.5, VDR: 1.6.0

TecVDR: AOPEN MK73LE-N, Duron 1.300, 256 MB, 1x 120 GB Samsung HD, Pioneer DVR-A04, Gehäusesonderbau, 1x TT-DVB-S V1.6 4MB, 1x DVB-S Nova, 1x AV-Board, SuSE 9.0, VDR: 1.3.11

7

Freitag, 9. Mai 2003, 12:02

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Hallo,

habe die frage in der ML gestellt und Sascha hat geantwortet :)

Ich werde es auch testen, habe heute aber keine Zeit.
Bitte meldet zurück ob es bei euch klappt !!!

Gruß
Viking

--------------------------------------------------------

Try inserting

device->SwitchChannel(curChan, false);

in line 64 of the plugin's status.c file.

Greetings,
Sascha Volkenandt
04.07.2007 Sharemarks 0.1.4pre6
AutoCutter 0.3.1
LC17

Bin dabei auf LinuxMCE umzustellen.
System : Viking LinuxMCE

Django

Meister

Beiträge: 1 963

Wohnort: Pliening

Beruf: BOfH

  • Nachricht senden

8

Freitag, 9. Mai 2003, 12:19

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

HI,

also hab' gerade nochmal meine erste VDR-Version gestartet:
1.1.21 mit streaming-plugin 0.1.0 funktioniert das Streamen.

Bei 1.1.25, 26 und 30 hab' ich es noch nicht geschafft es lauffähig richtig hinzubekommen.

cu,
BC

:evil: Nichts ist wahr, alles ist erlaubt! :evil:

VDR-Server: ASUS A7V8X, Duron 1.300, 256 MB, 3x 120 GB Maxtor HD, PIONEER DVR-106, Design Tower AIR Black, 40x4 LCD,
1x TT-DVB-S V1.6, 3x DVB-S Nova, URC-7562, CentOS 5.5, VDR: 1.6.0

TecVDR: AOPEN MK73LE-N, Duron 1.300, 256 MB, 1x 120 GB Samsung HD, Pioneer DVR-A04, Gehäusesonderbau, 1x TT-DVB-S V1.6 4MB, 1x DVB-S Nova, 1x AV-Board, SuSE 9.0, VDR: 1.3.11

Django

Meister

Beiträge: 1 963

Wohnort: Pliening

Beruf: BOfH

  • Nachricht senden

9

Freitag, 9. Mai 2003, 12:33

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

HI,

also bei 1.1.30 mit plugin-Version 0.1.1 May 9 12:28:52 vdr vdr[1095]: starting plugin: stream (0.1.1): Streams a channel into a network tritt folgendes auf:

Quellcode

1
2
3
4
5
6
May  9 11:14:07 vdr vdr[1277]: stream: broadcasting channel 1, Vpid = 163, Apid = 104
May  9 11:14:07 vdr vdr[1299]: streaming transceiver thread started (pid=1299)
May  9 11:14:07 vdr vdr[1300]: receiver thread started on device 3 (pid=1300)
May  9 11:14:13 vdr vdr[1299]: stream: connect nr. 0 from 192.168.10.50, port 32813 accepted
May  9 11:14:38 vdr vdr[1300]: ERROR: video data stream broken on device 3
May  9 11:14:38 vdr vdr[1300]: initiating emergency exit

Werd' nachher mal ausprobieren, was der Tip von viking zum status.c file bringt.
ciao,
Django

:evil: Nichts ist wahr, alles ist erlaubt! :evil:

VDR-Server: ASUS A7V8X, Duron 1.300, 256 MB, 3x 120 GB Maxtor HD, PIONEER DVR-106, Design Tower AIR Black, 40x4 LCD,
1x TT-DVB-S V1.6, 3x DVB-S Nova, URC-7562, CentOS 5.5, VDR: 1.6.0

TecVDR: AOPEN MK73LE-N, Duron 1.300, 256 MB, 1x 120 GB Samsung HD, Pioneer DVR-A04, Gehäusesonderbau, 1x TT-DVB-S V1.6 4MB, 1x DVB-S Nova, 1x AV-Board, SuSE 9.0, VDR: 1.3.11

10

Montag, 12. Mai 2003, 17:05

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Hallo,

den tipp von oben könnt ihr vergessen, klappt nicht.

Sascha kuckt sich das in den nächsten tagen an - dann medle ich mich wieder :)

Gruß
Viking
04.07.2007 Sharemarks 0.1.4pre6
AutoCutter 0.3.1
LC17

Bin dabei auf LinuxMCE umzustellen.
System : Viking LinuxMCE

11

Donnerstag, 5. Juni 2003, 09:05

RE: Stream-Plugin läuft nicht mit 2 DVB-Karten?!?

Hallo,

Sasche hatte noch keine Zeit. Ich habe es aber mittlerweile mit Streamdev am laufen :)
Ich habe noch nicht den neuen streamdev 0.1.0beta1 probiert aber mit 0.0.3beta1 geht es ganz gut mir dem Mplayer-Win32 von hier :

http://www2.mplayerhq.hu/MPlayer/releases/win32-beta/

Bild und Ton !!

Habs vorgestern ausprobiert. Manschmal kommt das bild nicht gleich ! sondern erst nach eine "denkpause", manschmal sofort. SAT scheint z.B, besser zu gehen als RTL ! Laut sascha liegt es daran das der Stream von SAT1/PRo7 besser kompatibel ist zu mplayer als die von RTL !

Einfach mplayer auspacken irgendwo und dann starten :

Quellcode

1
mplayer http://"IP-Adresse":3000/4


für kanal nummer 4
Ihr müsst aber erst den HTTP Server im streamdev plugin menü aktivieren !

Das 0.1.0beta1 abstürtzt wenn man im menü OK drückt ist in der ML schon gewesen, noch keine löung. Evt. einfach setup.conf per hand editieren !?

Übrigens gibt es ein Patch für den VDRADMIN 0.23 der das Streamdev inkludiert:
http://bartschnet.de/vdradmin-0.23-streamdev-patch.bz2

Install :
bzcat ./vdradmin-0.23-streamdev-patch.bz2 | patch -p0

Leider startet er standardmässig den MS Media Player und der läuft bei mir nicht mit dem http stream. Liegt an den mime extensions. Irgendwie muß man video/mpeg und audio/mpeg auf den MPLAYER umbigen. Hatte aber leider noch keine Zeit dafür :(

Gruß
Viking
04.07.2007 Sharemarks 0.1.4pre6
AutoCutter 0.3.1
LC17

Bin dabei auf LinuxMCE umzustellen.
System : Viking LinuxMCE

Immortal Romance Spielautomat