You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jobaka

Trainee

Posts: 149

Location: Solingen

  • Send private message

21

Tuesday, September 16th 2003, 5:47pm

RE: Fehler bei cvs-ebuilds

Schreib doch mal, was Du wie ersetzen willst, dann mach ich den regulären Ausdruck mal fertig.
Hardware: ABIT KT7-RAID, Athlon900, 80GB HDD, 256 MB RAM, DVB-S Rev.1.3, DVD-LW, 40x4 LCD blau inv., Zoltrix Nightingale mit opt. Modul, 10/100/1000 Ethernet, Verax-Lüfter für Netzteil, CPU und Gehäuse

Gehäuse: Scenic Desktop mit Alu-Verkleidung (geschliffen, natur eloxiert)

Software: LinVDR 0.6, VDR 1.3.11

Henning

Professional

Posts: 597

Location: Braunschweig

Occupation: Systemanalytiker

  • Send private message

22

Tuesday, September 16th 2003, 6:13pm

RE: Fehler bei cvs-ebuilds

Hallo,

also ich möchte am liebsten die beiden Zeilen die mit @install beginnen aus dem Makefile löschen (siehe Ausschnitt unten).
Habe als Lösung folgendes gefunden, aber trotzdem gern gewußt wie das mit /d gehen soll.
sed -i "s/@install.*$//" Makefile

Gruß Henning


all: libvdr-$(PLUGIN).so
@install -d ../../man
@install README ../../man/$(PLUGIN).man
Hardware: ASUS A8N-E, AMD64 3800 2GB, 2 * 250GB SATA-II Samsung, Siemens DVB-S Rev 1.3, Technisat DVB-S Rev. 1.6, LG 4167 DVD-RW, GF 6300
Software: Gentoo,2.6.17, GCC 3.4.6 VDR 1.4.3, OSD-Teletext, mp3ng, DVD, image, mplayer, pilotskin, director, femon, osdpip, burn

Henning

Professional

Posts: 597

Location: Braunschweig

Occupation: Systemanalytiker

  • Send private message

23

Tuesday, September 16th 2003, 6:23pm

RE: Fehler bei cvs-ebuilds

Hallo,

kann das digest für bitstreamout nach wie vor nicht einchecken. Bekommen nachfolgende Meldung. Hinweise? (Hab gerade eine neue Version vom clock plugin eingecheckt?!)

Henning

cvs server: [18:22:10] waiting for gentoo-deutsch's lock in /cvsroot/gentoo-deutsch/ebuilds/media-video/vdrplugin-bitstreamout/files
Hardware: ASUS A8N-E, AMD64 3800 2GB, 2 * 250GB SATA-II Samsung, Siemens DVB-S Rev 1.3, Technisat DVB-S Rev. 1.6, LG 4167 DVD-RW, GF 6300
Software: Gentoo,2.6.17, GCC 3.4.6 VDR 1.4.3, OSD-Teletext, mp3ng, DVD, image, mplayer, pilotskin, director, femon, osdpip, burn

Martini

Professional

Posts: 1,323

Location: Thüringen

  • Send private message

24

Tuesday, September 16th 2003, 6:57pm

RE: Fehler bei cvs-ebuilds

Hallo Henning

sed -i "/^@install -d \..\/..\/man*$/d" Makefile
sed -i "/^@install README \..\/..\/man\/\$(PLUGIN).man*$/d" Makefile

Habe ich gerade an einer Datei mit dem Inhalt getestet und es wird gelöscht.

Martin

jobaka

Trainee

Posts: 149

Location: Solingen

  • Send private message

25

Tuesday, September 16th 2003, 7:18pm

RE: Fehler bei cvs-ebuilds

Mein Vorschlag:

sed -i "/@install.*$/d" Makefile

Ist einfacher ;)
Hardware: ABIT KT7-RAID, Athlon900, 80GB HDD, 256 MB RAM, DVB-S Rev.1.3, DVD-LW, 40x4 LCD blau inv., Zoltrix Nightingale mit opt. Modul, 10/100/1000 Ethernet, Verax-Lüfter für Netzteil, CPU und Gehäuse

Gehäuse: Scenic Desktop mit Alu-Verkleidung (geschliffen, natur eloxiert)

Software: LinVDR 0.6, VDR 1.3.11

Martini

Professional

Posts: 1,323

Location: Thüringen

  • Send private message

26

Tuesday, September 16th 2003, 7:25pm

RE: Fehler bei cvs-ebuilds

Hi

Ja, hast sicherlich Recht. Danke für den Hinweis. Ich habe mehr oder weniger nur probiert. :D
Hab leider nicht so den Durchblick mit den Ausdrücken. :)
Dachte auserdem man muß die ganze Zeile angeben, aber wäre ja eigentlich verwunderlich wenns so wäre. Sed ist schon ein mächtiges Ding.

Martini

jobaka

Trainee

Posts: 149

Location: Solingen

  • Send private message

27

Tuesday, September 16th 2003, 7:50pm

RE: Fehler bei cvs-ebuilds

Hi,

hab ja auch was gelernt, das mit dem /d für Zeile löschen wusste ich noch nicht, hätte auch einfach nur den Text gelöscht und die Zeile leer stehenlassen.
Ich brauch mal so ne Kaffeetasse mit den ganzen regulären Ausdrücken, da gabs mal was...
Hardware: ABIT KT7-RAID, Athlon900, 80GB HDD, 256 MB RAM, DVB-S Rev.1.3, DVD-LW, 40x4 LCD blau inv., Zoltrix Nightingale mit opt. Modul, 10/100/1000 Ethernet, Verax-Lüfter für Netzteil, CPU und Gehäuse

Gehäuse: Scenic Desktop mit Alu-Verkleidung (geschliffen, natur eloxiert)

Software: LinVDR 0.6, VDR 1.3.11

Martini

Professional

Posts: 1,323

Location: Thüringen

  • Send private message

28

Tuesday, September 16th 2003, 7:54pm

RE: Fehler bei cvs-ebuilds

Quoted

Original von jobaka
Hi,

hab ja auch was gelernt, das mit dem /d für Zeile löschen wusste ich noch nicht, hätte auch einfach nur den Text gelöscht und die Zeile leer stehenlassen.
Ich brauch mal so ne Kaffeetasse mit den ganzen regulären Ausdrücken, da gabs mal was...


Cool. Echt? Ne Kaffetasse? Wenn du was drüber findest, sag sofort bescheid!!! :D:D:D

Martini

jobaka

Trainee

Posts: 149

Location: Solingen

  • Send private message

29

Tuesday, September 16th 2003, 8:14pm

RE: Fehler bei cvs-ebuilds

Hi,

schon passiert. Ist aber nur ne "vi"-Tasse, kann nicht erkennen wieviel da über reguläre Ausdrücke draufsteht. Aber vi ist ja auch schonmal verzwickt ;)

http://www.ixsoft.de/software/products/cups-catalog-de.html
Hardware: ABIT KT7-RAID, Athlon900, 80GB HDD, 256 MB RAM, DVB-S Rev.1.3, DVD-LW, 40x4 LCD blau inv., Zoltrix Nightingale mit opt. Modul, 10/100/1000 Ethernet, Verax-Lüfter für Netzteil, CPU und Gehäuse

Gehäuse: Scenic Desktop mit Alu-Verkleidung (geschliffen, natur eloxiert)

Software: LinVDR 0.6, VDR 1.3.11

Martini

Professional

Posts: 1,323

Location: Thüringen

  • Send private message

30

Tuesday, September 16th 2003, 8:27pm

RE: Fehler bei cvs-ebuilds

Hi

OT on
:lachen1 Cool. vi ist auch OK. Danke Jobaka :)
OT off

Martini

Henning

Professional

Posts: 597

Location: Braunschweig

Occupation: Systemanalytiker

  • Send private message

31

Tuesday, September 16th 2003, 8:54pm

RE: Fehler bei cvs-ebuilds

Ok,

neue Version des bitstreamout ist da. Nach wie vor ohne digest files. Keine Ahnung warum ich die nicht im CVS einchecken kann.

@jobaka
habe den sed Befehl getestet. Klappt prima.

Henning
Hardware: ASUS A8N-E, AMD64 3800 2GB, 2 * 250GB SATA-II Samsung, Siemens DVB-S Rev 1.3, Technisat DVB-S Rev. 1.6, LG 4167 DVD-RW, GF 6300
Software: Gentoo,2.6.17, GCC 3.4.6 VDR 1.4.3, OSD-Teletext, mp3ng, DVD, image, mplayer, pilotskin, director, femon, osdpip, burn

Martini

Professional

Posts: 1,323

Location: Thüringen

  • Send private message

32

Tuesday, September 16th 2003, 9:08pm

RE: Fehler bei cvs-ebuilds

Hallo Henning

Habe mal die digest Files eingecheckt. Ging bei mir... glaube ich. Kannst du mal nachschauen?

Martini

edit:
Ne, geht nicht. Gleicher Fehler wie bei dir. :(
/edit