Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

dontom

Fortgeschrittener

  • »dontom« ist der Autor dieses Themas

Beiträge: 369

Wohnort: Südliches Land der Burgen

  • Nachricht senden

1

Freitag, 1. Oktober 2004, 17:24

Ndsiswrapper und Netgear WG511t

Hi,

nachdem ich mit meinem Datendurchsatz mit dem madwifi-treibern nicht so recht zufrieden bin und mein VDR schon vieel zu lange stabil läuft, ausserdem Wochenende ist, wollte ich mal versuchen, ob ich den Durchsatz nicht mit einem anderem Treiber für die Netzerkkarte verbessern kann:

Hab' mir also die neuste Version vom ndiswrapper ( 0.10 ) heruntergeladen, entpackt, nur bringt mir ein make folgende Fehlermeldung:

vdr:/usr/src/ndiswrapper-0.10# make
make -C driver
make[1]: Entering directory `/usr/src/ndiswrapper-0.10/driver'
cc -DEXPORT_SYMTAB -DMODVERSIONS -include /lib/modules/2.4.24-ctvdr-2/build/include/linux/modversions.h -DNDISWRAPPER_VERSION=\"0.10\" -DEXTRA_VERSION=\"\" -DLINUX -D__KERNEL__ -DMODULE -I/lib/modules/2.4.24-ctvdr-2/build/include -Wall -Wstrict-prototypes -fomit-frame-pointer -fno-strict-aliasing -pipe -mpreferred-stack-boundary=2 -O2 -c -o usb.o usb.c
usb.c: In function `usb_bulk_or_intr_trans':
usb.c:222: parse error before `)'
make[1]: *** [usb.o] Fehler 1
make[1]: Leaving directory `/usr/src/ndiswrapper-0.10/driver'
make: *** [all] Fehler 2
vdr:/usr/src/ndiswrapper-0.10#

Wäre jemand von Euch so nett, mir unter die Arme zu greifen ?

TIA,
tom

Mein VDR

Asus P5QLE, Core2Duo 6600, GT640, 2GB RAM, 2 x TT S2-3200 im DIGN HV5 mit IMON-VFD & FB
yaVDR0.6.1 stable => softhddevice

tommiwe

Fortgeschrittener

Beiträge: 268

Wohnort: Bad Oeynhausen

  • Nachricht senden

2

Freitag, 1. Oktober 2004, 18:50

RE: Ndsiswrapper und Netgear WG511t

Hi!

Ich kann Dir auch nicht wirklich helfen, da ich auch das Problem habe. Ich habe hier allerdings die Version 2, bei der die madwifi-Treiber nicht gehen.
Hier ein Hinweis, den vom ndiswrapper-Forum bekommen habe., Probiers mal aus. Bei mir hing es leider immer noch.

--------------------------------------------------------------------------------------------

Here is what you want to do (assuming your source is in /usr/src/kernel-source-2.4.26):

ln -snf /usr/src/kernel-source-2.4.26 /lib/modules/`uname -r`/build

To check that the link is correct, make sure that

ls /lib/modules/`uname -r`/build/include/linux/version.h

works OK.

However, note that if you use the Debian kernel packaging system to build your own kernel from source (try "apt-get install kernel-package; man make-kpkg"), this link will be automatically set up for you. If you are using a prebuilt Debian kernel, "apt-get install kernel-headers-`uname -r`" should install the header files you need (including the symlink in /lib/modules) to build ndiswrapper. If you built your own kernel, don't use the kernel-headers packages for this.

----------------------------------------------------------------------------

Gruß

Thomas
ct-vdr 5 (1.4.2-1ctvdr2) mit Erweiterungen von tobi, Silverstone LC03, ASUS P4P800-VM, 256 MB, TT 1.5, P4 2 GHZ, Thermalright SLK 947 U, Tagan TG 330, Aopen DVD 1648, Samsung SV1203N, WLAN WG311v2 Netgear

dontom

Fortgeschrittener

  • »dontom« ist der Autor dieses Themas

Beiträge: 369

Wohnort: Südliches Land der Burgen

  • Nachricht senden

3

Freitag, 1. Oktober 2004, 19:11

Hi,

den link hab ich ja gesetzt, befürchte aber, dass die Fehlermeldung ganz was anderes aussagt, bin halt nur net der grosse Linux-Guru :(

Trotzdem, danke für Deine Hilfe,
tom

P.S.: Welche Version 2 hast Du, dass die madwifi-treiber net gehn ?

Mein VDR

Asus P5QLE, Core2Duo 6600, GT640, 2GB RAM, 2 x TT S2-3200 im DIGN HV5 mit IMON-VFD & FB
yaVDR0.6.1 stable => softhddevice

tommiwe

Fortgeschrittener

Beiträge: 268

Wohnort: Bad Oeynhausen

  • Nachricht senden

4

Freitag, 1. Oktober 2004, 21:34

Also, wenn ich mir die Fehlermeldung so anschaue, dann könnte man meinen, dass im Quellcode von usb.c ein Fehler in Zeile 222 vorliegt. Dort meckert zumindest der parser.
Leider bin ich kein C-Freak, um den Quellcode beurteilen zu können. Oft sind das aber auch nur Folgefehler.
Du könntest es mal mit einem anderen Kernel versuchen oder warten ob hier jemand Ahnung von C hat und sich die Datei mal anschauen kann.

Gruß

Thomas

P.S.: Die Version 2 bezog sich auf auf die WG311 (PCI), die mittlerweile einen Chipsatz von TI drin hat. Bei der WG511 geht wohl dann der Madwifi-Treiber
ct-vdr 5 (1.4.2-1ctvdr2) mit Erweiterungen von tobi, Silverstone LC03, ASUS P4P800-VM, 256 MB, TT 1.5, P4 2 GHZ, Thermalright SLK 947 U, Tagan TG 330, Aopen DVD 1648, Samsung SV1203N, WLAN WG311v2 Netgear

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »tommiwe« (2. Oktober 2004, 14:49)


5

Mittwoch, 16. März 2005, 14:45

RE: Ndsiswrapper und Netgear WG511t

dontom,

hast Du es eigentlich jemals geschafft, die WG511T mit ndiswrapper zum laufen zu bringen? Falls ja, hast Du den 108MBit Modus damit aktivieren können (der ja mit madwifi nicht geht)?

Demnos

Immortal Romance Spielautomat