Posts by Demnos

    Die wahrste und beste Beschreibung über Linux "Linux - das grösste Textadventure aller Zeiten" hat sich mal wieder bewahrheitet. Also, nun läuft es also problemlos.


    Ich bin immer noch nicht 100% sicher was den Grund angeht, aber nach dem aktuellen Stand der Ermittlungen war es weder APM noch APCI noch APIC noch Netzwerk noch cron/atd noch VGA, und "proffie" war wohl derjenige, der am nächsten dran war.


    Kurze Erklärung: Ich glaube, das das einmalige Setzen der Uhr mit hwclock das Problem gelöst hat. Evtl. war irgendwas im BIOS nicht richtig initialisiert und beim Auslesen der Uhrzeit gab die HW-Uhr einen Wert zurück, der nicht korrekt formatiert war oder so? Klingt wirr, aber im Moment habe ich keine bessere Erklärung für das Verhalten. Auslöser war wahrscheinlich der "courier" MTA daemon, der aber selber wohl nicht Schuld hatte, sondern nur nach 1 Stunde das Signal zum Absturz gab.


    Lange Erklärung:


    Mir ist gestern abend aufgefallen, dass in der Syslog irgendwo beim booten ein Eintrag war:

    Code
    1. 10:12:23 courierd: Waiting. shutdown time=Mon Jan 16 11:12:23 2006, wakeup time=Mon Jan 16 11:12:23 2006, queuedelivering=0, inprogress=0


    HA! dachte ich, jetzt habe ich ihn! "required stop" genau 1 Stunde nach dem start, das muss es sein. Oder? Also habe ich courier erstmal zum Testen von hand gestoppt.


    Nun war es mir ein wenig langweilig, eine Stunde zu warten, und so kam ich auf die Idee, mal die HW-Uhr etwas weniger als 1 Stunde vorzustellen. Das System lief nun problemlos weiter, auch über 1 (echte) Stunde lang. Also dachte ich: Das ist der Beweis, dass es courier war.


    Um das zu testen, habe ich dann rebooted, courier jetzt normal laufen lassen und die Uhr 58 Minuten vorgestellt. Eigentlich hätte der Fehler jetzt nach 2 Minuten auftreten müssen. Tat er nicht, und auch nach über 1 Stunde lief das System immer noch. Hmmm...


    Dritter Test: nochmal rebooted und diesmal NICHT an der Uhr gespielt. Courier lief dabei wieder ganz normal, und das System schaffte es locker über die magische Stunde...


    Inzwischen habe ich einen mit partimage gesicherten Stand zurückgespielt, den ich gemacht hatte bevor ich mit der Fehlersuche anfing. In diesem Stand ist alles wieder 100% so wie zuvor, als der Fehler jedesmal auftrat - und dieser Stand ist dann die ganze Nacht durchgelaufen, mit aktivem courier und allem.


    Warum das ganze mit Kanotix lief, weiss ich auch nicht, aber dort started (und restartet) auch nicht courier als MTA soweit ich mich erinnern kann...


    Also wenn jemand eine bessere Erklärung hat, immer her damit.


    Ansonsten vielen vielen Dank für alle, die sich an der Fehlersuche beteiligt haben, und die vielen nützlichen Tips und Hinweise gegeben haben, das war wirklich ermutigend. Ohne Euch hätte ich die Brocken schon längst hingeschmissen!

    Schon probiert, aber im BIOS war nix zum Thema Power-Save was man einstellen konnte.


    So, ich glaube aber ich habe es. Soeben ist mein Rechner zum ersten Mal über eine Stunde gelaufen. Leider habe ich 3 Sachen auf einmal verstellt und nun muss ich noch rausfinden, welche von denen es war. Sobald ich sicher bin, melde ich mich wieder.

    Quote

    Original von Krischi
    Hi erstmal


    Der Datenaustausch zw. beiden Rechnern geschieht bei mir von Windows aus per WinSCP. jenes Programm zeigt bei der Übertragung die entsprechende Geschw. an, ebenso zeigt mit der Taskmanager den selben Wert. Überprüft hab ich das ganze noch rechnerisch mit einer 100 MB großen datei und der dafür benötigten Zeit.


    Dir ist klar, das WinSCP jede Menge CPU Zeit auf beiden Seiten für die Verschlüsselung / Entschlüsselung benötigt? Achte mal auf die CPU Auslastung während WinSCP läuft, da wirst Du staunen. Ich weiss ja nicht welche CPU Du hast, jedenfalls wirst Du mit WinSCP kaum an die Grenze Deiner Leitung stossen, 100MBit/s kann der wohl nicht annähernd ver- und entschlüsseln.


    Miss mal mit reinem ftp!

    Also apm=off brachte nix.


    Es ist zum Heulen.


    Gerade getestet:


    1. System gebootet (19:30:00)
    2. hwclock auf 20:29:00 vorgestellt, he he he
    3. hwclock -s um auch systemuhr zu verstellen
    4. Rechner läuft auch um 20:31:00 noch!


    Also, verdrehen der Uhr führt nicht zum Absturz. Ich gehe davon aus, dass er dann um 20:30 (die echte Uhrzeit) wieder stehen bleibt...


    Interessant, auch wenn es mich nicht viel weiterbringt...

    Quote

    Original von proffie
    Ich bin zwar kein LINUX-Insider, aber kann es am clock liegen?
    werden irgendwo systemclock, HWclock, Netwerk-Clock oder Sommerzwit, UTC o.ä. angesprochen bzw. referenzen gesetzt?
    mich wundert die exaktheit.


    Leider weiss ich nicht genau, wo und wie ich danach suchen soll? Ich denke in jedem System werden diese Dinge irgendwo angesprochen, aber wo genau, und was davon könnte den Fehler auslösen?


    Aber die Exaktheit ist in der Tat erstaunlich. Wenn ich den Rechner boote und im syslog sehe, dass der kernel z.B. um 10:39:26 gestartet ist, kann ich um 11:39 zum Rechner gehen und exakt wenn die Sekunde von 25 auf 26 umspringt, kommt der kernel panic auf den Bildschirm.


    Achso, den Rechner habe ich beim Debian Installer immer auf UTC Uhr eingestellt. Könnte natürlich mal auf lokale Zeit umstellen...


    Mir ist noch was eingefallen: Die kernel panic Nachricht füllt ja mehr als den 80x25 Bildschirm und schiebt natürlich evtl. direkt davor liegende Nachrichten nach oben weg. Evtl. kann man per framebuffer einen längeren Schirm einstellen (43 Zeilen oder so) um alles lesen zu können...

    Quote

    Original von mgoeben
    Ich hatte das auch mal, bei mir war es apm.
    Seit dem boote ich mit der option apm=off und ohne automatischen Start des apmd.


    War es bei Dir auch jedesmal nach 60 Minuten? apm=off habe ich ja schon, aber an den apmd hatte ich noch nicht gedacht, werde ich mal probieren.


    EDIT: wie Du an meinem "ps-ef" log siehst, apmd läuft nicht! Aber ich hatte leider woanders gepennt, momentan starte ich tatsächlich mit "apm=power-off", werde also nochmal mit "apm=off" versuchen, vielleicht ist es ja genau das! Danke für den Tip.


    Die Änderungen am BIOS (VGA, etc) haben übrigens keine Besserung gebracht!


    Quote

    Original von Der_Pit
    Wie, Du hast schon mehrfach neu installiert und trotzdem geht's nicht? Hast Du dazu jedesmal neu formatiert?


    Ja, jedesmal ganz neu formatiert, zumindest die Partition, /dev/hda1 auf der ich immer rumspiele. Ich habe auf /dev/hda3 noch mein Produktionssystem (ctvdr3 mit 2.4 kernel) und das boote ich immer, wenn Frau und Kinder mal was sehen wollen. Zwischen den Systemen schalte ich um, indem ich auf jeder Partition eine andere lilo.conf habe, die im MBR /dev/hda jeweils die zu bootende Partition einträgt. Wenn ich also in mein Testsystem will, mache ich mount /dev/hda1 /mnt/hda1; chroot /mnt/hda1; lilo; exit; init 6


    Quote

    Check doch mal die Platte mit badblocks - evtl. startet nach einer Stunde irgendein update (manpages, locatedb...) das über defekte Sektoren stolpert. Hmm, aber cron hattest Du ja schon abgeschaltet, oder?


    Ja, cron und atd hatte ich abgeschaltet. badblocks kann ich nochmal versuchen, aber ein fsck von /dev/hda1 (gemacht, wenn ich /dev/hda3 gebooted habe) läuft immer problemlos durch.


    Quote

    Hast Du 'nen zweiten Rechner? Dann setz' das syslog doch mal um auf remote-logging, dann kannst Du die Fehlermeldung vielleicht besser abfangen und jemanden finden der damit was anfangen kann...


    Ok, gute Idee, das kann ich mal versuchen!

    Guter Tip. Gerade nochmal probiert: eine Kanotix CD mit 2.6.11 läuft absolut perfekt und stirbt nicht nach einer Stunde!!! Gerstern abend gebootet, heute morgen lebte der Rechner noch...


    Es ist also irgendwas mit der Installation nicht in Ordnung, wobei ich immer nur und mehrmals die Debian Install CD (mal "business card", mal "network install") genommen habe, sowohl sarge 3.1 als auch etch als auch 2 verschiedene "daily snapshots".


    Habe jetzt eben nochmal einiges in BIOS verändert:
    - VGA Shared memory von 32MB nach 4MB
    - AGP von 64MB auf 32MB (kleinster Wert, der erlaubt war)
    - APIC auch im BIOS disabled (obwohl ich ja schon mit "noapic" boote)


    Bei den Power Optionen im BIOS gab es nur die Wahl zwischen Sleep Mode S1, S3, Auto (S1 war eingestellt, habe ich gelassen) und ein paar Dingen zum Wakeup. Alle anderen Dinge waren bereits disabled.


    So, nun wieder eine Stunde warten....

    Also cron war es nicht. Nach kill von atd und cron war trotzdem nach einer Stunde wieder Schluss. Netzwerk scheidet auch aus (LAN Kabel steckt nicht und WLAN hatte ich ja testweise schon mal ausgebaut)


    Aber ich schau noch mal im BIOS und nach den Power Optionen.


    Danke schonmal an alle für die tollen Tips und Anregungen!

    Also in den cron / at spools stand nichts drin, aber ich kille die daemons jetzt mal. Test läuft.... (1 Stunde warten, dann melde ich mich wieder).


    Ansosten: Leider steht in den logfiles auch vor dem Absturz nichts drin, da hatte ich natürlich zuerst gesucht. Es steht nach dem System-Start im Prinzip eine Stunde lang nichts mehr drin (es sei denn, ich arbeite aktiv am System, mounte Platten etc)...


    torsten lang : Also apm=off, welche anderen Power Management Sachen könnte ich noch überprüfen? Grafikspeicher habe ich auch nicht verstellt, kann ich aber nochmal im BIOS nachprüfen. Aber würde dann die Panic nicht früher bzw unregelmässig auftreten, nicht immer nach 60 Minuten?

    Speichertest: Ja habe ich sogar gemacht, über 1 Stunde in der Schleife ohne Fehler. Speicherfehler würde auch nicht unbedingt einen Absturz exakt und konsistent nach 60 Minuten 0 Sekunden erklären, oder?


    Quote

    Original von wirbel
    Was läuft denn überhaupt noch alles auf dem System?


    ps -ef:



    lsmod:


    Ich hatte es in einem anderen Thread schon erwähnt, komme aber einfach nicht weiter.


    Mein Rechner (Hermes 651P; Celeron 2.0GHz, 512MB RAM, Orinoco WLAN 11Mbit (Prism2), TT1.6) hängt sich grundsätzlich exakt 60 Minuten und 0 Sekunden nach dem Starten auf, aber nur sofern ein 2.6er Kernel geladen wurde (egal welcher). Unter 2.4 läuft der Rechner absolut stabil.


    Ein identischer Fehler wurde bereits hier gepostet, allerdings ohne Lösung. Ich habe gegoogelt bis zum Umfallen, nichts gefunden.


    Welcher Dienst oder Timer könnte nach 60 Minuten zuschlagen und den Rechner anhalten?


    Symptome: Rechner bleibt einfach stehen. Auf dem Bildschirm kernel panic, allerdings kein Eintrag in irgendwelchen logdateien (/var/log/*).


    Bereits probiert:
    - Neuinstallation mit Debian Sarge und kernel 2.6.8-2
    - Neuinstallation mit Debian Etch und kernel 2.6.12-1
    - apt-get dist-upgrade von Etch auf Sid.
    - kernel upgrade auf 2.6.14-2
    - kernel upgrade auf 2.6.15
    - kernelsourcen 2.6.14 von kernel.org selbst gebaut
    - kernelsourcen 2.6.15 von kernel.org selbst gebaut
    - dabei verschiedene .configs probiert (default, wilderigel und eigene)


    - hdparm -d0 -u1 /dev/hda und hdc
    - sensors Paket neu installiert
    - WLAN Karte entfernt und deren Module nicht geladen
    - ich starte grundsätzlich mit "apm=power-off noapic nolapic acpi=off"


    VDR ist noch gar nicht installiert - nur das nackte Debian Grundsystem ohne extra Pakete.


    Also, wer könnte der Bösewicht in meinem System sein...und was kann ich tun, um das zu debuggen???? Bitte helft mir, ich habe jetzt schon 20 - 30 Stunden damit verschwendet und bin am Verzweifeln!



    SEHR MERKWÜRDIG:


    Da ich nach Platte bügeln und Neuinstallation sofort das gleiche Problem hatte, habe ich mal meine Fehlersucher etwas erweitert.


    Also, mein Rechner stüzt gar nicht nach *ungefähr* einer Stunde ab, sondern EXAKT, auf die Sekunde genau nach einer Stunde.


    Woran könnte es liegen, wie und wo würden die Experten jetzt weitersuchen. Es gibt keinen Logeintrag, der Rechner bleibt einfach nach 60 Minuten stehen.


    Nachtrag - wenigstens bin ich nicht alleine mit dem Problem, anscheinend hat jemand mit identischer HW auch das identische Problem:


    http://www.vdrportal.de/board/thread.php?threadid=43143

    Bis jetzt habe ich es immer noch nicht geschafft, überhaupt irgendeine Debian Installation mit irgendeinem 2.6er Kernel auf meinem Rechner zum Laufen zu bringen (wir hatten in einem anderen Thread bereits dazu diskutiert). Debian Sarge, Debian Etch, diverse Installer, 2.6.8-1, 2.6.12-1, 2.6.15, alles läuft und schmiert dann nach ziemlich genau einer Stunde(!) kommentarlos ab. Auf dem System läuft jeweils nichts, nicht mal den vdr habe ich installiert, einfach nur debian install und fertig.


    Ich kompliere auch schon gar nicht mehr selber, denn schon die kernels direkt vom Debian Server hängen sich nach einer Stunde auf. Es ist zum Heulen. Einzige Ausnahme war bislang die Kanotix vdr-live CD, die läuft und läuft und läuft. Was haben die da gemacht, was der Standard Kernel anscheinend nicht hat? 2.4er kernels laufen auch alle prima. Und warum stürzt es immer gerade nach ca. 1 Stunde ab?


    Nun experimentiere ich gerade mit ctvdr45, um zu sehen ob das läuft. Bin gespannt. Sehr sehr mysteriös das ganze...

    Quote

    Original von KleinKlausi
    Hallo,


    wäre super, wenn mir jemand einen Tip geben könnte, wie ich eine viertel Stunde normale VDR-Aufnahme in ca. 20 MB konvertiert kriege.


    Mit Requant oder als neu kodierte MPEG-2 kannst Du das meiner Erfahrung nach nicht schaffen, 15 Minuten (also ca. 300MB Originalgrösse) sind da nur in Briefmarkengrösse in 20MB unterzubringen. Es muss schon ein MPEG-4 verwendet werden!


    Da Du ja den ctvdr hast: Installiere dir doch einfach vdr-plugin-vdrrip.


    Dann einfach das Plugin vom VDR Menu aus starten, die Aufnahme auswählen, Parameter setzen (Du kannst die Dateigrösse vorgeben, also 20MB), den Codec auwählen (z.B. XVID) und fertig.


    Du wirst sehen, dass Du trotz MPEG4/XVID nicht in voller Auflösung arbeiten kannst, wenn Du in 20MB bleiben willst. Ich benutze das vdrrip Plugin täglich, um mir Sendungen für den PDA runterzurechnen. Mit der typischen PDA Auflösung (320 x 240) bekomme ich erstklassige Aufnahmen bei 2MB pro Minute, also 30MB für 15 Minuten. 20MB für 15 Minuten müssten auch noch recht ordentliche Bilder liefern. Aber eben nur bei 320 x 240. Höhere Auflösung erfordert höhere Bitrate...

    Quote

    Original von Fleischwurst
    Jo, läuft ziemlich zäh. Bezüglich des Servers... gibt es eine Möglichkeit per Paypal eine kleine Spende abzugeben?


    Natürlich auch von meiner Seit: Dankeschön :streichel


    Auf der Einstiegsseite gibt es links in der Mitte einen Paypal Knopf.

    Wollte nur mal fragen, ob irgendeiner von Euch, der den ctvdr45 mit dem 2.6.er kernel ausprobiert hat, auch eine PCMCIA-WLAN Karte ans Laufen bekommen hat?


    Ich habe eine stinknormale Orinoco drin, die seit Urzeiten von allen Wald-und-Wiesen Kernels unterstützt wird. Wenn ich den ctvdr45 installer mit 2.4 starte, wird sie auch gleich im Debian Installer erkannt, mit 2.6 nicht. Das ist komisch, denn der normale Debian Sarge 3.1 Installer von debian.org erkennt die Karte natürlich auch unter 2.6.


    Auch nach abgeschlossener Installation (wireless-tools und pcmcia sind installiert, yenta_socket lädt ohne Fehler beim booten) ist die Orinoco Karte nicht zu aktivieren. Die Treiber laden alle (lsmod zeigt orinoco, orinoco_cs, pcmcia etc.) aber ein iwconfig zeigt "no wireless extensions"


    Bevor ich jetzt mit der Fehlersuche weitermache wollte ich erstmal wissen, ob überhaupt schon einer WLAN unter ctvdr45 und 2.6. kernel am Laufen hat.


    Bitte melden (auch wenn ihr mit meinem Fehler nicht helfen könnt, mir reicht es zu wissen, das einer von Euch es am laufen hat)

    Quote

    Original von Jente
    In den Release-Notes steht schon, dass das manuelle Partitionieren (wie wohl schon bei der 4.0) nicht klappt.


    Du hast nicht richtig gelesen! In den Release Notes steht, dass das manuelle Partitionieren nicht funktioniert, wenn man die automatische Installation wählt (also beim boot prompt einfach enter drückt, oder "auto" bzw "auto26" eingibt). Bei der manuellen Installation "manual" oder "manual26" funktioniert sie hingegen wunderbar (selber schon ausprobiert).


    Also keine Sorge, cd einlegen, "manual" oder "manual26" und Deine Daten sind sicher (ausser Du machst selber einen Fehler bei der Partitionierung)