You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, April 19th 2004, 12:36pm

lirc funktioniert nicht auf anhieb

Hallo,

ich habe seit einiger Zeit das Problem, daß mein IR-Empfänger beim 1. Start des VDRs nicht mehr funktioniert.
Erst nachdem ich den VDR anhalte und Lirc neu starte (/etc/init.d/lirc restart) kann VDR wieder gesteuert werden.
Kann es sein, daß auf meinem Suse8.2 die Dienste in einer "falschen" Reihenfolge geladen werden ? Der Link /etc/init.d/rc3.d/S13lirc zeigt korrekt auf /etc/init.d/lirc.

Wie bekomme ich den VDR wieder dazu, sich auf anhieb fernsteuern zu lassen ? Irgendwelche Ideen ?

Danke schon mal...

CU
Mitch
i3-2120T - Suse 13.1 - VDR 2.0.5 - FF 2.3
i3-2120T - Suse 12.1 - VDR 1.6.0 - FF 2.3
Sempron 2800+ - Suse 11.2 - VDR 1.6.0 - FF 2.3
Duron 900 - Suse 8.2 - VDR 1.2.6 - FF 1.3

wirbel

Im Forum Zuhause

Posts: 9,944

Location: Berlin

  • Send private message

2

Monday, April 19th 2004, 12:50pm

RE: lirc funktioniert nicht auf anhieb

Bist du beim ersten Start überhaupt in runmode3?

3

Tuesday, April 20th 2004, 7:23am

RE: lirc funktioniert nicht auf anhieb

Quoted

Original von wirbel
Bist du beim ersten Start überhaupt in runmode3?


klar.

Mode5 ist zwas schön bunt, doch einfach zu langsam...

Mitch
i3-2120T - Suse 13.1 - VDR 2.0.5 - FF 2.3
i3-2120T - Suse 12.1 - VDR 1.6.0 - FF 2.3
Sempron 2800+ - Suse 11.2 - VDR 1.6.0 - FF 2.3
Duron 900 - Suse 8.2 - VDR 1.2.6 - FF 1.3

fraban

Trainee

Posts: 162

Location: Oberbayern

Occupation: Selbst.

  • Send private message

4

Wednesday, April 21st 2004, 11:41am

RE: lirc funktioniert nicht auf anhieb

Hi

bei mir lass ich den LIRC schon in runlevel 2 starten - das läuft so unter SuSe 8.2 9.0 sowie den Debians.

Gruß Frank
VDR1: 2x DVB-s Siemens REV 1.3 | Kernel 2.6.12-1-K7 | 1800 Mhz Athlon | 3x HDD 120GB | 256MB DDR | ASUS SPDIF - opt. TOSLINK --> MARANTZ SR 7200
VDR2: 1x WinTV DVB-s 1.3| Kernel 2.6.12-1-K7 | 3000 Mhz Athlon | 1x HDD 120GB | 512MB DDR
VDR3: 1x WinTV DVB-s 1.3| Kernel 2.6.12-1-K7| 2000 Mhz Athlon | 1x HDD 120GB | 512MB DDR

5

Thursday, April 22nd 2004, 1:25pm

RE: lirc funktioniert nicht auf anhieb

Quoted

Original von fraban
Hi

bei mir lass ich den LIRC schon in runlevel 2 starten - das läuft so unter SuSe 8.2 9.0 sowie den Debians.

Gruß Frank


Danke für die Info.
Ich habe gestern noch herausgefunden, daß bei jedem Boot der Port 0x2f8 (irq3) durch irgendwas schon benutzt wird. Nach Lektüre von Sandmanns Anleitung fügte ich in /etc/boot.local die folgende Zeile ein:
/bin/setserial /dev/ttyS1 uart none

Seitdem funktionierts auch wieder...

Bei meiner anderen Installation mußte ich diese Anpassung (noch) nicht machen und es funtkioniert trotzdem - warum auch immer...

CU
Mitch
i3-2120T - Suse 13.1 - VDR 2.0.5 - FF 2.3
i3-2120T - Suse 12.1 - VDR 1.6.0 - FF 2.3
Sempron 2800+ - Suse 11.2 - VDR 1.6.0 - FF 2.3
Duron 900 - Suse 8.2 - VDR 1.2.6 - FF 1.3

6

Thursday, April 22nd 2004, 1:39pm

das liegt am treiber für die com-schnittstellen im kernel.
sind diese fest eincompiliert kann lirc seinen eigenen treiber nicht einbinden.
der aufruf von "setserial /dev/ttyS1 uart none" scheint das wohl trotzdem irgendwie zu ermöglichen.

am besten die treiber für die com-schnittst. im kernel als modul einbauen.
dadurch können diese später von lirc entladen und durch den lirc-treiber ersetzt werden.

7

Friday, April 23rd 2004, 6:20am

Hallo Sledge,

Quoted

am besten die treiber für die com-schnittst. im kernel als modul einbauen.
dadurch können diese später von lirc entladen und durch den lirc-treiber ersetzt werden.


Werde ich mal heute Abend ausprobieren...

Danke und ein schönes Wochenende...

Mitch
i3-2120T - Suse 13.1 - VDR 2.0.5 - FF 2.3
i3-2120T - Suse 12.1 - VDR 1.6.0 - FF 2.3
Sempron 2800+ - Suse 11.2 - VDR 1.6.0 - FF 2.3
Duron 900 - Suse 8.2 - VDR 1.2.6 - FF 1.3