Posts by Frounts

    Nö danke, hat sich erledigt.

    Das MSI H110M Eco dient als Streaming Server, die NUC6 nur mehr als Streaming Clients. Ich kann damit das Haus + Werkstatt stabil versorgen und bin nicht auf die doofe Strong-Kiste angewiesen und kann damit die Vorteile des VDR nutzen.

    Vielen Dank für deine Arbeit. Ist cool, was Du da geleistet hast :-)


    Frounts

    Nach ein paar Wochen des Testens bin ich bei folgender Hardware stehen geblieben: MSI H110M Eco mit Pentium G4400.

    Läuft stabil mit 2 WinTV-CI USB. Bei nicht verwenden geht der PC in den Ruhezustand, wacht dadurch schneller wieder auf -> kein Problem für die WinTV-CI USB.

    Das Dell Notebook hat, wie prophezeit, nur 2 Wochen gehalten.


    Fr.

    Ich durfte mir von der Firmenschrottkiste ein Dell D830 Notebook mit NVIDIA Quadro NVS 140M zum Testen nehmen, welches den Nvidia NV Bug hat. Das Mainboard war heute für 12min im Backofen, geht wieder... :-)


    Ein Test mit V3.1a: Perfekt; ORF1 HD & Co läuft ohne Probleme mit WinTV-CI


    ßßßuper!

    Fr.

    Ich Idiot... Patch gibs nur unter MLD unstable nicht testing

    Das WinTV-CI hängt nicht am externen USB3, sondern am internen USB 2.0


    Durchsatz passt:

    Code
    1. MLD> ./ci_throughput.pl
    2. Writing to '/dev/dvb/adapter1/sec0' in blocks of 3840 TS (721920 bytes) for 20 seconds ...
    3. Bitrate OUT(633600 TS): 47.46 Mbit/s
    4. Bitrate IN (621979 TS): 46.59 Mbit/s
    5. MLD>


    Hmm... WinTV-CI defekt?

    Files

    • messages.txt

      (204.81 kB, downloaded 24 times, last: )

    USB2.0 Kabel war schnell erledigt, hat aber leider nichts gebracht. Exakt selbes verhalten.

    ca0 löschen geht.


    Ich werde mal warten, bis Clausmuus den Patch eingespielt hat.

    Danke für die Unterstützung, tolle Arbeit.

    Fr.


    Danke für die Info.

    Ich hab Clausmuus gebeten, den Patch beim MLD-Paket: usb2ci zu integrieren.


    Das WinTV-CI hängt natürlich an einem USB3.0 Port, da mein System (NUC6CAYS) extern nur USB3.0 hat. Intern gibt es USB2.0, da muss ich erst löten, passender Stecker mit Kabel hab ich zufällig.


    Quelle: Manual

    Code
    1. USB 3.0 ports: Two ports are implemented with external front panel connectors (one blue and one ambercharging capable)
    2. Two ports are implemented with external back panel connectors (blue)
    3. USB 2.0 ports: Two ports via twosingle-port internal 1x4 1.25 mm pitch headers(white)
    4. One port is reserved for an M.2 2230 Type E Module

    LG Fr.

    Es wird... :-)

    Pixelmatsch auf ORF1 HD gibs schon mal.


    Die Abfragezeiten sind extrem kurz:

    Code
    1. Nov 4 19:26:01 MLD user.info kernel: [ 209.269016] wintv_usb2ci: ca_ioctl : CA_GET_SLOT_INFO [0] : CAM READY
    2. Nov 4 19:26:10 MLD user.warn kernel: [ 218.564170] wintv_usb2ci: ts_urb_complete : TS CAM-IO: +8
    3. Nov 4 19:26:10 MLD user.info kernel: [ 218.676936] wintv_usb2ci: CI_WriteExchange : [50/05] response time 95 ms
    4. Nov 4 19:26:11 MLD user.err vdr: [4043] ERROR: skipped 133 bytes to sync on start of TS packet at device.c/PlayTs(1613)
    5. Nov 4 19:26:11 MLD user.err vdr: [4043] ERROR: skipped 188 bytes to sync on start of TS packet at device.c/PlayTs(1613)
    6. Nov 4 19:26:11 MLD user.err vdr: [4043] ERROR: skipped 107 bytes to sync on start of TS packet at device.c/PlayTs(1613)
    7. Nov 4 19:26:11 MLD user.err vdr: [4043] ERROR: skipped 188 bytes to sync on start of TS packet at device.c/PlayTs(1613)
    8. Nov 4 19:26:11 MLD user.info kernel: [ 219.092936] wintv_usb2ci: CI_WriteExchange : [20/00] response time 96 ms
    9. Nov 4 19:26:11 MLD user.err vdr: [3996] DDCI-Err (ddcitsrecv.cpp,151): skipped 188 bytes to sync on start of TS packet
    10. Nov 4 19:26:11 MLD user.info kernel: [ 219.188929] wintv_usb2ci: CI_WriteExchange : [50/05] response time 95 ms


    Das komplette Log ist auch dabei.

    Auf die Schnelle mit Sundtek und WinTV-CI, mehr Zeit hab ich nicht:


    Code
    1. MLD> cat /etc/modprobe.d/custom.conf
    2. options wintv_usb2ci adapter_nr=1
    3. MLD>
    4. MLD> ls -R /dev/dvb/*
    5. /dev/dvb/adapter0:
    6. demux0 dvr0 frontend0
    7. /dev/dvb/adapter1:
    8. ca0 sec0
    9. MLD>

    Danke, LG Fr.

    Test Sundtek mit WinTV-CI


    Ich hab im meiner Schrottkiste noch ein TT CT2-4650 CI V1.1 gefunden; selbe Prozedure:


    Mit WinTV-CI:

    Code
    1. MLD> ls -l /dev/dvb/*
    2. crw-rw---- 1 root video 212, 0 Nov 3 20:37 ca0
    3. crwxrwxrwx 1 root root 212, 3 Nov 3 20:37 demux0
    4. crwxrwxrwx 1 root root 212, 4 Nov 3 20:37 dvr0
    5. crwxrwxrwx 1 root root 212, 2 Nov 3 20:37 frontend0
    6. crw-rw---- 1 root video 212, 1 Nov 3 20:37 sec0
    7. MLD>

    Ohne WinTV-CI:

    Code
    1. MLD> ls -l /dev/dvb/*
    2. crwxrwxrwx 1 root root 212, 3 Nov 3 20:37 demux0
    3. crwxrwxrwx 1 root root 212, 4 Nov 3 20:37 dvr0
    4. crwxrwxrwx 1 root root 212, 2 Nov 3 20:37 frontend0
    5. MLD>

    Evtl. ein Rechteproblem?

    Oben, im Log mit der TT S2-6400 steht:

    Nov 2 23:53:54 MLD user.err vdr: [12156] DDCI-Err: can't write to CI adapter (/dev/dvb/adapter0/ca0): Operation not permitted


    LG Fr.

    Bitte um ein wenig Geduld, ich hab da was entdeckt:

    Code
    1. Nov 3 16:39:11 MLD user.info vdr: [1989] DDCI-Inf: plugin version 1.0.5 initializing (compiled for VDR version 2.4.1)
    2. Nov 3 16:39:11 MLD user.info vdr: [1989] DDCI-Inf: no DD CI adapter found
    3. Nov 3 16:39:11 MLD user.info vdr: [1989] DDCI-Inf: plugin started

    Ich glaub, der Sundtek MediaTV Digital Home III (DVB-C/T/T2) USB-Stick passt nicht.

    Ich kann damit zwar ORF1 in SD und SLO1 HD schauen (eh klar, unverschlüsselt), aber sobald ich auf ORF 1 HD umschalte, passiert aktuell gar nichts mehr.


    Ich werde mir auch einen August T230 DVB-T2 Stick bestellen, melde mich dann wenn ich mehr weiß

    Ja, das CAM-Modul ist im VDR-Menü da und ich kann mich durchs Menü bewegen.


    Durchsatztest schaut gut aus:

    MLD> ./ci_throughput.pl

    Writing to '/dev/dvb/adapter2/sec0' in blocks of 3840 TS (721920 bytes) for 20 seconds ...

    Bitrate OUT(641280 TS): 48.02 Mbit/s

    Bitrate IN (637908 TS): 47.77 Mbit/s

    MLD>


    claus was so nett und hat ein Paket gebaut:

    https://minidvblinux.de/forum/…g75266/topicseen.html#new


    Neues Testsystem: MLD5.4 testing x86 mit TT S2-6400, Alphacrypt Classic V3.28 mit ORF-Karte,

    Kanal: ORF2 HD St


    Hallo,

    Ist die Version V3.1 im GitHub aktuell? Mein SimplyTV-Modul wird zwar erkannt, aber irgendwie passiert gar nichts.

    System: MLD5.4 testing mit einem NUC6


    viel zu kurze Antwortzeiten:

    Nov 2 19:02:37 MLD user.info kernel: [ 224.303410] wintv_usb2ci: CI_read_CMD_REPLY : [06] 119/60/59

    Nov 2 19:02:37 MLD user.info kernel: [ 224.335409] wintv_usb2ci: CI_read_CMD_REPLY : [06] 59/59/0

    Nov 2 19:02:37 MLD user.info kernel: [ 224.335414] wintv_usb2ci: CI_WriteExchange : [80/06] response time 64 ms

    Nov 2 19:02:39 MLD user.info kernel: [ 226.479411] wintv_usb2ci: CI_read_CMD_REPLY : [06] 100/60/40

    Nov 2 19:02:39 MLD user.info kernel: [ 226.511408] wintv_usb2ci: CI_read_CMD_REPLY : [06] 40/40/0

    Nov 2 19:02:39 MLD user.info kernel: [ 226.511413] wintv_usb2ci: CI_WriteExchange : [80/06] response time 64 ms

    Nov 2 19:02:41 MLD user.info kernel: [ 228.623419] wintv_usb2ci: CI_read_CMD_REPLY : [06] 119/60/59

    Nov 2 19:02:41 MLD user.info kernel: [ 228.655420] wintv_usb2ci: CI_read_CMD_REPLY : [06] 59/59/0

    Nov 2 19:02:41 MLD user.info kernel: [ 228.655427] wintv_usb2ci: CI_WriteExchange : [80/06] response time 64 ms




    Danke für die Info mit dem anpassen von CA Wert im doscan.lua Script. Gleichzeit hab ich die TranspoderList.json händisch upgedatet für Astra E19.2, da waren doch einige Fehler drinnen.


    Damit wurden bei mir aus ~500 Sender -> 1121 Sender. Wobei nach dem Scan die Meldung kommt: 1121 Channels found, time: 801 seconds

    time: xxx seconds sehe ich übrigen zum ersten Mal.


    Ich nutze die M3U-Listen an diversen Geräte für VLC. Das was ich brauche, kopiere ich zusammen, der Rest fliegt von der Liste raus.