Posts by panik105

    Hallo,


    inzwischen habe ich nach endloser Bastelei mal wieder eine Konstellation gefunden, die stabil läuft, deshalb einige Infos dazu :
    (leider kann ich nicht mehr zu allen Punkten Links zu den entsprechenden Threads angeben)


    Quote

    Original von panik105
    - DVD-Wiedergabe :
    - ohne Deaktiviern von Dolby unter Einstellungen/DVB gar kein Ton mehr
    - nach dieser Umstellung immer nur die erste Tonspur (d.h. dass man des öfteren nur den englischen Ton bekommt). Ich habe irgendwo gelesen, dass dies nur durch Einspielen eines Kernels 2.6.x und/oder eines neuen DVB-Treibers zu beheben ist. Richtig ?
    Das möchte ich aber ungern tun, da alle meine Tests mit den neuen Treibern zeigten, dass die alten eben wesentlich stabiler liefen


    Inzwischen habe ich auf die neuen Treiber umgestellt und dann verschiedene Firmware-Dateien runtergeladen (inzwischen 2622). Damit geht die DVD-Wiedergabe wieder.
    Allerdings gibt es mit diesen neuen Treiber haufenweise andere Probleme, die ich durch Umstellen auf grub, Parallelinstallation von 2.4.27, 2.6.12 und 2.6.15 sowie viele andere Umstellungen versucht habe in den Griff zu bekommen. Hier eine Übersicht :
    - 2.6.15 läuft bei mir nicht (alle paar Stunden bleibt das ganze System mit kernel panic sthen)
    - bei 2.6.12 klappt die Wiedergabe von Audio-CDs mittels cdfs nicht (Threads dazu existieren)
    - Alles was grab verwendet (Screenshot-Plugin, vdradmin, vdr-xxv, vdrconvert) grabbt von der falschen Karte (analog). Lösung ist momentan den vdr selbst zu übersetzen und dafür zu sorgen, dass immer von /dev/video statt von /dev/video<n> gegrabbt wird. Dann /dev/video als Link auf das richtige Device erzeugen. (Diese Lösung ist von jemand anderem, der Thread ist mir leider auch entfallen :-))
    - Nach einigen Stunden Inaktivität hängt sich der Treiber weg. Vdr läuft, Bild schwarz. Leider klappt auch der runvdr-Mechanismus nicht, d.h. Timer führen zu ständigen vergeblichen vdr-Neustarts. Nur ein manuelles vdr stop; modprobe -r dvb-ttpci; modprobe dvb-ttpci; vdr start bringen den vdr wieder auf die Beine.
    Lösung : EPGScan auf 0 drehen und mittels einem Script wie in http://www.vdr-portal.de/board/thread.php?postid=408715 des Nachts die Daten nur von den "guten" Sendern holen. Wahrscheinlich hängt er sich weg, wenn er auf die analogen Kanäle schaltet (s. u.)


    Quote

    Original von panik105
    - Analogtv-plugin :
    Wie immer das grösste aller Probleme beim Update
    - es ruckelt derart krass, dass man kaum vernünftig gucken/aufnehmen kann (3-4 Aussetzer pro Sekunde)
    - es ist kein Umschalten von analogem Kanel auf analogen Kanal mehr möglich, hierbei resettet sich der vdr reproduzierbar. Wenn ich zwischendurch auf einen digtalen Kanal wechsle, funktioniert es aber


    Vor langer Zeit gab es mal ein Problem, dass die im analogtv-plugin enthaltene mp1e-Version bei mir (und anderen) nicht lief. (Lösung s. http://www.vdrportal.de/board/thread.php?threadid=27461).
    Nahme ich das so entstandene mp1e-binary, dann ist das Ruckeln weg.
    Das Umschalten funktioniert (durch irgendeine andere Änderung) inzwischen in 2/3 aller Fälle, in den anderen Fällen restartet der vdr. Scheinbar hat es irgendwas mit stehenbleibenden mp1e-Threads zu tun.
    Wenn ich diese mittels kill beende, dann klappt das Umschalten wieder.


    Tschuess..
    Michael

    Hallo,


    heute mal wieder ne lange Mail..


    nachdem ich zur Überzeugung gekommen bin, dass tatsächlich niemand mehr tobi/testing verwendet :-) und inzwischen ja sogar ctvdr4.5 bei 1.3.x angekommen ist, habe ich mich am Wochenende auch mal an den Umstieg auf tobi/experimental gewagt.


    Das allermeiste lief auf Anhieb oder nach kleinen Änderungen, ausserdem habe ich inzwischen auch noch eine ganze Reihe Plugins installiert, die es bisher noch gar nicht gab. Ich finde es ziemlich klasse, was sich da getan hat, z.B. Wahl des Audiokanals, VPS, Skins, und und und (ich hatte quasi noch nie in vdrdevel reingeschaut)
    Insbesondere laufen erstmalig folgende Sachen :
    - vdr-plugin-control (führte regelmässig zum Crash, der ganze vdr lief instabil, wenn es nur installiert war)
    - grössere Textausgaben im vdr-Fenster wie z.B. vdr-Wartung/Informationen über das VDR-System (Aufruf führte reproduzierbar zum Neustart des vdr)



    An einigen Stellen habe ich lange gekämpft und auch keine entsprechenden Forumeinträge gefunden :
    - xxv :
    - Ich konnte im Music-Modul keine MP3s mehr abspielen, da als Link immer etwas in der Art http://undefined/?cmd=mplaylist&data=6&binary=1 gesendet wird -> lässt sich beheben, indem man einen anderen als den Default-Skin auswählt
    - Mal am Rande : Warum geht der Firefox bei so einem Link auf http://undefined.cc/ ?


    - xxv :
    - Irgendjemand modifiziert seit dem Umstieg regelmaessig von alleine meine channels.conf (hat das was mit AutoPID zu tun ?)
    - alle so gefundenen Kanäle kann ich eh nicht anwählen weil sie entweder verschlüsselt sind oder analoge Kanäle mit falscher Kennung (2001 statt A0), dazu später mehr
    - in der channels.conf wurden so auch Sektionen neu erstellt, die es bei mir schon gab, d.h. sie waren dann doppelt vorhanden (z.B. Sport, Musik, Vollprogramme, usw..)
    - darüber fällt xxv, es wird nur die jeweils 2. Sektion berücksichtigt, alle Kanäle in der jeweils 1. Sektion fehlen sowohl in der Kanalliste als auch überall sonst (Was läuft jetzt, Programmübersicht) -> Abhilfe brachte ein manuelles Umbennen der bereits vorhandenen Sektionen



    Andere Punkte habe ich gar nicht zum Laufen gebracht :
    - vdr_plugin_clock läuft nicht mehr (macht einfach gar nix) -> egal, deinstalliert


    - DVD-Wiedergabe :
    - ohne Deaktiviern von Dolby unter Einstellungen/DVB gar kein Ton mehr
    - nach dieser Umstellung immer nur die erste Tonspur (d.h. dass man des öfteren nur den englischen Ton bekommt). Ich habe irgendwo gelesen, dass dies nur durch Einspielen eines Kernels 2.6.x und/oder eines neuen DVB-Treibers zu beheben ist. Richtig ?
    Das möchte ich aber ungern tun, da alle meine Tests mit den neuen Treibern zeigten, dass die alten eben wesentlich stabiler liefen


    - Analogtv-plugin :
    Wie immer das grösste aller Probleme beim Update
    - mittels dpkg-reconfigure eine channels.conf erzeugt, diese enthält im 9. Feld 32001, damit es funktioniert, muss dort aber A0 stehen. Die automatisch erweiterten Einträge (s.o.) haben dort 2001 stehen, das funktioniert aber auch nicht (in beiden Fällen kommt "Kanal nicht verfügbar"
    - es ruckelt derart krass, dass man kaum vernünftig gucken/aufnehmen kann (3-4 Aussetzer pro Sekunde)
    - es ist kein Umschalten von analogem Kanel auf analogen Kanal mehr möglich, hierbei resettet sich der vdr reproduzierbar. Wenn ich zwischendurch auf einen digtalen Kanal wechsle, funktioniert es aber


    Da das analogtv-plugin grundsätzlich Probleme macht und es inzwischen ja Privatsender digital bei iasy im Kabel gibt : Würde das funktionieren ?
    - Gibt es noch irgendwo CI-Karten für Hauppauge DVB-C zu kaufen ?
    - Welches CAM-Modul braucht man ?
    - Bekommt man überhaupt eine Smartcard ohne Receiver von iesy ?
    - Hat schon irgendjemand damit Erfahrungen/Ideen ?


    Tschuess..
    Michael

    Quote

    Original von chipsfrisch
    Habe gerade das ISO gebrannt und es läuft auf dem DVD-Player.


    Ach so: Ich habe es auf die neue c't vdr 4.5 geschoben an der ich seit einer Woche am basteln bin.
    Muss aber sagen: Läuft sonst gut.
    Bis auf die Macken.


    Wie schon in einem anderen Thread geschrieben :
    Hilft nur bei vdr2dvd, nicht bei vdr2divx und vdr2mpg, dort wird in jedem Fall tcmplex benötigt.

    Quote

    Original von tuffman_de
    Der Parameter USE_TCMPLEX_PANTELTJE="yes" (vdrconvert.conf) bringt vdrconvert dazu tcmplex_panteltje zu benutzen statt tcmplex.


    Und jetzt funzt alles wie erwartet


    Das gilt aber zumindest in meiner Version (tobi/testing) nur für vdr2dvd.sh, nicht für vdr2mpg.sh und vdr2divx.sh, dort wird immer TCMPLEX verwendet.

    Hallo,


    ich betreibe ct-vdr3 mit anschlieseendem Umstieg auf e-tobi testing.
    Auszug aus sources.list :
    deb http://e-tobi.net/vdr-experimental sarge base backports
    deb http://e-tobi.net/vdr-testing sarge base backports addons vdr-bigpatch
    deb http://e-tobi.net/vdrdevel-experimental sarge base backports addons vdr-multipatch
    deb ftp://ftp.nerim.net/debian-marillat/ sarge main


    D.h. unter anderem, dass ich seit Monaten von http://www.vdrportal.de/board/thread.php?threadid=35134 betroffen war.
    Seit ein paar Tagen klappt das jetzt ohne Basteln, allerdings hatte ich dafür 2 neue Probleme : Wegen fehlendem tcmplex brach das Erstellen von mpegs und dvds mittels vdrconvert ab (Lösung : http://www.vdrportal.de/board/thread.php?threadid=43677), ausserdem konnten keien dvds erstellt werden wegen eines Problems mit dvdauthor (Lösung : http://vdr-portal.de/board/thread.php?threadid=42430)


    2 Fragen dennoch : Ich habe jetzt tcmplex einfach von hand aus einem Backup eingespielt, lese aber heute, dass es eine Konfigvariable in vdrconvert.conf gibt, mit der man einstellen kann, dass es nicht verwendet werden soll : Wie ist denn der default ?
    Ausserdem frage ich mich, warum das scheinbar kaum jemand anderen Probleme bereitet (s. diverse Threads, wo z.B. das Fehlen von tcmplex bestätigt, aber als ohne weitere Auswirkungen auf das System beschrieben wird).
    Verwende ich eine vdr-Variante, die inzwischen nicht mehr unterstützt bzw. von kaum jemandem benutzt wird, d.h. sind alle schon bei vdr-experimental ?


    Tschuess..
    Michael

    Nochmal hallo,


    ein bisschen weiter suchen laesst einen die Stelle finden an der /usr/sbin/runvdr die entsprechende Meldung ausgibt, d.h. offensichtlich schmier der vdr-Prozess ab und wird entsprechend neu gestartet.


    Warum wird eingentlich genau in dem Falle, wo /tmp/vdr.err durch den nachfolgenden Neustart überschrieben wird, sein Inhalt nicht in die Logdatei geschrieben, während dies beim endgültigen Abbruch, wo sie eh stehenbleibt, getan wird ?


    Also ein bisschen modifiziert :


    56,57c56
    < ERR=`cat /tmp/vdr.err`
    < logger -t runvdr "restarting VDR ($ERR)"
    ---
    > logger -t runvdr "restarting VDR"


    und schon ist das Log zugemüllt mit Meldungen des txtsubs-Plugins :-(
    Dieses deinstalliert und man erhält :


    May 9 14:04:31 mvdr runvdr: restarting VDR (/usr/sbin/runvdr: line 1: 12983 Speicherzugriffsfehler vdr
    -v /var/lib/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -P teletext -P osdteletext -P "mp3 -m /usr/l
    ib/vdr-plugin-mp3/mount.sh -i /usr/lib/vdr-plugin-mp3/image_convert -c /var/cache/vdr-plugin-mp3/images/"
    -P "image -m /usr/lib/vdr-plugin-image/mount.sh -C /usr/lib/vdr-plugin-image/imageplugin.sh" -P "mplayer
    -m /usr/lib/vdr-plugin-mplayer/mount.sh -M /usr/lib/vdr-plugin-mplayer/mplayer.sh" -P "dvd -C /var/cache
    /vdr/dvd" -P dvdselect -P "vcd -v /dev/dvd" -P pcd -P "mailbox -m /usr/lib/vdr-plugin-mailbox/mailcmd.sh"
    -P "vbox " -P newsticker -P weather -P clock -P analogtv -P screenshot -P femon -P osdpip -P "tvonscreen
    " -P calendar -P pilot -P prefermenu -P timeline -P streamdev-client -P streamdev-server -P games -P fre
    ecell -P console -P vdrc -P solitaire -P playlist -P "autotimeredit " -P undelete -P "vdrrip -p /usr/bin/
    mplayer -e /usr/bin/mencoder -d /dev/dvd" -P "graphlcd -c t6963 -x 240 -y 64"


    Also: Speicherzugriffsfehler. So, und jetzt weiss ich nicht mehr weiter.


    Tschuess..
    Michael

    Hallo,


    hat dieses Problem wirklich sonst niemand ? Ich habe in letzter Zeit noch festgestellt, dass dies auch beim mp3-plugin passiert. Auch hier weiss ich definitiv, dass ich solche Restarts früher niemals hatte. (Ich weiss, dass mp3- und mplayer-Plugin irgenwie miteinander verwandt sind :-))
    Der Restart erfolgt hierbei erst einige Sekunden nach Ende - wenn man schnell genug ist, kann man sogar noch das OSD-Menu aufmachen und darin blättern.


    Tschuess..
    Michael

    Hallo,


    ich benutze ctvdr3 (tobi/testing) mit DVB-C und analogtv.
    Seit einiger Zeit (ich kann es leider nicht an einem bestimmten Update festmachen) habe ich beim verwenden des mplayer-plugins das Problem, das bei 2/3 aller Aurufe nach dem Abspielen des Videos der VDR neu gestartet wird. Das passierte auch früher sehr selten mal, leider ist es inzwischen fast die Regel. Ich kann nicht feststellen, dass es von bestimmten Dateien abhängt. Es ist auch egal, ob ich das Video bis zum Ende laufen lasse oder vorher abbreche. Beim Beenden des Abspielvorgangs wird der VDR neu gestartet. Die Logdateien (/var/log/messages) sehen z.B. so aus :
    r 13 01:42:22 mvdr vdr[18031]: switching to channel 15
    Apr 13 01:42:39 mvdr logger: *** Starting mplayer.sh Version 0.8.6
    Apr 13 01:42:39 mvdr logger: *** DEBUG: Variable CFGFIL has value "/etc/vdr/plugins/vdrmplayer.sh.conf"
    Apr 13 01:42:39 mvdr logger: *** Use Option USERDEF at your own risk!
    Apr 13 01:42:41 mvdr logger: *** INFO: Source Video has Resolution of 320 x 240 ...
    Apr 13 01:42:41 mvdr logger: *** INFO: For Sqare Pixels we would scale to 384 x 288 ...
    Apr 13 01:42:45 mvdr runvdr: restarting VDR
    Apr 13 01:42:51 mvdr kernel: DVB: registering new adapter (Technotrend/Hauppauge PCI rev2.1 or 2.2).
    Apr 13 01:42:51 mvdr kernel: PCI: Found IRQ 11 for device 00:07.0
    Apr 13 01:42:51 mvdr kernel: PCI: Sharing IRQ 11 with 00:02.7
    Apr 13 01:42:51 mvdr kernel: DVB: VES1820(0): setup for tuner sp5659c
    Apr 13 01:42:51 mvdr kernel: DVB: VES1820(0): pwm=0x40
    Apr 13 01:42:51 mvdr kernel: DVB: registering frontend 0:0 (VES1820 based DVB-C frontend)...
    Apr 13 01:42:55 mvdr kernel: DVB: AV7111(0) - firm f0240009, rtsl b0250018, vid 71010068, app 8000261a
    Apr 13 01:42:55 mvdr kernel: DVB: AV7111(0) - firmware supports CI link layer interface
    Apr 13 01:42:55 mvdr kernel: av7110(0): Crystal audio DAC detected
    Apr 13 01:42:55 mvdr kernel: Technotrend/Hauppauge PCI rev2.1 or 2.2 adapter 0 has MAC addr = 00:d0:5c:1f:7a:97
    Apr 13 01:42:55 mvdr vdr[30483]: VDR version 1.2.6 (ElchiAIO4d) started
    Apr 13 01:42:55 mvdr vdr[30483]: loading plugin: /usr/lib/vdr/plugins/libvdr-teletext.so.1.2.6


    Wo wird evtl. noch protokolliert, welcher Teil Probleme macht (cdr, plugin, mplayer oder dvb-Treiber) ?


    Tschuess..
    Michael


    Hallo,


    nachdem mir dieses Paket "versehentlich" mittels apt-get upgrade
    reingerutscht ist, startet der vdr ständig durch, da analogtv einen
    Speicherzugriffsfehler bringt.


    Stöbern im Forum liefert mir das folgende :


    http://www.vdrportal.de/board/thread.php?threadid=28012&sid=&hilight=analogtv


    Ich habe hier DVB-C und alte WinTV-Karte, aber ansonsten genau den
    bechriebenen Effekt.


    Heisst das, das neue Plugin ist per default nicht mehr in Kombination mit einer FF-Karte zu gebrauchen ?


    Tschuess..
    Michael

    Hallo,


    ich habe heute mal mit dem graphlcd-plugin rumgespielt; da ich aber (noch) kein Display habe, wollte ich das ganze mal mit dem framebuffer versuchen.


    -ctvdr 3
    -Hermes 651 und Monitor am VGA-Ausgang
    -tobi - testing


    -modprobe vga16fb -> keine Fehlermeldung, Framebuffer ist aktiv (sieht man m.E. schon an den Buchstaben :-))
    -cat <irgendwas> > /dev/fb0 bringt (korrekterweise) das Display durcheinander


    -apt-get install fbset
    -fbset sagt
    mode "640x480-59"
    # D: 25.176 MHz, H: 31.469 kHz, V: 59.489 Hz
    geometry 640 480 640 480 4
    timings 39721 48 16 39 8 96 2
    rgba 6/0,6/0,6/0,0/0
    endmode


    -in /etc/vdr/plugins/plugin.graphlcd.conf steht
    -c framebuffer -z 1


    -in /var/log/messages steht beim vdr-Start
    The framebuffer device was opened successfully.
    V01: xres: 640, yres 480, vyres: 480, bpp: 4, linelenght: 80


    -alle Konfigurationsoptionen (mittels OSD einsehbar) sind unverändert


    soweit in Ordnung, oder ?


    Aber : wo sehe ich jetzt was ? :-)
    Ich habe F1-F6 Konsolen, F8 die VDR-Konsole und kein X am Laufen.


    Tschuess..
    Michael


    Hallo,


    es klappt :-)


    ich habe mir mittels cvs den aktuellen mp1e-Quellcode geholt, dann deinen Patch angewandt und neu übersetzt und schon funktioniert alles wie gehabt (wohlgemerkt ohne Änderungen am analogtv selbst !).


    D.h. dass tatsächlich nur das mp1e im analogtv-Paket nicht passt !


    Vielen Dank nochmal.


    Tschuess..
    Michael

    Quote

    Original von vdrviewer


    Habe den heutigen CVS Stand von rte und analogtv ausgescheckt:
    rte 0.9.5
    analogtv 0.9.37


    wenn gewünscht stelle ich hier den quick and dirty patch bereit


    Hallo,


    so ganz verstanden habe ich das nicht.


    Ich habe ja überhaupt kein vdrdevel, sondern den normalen (aber macht das in diesem Zusammenhang einen Unterschied ?)
    Zwischenzeitlich bin ich von ct-stable über ct-testing bei tobi-testing gelandet - eine neuere analogtv-Version ergab sich dadurch aber nicht (alles 0.9.33)
    Erst tobi-experimental würde 0.9.36 enthalten, da will ich aber eigentlich nicht hin, weil zu unsicher.



    Heisst das, du gehst davon aus, dass auch die 0.9.33 falsch gepatcht wurde ?
    Kann ich mir einfach so cvs-Versionen selbst kompilieren und ins System einspielen ohne dass die paketverwaltung durcheinander kommt ?


    Ich hatte mir in der Zwischenzeit auch die Quellen geholt und inspiziert, dabei habe ich festgestellt, dass die lt. diverser Internet-Threads zur Behebung dieses Fehlers zu patchenden Passagen in mp1e bereits gepatcht waren.
    Jetzt habe ich mir eben den Quelltext nochmal angesehn bzgl. der von die genannten Punkte -> CPU_CYRIX_NEHEMIAH ist hier noch nicht zu finden
    und mpeg1.c Zeile 216 ist eine Leerzeile :-)


    Evtl. könntest du nochmal genauer sagen, um was für eine Stelle es sich da genau handelt (oder vielleicht doch den Quick und dirty-Oatch bereitstellen :-))


    Tschuess..
    Michael

    Hallo,


    ich habe nach Umstieg von ctvdr2 auf ctvdr3 und einigem Basteln
    inzwischen wieder alles am Laufen ausser dem analogtv-Plugin.


    Vorab ein paar Infos :
    - Hardware ist das ursprünglich mal von ct empfohlene MSI651-Barebone-System mit DVB-C-FF-Karte und alter WinTV-Karte.
    - unter ctvdr2 lief das analogtv-Plugin
    - mit ctvdr3 bekomme ich beim analogtv-Plugin maximal 1-2 Bilder, dann nix
    mehr (vdr und osd inkl. Fernbedienung funktionieren aber weiterhin, nur
    mp1e schmiert ab)
    - mit ctvdr3 läuft jetzt im Gegensatz zu ctvdr2 auch alsa inkl. OSS-Emulation
    (überprüft z.B. mit xmms und xawtv)
    - Problem tritt aber auch dann auf, wenn ich alsa entlade, den OSS-Treiber
    starte und dann auf analog-Kanal schalte


    Nun zum Problem :


    In /tmp/vdr.err steht
    mp1e:v4l25.c:148: Failed to enqueue capture buffer (22, Invalid argument)


    mp1e meldet dasselbe auf Kommando-Zeile (z.B. mit Parameter -p /dev/dsp oder alsa/default, -x /dev/mixer, -c /dev/video)


    Googlen ergibt, dass es irgendwann mal ein mp1e gab, das mit bttv nicht
    zurechtkam und für analogtv gepatcht werden musste und sonst diese Meldung brachte.
    Die Version gehört aber zum Plugin ?! ich habe mir das Plugin aktuell gestern
    nochmal neu installiert -> kein Unterschied


    Sollte die mp1e-Version, die im analogtv-Plugin des ctcdr3-Repository liegt,
    nicht schon passend sein ? Läuft das bei jemandem (mit möglichst ähnlicher
    Konfig) ?


    Tschuess und feiert schoen..
    Michael

    Quote

    Original von TomG


    Kann ich leider nicht testen, da ich keine PhotoCD besitze. Kann das Problem jemand bestätigen?


    Da es quasi so gut wie keine PhotoCds mehr gibt, ist das natuerlich nicht so wichtig. War nur der Vollstaendigkeit halber.


    Quote


    Ich gebe dir Recht, dass das nicht so bleiben kann. Allerdings wird die Sache noch komplizierter durch die neue Version des OSD-Teletext-Plugins (ich hoffe, wir kommen bald dazu, endlich auf die neue Version umzustellen), da dort - wenn ich mich recht erinnere - die Teletext-Daten in einem anderen Format abgelegt werden, so dass das Zusammenspiel der beiden Plugins sowieso nicht mehr klappt. (Hat jemand Erfahrungen damit?)


    Als schnelle Abhilfe empfehle ich dir, eines der beiden Verzeichnisse in einen Link auf das andere umzuwandeln.


    So gehts, Danke. Haette ich eigentlich auch selbst drauf kommen koennen !


    Mit minmal geänderten Konfigwerten habe ich uebrigens inzwischen auch wieder xfree86 am Laufen. Waren wohl kleine Unterschiede im vesa-Treiber der unterschiedlichen Versionen.


    Tschuess..
    Michael

    Quote

    Original von TomG


    Installiere Version 1.1.1-4 von dvb-dev, da ist dieser Konflikt gelöst. Das Paket ist Original-Debian-Sarge - du brauchst also den entsprechenden Eintrag in der sources.list.


    Tom


    Danke. So hat es geklappt !


    Und nach einigen weiteren Problemchen dann letztlich auch die Audio-CD Wiedergabe mit dem so erstellten Paket.


    Tschuess..
    Michael

    Hallo,


    ich bin so ziemlich seit Beginn des ct-vdr-Projektes dabei,
    habe dann irgendwann auch auf Version2 upgedatet. Nachdem
    inzwischen seit einigen Wochen ctvdr draussen ist, es aber
    leider keinerlei "offizielle" Aussage bzgl. Update eines
    bestehenden Systems gab, habe ich mich am Wochenende hingesetzt
    und mit folgender Vorgehensweise auf ctvdr3 umgestellt :


    - Sichern relevanter Konfiginformationen
    - Neuinstallation mittels des heruntergeladenen ctvdr306.iso-Images
    - Beibehalten der Partition mit den Aufnahmen
    - manueller Abgleich der Konfiguration mit den alten Dateien


    Soweit klappt das auch ganz gut, ich habe aber trotzdem noch eine
    ganze Reihe von Fragen/Anmerkungen :


    - Ich kann bestätigen, dass die Installation scheitert, falls man
    das mplayer-plugin anwählt, eine Installtion ohne mit anschliessender
    manueller Installation des Plugins klappt dagegen einwandfrei


    - Audio-CDs können vom mp3-plugin nicht mehr abgespielt werden
    (s. meine Antwort in anderem Thread dazu)


    - der PhotoCD-Plugin funktioniert nicht mehr : bei jedem Zugriff
    auf eine PhotoCD wird der vdr neu gestartet


    - Problem mit den 2 teletext-plugins :
    Ich hatte /vtx (das bislang von beiden genutzt wurde), wie hier
    schon öfter vorgeschlagen mittels eines tmpfs-Eintrags im Ram
    liegen und wunderte mich, dass dort keinerlei Dateien mehr entstanden.
    Nach Durchlesen der Debian-changelogs der beiden Plugins weiss
    ich, dass teletext seine Dateien jetzt in /var/cache/vdr-plugin-teletext
    ablegt, osdteletext aber in /var/cache/vdr/vtx.
    Hierdurch ist es m.E. nicht mehr sinnvoll, den osdteletext ohne die Option
    -r zu starten, da er die Dateien des anderen Plugins nicht mehr findet.
    Die Verzeichnisse sollten unbedingt wieder vereinheitlicht werden !


    - analogtv funktionert zunächst nicht mehr (habe TT-DVB-C-Karte und
    WinTV-analog - lief mit ctvdr2 zusammen)
    Wenn ich das bttv-Modul vor dvb-ttpci lade (wie in Anleitung angegeben),
    dann erhalte ich nur einen schwarzen Bildschirm. Ausserdem habe ich dann
    bei den digitalen Kanälen nur noch Bild und keinen Ton mehr.
    Lade ich es nicht vorher, kommt (richtigerweise) "Transfermode konnte
    nicht gestartet werden".
    Dies muss ich aber noch näher untersuchen. Sollte jemand diese
    Kombination bereits lauffähig haben, wären Infos zur genauen
    Vorgehensweise aber trotzdem nett.


    - Eine Sache, die nicht unbedingt mit dem vdr selbst zu tun hat :
    Ich habe zu Testzwecken einen xfree86 auf dem vdr laufen und habe mir
    auch dort die relevanten Konfiginformationen gesichert :
    Section "Device"
    Driver "vesa"
    Section "Monitor"
    HorizSync 28-31
    VertRefresh 45-55
    alle Modi 640x480
    Wie man sieht, handelt es sich bei dem Monitor um eine uralte Kiste,
    der aber nichtsdestotrotz mit genau diesen Werten unter woody funktionierte.
    Jetzt bekomme ich nur die Meldungen :
    (EE) VESA(0): No matching modes
    (EE) Screen(s) found, but none have a usable configuration


    Für sachdienliche Hinweise zu diesen Punkten wäre ich dankbar.


    Tschuess..
    Michael


    P.S.: Ansonsten finde ich das Update prima, das allermeiste funktioniert
    problemlos (Habe so ca. 2 Dutzend Plugins usw. am Laufen)

    Hallo,


    habe hier auch das beschriebene Problem, dass ich keine Audio-CDs
    mehr abspielen kann nach Umstieg von ctvdr2 auf ctvdr3.
    Ein Einspielen des Binärpaketes scheitert bei mir mit den Meldungen,
    dass nicht auflösbare Abhängigkeiten zu libstdc++2.10-glibc2.2 und
    libvorbis0 bestehen (ich nehme an, dass es gar nicht für die
    ctvdr3-Variante ist ?!).


    Deshalb der Versuch, selbst zu übersetzen :
    Ich bin nach http://www.e-tobi.net/cgi-bin/main.cgi/=compiling
    vorgegangen und stosse dabei auf das Problem, dass apt-get build-dep
    bei sämtlichen Plugins vdr-dev nicht installieren kann, da dvb-dev
    mit linux-kernel-headers kollidiert :
    dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/dvb-dev_1.0.1-8ct_all.deb (--unpack):
    versuche »/usr/include/linux/dvb/audio.h« zu überschreiben, welches auch in Paket linux-kernel-headers ist


    Ich habe hier im Forum gesucht und gleich mehrfach Leute mit
    demselben Problem gefunden, aber keine Lösung.
    (m.E. kollidieren die Dateien aus dvb-dev mit den im Kernel (ab 2.6 ?)
    bereits enthaltenen gleichnamigen Dateien)


    Tschuess..
    Michael

    Hallo,


    meiner Ansicht nach ist in dem Skript der Fehler, dass für das Auftreten von vdr2vcd und vdr2svcd jeweils beide Einträge erzeugt werden
    (mit | verknüpft).
    Ich habe einfach wieder 2 Blöcke draus gemacht, dann gings :


    vdr2vcd )
    if [ "`which tosvcd`" != "" ]; then
    egrep "vdr2vcd" $RECCMDSFILE_TEMPLATE >> $RECCMDSFILE
    fi
    ;;
    vdr2svcd )
    if [ "`which tosvcd`" != "" ]; then
    egrep "vdr2svcd" $RECCMDSFILE_TEMPLATE >> $RECCMDSFILE
    fi
    ;;


    Tschuess..
    Michael

    Quote

    Original von psct


    Wie in der Doku auf unserer Web-Site steht, müssen die PVR-Treiber unbedingt zuerst geladen sein, also /dev/video0 bekommen. Die Nichtexistenz von /dev/video1 stört zumindest bei meinem Testsystem den Betrieb der DVB-Karte praktisch nicht.


    Peter


    An (mindestens) einer Stelle ist das wichtig : wenn man in vdradmin Bilder im "Fernseher" haben möchte. Nach Anlegen von /dev/video1 ging das hier wieder. (Zwar bttv hier und nicht ittv, aber das ist wohl egal)


    Tschuess..
    Michael