Posts by c.h.

    @M-Reimer

    Mit der seriellen Schnittstelle habe ich bislang gute Erfahrung gemacht.

    Bei yaVDR war es auch keine große Schwierigkeit. Wenn man es verstanden hat, was man beachten muss, funktioniert es in der Regel.


    Sicherlich ist die Verwendung der seriellen Schnittstelle oldschool, aber als ein kleines Bastelprojekt kann man auch mal einen Klassiker zusammen bauen. ;)


    Den Thread zu deinem IRMP2Keyboard-Projekt habe ich mir auch schon durchgelesen, interessanter Ansatz.

    Was für ein IR-Empfänger verwendest du für dein Projekt?


    @Emma53

    Danke für die Links, der Aufbau der Schaltung ist wohl immer gleich. Also könnte es wohl funktionieren.

    Der originale IR-Empfänger ist empfangsstark und konnte deshalb auch auf der Rückseite platziert werden.

    Die Option für ein Kabel habe ich mir auch schon überlegt, mal schauen.

    Bei den IR-Empfänger kann ich einen in 36 und 38 kHz bestellen, sicher ist sicher. :)


    Vielen Dank!


    Schöne Grüße


    Christian

    Der VDR ist im Normalfall an einem Multischalter für Astra / Hotbird angeschlossen.

    Da nur eine Satleitung vorhanden ist, wird diese mit einem Kathrein EBC 10 auf die beiden Tuner aufgeteilt.

    In den LNB-Einstellungen sind die beiden Tuner auch auf Sat-Kabel 1 fixiert.


    Um mit der Drehanlage auch die schwachen Satelliten zu empfangen, habe ich den EBC 10 nicht verwendet.

    Den VDR habe ich so eingestellt, dass er nur mit dem ersten Tuner / Device 0 starten soll (--device=0) und hier die Drehanlage angeschlossen.

    Da es mit der DD Cine S2 V7A nicht funktioniert hat, habe ich es mit den beiden anderen Karten getestet.

    Bei den Test waren die verschiedenen Satkarten immer alleine im System verbaut.


    Nächste Woche kann ich das System nochmals intensiver testen.

    Zusätzlich kann ich es auch noch mit den anderen VDRs probieren.


    Gibt es die Möglichkeit beim VDR mitzuloggen, was für DiSEqC-Befehle gesendet werden?

    Im normalen System-Log wird das wahrscheinlich nicht drin sein, oder?


    Schöne Grüße


    Christian

    Da die Karte ja aus der Zeit stammt, wo der Kerneltreiber stehen geblieben ist, würde ich vielleicht mal den neuesten vom Hersteller versuchen. Die Kerneltreiber werden ja nicht mehr gepflegt.

    Das könnte ich mal probieren.

    Was vielleicht auch noch eine Idee wäre, den alten Maintainer Daniel / nst mal anzufragen, ob er vielleicht eine Idee hätte.


    Code
    1. S19.2E 11700 V  9750 t V W20 P22 W20 t v
    2. S19.2E 99999 V 10600 t V W20 P22 W20 T v
    3. S19.2E 11700 H  9750 t V W20 P22 W20 t V
    4. S19.2E 99999 H 10600 t V W20 P22 W20 T V

    Diese Einstellungen in der diseqc.conf sind mir bekannt und habe sie mit allen o.g. Karten getestet.

    Aber meine V-BOX hat darauf leider nicht angesprochen.


    Laut diseqc.c aus dem vdr-2.4.4 Quelltext wird der Befehl 31 zur Ansprache des Positioner verwendet.


    Da es sicherlich wenige VDR-User gibt, die mit einer Drehanlage ausgestattet sind,

    wird der betreffende vdr-Quellcode noch wenig getestet worden sein.


    Schöne Grüße


    Christian

    Hallo zusammen,


    an meinem alten VDR 5 war mal ein serieller IR-Empfänger angeschlossen.


    Der IR-Empfänger wurde in einem grauen econ connect PH9 D-SUB Gehäuse eingebaut (Conrad-Best-Nr. 801092737 - YD).

    Der IR-Empfänger selber guckt an der Kabelöffnung hervor.

    Im Inneren ist eine mit SMD-Bauteilen bestückte Platine eingebaut.

    Unterstützt werden RC5 und RC6-Codes in Verbindung mit LIRC und scancode.


    Vielleicht kennen manche diese Ausführung, diese gab es mal Anfang der 2000er-Jahre im dvb-shop.


    Nun habe ich Lust, einen seriellen IR-Empfänger auf Basis von LIRC aus der vdr-wiki.de nachzubauen.

    Das Ziel ist, die äussere Optik des originalen Empfänger zu erreichen.


    Ich bin mir aber bei der Auswahl der IR-Empfänger nicht so ganz schlüssig und möchte bei euch gerne mal um Rat fragen.


    Folgende Fragen sind für mich noch offen:

    • Welche Trägerfrequenz ist besser geeignet? 36 oder 38 kHz
    • Unterstützung für RC5 und RC6
    • Für was steht AGC / Unterschied AGC2 oder AGC4
    • IR-Empfänger-Ersatztyp kompatibel zur LIRC-Schaltung?


    Bei Conrad und Reichelt sind folgende in Frage kommenden IR-Empfänger verfügbar:

    • Vishay TSOP4836
    • Vishay TSOP4838
    • TRU COMPONENTS OS-1638


    Bei Reichelt wäre auch der Ersatztyp TSOP31238 für den TSOP1738 verfügbar,

    dieser würde aber aufgrund seiner Abmessungen nicht in Frage kommen.


    Folgende weiteren Bauteile, würde ich gerne verwenden:

    • Spannungsversorgung L78L05 im TO92-Gehäuse
    • Standarddiode 1N4148
    • Metallschicht-Widerstand 4.7 kΩ / 0,25 W
    • Elko 4.7 µF 25 V 20 % (Ø x H) 4 mm x 7 mm
    • Alternative: Elko SMD 4.7 µF 25 V 20 % (Ø x H) 4 mm x 5.5 mm
    • econ connect BU9LK/V D-SUB Buchsenleiste 180 ° Polzahl: 9 Lötkelch
    • econ connect PH9 D-SUB Gehäuse grau / schraubbar


    Die Auswahl der Standard-Bauteile dürfte so passen oder was meint ihr?


    Vielen Dank für eure Hilfe!


    Schöne Grüße


    Christian

    Hallo zusammen,


    um meine Drehanlage etwas intensiver zu nutzen, habe ich diese an den VDR 3 angeschlossen.


    Bei der Drehanlage handelt es sich um eine Kathrein CAS 012 mit dem Polarmount ZAS 05/P und dem Schubstangenmotor ZAS 05/M.

    Der Schubstangenmotor funktioniert mit 36 Volt und wird über eine V-BOX II/III gesteuert.

    In der V-BOX sind die einzelnen Positionen als Positionsplätzen 1 bis 99 gespeichert.


    Mit dem DiSEqC 1.2-Befehl [E0 31 6B nn] kann die Drehanlage auf die abgespeicherten Satpostionen gefahren werden.



    Im VDR 3 verwende ich eine Digital Devices Cine S2 V7A.


    Nun habe ich das Problem, dass mit dieser Satkarte die DiSEqC 1.2-Befehle

    irgendwie nicht verarbeitet werden und sich die Drehanlage dementsprechend nicht dreht.


    Als Versuch habe ich mal eine Digital Devices Cine S2 V6.1 und eine TechnoTrend S2-1600 eingebaut.

    Bei diesen Satkarten hat die V-BOX reagiert und die Drehanlage auf die gewünschte Position gedreht.


    Habt ihre eine Idee, was die Ursache sein kann?

    Die Stromversorgung ist an der DD Cine S2 V7A angesteckt,

    aber es muss ja nur das LNB mit Spannung versorgt werden.


    Als Betriebsystem kommt Ubuntu Bionic 18.04 mit yavdr-ansible zum Einsatz,

    somit werden die Treiber aus dem Kernel verwendet.


    Könnte hier die Treiber als Ursache in Frage kommen?


    Vielen Dank für eure Hilfe!


    Schöne Grüße


    Christian

    Bei yavdr fehlen die Skin-Logos, sie können aber unter http://andreas.vdr-developer.o…logos-xpm-hi-20070702.tgz heruntergeladen werden.


    Die icons / flags müssen nach /usr/share/vdr-enigmang-icons/ in die beiden Ordner icons und flags entpackt werden, dann werden die Skin-Logos angezeigt.


    Die Senderlogos verwende ich selber nicht, aber man muss nur ein Ordner mit logos anlegen und die Logos im xpm-Format ablegen.


    Schöne Grüße


    Christian

    Euer Problem ist wohl ähnlich gelagert, wie mein Audio-Problem mit yavdr-ansible unter Ubuntu 18.04.

    Der VDR-Prozess funktioniert über HDMI, aber bei Firefox und dem VLC-Player wurde je nach Webseite und Codec mal Audio ausgeben oder mal nicht. seahawk1986 hatte es sich auch angesehen, aber er konnte auch noch keine Lösung finden.

    Als Abhilfe laufen Firefox und der VLC-Player über den analogen Stereoausgang.


    Hier ist der entsprechende Thread: [yaVDR ansible] Firefox teilweise kein Audio bei Videos via HDMI


    Schöne Grüße


    Christian

    Das stimmt so nicht. Ich kuemmere mich um den saa716x-Treiber (insbesondere fuer die TechnoTrend S2-6400). DigitalDevices-Karten habe ich nicht, somit auch nichts an den zugehoerigen Treibern entwickelt.

    Sorry, da habe ich dich mit nst verwechselt.


    Ich habe auch wieder den Thread wiedergefunden, wo es um die DD-Produkte geht.

    In Beitrag 634 / 635 schreibt nst, was von den DD-Produkten ab dem 4.17 / 4.18-Kernel unterstützt wird.

    Schade, dass er dann kurze Zeit später aufgegeben hat.


    Schöne Grüße


    Christian

    Woran liegt es, dass Digital Devices nicht aktiv ihre Treiber bei kernel.org einreicht?


    In verschiedenen Beiträgen hier im Forum, wurde schon öfters der Unmut gegenüber dem Linux-Media Maintainer Mauro Chehab geäussert.

    Liegt es vielleicht daran, dass Digital Devices keine Treiber einreicht?


    Die momentanen DD-Treiber im Kernel hat der User S:oren mit viel Mühe reinbekommen.

    Den damaligen Verlauf kann gut im Thread media-build-dkms, ab Beitrag 55 nachlesen.


    Was meint ihr zu diesen Umständen?


    Schöne Grüße


    Christian

    Bei welchem Kabelanbieter bist du und an welchem Ort ist der Kabelanschluss?

    Wenn der Kabelanbieter Vodafone ist, handelt es sich laut vodafonekabelforum.de um den ehemaligen Sendeplatz von Zee.One. Auf dem Infokanal ist bis zum 24.08.2020 Romance TV empfangbar, zum Empfang braucht man eine Smartcard.


    Mehr Infos:

    https://helpdesk.vodafonekabelforum.de/wiki/Hauptseite (Meldung vom 14.07.2020)

    https://www.vodafonekabelforum…opic.php?p=669369#p669369


    Schöne Grüße


    Christian

    Hast du da den passenden Eingang genommen? IIRC gab es bei den Samsung-TVs immer einen speziellen für PCs - laut Handbuch müsste man über Quelle -> Anschlussplan -> PC darauf kommen, wo ein PC hängen sollte.

    Laut Anschlussplan ist wohl egal, wo der PC angeschlossen wird.

    Versuchsweise habe ich mal die HDMI-Eingänge umgesteckt, wenn der VDR läuft, ist dann möglich in den benutzerdefinierten Einstellmodus zu gelangen.

    Aber nach einem Neustart des Rechner sind die Einstellungen wieder verloren und man ist wieder im 16:9-Modus gefangen. Vielleicht hängt es auch mit dem Bootvorgang zusammen, der Rechner bootet in UHD-Auflösung mit 30p und nach dem Start vom Display-Server wird auf 1920x1080 / 50p umgeschaltet.

    Ich finde die Bildqualität bei SD-Sendern mit nvidia-Karten besser als mit meinem Haswell-Laptop.

    Ja das stimmt!

    Aber ich wollte es mal ausprobieren, wie die Darstellung mit der Intel-Grafik ist.

    Da ich meistens die HD-Programme der Öffentlich-Rechtlichen anschaue, kann ich mit dieser Einschränkung leben. Vielleicht darf die Grafikkarte mal wieder zurück in den VDR.


    Vielen Dank für deine Hilfe!


    Schöne Grüße


    Christian

    Hallo seahawk1986,


    vielen Dank für deine Rückmeldung!


    Ich habe mal in der Bedienungsanleitung und am Fernseher nachgeschaut.

    Bei der Bildeinstellung gibt es die Möglichkeiten "16:9 Standard", "Benutzerdefiniert" und "4:3".

    In der Einstellung "Benutzerdefiniert", wäre es möglich den Overscan zu beinflussen.

    Aber beim bestätigen der Einstellung lande ich immer wieder bei 16:9.


    Beim Fernseher handelt es sich um ein Samsung UE43RU7449.

    Beim VDR 1 habe ich bei der letzten Revision und Update auf yavdr-ansible die Asus Grafikkarte GT 730 ausgebaut,

    die Bildausgabe läuft somit über die integrierte Grafikkarte der CPU.


    Könnte man bei der Intel-Grafikkarte analog der Nvidia-Karten an der xorg.conf etwas beinflussen?


    Schöne Grüße


    Christian

    Hallo zusammen,


    ich habe mir einen neuen Fernseher für VDR 1 gekauft.


    Damit die Grafikeinstellungen passen, habe ich das yavdr-ansible-playbook durchlaufen gelassen.


    Nun habe ich noch das Problem, dass meine genutzten Applikationen Firefox und VLC-Player etwas über den Bildschirmrand hinausgehen und somit mit der Maus nicht mehr erreichbar sind.


    Welche Datei müsste man resetten bzw. editieren, sodass die Fenstergröße zum neuen Fernseher passt?


    Vielen Dank!


    Schöne Grüße


    Christian

    @kdgsv


    Ich hatte mal mit meinem ASRock 960GM-GS3 FX / VDR 4 auch das Problem, dass das Motherboard bei Timer-Aufnahmen nicht hochgefahren ist. Der Grund bzw. Ursache hierfür war, dass im Bios Restore on AC / Power Loss auf Power On eingestellt war.


    Bei der Einstellung Power Off funktioniert das automatische aufwachen wunderbar.


    Falls nun mal ein Stromausfall eintritt, hilft der atric IR-Einschalter Rev. 5, indem er ein Einschalt-Impuls abgibt.

    Da das N68-GS und das 960GM-GS3 FX beide das AMI-Bios haben, vermute ich mal bei Dir das gleiche Problem.


    Hier noch der der Thread zu meinem Motherboard: [Gelöst] ACPI Wakeup ASRock 960GM-GS3 FX


    Hier noch die getesteten ACPI-Einstellungen:

    ASRock 960GM-GS3 FX ACPI Settings


    Suspend To RAM: Auto

    (Check Ready Bit: Auto)

    Away Mode Support: Disabled


    Restore on AC / Power Loss: Power Off

    Ring-In Power On: Disabled

    PCI Devices Power On: Disabled

    PS/2 Keyboard Power On: Disabled

    RTC Alarm Power On: By OS


    ACPI HPET Table: Disabled


    Viel Erfolg!


    Schöne Grüße


    Christian

    Hallo george-01,


    der VDR unterstützt ab vdr-1.7.2 den Einkabelstandard SCR/EN50494, ab Version vdr-2.1.18 auch den Standard SCR/EN50607.


    Das UAS 481 entspricht dem Standard SCR/EN50494.


    Die diseq.conf muss so aussehen:



    In der scr.conf muss pro Tuner eine Teilnehmer-Frequenz angegeben werden, hier die Teilnehmer-Frequenzen des UAS 481:


    Code: scr.conf
    1. 0 1400
    2. 1 1516
    3. 2 1632
    4. 3 1748


    Die nicht benötigten Teilnehmer-Frequenzen müssen dann auskommentiert werden.

    Im Setup-Menü muss noch "DISEqC benutzen" auf "ja" eingestellt sein.


    Links: vdr-wiki - SCR_Single_Cable_Distribution


    Viel Erfolg!


    Schöne Grüße


    Christian

    Hallo zusammen,


    bei meinem VDR 1 habe ich das Problem mit dem spulen heute auch festgestellt.

    Vorspulen, zurück- und vorspringen funktionieren, das zurückspulen wird aber ignoriert.


    Dies betrifft die HD-Sender, bei den SD-Sendern scheint es zu funktionieren.

    Außerdem kann ich die Index Datei und die Wiedergabeposition bei HD und SD nicht löschen.


    Der VDR läuft unter Ubuntu 18.04, als Ausgabe wird die Intel GPU verwendet und
    die Updates sind aktuell. Geupdatet habe ich heute und letzte Woche am Sonntag.


    Auf dem VDR 4 konnte ich die Probleme Spulprobleme nicht beobachten, die Index Datei und die Wiedergabepostion lässt sich aber auch nicht löschen. Dieser VDR läuft auch auf Ubuntu 18.04 mit einer GT 710, allerdings sind die Updates nicht ganz aktuell.


    Schöne Grüße


    Christian

    Ich habe die Prozessenummer mal händisch herausgesucht:


    sudo pgrep firefox 1359


    sudo cat /proc/1359/environ:

    LANG=de_DE.UTF-8MANAGERPID=1070DISPLAY=:0INVOCATION_ID=c88a2d6cc4814278a7f185a02760e5f1GIO_LAUNCHED_DESKTOP_FILE_PID=1359USER=vdrPWD=/var/lib/vdrHOME=/var/lib/vdrJOURNAL_STREAM=9:29931XDG_DATA_DIRS=/usr/local/share/:/usr/share/:/var/lib/snapd/desktopSHELL=/bin/bashMOZ_APP_LAUNCHER=/usr/bin/firefoxGIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/firefox.desktopSHLVL=0LOGNAME=vdrDBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/666/busXDG_RUNTIME_DIR=/run/user/666PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin


    Ich hoffe, du kannst damit etwas anfangen.


    Schöne Grüße


    Christian

    seahawk1986, vielen Dank für die ausführlichen Informationen!

    Konntest du die Ausgaben von pactl info und pactl list auswerten?

    Die Quelle in Pulseaudio gemuted ist
    Die Quelle mit dem richtigen Ausgang verbunden ist
    Pulseaudio Zugriff auf den Ausgang hat
    Der Ausgang gemuted ist

    Alle Quellen und Ausgangssignale sind auf Lautstärke 100.


    Hilft ein Detachen und erneutes Attachen des VDR-Frontends? frontend-dbus-send stop gefolgt von frontend-dbus-send start?

    Durch ein Detachen und erneutes Attachen des VDR-Frontends, gab es keine Audioausgabe.

    Nur ein kompletter Neustart hat geholfen.


    Ich habe noch paar Versuche mit Firefox gemacht.

    Die Stereo-Ausgabe habe ich mal deaktiviert, sodass nur die HDMI-Audio-Ausgabe zur Verfügung steht.


    • Videos aus der ARD-Mediathek laufen ohne Probleme über HDMI-Audio.
    • Wenn ich in einem zweiten Tab ein ZDF-Video oder Youtube-Video mit mp4a-Audio öffne
      und gleichzeitig das Video aus der ARD-Mediathek laufen lasse, ist der Ton auch in den Problem-Videos vorhanden.
    • Bei Pausierung in der ARD-Mediathek bleibt den Ton erhalten, bis das ZDF-Video oder Youtube-Video pausiert wird.
    • Wird nun als erstes wieder das ZDF-Video oder Youtube-Video gestartet,
      ist wieder kein Ton vorhanden und zusätzlich auch im Video aus der ARD-Mediathek.
    • Wenn Firefox ohne Ton beendet wird, überträgt es sich manchmal auch auf den VDR (siehe Antwort oben).

    Es scheint so, als würden sich die Tabs in Firefox positiv (Ton) oder negativ (kein Ton) beeinflussen.


    Woran könnte dieses Verhalten liegen? An Firefox oder PulseAudio?


    Was gibt es noch für Möglichkeiten, dass ganze zu protokollieren und auszuwerten?

    Kann man die PulseAudio-Konfiguration irgendwie zurücksetzen?


    Schöne Grüße


    Christian

    Hallo seahawk1986,


    danke für deine Rückmeldung!


    Die gewünschten Informationen von pactl info und pactl list habe ich in einer zip-Datei beigefügt.

    Ich habe die Ausgaben / Tests mit dem VDR und Firefox in verschiedenen Einstellungen (HDMI / Analog-Ausgabe und Audiocodecs) durchgeführt.


    Beim Testen sind mir folgenden Dinge aufgefallen:

    • Videos mit dem Audiocodec opus (251) werden sowohl auch auf HDMI und Stereo analog ausgegeben,
      HDMI allerdings nur wenn Stereo analog ausgeschaltet ist.
    • Videos mit dem Audiocodec mp4a werden nur auf Stereo analog ausgegeben.
      Wenn die Stereo analog-Ausgabe abgeschaltet ist, sieht man im HDMI-Gerät nur noch den Levelmeter ohne hörbaren Ton.
    • Wenn eine Applikation (Firefox / VLC) beendet wird, hat der VDR ab und zu auch kein Ton, wo nur ein Neustart bzw. manchmal ein umschalten hilft.

    Wie ist eigentlich der "normale" Signalverlauf von der Audio-Quelle bis zum Audio-Ziel?

    Welche Programme haben im Hintergrund die Finger im Spiel?

    Könnte man in den entsprechenden Konfigurationsdateien etwas bewirken?


    VIelen Dank!


    Schöne Grüße


    Christian


    silverstone-vdr_pactl.zip