Posts by c.h.

    Ich habe die Prozessenummer mal händisch herausgesucht:


    sudo pgrep firefox 1359


    sudo cat /proc/1359/environ:

    LANG=de_DE.UTF-8MANAGERPID=1070DISPLAY=:0INVOCATION_ID=c88a2d6cc4814278a7f185a02760e5f1GIO_LAUNCHED_DESKTOP_FILE_PID=1359USER=vdrPWD=/var/lib/vdrHOME=/var/lib/vdrJOURNAL_STREAM=9:29931XDG_DATA_DIRS=/usr/local/share/:/usr/share/:/var/lib/snapd/desktopSHELL=/bin/bashMOZ_APP_LAUNCHER=/usr/bin/firefoxGIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/firefox.desktopSHLVL=0LOGNAME=vdrDBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/666/busXDG_RUNTIME_DIR=/run/user/666PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin


    Ich hoffe, du kannst damit etwas anfangen.


    Schöne Grüße


    Christian

    seahawk1986, vielen Dank für die ausführlichen Informationen!

    Konntest du die Ausgaben von pactl info und pactl list auswerten?

    Die Quelle in Pulseaudio gemuted ist
    Die Quelle mit dem richtigen Ausgang verbunden ist
    Pulseaudio Zugriff auf den Ausgang hat
    Der Ausgang gemuted ist

    Alle Quellen und Ausgangssignale sind auf Lautstärke 100.


    Hilft ein Detachen und erneutes Attachen des VDR-Frontends? frontend-dbus-send stop gefolgt von frontend-dbus-send start?

    Durch ein Detachen und erneutes Attachen des VDR-Frontends, gab es keine Audioausgabe.

    Nur ein kompletter Neustart hat geholfen.


    Ich habe noch paar Versuche mit Firefox gemacht.

    Die Stereo-Ausgabe habe ich mal deaktiviert, sodass nur die HDMI-Audio-Ausgabe zur Verfügung steht.


    • Videos aus der ARD-Mediathek laufen ohne Probleme über HDMI-Audio.
    • Wenn ich in einem zweiten Tab ein ZDF-Video oder Youtube-Video mit mp4a-Audio öffne
      und gleichzeitig das Video aus der ARD-Mediathek laufen lasse, ist der Ton auch in den Problem-Videos vorhanden.
    • Bei Pausierung in der ARD-Mediathek bleibt den Ton erhalten, bis das ZDF-Video oder Youtube-Video pausiert wird.
    • Wird nun als erstes wieder das ZDF-Video oder Youtube-Video gestartet,
      ist wieder kein Ton vorhanden und zusätzlich auch im Video aus der ARD-Mediathek.
    • Wenn Firefox ohne Ton beendet wird, überträgt es sich manchmal auch auf den VDR (siehe Antwort oben).

    Es scheint so, als würden sich die Tabs in Firefox positiv (Ton) oder negativ (kein Ton) beeinflussen.


    Woran könnte dieses Verhalten liegen? An Firefox oder PulseAudio?


    Was gibt es noch für Möglichkeiten, dass ganze zu protokollieren und auszuwerten?

    Kann man die PulseAudio-Konfiguration irgendwie zurücksetzen?


    Schöne Grüße


    Christian

    Hallo seahawk1986,


    danke für deine Rückmeldung!


    Die gewünschten Informationen von pactl info und pactl list habe ich in einer zip-Datei beigefügt.

    Ich habe die Ausgaben / Tests mit dem VDR und Firefox in verschiedenen Einstellungen (HDMI / Analog-Ausgabe und Audiocodecs) durchgeführt.


    Beim Testen sind mir folgenden Dinge aufgefallen:

    • Videos mit dem Audiocodec opus (251) werden sowohl auch auf HDMI und Stereo analog ausgegeben,
      HDMI allerdings nur wenn Stereo analog ausgeschaltet ist.
    • Videos mit dem Audiocodec mp4a werden nur auf Stereo analog ausgegeben.
      Wenn die Stereo analog-Ausgabe abgeschaltet ist, sieht man im HDMI-Gerät nur noch den Levelmeter ohne hörbaren Ton.
    • Wenn eine Applikation (Firefox / VLC) beendet wird, hat der VDR ab und zu auch kein Ton, wo nur ein Neustart bzw. manchmal ein umschalten hilft.

    Wie ist eigentlich der "normale" Signalverlauf von der Audio-Quelle bis zum Audio-Ziel?

    Welche Programme haben im Hintergrund die Finger im Spiel?

    Könnte man in den entsprechenden Konfigurationsdateien etwas bewirken?


    VIelen Dank!


    Schöne Grüße


    Christian


    silverstone-vdr_pactl.zip

    Kannst du ein Beispiel-Video verlinken, mit dem das auftritt? Sind eventuell aus Versehen Passthrough-Formate in den Pulseaudio/pavucontrol-Einstellungen aktiv, die dein TV nicht unterstützt?

    Klar gerne:

    https://www.youtube.com/watch?v=iWMLOQoDr3o

    oder

    https://www.zdf.de/comedy/heut…13-dezember-2019-100.html


    Die HDMI-Audioausgabe ist in den erweiterten Einstellungen nur auf PCM eingestellt.

    Der Fernseher ist ein Samsung LE32B650, schon 11 Jahre alt aber immer noch gut. ;)


    Schöne Grüße


    Christian

    Hallo zusammen,


    wenn man auf einem Radiosender eine Sofortaufnahmen startet, wird der VDR unbedienbar und nur ein Reset hilft noch.

    Als Auslöser für dieses Problem habe ich das vdr-plugin-permashift identifiziert.


    Bei deaktiviertem Plugin (vdrctl) sind Sofortaufnahmen auf Radiosendern möglich.


    Betroffen sind die yaVDR-Versionen 0.6.x und ansible.

    Getestet habe ich auf VDR 1 bis 3.


    Ist das Problem bekannt und gibt es hierfür eine Lösung?


    Vielen Dank!


    Schöne Grüße


    Christian

    Hallo zusammen,


    über die Weihnachtszeit habe ich auf meinen VDR 1 yavdr-ansible installiert.

    Die Grafikkarte habe ich ausgebaut, die Videoausgabe erfolgt nun über die Onboard-Grafikkarte.


    Nun ist mir im Regelbetrieb aufgefallen, dass bei manchen Videos in Firefox kein Audio über HDMI an den Fernseher ausgeben wird.

    In der PulseAudio-Steuerung wird der Pegel von Firefox im Levelmeter angezeigt.


    Wenn ich in PulseAudio auf die analoge Stereo-Ausgabe umschalte, höre ich den Ton an meiner Stereo-Anlage.

    Bei youtube handelt es sich laut Statistiken für Nerds um Videos mit mp4a-Stream.


    Fehlt in meiner Installation noch bestimmte Codecs oder Konfiguration?


    Vielen Dank!


    Schöne Grüße


    Christian

    Danke seahawk1986 für die Infos!


    Ich habe deine Vorschläge mal ausprobiert.

    entweder über menuorg (z.B. mit einem echo firefox | at now)

    Ich habe in der /var/lib/vdr/plugins/menuorg.xml eine Zeile mit dem Befehl<command name="Firefox (VDR attached)" execute="echo firefox | at now" /> eingefügt.

    Wenn man im Menü diesen Befehl auslöst startet Firefox aber nicht.


    man kann wie bei Openbox üblich mit STRG + ALT + links/rechts zwischen den Arbeitsflächen wechseln und mittels Rechtsklick auf den Desktop-Hintergrund obmenu (das Start-Menü von Openbox) aufrufen

    Diese Variante funktioniert!

    Allerdings ist man auf dem 2. Desktop und sieht kein Bild mehr.

    In yaVDR 0.6 wird Firefox als Overlay auf die Bildausgabe gelegt.

    Wäre es möglich, auf dem Desktop wo softhddevice läuft, auch das obmenu verfügbar zu machen?

    Denn bei einem Rechtsklick wird im softhddevice kein obmenu angezeigt.

    Wenn man mag, kann man sich auch einen Hotkey in der /var/lib/vdr/.config/openbox/rc.xml dafür einrichten.

    Diese Variante habe ich mit folgendem Code ausprobiert:

    Code
    1. <keybind key="W-i">
    2. <action name="Execute"
    3. <execute>firefox</execute>
    4. </action>
    5. </keybind>

    Ist die Syntax für den Hotkey richtig geschrieben?

    Die Syntax hatte ich im untereren Bereich des <keyboard> </keyboard>-Bereiches eingefügt.

    Nach einem Neustart war das softhddevice in einem Fensterrahmen dargestellt und das Menüs schräg verschoben.

    Der Hotkey hat leider nicht funktioniert.


    Gibt es auch noch die Möglichkeit das ganze über die .desktop-Dateien und entsprechende Startargumente zu steuern?


    Schöne Grüße


    Christian

    Gibt es die Möglichkeit, dass der Webbrowser Firefox gleichzeitig mit dem VDR läuft?

    Dies wäre ganz praktisch, wenn man z.B. in der Werbepause nur kurz etwas nachschauen möchte.


    Im Menü könnte es vielleicht so aussehen:

    • Firefox Web Browser (VDR detached)
    • Firefox Web Browser (VDR attached)

    Vorab vielen Dank!


    Schöne Grüße


    Christian

    Super!

    Vielen Dank für die Aufklärung!


    Wird es auch wieder ein Webinterfaces für die Konfiguration von yaVDR ansible geben?

    Zur Einrichtung und Wartung ist es schon eine große Erleichterung!

    Kann man dich hier irgendwie unterstützen?


    Schöne Grüße


    Christian

    Hallo zusammen,


    kürzlich habe ich bei meinem yaVDR-ansible-Rechner mit ein paar Plugins ergänzt, unter anderem auch mit dem vdr-plugin-undelete.

    Dabei habe ich festgestellt, dass das Plugin in seinen Einstellungen nur ein leeres OSD anzeigt.

    Bei der 0.6.2-Installation ist das Problem nicht vorhanden. Ist da beim erstellen des Plugin etwas schief gegangen?


    Dann hätte ich noch ein Frage zum starten und stoppen von eventlircd.

    Laut Dokumetation von yaVDR 0.7 soll der Dienst mit sudo systemctl stop eventlircd{.service,socket} gestoppt und mit sudo systemctl start eventlircd{.service,socket} gestartet werden.


    Wenn ich diesen Befehl in der Konsole absetze erhalte ich aber folgende Fehlermeldung:

    Failed to stop eventlircdsocket.service: Unit eventlircdsocket.service not loaded. Warning: Stopping eventlircd.service, but it can still be activated by: eventlircd.socket


    Ist der Befehl falsch geschrieben, dass es zu dieser Fehlermeldung kommt?


    Mit den Befehlen sudo service eventlircd stop und sudo service eventlircd start klappt ein start/stoppen von eventlircd um z.B. die Codes für eine Fernbedienung auszulesen.


    Vielen Dank!


    Schöne Grüße


    Christian

    Hallo zusammen,


    auf meinen VDRs nutze ich das yavdr-addon-youtube.


    Seit Anfang der Woche wird beim starten des Addon der Hinweis ausgeben, dass diese Version von YouTube bald bald nicht mehr verfügbar ist.

    Es handelt sich hierbei um folgende Adresse: https://www.youtube.com/tv




    Habt ihr was mitbekommen, weshalb das YouTube TV-Portal eingestellt werden soll?

    Gibt es alternative Links, außer der normalen Youtube-Startadresse?


    Schöne Grüße


    Christian

    Ah, du hast noch eine alte KODI 17 Version installiert, bei der das Update auf KODI 18 nicht sauber klappt. Am besten du entfernst die alten KODI-Pakete und lässt sie danach vom Playbook wieder installieren.

    sudo apt remove kodi*

    Jetzt ist das ansible playbook ohne Fehler durchgelaufen!


    Vielen Dank!


    Noch eine Frage zur Anleitung, fehlt unter Punkt "1.3.1 Herunterladen von yavdr-ansible" nicht noch der Befehl $ git checkout bionic?


    Schöne Grüße


    Christian

    Danke für die Informationen!

    Die Fehlermeldung des ansible-playbook werde ich am Wochenende nachreichen!


    Schöne Grüße


    Christian

    Danke seahawk1986 für die erste Dokumentation!


    Am Wochenende wollte ich meine yavdr-ansible-Installation von Anfang Januar updaten.

    Leider haben sich hier ein paar Fallstricke aufgetan und möchte gerne fragen, wie ich diese wieder gelöst bekomme.


    Das Update habe ich per sudo apt-get update && sudo apt-get dist-upgrade angestossen.

    Anschließend wollte ich das Ansible-Playbook für yavdr ansible per git pull aktualisieren.

    Hier gab es die Meldungen das unterschiedliche Versionstände vorhanden sind und diese gemergt werden sollen.

    Da ich mir in der weiteren Vorgehenweise nicht sicher war, habe meinen alten Stand von Januar gelöscht und habe den aktuellen Stand von git heruntergeladen.


    Anschließend wollte ich das ansible-playbook nochmals durchlaufen lassen, aber es bricht mir am 3. Punkt beim Update der Paketquellen ab.

    Wie kann ich dieses Problem lösen, sodass das Playbook wieder durchläuft?


    Hier noch ein paar generelle Fragen zum Update, git und Ansible-playbook:

    • Wird git und das ansible-playbook nur für die erste Installtion und Einrichtung oder auch bei Updates benötigt?
    • Wie werden momentan/zukünftig die ansible-Updates veröffentlicht? Per git oder über apt bzw. apt-get? (Punkt 2.4.1 in der Anleitung)
    • Wie sollte man sich bei der Aktualisierung über git pull bei Konflikten entscheiden? (merge)
    • Wie sollte man sich beim Update über apt bzw. apt-get bei Abfragen entscheiden? (Paketverwalter, aktuelle, neue Version, etc.)

    Vielen Dank!


    Schöne Grüße


    Christian

    Um das Thema nochmals aufzugreifen, am Wochenende habe ich mal bei VDR 2 (ansible / Versionsstand ca. Januar) und VDR 3 (yavdr 0.6) den Sender L-TV getestet.


    Auf beiden VDRs war leider auch kein Ton zu hören.

    Auf dem VDR 1 habe ich gerade mit KODI den Sender getestet, hier wird der Ton wiedergegeben.


    Gibt es eine Möglichkeit z.B. auf der Konsole die Video- und Audio-Decodierung anzuzeigen zu lassen, was der VDR gerade decodiert bzw. verarbeitet?


    Schöne Grüße


    Christian

    Darf dein VDR die Transponderinformationen selbstständig aktualisieren?

    Der VDR darf neue Transponder hinzufügen.


    Beim lokalen Netzwerkstream (streamdev-plugin) zum VLC-Player (Version 2.1.0) ist auch kein Ton vorhanden.

    Beim lokalen VLC-Player ist die Audioausgabe (PulseAudio) nicht auf den Fernseher (HDMI) sondern für den Audioverstärker (analog/Klinkenstecker) eingerichtet. Somit funktioniert der Ton beim VLC-Player. Ein Denkfehler meinerseits. ;)


    Beim VDR-Betrieb kommt von L-TV bei PulseAudio auch schon kein Ton an.


    Schöne Grüße


    Christian

    Hallo zusammen,


    mir ist schon länger aufgefallen, dass ich bei dem Lokalsender L-TV auf dem Fernseher mit dem VDR 1 / (VDR 3) keinen Ton habe.

    Beim lokalen Netzwerkstream (streamdev-plugin) zum VLC-Player (Version 2.1.0) ist auch kein Ton vorhanden.

    Per Netzwerkstream (streamdev-plugin) zum VLC-Player (Version 3.0.6) / Windows 10-Rechner ist der Ton aber vorhanden.


    Woran könnte dieses Problem liegen?


    Senderparameter

    Name: L-TV

    Position: Astra 19,2° Ost

    Transponder: 115

    Frequenz: 12663 MHz

    Polarisation: Horizontal

    Symbolrate: 22000

    FEC: 5/6

    Modulation: DVB-S


    Video: Auflösung 720x576 / MPEG 4 / H264

    Audio: Bitrate 96 kB/s / Abstastrate 32000 Hz / Bits pro Sample 32 / MPEG Audio Layer 1/2


    Vielleicht könntet ihr den Sender mal auf euren VDRs testen und hier ein Feedback geben.

    Eine Lösung für das Problem wäre auch super!


    Vorab vielen Dank!


    Schöne Grüße


    Christian

    Hallo Matthias,


    soweit sieht das ganze gut aus!


    In der Satellitentechnik ist DiSEqC neben den 14/18-Volt und 22 KHz-Umschaltung heutzutage Standard.

    Der Fernseher von der Schwiegermutter unterstützt laut Anleitung DiSEqC und kann somit ohne Probleme verwendet werden.


    Bei Multischalter-Betrieb verwendet man in der Regel Quattro-LNB, hier liegen die vier Empfangsbereiche einzeln an den vier Ausgängen an.

    Bei einem Quad-LNB können vier Receiver direkt angeschlossen, da die hier zusätzlich ein interne 22 KHz-Umschaltung integriert ist.

    Um nun mehr als vier Teilnehmer zu versorgen, unterstützen die meisten Multischalter auch Quad-LNB,

    indem im High-Band noch das 22 KHz-Signal aufmoduliert wird.


    Zu der Auswahl der Marke der LNBs kann ich keine Erfahrungswert liefern, da ich meistens Kathrein-LNBs verwende.

    Aber die Marke Inverto scheint aber gut zu sein. Preislich wären pro LNB 30 bis 40 Euro ein guter Wert.


    Beim Koaxialkabel würde ich auch auf hochwertiges Kabel setzen z.B. Kathrein LCD 111.

    Ein zusammenflicken von alten und neuen Kabeln sollte man vermeiden!

    Wenn es nicht vermeidbar, wäre es sinnvoll zu wissen, welche Kabel-Bezeichnungen zum Einsatz kommen sollen.

    So kann man abschätzen, ob das jeweilige Kabel noch geeignet ist.


    Die Satanlage sollte mit Hilfe von einem Satmessgerät eingemessen werden, da hier drei Postionen empfangen werden sollen und zusätzlich noch der Aspekt des UK-Spotbeam.


    Schöne Grüße


    Christian

    Hallo Matthias,


    vielen Dank für die Beantwortung des Fragenkataloges, ich werde mich morgen näher damit beschäftigen und etwas dazu schreiben.


    Aber nur mal vorab für den Standort der Satantenne, gibt es die Seite https://www.dishpointer.com.


    Hier kannst du deinen Standort eingeben und das Schüsselsymbol auf deinen gewünschten Montageort setzen.

    Nun die gewünschte Satposition einstellen und schauen was passiert. ;)
    Wenn du noch das Häkchen bei Options auswählst, kannst du noch die Höhe von eventuell vorhandenen Gebäuden oder Bäumen abschätzen.


    Schöne Grüße


    Christian