Anfängerproblem: Streamdev-Server Plugin is Missing

  • Hallo erst mal an alle. :moin


    Ich lese und beschäftige mich zwar schon einige Zeit mit dem VDR-Projekt,
    habe jetzt aber erstmalig ein Problem wo ich nicht mehr weiter weiss und ich um
    Eure Hilfe bitte....


    Gern wollte ich mit Streamdev im Netzwerk bzw. über´s Internet Live TV schauen.


    Jedoch bekomme ich Streamdev-server nicht ans laufen, egal was ich mache.
    Sobald ich im Admin-Menü den Streamdev-server eine Nr. zuweise und den VDR neu
    starte, lese ich der Messages-Log die Meldung:


    Code
    1. [logger] vdr: missing plugin 'streamdev-server_'


    Natürlich habe ich hier zuvor gelesen und habe dann versucht mit:


    Plugin Installation
    und
    neu Kompelieren


    den Fehler zu lösen...jedoch bleibt die Fehlermeldung gleich.


    System ist Gen2Vdr2.0 (Update´s alle 27)
    Hardware: Samsung SMT7020s


    Wäre nett, wenn mich Newbie jemand ein bisschen an die Hand nehmen könnte :newbie


    LG
    Realmanitu

  • Hallo,


    erstmal herzlich willkommen im VDR-Portal ;)
    Ich kenne mich mit Gen2VDR zwar jetzt nicht direkt aus, aber die Fehlermeldung sagt aus, dass ein Plugin mit dem Namen "streamdev-server_" nicht gefunden wird...
    I.d.R. müssen Plugins mit ihrem korrekten Namen aufgerufen werden, damit sie von VDR gefunden werden. Dieser Unterstrich in "Streamdev-server_" kommt mir ein wenig seltsam vor, kann es sein das da irgendwo ein Schreibfehler im Pluginaufruf steckt?
    Bei mir muss ich den streamdev-server mit "-P streamdev-server" aufrufen, also ohne diesen Unterstrich.


    Evtl. kannst du mal versuchen, das Plugin nicht über das OSD, sondern über die Konsole zu aktivieren (siehe hier: http://www.vdr-wiki.de/wiki/in…ration_Konsole#vdrplugins)


    Also:



    Vielleicht hilft dir das weiter.


    Gruß


    Tuxer

    Server
    Software: Debian Lenny, VDR 1.6.0, vdradmin-am, streamdev-server, femon. epgsearch
    Hardware: Chenbro RM314, ABit AV8, AMD64 3200+, 512MB RAM, 4x Seagate 250GB@RAID5, 3ware 8500-4 SATA, Hauppauge dvb-s rev1.6+Nova-S


    Wohnzimmer VDR
    Software: Debian Lenny, VDR 1.6.0, dvd, remote, games, femon, streamdev-client
    Hardware: MSI Hermes 845GL, Hauppauge Nexus-S rev2.1, Nova-T FB, NEC DVD-Brenner

  • Hallo Tuxer,


    schön dass Du mir so schnell geantwortet hast.... :arme


    Leider hatte ich zum Wochenende nicht so viel Zeit, Deinen Tip sofort umzusetzen bzw. zu testen :versteck


    Mir kam dass mit dem "_" dahinter auch schon komisch vor....


    So, dann mache ich dass jetzt mal sooo:



    Resultat ist leider: (kleiner Ausschnitt nur)...



    Ich habe mal an der Stelle aufgehört, bis er meldet dass das Plugin nicht da ist....



    Hmmm, also immer noch das gleiche Problem !?!!!




    Hast Du noch ne Idee ?! :lovevdr
    Ich weiß mir leider keinen Rat mehr.......


    LG


    Manitu

  • Hallo,


    schade, naja ein Versuch war es wert...
    Startet dein VDR ohne das Streamdev-server plugin?
    Wie hast du das Streamdev-plugin denn installiert?


    Gruß


    Tuxer

    Server
    Software: Debian Lenny, VDR 1.6.0, vdradmin-am, streamdev-server, femon. epgsearch
    Hardware: Chenbro RM314, ABit AV8, AMD64 3200+, 512MB RAM, 4x Seagate 250GB@RAID5, 3ware 8500-4 SATA, Hauppauge dvb-s rev1.6+Nova-S


    Wohnzimmer VDR
    Software: Debian Lenny, VDR 1.6.0, dvd, remote, games, femon, streamdev-client
    Hardware: MSI Hermes 845GL, Hauppauge Nexus-S rev2.1, Nova-T FB, NEC DVD-Brenner

  • Hallo Tuxer :moin


    ja ein Versuch ist es immer Wert.... :tup


    Ja mein VDR startet vollständig und lässt sich ansonsten auch ganz normal benutzen, auch alle anderen Plugins funktionieren, nur eben bis auf den Streamdev-Server !


    Bei Gen2Vdr ist eine sep. Installation eigentlich nicht nötig, da es bereits vorinstalliert ist und nur noch manuell oder im Admin-Modul eingeschaltet/gestartet werden muss....



    Gruß


    Manitu

  • Puh, ich fürchte dann gehen mir langsam die Ideen aus, bin wie gesagt kein Gen2VDR Experte....
    Das Problem scheint aber auch nicht alltäglich zu sein, zumindest ist über die Suche/Google nicht wirklich etwas brauchbares dazu zu finden.


    Was ich noch tun würde:
    Stoppe VDR und versuch ihn mal manuell über die Kommandozeile zu starten:


    Code
    1. /usr/local/bin/vdr -u root -w 60 --config=/etc/vdr --shutdown='/_config/bin/vdrshutdown' --epgfile=/video/epg.data --log=0 --video=/video --record='/tmp/vdr/vdr_record' --lib=/usr/local/lib/vdr
    2. --plugin='xineliboutput --local=none --remote=37890 --primary' --plugin='skinneutrino ' --plugin='statinfo '
    3. --plugin='status ' --plugin='channelscan ' --plugin='control ' --plugin='cpumon ' --plugin='streamdev-server '
    4. --plugin='mount ' --plugin='newsticker --output=/tmp/newsticker' --plugin='skinelchi -l /etc/vdr' --plugin='sysinfo '
    5. --plugin='admin ' --plugin='statusleds ' --plugin='weatherng --script=/etc/vdr/plugins/weatherng'


    Das muss alles in eine Zeile!


    Wie du sehen kannst habe ich alle Unterstriche bei streamdev-server entternt, ich kann mir nämlich immer noch nicht vorstellen, dass die da hingehören...


    Wie sieht es dann aus?
    Wie sieht der Aufruf aus, wenn du streamdev-client mitstartest?
    Stehen da auch diese komischen Unterstriche dabei? z.B. streamdev-client_ _?


    Gruß


    Tuxer

    Server
    Software: Debian Lenny, VDR 1.6.0, vdradmin-am, streamdev-server, femon. epgsearch
    Hardware: Chenbro RM314, ABit AV8, AMD64 3200+, 512MB RAM, 4x Seagate 250GB@RAID5, 3ware 8500-4 SATA, Hauppauge dvb-s rev1.6+Nova-S


    Wohnzimmer VDR
    Software: Debian Lenny, VDR 1.6.0, dvd, remote, games, femon, streamdev-client
    Hardware: MSI Hermes 845GL, Hauppauge Nexus-S rev2.1, Nova-T FB, NEC DVD-Brenner

  • Hy Tuxer,


    also ich finde es prima....dass Du Dir immer noch was neues einfallen lässt ! :idee :respekt


    Ich war leider mit meinen begrenzten Linux-Fähigkeiten schon viel schneller aufgeschmissen :computertod
    Natürlich hatte ich auch Google/die VDR-Wiki und die sufu hier und im HTPC-Forum durchsucht, leider ohne Erfolg...klar sonst hätte ich ja auch nichts geschrieben ! :lol2


    Oha, jetzt muss ich mal etwas tricksen, da ich nicht zuhause am Gerät bin...
    aber dank Putty und VPN sollte das auch klappen :schiel



    Okay, das klappt, dann mal Feuer frei ;-)



    vdr: no primary device found - using first device! ?!


    Habe es mehrfach getestet !


    Dass mit den Unterstrichen kam mir auch schon immer sehr komisch vor, können das evtl. Parameteraufrufe sein, die nicht definiert sind ?!


    Zu Deiner Frage zu dem Streamdev-Clienten, den hatte ich auch schonmal aktiviert habe nur "natürlich" nicht darauf geachtet....da er ja lief !


    Aber ich teste es mal:


    Code
    1. gen2vdr ~ # stp vdr
    2. * WARNING: you are stopping a boot service.
    3. * Stopping vdradmin-am ... [ ok ]
    4. * Stopping vdr ... Shutting down VDR Waiting for vdr termination ... [ ok ]
    5. gen2vdr ~ # cd /etc/vdr/plugins/admin/cfgplg.sh
    6. Plugins < xineliboutput skinneutrino statinfo status channelscan control
    7. cpumon mount newsticker skinelchi sysinfo admin statusleds weatherng>
    8. gen2vdr ~ # /etc/vdr/plugins/admin/setadmval.sh PLG_streamdev-client 10
    9. root: Changing PLG_streamdev-client to <10> from <0> in /etc/vdr/plugins/admin/admin.conf
    10. Plugins < sc mp3 xineliboutput mplayer osdteletext epgsearch extrecmenu skinelchi admin statinfo streamdev-client femon channelscan channelswitcher clock>


    So ich starte dann mal neu und dann mal sehen, was die Messages.log sagt:


    Ups hatte gerade noch den "streamdev-server nicht gestartet...nachgeholt mit


    "/etc/vdr/plugins/admin/setadmval.sh PLG_streamdev-client 7"


    und nochmal der neustart ;-)
    hier ist er also aktiv(iert):


    Code
    1. gen2vdr ~ # /etc/vdr/plugins/admin/cfgplg.sh
    2. Plugins < sc mp3 xineliboutput mplayer osdteletext epgsearch extrecmenu streamdev-server skinelchi admin statinfo streamdev-client femon channelscan channelswitcher clock>



    Weiteres erspare ich UNS...dort werden nur noch alle Dienste/usw. gestartet unter anderem auch der streamdev-client und der Rest, bis auf das besagte "Missing-Plugin" = "Streamdev-server" :schiel


    Na :mahlzeit


    Lg


    Manitu

  • Quote


    vdr: no primary device found - using first device! ?!


    Habe es mehrfach getestet !


    Dass mit den Unterstrichen kam mir auch schon immer sehr komisch vor, können das evtl. Parameteraufrufe sein, die nicht definiert sind ?!


    Kann es sein, dass beim beenden von VDR über dieses "stp vdr" Kommando auch der DVB Treiber entladen wird?! Dann könnte es sein, das die Karte nicht mehr gefunden wird...
    Kann man irgendwie herausfinden, was hinter diesem stp/stt vdr Start/Stop Script steckt?
    Was genau tut es? Ich kenne dafür den Aufbau von Gen2VDR leider zu wenig...
    Beim "normalen" VDR gibts dafür ein runvdr Script, aber das ist bei Gen2VDR wohl alles ein bisschen anders...


    Das ist jetzt der Punkt wo ich anfangen müsste zu pfuschen ;)
    Du könntest vdr mit "stt vdr" starten, dann suchst du die PID des Prozesses über "ps ax" heraus und killst einfach den vdr Prozess. Anschließend kannst du nochmal versuchen VDR manuell zu starten.
    Dann dürfte die Meldung eigentlich nicht mehr kommen.

    Server
    Software: Debian Lenny, VDR 1.6.0, vdradmin-am, streamdev-server, femon. epgsearch
    Hardware: Chenbro RM314, ABit AV8, AMD64 3200+, 512MB RAM, 4x Seagate 250GB@RAID5, 3ware 8500-4 SATA, Hauppauge dvb-s rev1.6+Nova-S


    Wohnzimmer VDR
    Software: Debian Lenny, VDR 1.6.0, dvd, remote, games, femon, streamdev-client
    Hardware: MSI Hermes 845GL, Hauppauge Nexus-S rev2.1, Nova-T FB, NEC DVD-Brenner

  • Quote

    Kann es sein, dass beim beenden von VDR über dieses "stp vdr" Kommando auch der DVB Treiber entladen wird?! Dann könnte es sein, das die Karte nicht mehr gefunden wird...


    Würde zumindest die Fehlermeldung erklären...


    Quote

    Kann man irgendwie herausfinden, was hinter diesem stp/stt vdr Start/Stop Script steckt? Was genau tut es? Ich kenne dafür den Aufbau von Gen2VDR leider zu wenig...


    Klar, kann ich gern mal nachschauen:


    stp vdr macht nix besonderes als den "Parameter" VDR an ein script mit dem Namen VDR stop zu übergeben.


    siehe hier:
    /usr/bin/stp

    Shell-Script
    1. #!/bin/sh
    2. /etc/init.d/$1 stop


    Die Datei "etc/init.d/vdr" lege ich mal an Anhang anbei :-)


    Quote

    Du könntest vdr mit "stt vdr" starten, dann suchst du die PID des Prozesses über "ps ax" heraus und killst einfach den vdr Prozess. Anschließend kannst du nochmal versuchen VDR manuell zu starten.


    Okay, habs mal versucht...aber irgendwie ist mir nicht klar welcher Prozess der vdr genau ist, bzw. welchen ich killen muss !
    Ich habe mal ein paar die vom Namen "als verdächtig" schienen gekillt, jedoch hatte ich dann das gleiche Problem, dass eben das Device nicht mehr vorhanden war.


    Hmmm, ich versuche nochmal den einen oder anderen Prozess... :lol2