A very annoying problem: picture gone after about 5h

  • Hi all!

    I have Hauppauge WindTV PCI DVB-C rel. 2.something (the one with hw mpeg decode) and I had vdr-1.2.6/driver 08.11.2003 up and running quite well. There were however problems with crashing and pausing never actually worked, so I decided to try newer version.

    I have Fedora Core 3 installed and I got everything up and running with instruction from the vdrportal site, but I encountered a very annoying problem. After about 5h of inactivity (TV is not on, VDR is) the vdr or the driver somehow shuts down my card and the picture&voice is gone. I can still use vdr menus etc and watch previously recorded material but I can't watch TV nor record anything new until I reboot the machine.

    I have the dvb_shutdown_timeout=0 parameter activated and userinactivitytimeout is 0 and I've tried to play with any timeout options I have found - to no success.

    I tried with FedoraCore 3 (newest) kernel drivers as well as cvs drivers from linuxtv.org - no difference.

    I've tried with various version of firmware (also the newest fw as of writing which is dvb-ttpci-01.fw-261d).

    I even installed vdr-1.2.6 back (not the old driver, which I can't build in FC3), but that didn't help either.

    Is there some new timeouts in the newer drivers or what am I missing here? I haven't tried to reinstall old linux with old drivers and "old" vdr-1.2.6 back yet, I hope to be able to run with newer (and otherwise much better) drivers. Yes, otherwise everything works fine, but I can't put i.e. my vdr to record something during the weekend when I'm away.

    Thank you for any help!

    >> Johannes Kleimola <<

  • I did not send you the logs because they did not reveal anything unusual beside what normal operation does. The initialization of the card goes well and all the other log entries are mostly just channel switches.

    I recently updated my Fedora 3 with latest rpms making my kernel version 2.6.10-1.741_FC3 (and I use the kernel provided drivers). I also compiled vanilla vd-1.3.19 with


    patches. Now the vdr seems to work much better. When the TV is off for a long time (and vdr is on) and I then open the TV, the picture is still gone, but switching channel now wakes it up and recording also seems to work.

    So the reason why the vdr did not wake up before remains unknown. Btw, what is the reason that the picture goes black even though I have applied

    options dvb-core dvb_shutdown_timeout=0

    to the /etc/modprobe.conf

    >> Johannes <<

  • I think it's the EPG-scanning feature, which tunes away your card to collect EPG data. Default is after 5 hours....

    To change this behaviour go to settings -> epg and change the value for scanning to "0".

    best regards,

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!