Xineliboutput fails to start in Ubuntu 20.04 (SOLVED)

  • Ubuntu 20.04 using most recent VDR binaries from Ubuntu and some other repositories (fnu, seahawk etc.). More or less everything I want works but I would like to set up certain settings via VDR GUI in Ubuntu desktop. That has never started in this new setup. If I click the VDR application it opens and goes away immediately. In same time it writes something like this in log:




    I have searched in forum. So far following things tried without success


    • allowed_hosts.conf should be allow all mode
    • That symlink trial in one thread is done - no success


    Bascially my guess is that it might be related on following things

    • Graphics driver issues
    • Could that LIRC have some role - I have tried to disable it totally but here it jumps on list
    • Some firewall issues?


    This is no major issue. I have been using this setup for several months and it does all the things I need. I am running desktop computer in basement acting as a VDR server and media itself is used via Kodi and other apps all over my home network. So seeing VDR running on Ubuntu desktop is just a final last thing that does not work in my setup and need is just minor configuration/settings need every here and then. Some settings are just handier setup using GUI than settings files.

  • This issue was dealed in this forum - just took a while before I was able to find story with google translate


    Problem mit vdr-sxfe


    I catch the idea by starting GUI with command


    vdr-sxfe --verbose


    Ẃhere error message linked to libavio with lines:

    Code
    1. libavio: no avio protocol for 'xvdr://127.0.0.1:37890'
    2. libavformat: Could not open source 'xvdr://127.0.0.1:37890': Protocol not found
    3. xine: cannot find input plugin for MRL [xvdr://127.0.0.1:37890#nocache]
    4. [243810] [vdr-fe] fe_xine_open: xine_open("xvdr://127.0.0.1:37890#nocache") failed
    5. Error opening xvdr://127.0.0.1:37890


    And then I had right terms for google


    In nutshell - libxine2-xvdr....package I am using was missing xineplug_inp_xvdr.so file. Download that package somewhere and copy that file to folder /usr/lib/x86_64-linux-gnu/xine/plugins/2.7/


    And it works :thumbup: