[Patch] Patch für streamdev für vdr-2.4.0 (OpenSuse Leap 15.0)

  • Hallo zusammen, da ich nichts gefunden habe, habe ich mal einen Patche für das oben angegebenen Plugin erstellt und angehängt.

    Dieser bezieht sich auf die git-Versionen des Plugins.

    Mit diesem konnte ich das Plugin erfolgreich unter OpenSuse Leap 15.0 übersetzen.

    Natürlich funktionieren es auch ohne Absturz, soweit ich das bisher getestet habe ;-)

    streamdev-fixes-2.4.0.diff


    Ich hoffe, dass ich damit den ein oder anderen glücklich machen konnte.

  • Hallo,

    also zu streamdev kann ich nichts sagen, aber epgsearch geht bei mir auf der Leap 15 auch ohne Patch.

    Oder habe ich etwas übersehen ?

    Was macht der Patch den genau ?

    Ich hatte nur das Problem, das sich das "Böse" Plugin nicht bauen lies.

    Gruß

    speed

  • Hallo Speed!

    Auch mit vdr-2.4.0?

    Hier wurden nämlich von cListObject abgeleitete Klassen zugewiesen, was aber aufgrund des 'verbotenen' Assignment-Operators der Basisklasse nicht erlaubt ist. Außerdem fehlte an einigen Stellen std:: vor min/max


    Gruß, Chris

  • Hallo Chris,

    ich hatte mir epgsearch aus dem Git geholt, und es kompilierte sauber durch.


    https://projects.vdr-developer…in-epgsearch-2.4.0.tar.gz


    Habe es jetzt seit Wochen im Einsatz, und mir ist nichts negatives aufgefallen.

    Aber danke für deine Info, dann wende ich deinen Patch mal an.

    Achja ist VDR 2.4

    Gruß

    speed

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von speed ()

  • Hallo Speed,

    offensichtlich ist mir dieser git-Stand durch die Lappen gegangen...

    Vielen Dank für den Hinweis

    Wenn es bei Dir kompiliert und läuft, brauchst Du meinen Patch nicht.

    Ich hatte anscheinend eine etwas ältere Version...

    Gruß, Chris


    PS: Ich denke, mein Patch für epgsearch ist damit obsolet und ich hoffe, dass ich nicht auch beim streamdev was übersehen und mir unnötige Arbeit gemacht habe (Hat aber Spaß gemacht...).