[gelöst] Gyration Fernbedienung: Farbtasten funktionieren nach dem letzten dist-upgrade nicht mehr.

  • Hallo Experten,


    nach der Installation von yaVDR 0.4 funktionierte meine Gyration GYR3101EU ootb, inklusive der Farbtasten. Vorgestern (28.11.2011) habe ich dann wieder mal ein dist-upgrade gemacht und nun funktionieren die Farbtasten nicht mehr...
    Alle anderen Tasten funktionieren auf der Fernbedienung.


    sudo evtest /dev/input/event2 -> Alle Tasten (bis auf die Maus) liefern eine Anzeige, keine Reaktion bei den Farbigen Tasten


    sudo ir-keytable -t --device /dev/input/event2 -> Alle Tasten (bis auf die MAus) liefern eine Anzeige, keine Reaktion bei den Farbigen Tasten


    Auch die Deinstallation und erneute Installation von hid-gyration-dkms hat nichts gebracht.


    Wie sieht es denn bei denn anderen Gyration-Benutzern aus, funktionieren die Farbtasten?


    Gruß
    Jörg

    1. HD-VDR: yaVDR 0.5, Asrock Q1900M, 2GB RAM, TeVii S660 DVB-S2 USB, 250 GB SATA, ASUS GT630-SL-1GD3-L
    2. Server-VDR: yaVDR 0.5, FuSi Celsius M450, Intel Core2 Duo E6420 2x2,13GHz, 4GB RAM, 250GB SATA, 1TB SATA, 1.5TB SATA, FF1.3 mit defektem TV-Out, KNC DVB-S One budget, dient als File- und Streaming-Server, WOL um Strom zu sparen
    3. LG 42PG6000 Plasma (HD-Ready)

    The post was edited 1 time, last by holylinsman ().

  • Hier schon - aber die Rot/Blau macht zicken, hat aber nichts mit dist-upgrade zu tun. Ist das dkms erfolgreich gebaut und danach auch das Modul neu geladen worden ? Die Gyration arbeitet als "Tastatur" also nichts mit ir-keytable, evtest dürfte zum testen aber gehen.

  • Beim letzten dist-upgrade hatte ich irgendwas mit "gyration" mitbekommen... Jedenfalls funktionierten die Farbtasten am Anfang und nach diesem Update nicht mehr.


    hid-gyration-dkms hatte ich mit sudo apt-get purge deinstalliert und danach mit sudo apt-get install wieder installiert. Da da keine Fehler auftauchten, gehe ich davon aus, dass das geklappt hat...


    Wenn die Farbtasten mit evtest keine Reaktion zeigen, woran kann das dann liegen?


    Gruß
    Jörg

    1. HD-VDR: yaVDR 0.5, Asrock Q1900M, 2GB RAM, TeVii S660 DVB-S2 USB, 250 GB SATA, ASUS GT630-SL-1GD3-L
    2. Server-VDR: yaVDR 0.5, FuSi Celsius M450, Intel Core2 Duo E6420 2x2,13GHz, 4GB RAM, 250GB SATA, 1TB SATA, 1.5TB SATA, FF1.3 mit defektem TV-Out, KNC DVB-S One budget, dient als File- und Streaming-Server, WOL um Strom zu sparen
    3. LG 42PG6000 Plasma (HD-Ready)

  • Dann ist das dkms nicht aktiv. Das hid-gyration-dkms sorgt dafür das die Farbtasten gehen. Nicht mehr und nicht weniger. Wie gesagt nach der Installation des dkms ein rmmod hi-gyration und modprobe hid-gyration sollte die Farbtasten wieder aktiv machen. Ab Kernel 3.0 oder so sind die Farbtasten auch im normalen Kernel.

  • Hi Steffen,


    habe deinen letzten Tip ausprobiert und das hid-gyration ent- und wieder geladen, doch ohne Erfolg.


    Hast du noch eine Idee?


    Gruß
    Jörg

    1. HD-VDR: yaVDR 0.5, Asrock Q1900M, 2GB RAM, TeVii S660 DVB-S2 USB, 250 GB SATA, ASUS GT630-SL-1GD3-L
    2. Server-VDR: yaVDR 0.5, FuSi Celsius M450, Intel Core2 Duo E6420 2x2,13GHz, 4GB RAM, 250GB SATA, 1TB SATA, 1.5TB SATA, FF1.3 mit defektem TV-Out, KNC DVB-S One budget, dient als File- und Streaming-Server, WOL um Strom zu sparen
    3. LG 42PG6000 Plasma (HD-Ready)

  • Noch einmal das Modul entladen und das dkms de- und wieder installiert. Nach einem Reboot, habe ich es noch einmal mit rmmod / modprobe versucht.


    Jetzt funktionieren die Farbtasten.


    Mal schauen, wie es nach einem weiteren Neustart aussieht...
    ...nach einem Reboot funktionieren sie nicht mehr, allerdings hilft rmmod / modprobe, und sie funktionieren wieder.


    "modinfo hid-gyration":

    Code
    1. filename: /lib/modules/2.6.38-13-generic/updates/dkms/hid-gyration.ko
    2. license: GPL
    3. srcversion: 8FEF7F5EC8532DF1FBDC218
    4. alias: hid:b0003v00000C16p00000008
    5. alias: hid:b0003v00000C16p00000003
    6. alias: hid:b0003v00000C16p00000002
    7. depends: hid
    8. vermagic: 2.6.38-13-generic SMP mod_unload modversions


    "dkms status":

    Code
    1. hid-gyration, 3101EU, 2.6.32-24-generic, i686: built
    2. hid-gyration, 3101EU, 2.6.38-13-generic, x86_64: installed
    3. nvidia-current, 270.41.06, 2.6.38-12-generic, x86_64: installed
    4. nvidia-current, 270.41.06, 2.6.38-11-generic, x86_64: installed
    5. nvidia-current, 270.41.06, 2.6.38-13-generic, x86_64: installed
    6. ati-remote, 0.0.1, 2.6.38-12-generic, x86_64: installed
    7. ati-remote, 0.0.1, 2.6.38-8-generic, i686: built
    8. ati-remote, 0.0.1, 2.6.38-13-generic, x86_64: installed


    nach dem Reboot (Farbtasten funktionieren nicht)
    "dmesg | grep hid"

    Code
    1. [ 3.902945] usbcore: registered new interface driver usbhid
    2. [ 3.902947] usbhid: USB HID core driver
    3. [ 3.940347] gyration 0003:0C16:0002.0001: input,hiddev0,hidraw0: USB HID v1.10 Keyboard [Gyration Gyration RF Technology Receiver] on usb-0000:00:02.0-3/input0
    4. [ 3.949583] gyration 0003:0C16:0002.0002: input,hiddev0,hidraw1: USB HID v1.20 Mouse [Gyration Gyration RF Technology Receiver] on usb-0000:00:02.0-3/input1
    5. [ 4.330233] generic-usb 0003:1241:F767.0003: input,hidraw2: USB HID v1.10 Keyboard [HOLTEK Wireless 2.4GHz Trackball Keyboard] on usb-0000:00:04.0-3/input0
    6. [ 4.342573] generic-usb 0003:1241:F767.0004: input,hiddev0,hidraw3: USB HID v1.10 Mouse [HOLTEK Wireless 2.4GHz Trackball Keyboard] on usb-0000:00:04.0-3/input1


    Und nach dem Ent- und Neuladen:

    Code
    1. [ 170.715896] gyration 0003:0C16:0002.0001: input,hiddev0,hidraw0: USB HID v1.10 Keyboard [Gyration Gyration RF Technology Receiver] on usb-0000:00:02.0-3/input0
    2. [ 170.716614] gyration 0003:0C16:0002.0002: input,hiddev0,hidraw1: USB HID v1.20 Mouse [Gyration Gyration RF Technology Receiver] on usb-0000:00:02.0-3/input1


    Hilft das?


    Gruß
    Jörg

    Files

    • dmesg.zip

      (14.51 kB, downloaded 48 times, last: )

    1. HD-VDR: yaVDR 0.5, Asrock Q1900M, 2GB RAM, TeVii S660 DVB-S2 USB, 250 GB SATA, ASUS GT630-SL-1GD3-L
    2. Server-VDR: yaVDR 0.5, FuSi Celsius M450, Intel Core2 Duo E6420 2x2,13GHz, 4GB RAM, 250GB SATA, 1TB SATA, 1.5TB SATA, FF1.3 mit defektem TV-Out, KNC DVB-S One budget, dient als File- und Streaming-Server, WOL um Strom zu sparen
    3. LG 42PG6000 Plasma (HD-Ready)

    The post was edited 1 time, last by holylinsman ().

  • Ja, scheint funktioniert zu haben.
    Und wieso hat das jetzt geklappt?


    Gruß
    Jörg

    1. HD-VDR: yaVDR 0.5, Asrock Q1900M, 2GB RAM, TeVii S660 DVB-S2 USB, 250 GB SATA, ASUS GT630-SL-1GD3-L
    2. Server-VDR: yaVDR 0.5, FuSi Celsius M450, Intel Core2 Duo E6420 2x2,13GHz, 4GB RAM, 250GB SATA, 1TB SATA, 1.5TB SATA, FF1.3 mit defektem TV-Out, KNC DVB-S One budget, dient als File- und Streaming-Server, WOL um Strom zu sparen
    3. LG 42PG6000 Plasma (HD-Ready)

  • nach der Installation des Kernels scheint die initrd neu genieriert worden zu sein - ohne das modifizierte Modul - das Modul wurde schon aus der initrd geladen. Ich vermute dem dkms Paket muss noch gesagt werden das ein neu generieren des initrd notwendig ist. Scheint nun aber zum ersten mal so aufgetreten zu sein. Mal manpage lesen was sich da machen lässt...