You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

tommiwe

Intermediate

  • "tommiwe" started this thread

Posts: 268

Location: Bad Oeynhausen

  • Send private message

1

Friday, September 24th 2004, 11:46am

und schon wieder lirc

Mahlzeit!

die FB macht mich noch wahnsinnig. Bin gerade etwas in Eile, darum erst nur mal ne Frage:. Was haltet Ihr von diesen Meldugen:

Sep 24 11:37:33 vdr kernel: Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
Sep 24 11:37:33 vdr kernel: ttyS00 at 0x03f8 (irq = 4) is a 16550A
Sep 24 11:37:33 vdr kernel: ttyS01 at 0x02f8 (irq = 3) is a 16550A

Sep 24 11:37:33 vdr kernel: lirc_serial: port 02f8 already in use, proceeding anyway
Sep 24 11:37:33 vdr kernel: lirc_serial: compile the serial port driver as module and
Sep 24 11:37:33 vdr kernel: lirc_serial: make sure this module is loaded first
Sep 24 11:37:33 vdr kernel: lirc_serial: auto-detected active low receiver

Sep 24 11:37:33 vdr kernel: ttyS2: LSR safety check engaged!
Sep 24 11:37:33 vdr kernel: ttyS2: LSR safety check engaged!
Sep 24 11:37:33 vdr lircd 0.6.6[685]: lircd(any) readySep 24 11:37:54 vdr lircd 0.6.6[685]: accepted new client on /dev/lircd
Sep 24 11:37:54 vdr vdr[1591]: LIRC remote control thread started (pid=1591)
Sep 24 11:37:54 vdr vdr[1592]: KBD remote control thread started (pid=1592)
Sep 24 11:37:54 vdr vdr[1277]: remote control LIRC - keys known
Sep 24 11:37:54 vdr vdr[1277]: remote control KBD - keys known

Sep 24 11:38:15 vdr lircd 0.6.6[685]: accepted new client on /dev/lircd
Sep 24 11:38:21 vdr lircd 0.6.6[685]: removed client

Ich hatte vorgestern die FB angelernt und es lief alles. irw gab auch die korrekten Codes aus. Am nächsten Tag war es als ob lirc noch nie gelaufen wäre.

Gruß

Thomas
ct-vdr 5 (1.4.2-1ctvdr2) mit Erweiterungen von tobi, Silverstone LC03, ASUS P4P800-VM, 256 MB, TT 1.5, P4 2 GHZ, Thermalright SLK 947 U, Tagan TG 330, Aopen DVD 1648, Samsung SV1203N, WLAN WG311v2 Netgear

2

Friday, September 24th 2004, 4:06pm

hi,
sieht doch alles gut aus.
jetzt sorgst du nur noch dafür das der kernel-serial-driver NICHT mehr geladen wird. der verträgt sich nämlich nicht mir lirc_serial. alternativ kannst du auch den weg über setserial gehen, der in meinen augen aber nicht so schön ist.

mfg carsten
Meine Homepage mit VDR-Projekten: http://ca.rstenpresser.de/~cpresser/

Bitz

Intermediate

Posts: 488

Location: Frankfurt/M

  • Send private message

3

Friday, September 24th 2004, 4:41pm

hm, das lief bei mir auch eine ganze Weile trotz dieser Fehlermeldung "port 02f8 already in use, proceeding anyway"

Geht denn die FB?
Ab wo ist denn der Prozess

com1-->bios-->lirc_serial-->lircd-->/dev/lirc/-->vdr

tot?

Vielleicht ist der gerade laufende Thread mit Telly
über lirc-fehlersuche eine Hilfe:

http://www.vdrportal.de/board/thread.php…3757#post193757

Grüsse,
Bitz

tommiwe

Intermediate

  • "tommiwe" started this thread

Posts: 268

Location: Bad Oeynhausen

  • Send private message

4

Friday, September 24th 2004, 5:48pm

Also den Kernel neu kompilieren?
Mit setserial hatte ich auch keinen Erfolg.
Ich war erstaunt, dass es in /etc bei mir keine serial.conf gibt.

Hat die jemand für mich?

Gruß

Thomas
ct-vdr 5 (1.4.2-1ctvdr2) mit Erweiterungen von tobi, Silverstone LC03, ASUS P4P800-VM, 256 MB, TT 1.5, P4 2 GHZ, Thermalright SLK 947 U, Tagan TG 330, Aopen DVD 1648, Samsung SV1203N, WLAN WG311v2 Netgear

5

Friday, September 24th 2004, 6:56pm

hi,
probier mal "rmmod serial". wenn das taugt (die vorher beschriebene prozess-kette dann wieder neu starten), dann sollte es reichen ein "alias serial off" in die modules.conf einzubauen.
Meine Homepage mit VDR-Projekten: http://ca.rstenpresser.de/~cpresser/

Bitz

Intermediate

Posts: 488

Location: Frankfurt/M

  • Send private message

6

Friday, September 24th 2004, 9:40pm

Auf meinem c't-vdr läuft der 2.4.24-ctvdr-2 - kernel mit fest eincompilerten (kein Modul)
serial-unterstützung + ausserdem lirc ohne probleme.
Soweit ich sehen kann wird serial beim kompletten Start nicht ein einziges Mal angefasst.
Aaaber:
modules.conf hat einen Eintrag:

### update-modules: start processing /etc/modutils/lirc
#This file is modified by lirc's maintainer scripts.
#Any 'options' line asociated with the selected hardware will be replaced.
#However 'add options' lines will be left alone, so you can use that for
#additional module parameters.
# ej:
# add options lirc_serial sense=0
pre-install lirc_serial /bin/setserial /dev/ttyS0 uart none
options lirc_serial io=0x3f8 irq=4

tommiwe

Intermediate

  • "tommiwe" started this thread

Posts: 268

Location: Bad Oeynhausen

  • Send private message

7

Saturday, September 25th 2004, 12:22am

Kann mich leider erst nächste Woche wieder mit beschäftigen.
Melde mich dann wieder.

Gruß

Thomas
ct-vdr 5 (1.4.2-1ctvdr2) mit Erweiterungen von tobi, Silverstone LC03, ASUS P4P800-VM, 256 MB, TT 1.5, P4 2 GHZ, Thermalright SLK 947 U, Tagan TG 330, Aopen DVD 1648, Samsung SV1203N, WLAN WG311v2 Netgear

8

Saturday, September 25th 2004, 2:03pm

hi,
das macht sinn blitz. wie der name schon sagt wird vor dem laden des lirc_serial moduls dem kernel treiber über setserial gesagt das er sich bitte raushalten soll.

ich frage mich nur warum bei dem standard-c't-vdr-kernel serial nicht gleich als modul dabei ist.

mfg carsten
Meine Homepage mit VDR-Projekten: http://ca.rstenpresser.de/~cpresser/

tommiwe

Intermediate

  • "tommiwe" started this thread

Posts: 268

Location: Bad Oeynhausen

  • Send private message

9

Tuesday, September 28th 2004, 2:25pm

Aloa! Da bin ich wieder!

Vorab: Es läuft wieder. :-)
Ich habe mit modconf das Modul lirc_serial rausgeschmissen und dann mittels Konsole lirc_serial, lircd und setserial benutzt um die Module zu entladen und wieder neu zu starten und alles, was sonst notwendig ist. Davor hatte ich im Bios mal com2 deaktiviert.
Auf alle Fälle wird com1 erkannt, lird gestartet und lirc_serial ebenfalls.
Mittels irw, kann ich sehen, was auf Knopfdruck für ein Befehl abgearbeitet wird.

AAAABBBBEEERRRR:
Beim Drücken irgendwelcher Knöpfe (z. B. Menü) auf der FB, tut sich am Fernseher nichts. :-(((
Ich hatte die /etc/vdr/remote.conf entfernt. Trotzdem komme ich nicht in den Anlernmodus.
Was muss ich denn noch tun?

Quoted

Original von Bitz
modules.conf hat einen Eintrag:

### update-modules: start processing /etc/modutils/lirc
#This file is modified by lirc's maintainer scripts.
#Any 'options' line asociated with the selected hardware will be replaced.
#However 'add options' lines will be left alone, so you can use that for
#additional module parameters.
# ej:
# add options lirc_serial sense=0
pre-install lirc_serial /bin/setserial /dev/ttyS0 uart none
options lirc_serial io=0x3f8 irq=4

Komisch. Das sieht bei mir anders aus. Muss ich was beachten, wenn ich von Hand die Zeilen ändere?

Gruß

Thomas
ct-vdr 5 (1.4.2-1ctvdr2) mit Erweiterungen von tobi, Silverstone LC03, ASUS P4P800-VM, 256 MB, TT 1.5, P4 2 GHZ, Thermalright SLK 947 U, Tagan TG 330, Aopen DVD 1648, Samsung SV1203N, WLAN WG311v2 Netgear