You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Saturday, August 5th 2006, 4:22pm

mplayer(plugin) spielt keine Videos ab

Hallo!

Ich hab ein Problem mit dem mplayer(plugin). Wenn ich ein Video abspielen möchte, erscheint in /var/log/messages nur Folgendes:

Aug 5 00:00:32 scotty logger: *** Starting mplayer.sh Version 0.8.6
Aug 5 00:00:32 scotty logger: *** DEBUG: Variable CFGFIL has value "/etc/vdrdevel/plugins/vdrdevelmplayer.sh.conf"
Aug 5 00:00:32 scotty logger: *** Use Option USERDEF at your own risk!
Aug 5 00:00:34 scotty logger: *** INFO: Source Video has Resolution of 384 x 288 ...
Aug 5 00:00:34 scotty logger: *** INFO: For Sqare Pixels we would scale to 768 x 576 ...

Der Fernseher wird kurz schwarz und schaltet wieder auf's aktuelle TV-Programm. Installiert hab ich Debian 3.1 und VDR 1.3.49 (Tobi's Testing) mit mplayer Versionen (dpkg -l):

ii mplayer-586 1.0-pre7cvs200 The Ultimate Movie Player For Linux
ii mplayer-skin-b 1.5-0.5 default skin for mplayer
ii vdrdevel-plugi 0.9.14+0.9.15p Plugin to vdr that integrates mplayer

Hat irgendjemand einen Tipp? Einen Link ins Forum wo das schon mal beschrieben wurde (es steht bestimmt irgendwo, aber ich bin wahrscheinlich mal wieder zu blind...)? Ach ja: Die setup.conf vom VDR sieht wie folgt aus (mplayer-Einträge):

mplayer.ControlMode = 1
mplayer.HideMainMenu = 0
mplayer.KeyCmd0 = osd
mplayer.KeyCmd1 = audio_delay -0.1
mplayer.KeyCmd2 = switch_audio
mplayer.KeyCmd3 = audio_delay +0.1
mplayer.KeyCmd4 = quit
mplayer.KeyCmd5 = quit
mplayer.KeyCmd6 = quit
mplayer.KeyCmd7 = pt_step -1
mplayer.KeyCmd8 = loadlist /tmp/playlist
mplayer.KeyCmd9 = pt_step 1
mplayer.ResumeMode = 1

Merci!
Cetixx
Kopfstation: Netceiver, 1x Dual LNB-DVS-S2
Server + Client: Asus P7H55-V, Core i3-530, 8GB RAM, HDD 3,5" 2 TB, Gentoo mit Kernel 3.11, VDR-2.0.2

2

Saturday, August 5th 2006, 4:53pm

das kann alles mögliche sein!
hast du ne ff-karte?
aktiviere debug in der configuration zu mplayer.sh.
beende vdr und starte das mplayer.sh script manuell auf der console, dann bekommst du auch die ausgabe vom mplayer selbst zu sehen (womit sich wohl der fehler finden lässt).
Meine Homepage mit VDR-Projekten: http://ca.rstenpresser.de/~cpresser/

3

Saturday, August 5th 2006, 9:47pm

Danke für den Hinweis! Der Debugmode war schon nicht schlecht. Es wird anscheinend kein Dateiname an mplayer übergeben:

Aug 5 17:28:55 scotty logger: *** DEBUG: Variable CMDLINE has value "/usr/bin/mplayer -vo mpegpes -ao mpegpes -vop lavc=5000:25,expand=480:576:-1:-1:1,scale=480:576 -framedrop -cache 4096 -slave -nolirc -subpos 80 -sub-bg-color 0 -sub-bg-alpha 30 -slave -quiet -osdlevel 0 "

Zum Schluss sollte noch der Dateiname auftauchen. Hmmm... Muss ich noch rausfinden, warum der Dateiname nicht übergeben wird. Eine FF-Karte habe ich.

Merci!
Kopfstation: Netceiver, 1x Dual LNB-DVS-S2
Server + Client: Asus P7H55-V, Core i3-530, 8GB RAM, HDD 3,5" 2 TB, Gentoo mit Kernel 3.11, VDR-2.0.2

blafasel

Intermediate

Posts: 390

Location: HH

  • Send private message

4

Saturday, August 5th 2006, 9:54pm

Falls Du mehr als eine Karte hast, könnte auch noch der folgende Eintrag in der mplayer.sh.conf interessant sein:

...
# Video out device
# most users will want the default of 'mpegpes', but users with a dxr3
# need to use 'dxr3'
#VO="dxr3"
#VO="mpegpes:card=2"
VO="mpegpes"
...


Evtl. musst Du VO="mpegpes:Card=X" verwenden.


Gruss
blafasel
Produktiv:
HW: Zalman HD 160 HTPC ° Intel Core i5-2500K ° 8 GB RAM ° 20TB HDDs ° 2x Satelco Easywatch DVB-C ° 4x Digital Devices DuoFlex-CT
SW: yavdr 0.5.0 ° Kernel 3.8.0-44 ° VDR 2.0.6
VDR-User #72 / Follow me on Twitter

5

Saturday, August 5th 2006, 10:44pm

Hallo Blafasel!

Hab ich probiert, bringt aber nichts. Ich hab aber den Ausgang auch am ersten Adapter, das sollte passen. Ich seh auch auf der Kommandozeile das er die erste Karte anspricht. Ich hab die Debugausgabe jetzt etwas angepasst und mal eine Datei direkt übergeben. Leider bleibt's dabei, das der Bildschirm nur kurz flackert :-( In der /var/log/messages steht jetzt Folgendes:

Aug 5 22:35:58 scotty logger: *** Starting mplayer.sh Version 0.8.6
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable CFGFIL has value "/etc/vdrdevel/plugins/vdrdevelmplayer.sh.conf"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable USEAC3 has value "false"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable AC3AOUT has value "-ao mpegpes -ac hwac3"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable TV_ASPECT has value "4/3"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable PAL has value "true"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable NTSC has value "true"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable USE_SPEED has value "true"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable DETC_FILTER has value "detc=dr=2:am=1"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable MPLAYER has value "/usr/bin/mplayer"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable VOP has value "lavc=5000"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable VO has value "mpegpes"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable AO has value "mpegpes"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable CACHE has value "4096"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable CACHESTR has value "-cache 4096"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable FRAMEDROP has value "true"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable FDSTR has value "-framedrop"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable LIRCRC has value ""
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable LIRCSTR has value ""
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable SUBTITLE has value " -subpos 80 -sub-bg-color 0 -sub-bg-alpha 30"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable REMOTE has value ""
Aug 5 22:35:58 scotty logger: *** Use Option USERDEF at your own risk!
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable USERDEF has value "-slave -quiet -osdlevel 0"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable XResPAL has value "352 480 528 544 688 704 720"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable XResNTSC has value "352 480 512 640 704 720"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable SLOW_CPU has value "false"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable DVDFiles has value "/var/lib/vdrdevel-plugin-mplayer/DVD-VCD"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable DVD has value "/dev/hdc"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable DVDLANG has value "de"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable DVDOPTIONS has value "-aop list=volume:volume=170"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable VCDOPTIONS has value ""
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable MPEG_DIRECT has value "true"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable SUFFIX has value ".avi"
Aug 5 22:35:58 scotty logger: *** DEBUG: Variable MPLAYER_V1 has value "true"
Aug 5 22:35:58 scotty logger: *** DEBUG: Calling getvidxy function to analyze source video stream ...
Aug 5 22:35:59 scotty logger: *** DEBUG: OutputFromMPLAYER: "ID_VIDEO_ID=0 ID_AUDIO_ID=1 ID_FILENAME=/tmp/scene/ppot_-_cannon_fodder_live_at_crc_2005.avi ID_DEMUXER=avi ID_VIDEO_FORMAT=DX50 ID_VIDEO_BITRATE=344944 ID_VIDEO_WIDTH=360 ID_VIDEO_HEIGHT=288 ID_VIDEO_FPS=25.000 ID_VIDEO_ASPECT=0.0000 ID_AUDIO_CODEC=mp3 ID_AUDIO_FORMAT=85 ID_AUDIO_BITRATE=112000 ID_AUDIO_RATE=48000 ID_AUDIO_NCH=2 ID_LENGTH=415.72 ID_VIDEO_CODEC=ffodivx"
Aug 5 22:35:59 scotty logger: *** DEBUG: MPLAYER_RETURN: "0"
Aug 5 22:35:59 scotty logger: *** DEBUG: parsed output for ORIG_X: "360"
Aug 5 22:35:59 scotty logger: *** DEBUG: parsed output for ORIG_Y: "288"
Aug 5 22:35:59 scotty logger: *** DEBUG: parsed output for ORIG_FPS: "25.000"
Aug 5 22:35:59 scotty logger: *** DEBUG: parsed output for ORIG_ASPECT: "0.0000"
Aug 5 22:35:59 scotty logger: *** DEBUG: parsed output for VIDEO_FORMAT: "DX50"
Aug 5 22:35:59 scotty logger: *** DEBUG: parsed output for AUDIO_CODEC: "mp3"
Aug 5 22:35:59 scotty logger: *** INFO: Source Video has Resolution of 360 x 288 ...
Aug 5 22:35:59 scotty logger: *** DEBUG: PAL or unknown "25.000"
Aug 5 22:35:59 scotty logger: *** DEBUG: Variable MAX_X has value "768"
Aug 5 22:35:59 scotty logger: *** DEBUG: Variable NEW_Y has value "614"
Aug 5 22:35:59 scotty logger: *** INFO: For Sqare Pixels we would scale to 768 x 614 ...
Aug 5 22:35:59 scotty logger: *** DEBUG: Variable XResTEMP has value "352 480 528 544 688 704 720"
Aug 5 22:35:59 scotty logger: *** DEBUG: Variable AnzahlVonXResTEMP has value "7"
Aug 5 22:35:59 scotty logger: *** DEBUG: Variable NEW_X has value "480"
Aug 5 22:35:59 scotty logger: *** DEBUG: setting REAL_Y = FULL_Y ""
Aug 5 22:35:59 scotty logger: *** DEBUG: Variable CMDLINE has value "/usr/bin/mplayer -vo mpegpes -ao mpegpes -vop lavc=5000:25,expand=480:576:-1:-1:1,scale=480:576 -framedrop -cache 4096 -subpos 80 -sub-bg-color 0 -sub-bg-alpha 30 -slave -quiet -osdlevel 0 /tmp/hybris_nemesis-south_party_divx.avi"

Falls noch jemand eine Idee hat...

Merci
Cetixx
Kopfstation: Netceiver, 1x Dual LNB-DVS-S2
Server + Client: Asus P7H55-V, Core i3-530, 8GB RAM, HDD 3,5" 2 TB, Gentoo mit Kernel 3.11, VDR-2.0.2

6

Saturday, August 5th 2006, 10:47pm

Teste mal mit *.vdr Dateien, das schliest schon mal nen Fehler mit Formaten weitgehend aus.
2003 - 2011 - R.I.P.

7

Saturday, August 5th 2006, 10:51pm

das hier passt irgendwie nicht zusammen:
- /tmp/scene/ppot_-_cannon_fodder_live_at_crc_2005.avi
- /tmp/hybris_nemesis-south_party_divx.avi

hast du schon mal - wie empfohlen das script manuell auf einer console gestartet?
ersetze noch das "-quiet" durch ein "-v" und schon bekommst du ne menge mehr debug-ausgaben!
Meine Homepage mit VDR-Projekten: http://ca.rstenpresser.de/~cpresser/