Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 20. Dezember 2007, 13:59

kernel parameter und fb.modes gesucht fuer SMT 7020s

Hi,

hat jemand eine brauchbare kernel append-Zeile und fb.modes, um den Framebuffer der SMT-7020s mit 720x576-50 darzustellen?

Alles was ich bisher geschafft habe, waren entweder 60Hz oder 800x600 :-(

Merci,

Andreas
VDR: ASUS AT3ION-T, 2GB, Satix S2 Dual, 1TB 2.5", yavdr 0.4
Server: Intel DH67CF, Pentium G620, 8GB, 2x1000GB 2.5" Raid1, WLAN, Ubuntu 12.04 @22W
TV: Panasonic P50G30

2

Freitag, 21. Dezember 2007, 09:29

Setz mal den vsync1 auf 49 in deiner Append-Zeile. Die Funktion validate_mode errechnet dort nämlich einen Wert von 49,x
Laufen tut die karte aber trotzdem mit sauberen 50Hz.

3

Freitag, 21. Dezember 2007, 11:19

Hi,

ich habe jetzt folgende Einstellungen getestet:

agpgart video=i810fb:vram:8,xres:720,yres:576,bpp:24,hsync1:30,hs
ync2:55,vsync1:49,vsync2:55,accel,mtrr

Damit bekomme ich einen 720x576-55Hz modus, vdr-fbfe ist damit aber weniger gluecklich:

[1721] [input_vdr] Fifo buffer still full after poll !

vsync2 auf 51 geht auch noch, damit gibts einen 51Hz modus. vsync2 auf 50Hz ergibt leider keinen gueltigen Modus.

Nur mit 800x600 komme ich auf meine 50Hz:

video=i810fb:vram:8,xres:800,yres:600,bpp:16,hsync1:30,hsync2:55,vsync1:49,vsync2:50,accel,mtrr

Umschalten auf 720x576 kann ich damit aber nicht mehr:

# fbset 720x576-50
ioctl FBIOPUT_VSCREENINFO: Invalid argument

Offenbar will aber vdr-fbfe nur mit einen 50Hz Modus laufen :-(
VDR: ASUS AT3ION-T, 2GB, Satix S2 Dual, 1TB 2.5", yavdr 0.4
Server: Intel DH67CF, Pentium G620, 8GB, 2x1000GB 2.5" Raid1, WLAN, Ubuntu 12.04 @22W
TV: Panasonic P50G30

4

Sonntag, 30. Dezember 2007, 13:28

Hi,

jetzt grab ich das Projekt doch nochmal aus. Ich habe jetzt folgende Kernel-Parameter:

Quellcode

1
agpgart video=i810fb:vram:8,xres:800,yres:600,bpp:16,hsync1:30,hsync2:55,vsync1:49,vsync2:50,accel,mtrr,render

Und diese fb.modes:

Quellcode

1
2
3
4
5
6
mode "720x576-50"
# D: 27.000 MHz, H: 31.250 kHz, V: 50.000 Hz
   geometry 720 576 720 576 32
   timings 37037 64 16 39 5 64 5
   accel true
endmode

Damit habe ich nach dem Booten einen 800x600 Modus, und nach einem fbset einen 720x576-50Hz Modus:

Quellcode

1
2
3
4
5
6
7
8
9
root@samsung:~# fbset 720x576-50
root@samsung:~# fbset -i

mode "720x576-50"
    # D: 27.000 MHz, H: 31.250 kHz, V: 50.000 Hz
    geometry 720 576 720 576 32
    timings 37037 64 16 39 5 64 5
    rgba 8/16,8/8,8/0,8/24
endmode

Leider tut damit der Framebuffer immer noch nicht richtig:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
root@samsung:~# vdr-fbfe --aspect=16:9 --nokbd --udp --lirc --fullscreen --post tvtime:method=Linear,cheap_mode=1,pulldown=0,use_progressive_frame_flag=1   
vdr-fbfe 1.0.0rc2  (build with xine-lib 1.1.2, using xine-lib 1.1.2)

Aspect ratio: 16:9
Keyboard input disabled
Protocol: UDP
LIRC device:  /dev/lircd
Fullscreen mode
Post plugins: tvtime:method=Linear,cheap_mode=1,pulldown=0,use_progressive_frame_flag=1

VDR server not given, searching ...
Found VDR server: host 10.0.0.6, port 37890
[3391] [vdr-fe]    fbfe_display_open: failed to set /dev/tty to graphics mode
[3391] [vdr-fe]       (ERROR (xine_fbfe_frontend.c,190): Invalid argument)


Press Esc to exit

[3391] [input_vdr] Connecting (control) to tcp://10.0.0.6:37890 ...
[3391] [input_vdr] Server greeting: VDR-1.4.7 xineliboutput-1.0.0rc2 READY
[3391] [input_vdr] Connected (control) to tcp://10.0.0.6:37890
[3391] [input_vdr] Connecting (data) to udp://10.0.0.6 ...
[3401] [vdr-fe]    lirc forwarding started
[3391] [input_vdr] Data stream connected (UDP)
[3391] [input_vdr] WARNING: Video output driver reports it does not support unscaled overlays !
[3404] [input_vdr] SCR jump: +40 ms (live=1, tunning=2) time 0s
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[3404] [input_vdr] Fifo buffer still full after poll !
[...]
Es erscheint kurz ein Bild, eine Sekunde Ton, und danach endlose "Fifo buffer still full after poll" Fehlermeldungen.

Was laeuft denn hier noch schief?

Danke,

Andreas
VDR: ASUS AT3ION-T, 2GB, Satix S2 Dual, 1TB 2.5", yavdr 0.4
Server: Intel DH67CF, Pentium G620, 8GB, 2x1000GB 2.5" Raid1, WLAN, Ubuntu 12.04 @22W
TV: Panasonic P50G30

5

Dienstag, 1. Januar 2008, 12:17

Mit dem 800x600-50Hz Modus laeuft der vdr-fbfe zwar, allerdings ohne Bild, nur mit Ton, und gelegentlichen Fehlern:

[8228] [input_vdr] SCR jump: +40 ms (live=1, tunning=2) time 0s
[8228] [input_vdr] SCR jump: +40 ms (live=1, tunning=2) time 0s
[8228] [input_vdr] SCR jump: +40 ms (live=1, tunning=2) time 6s
[8228] [input_vdr] SCR jump: +40 ms (live=1, tunning=2) time 6s

Die 720x576-50 Variante scheint mir also naeher an der Wahrheit zu sein, aber was bedeutet diese Fehlermeldung?

[3404] [input_vdr] Fifo buffer still full after poll !
VDR: ASUS AT3ION-T, 2GB, Satix S2 Dual, 1TB 2.5", yavdr 0.4
Server: Intel DH67CF, Pentium G620, 8GB, 2x1000GB 2.5" Raid1, WLAN, Ubuntu 12.04 @22W
TV: Panasonic P50G30

6

Dienstag, 1. Januar 2008, 12:26

Ok, ich glaube der Fehler lag am "-depth" Parameter des fbset. Mit Tiefe 16 laeuft der Framebuffer, Tiefe 24 und 32 fuehren zu dem "Fifo Buffer still full" Fehler.
VDR: ASUS AT3ION-T, 2GB, Satix S2 Dual, 1TB 2.5", yavdr 0.4
Server: Intel DH67CF, Pentium G620, 8GB, 2x1000GB 2.5" Raid1, WLAN, Ubuntu 12.04 @22W
TV: Panasonic P50G30

7

Dienstag, 26. Januar 2010, 21:03

Danke das wars --- 16 bit Farbtife gilt auch für viafb und epia boards

Immortal Romance Spielautomat