Posts by berndb

    Zwei ältere Festplatten aus dem Schrank geholt und zwei vdrs kompiliert:


    a) aktuelles archlinux 32bit (Kernel 5.9.x); Treiber in Kernel vorhanden, nur Firmwaredatei noch in /lib/firmware kopiert

    b) altes 32 bit ubuntu (trusty 14.04) mit Kernel 3.13; diese Treiber hier verwendet


    Ergebnis:

    mit a) bekomme ich auf den ITV HD Kanälen nur grünen Bildmatsch im Player angezeigt, STV HD geht, aber offenbar störanfällig

    mit b) Empfang wie auf Windows mit der gleichen Karte, ITV HD geht auch


    Beim Integrieren des Treibers in den Kernel ist vielleicht was schief gelaufen. Da der in Version b) verwendete Treiber die Firmware offenbar direkt integriert hat, liegt es vielleicht auch an der Firmware? We'll will never know.


    Wer um der guten alten Zeiten willen die Karte unter Linux verwenden will, dem empfehle ich, sie nicht mit einem aktuellen Kernel zu verwenden, sondern sich die Mühe zu machen, den Vorgänger-Patch zu verwenden, wie der in Version b). Die Treiber (getestet die Version für Kernel 3.13) auch nochmal in Anhang.

    Namen hat es bei mir keine:

    Code
    1. ./svdrpsend.sh lstd
    2. 220 amd64-archlinux SVDRP VideoDiskRecorder 2.4.4; Tue Sep 22 16:03:32 2020; UTF-8
    3. 250-1 [--] Silicon Labs Si2168
    4. 250-2 [--] Silicon Labs Si2168
    5. 250-3 [DP]
    6. 250 4 [D-]

    Aber ist nicht schwer zu raten, wer wer ist. O.K., vielen Dank, das hatte ich nicht auf dem Schirm!

    Ich blindes Huhn habe, da ich auch softhddevice mitstarte und das xinelibout-Plugin das letzte in der Startliste ist, in die setup.conf


    PrimaryDVB = 4


    eingetragen und xineliboutput funktioniert.


    Wenn ich xineliboutput vor softhddevice in die Startzeile eintrage, funktioniert xineliboutput mit dem Eintrag


    PrimaryDVB = 3


    In beiden Fällen bekomme ich aber nur ein schwarzes Fenster mit softhddevice. Beides kann ich also nicht verwenden?


    Ich dachte, ich hätte beides betrieben und wahlweise das eine oder andere an- und wieder abgeschaltet. Der vdr startet erst einmal headless, also mit softhddevice "detached" und xineliboutput mit "locale=none".

    Ich habe dieses hier: ua0lnj / vdr-plugin-softhddevice auf meinem Ryzen-Rechner laufen.


    Stottert ein wenig in den ersten Sekunden, aber soweit läuft es. Benutze es eigentlich hauptsächlich, wenn ich mal das OSD brauche, also nicht sooo oft. Gerade gestern aber habe ich meinen Abzug von damals mit vdr-2.4.4 gebaut. Die dort beschriebenen Startprobleme sind weg, Startoptionen bei mir

    Code
    1. -P "softhddevice -v vdpau -g 960x540 -D"

    Prozessor + Grafik:

    Code
    1. AMD Ryzen 5 2400G with Radeon Vega Graphics

    Kann keinen Unterschied ausmachen:

    ich stehe mal wieder auf dem Schlauch.

    Ich habe meinen vdr von 2.4.1 auf 2.4.4 upgedated und muss dabei feststellen, dass ich keine Verbindung mehr mit xineliboutput herstellen kann:



    Habe mir hier:

    https://sourceforge.net/projects/xineliboutput/

    heute einen git.Snapshot gezogen.


    Ich kompiliere alles im source-Verzeichnis und starte den vdr auch von dort, also so ganz altmodisch. Die *.conf Dateien habe ich dabei gar nicht angefasst. Live und ein softdevice-plugin inkl. streamdev laufen nach ersten Tests. Hat jemand eine Idee?

    Gut, lineares Fernsehen ist eh ein Modell von gestern und der Tatort, und dann noch einer mit Til Schweiger, ist auch nicht jedermanns Sache.

    Ich bin nun wirklich kein GEZ-Hater oder Feind des ÖRs, aber die Antwort unten lässt mich doch ein wenig verzweifeln.


    Ich machte die ARD via Email darauf aufmerksam, dass in der gestrigen Tatort-Ausstrahlung der Abspann fehlte und statt dessen direkt ein weiteres Programm beworben wird. Zugleich wies ich darauf hin, dass im jüngsten Tatort aus Ludwigshafen im laufenden Programm eine Einblendung für die "Bonusfamilie" geschaltet wurde.

    Die Antwort kam umgehend:


    Code
    1. ...
    2. vielen Dank für Ihre Mail und Ihr Interesse am Programm des Ersten Deutschen Fernsehens.
    3. Leider sehen die wenigsten ZuschauerInnen den Abspann eines Films bis zum Schluss an, weil sie währenddessen umschalten.
    4. Wenn der Sendeplan nicht anders einzuhalten ist, müssen Abspänne daher hin und wieder gekürzt werden.
    5. Wir bitten um Verständnis, dass wir mit dieser Regelung nicht hohen cineastischen Erwartungen gerecht werden können. Vielmehr müssen wir die unterschiedlichen Interessen der ZuschauerInnen berücksichtigen.
    6. Zudem bedauern wir Ihre Kritik an den Werbemaßnahmen für Sendungen im Ersten.
    7. Auf Werbung für unsere Programme können wir leider nicht verzichten. Die ZuschauerInnen schätzen dies als willkommene Orientierung durch die Vielzahl der Angebote. Auch mit den Aufsichtsgremien der ARD besteht Einigkeit, dass Werbemaßnahmen nötig und akzeptiert sind, damit die BeitragszahlerInnen auf teuer produzierte Programme effektiv aufmerksam gemacht werden können.
    8. Wir hoffen, Sie dennoch weiterhin zu den regelmäßigen ZuschauerInnen des Ersten zählen zu dürfen und wünschen Ihnen noch einen schönen Tag.
    9. Mit freundlichen Grüßen
    10. ...


    Sind Werbung im laufenden Programm und fehlende Abspänne wirklich für alle ein zu begrüßender Service? Bin ich wirklich kein "Zuschauer", wie mir die Antwort der ARD unten erklärt? Letzte Hoffnung Mediathek?

    Ich habe einen Pentium 4560, mit dem ich meinen Film-Abspiel-PC im Wohnzimmer betreibe.

    Anfangs war das ätzend, da irgendwas immer nicht so richtig ging, mal wurden 50 fps von den ÖR nicht richtig abgespielt (Bild gefühlt Zeitlupe, Ton o.k.), mal gab es krassses Tearing ...

    Daher habe ich immer wieder meine Nvidia-Karten aus der Schublade geholt (Nvida GT 630 oder Gforce 210). Die Unterstützung für Linux war oder ist wahrscheinlich einfach lückenloser, für einen vdr gilt das sicherlich noch deutlich mehr.


    Was ich aber immer sofort vermisst habe, ist die sehr gute neutrale Farbwiedergabe der intel on board chips. Die Nvidia-Farben scheinen mir kräftiger und mehr in das rötliche abgestimmt zu sein, via nvidia-setup habe ich das nie so wirklich in den Griff gekriegt.


    Aber alles Leiden auf sehr hohem Niveau und Einbildung auch nicht ausgeschlossen, aber so bekamen die Intel-Dinger immer wieder ihre Chance in einer Bastelstunde.


    Inzwischen weiß ich gar nicht mehr, wann ich zuletzt einen Film mit nvidia-Karte geschaut habe. Egal ob DVD oder HD-Aufnahme, ich vermisse da gar nichts mehr und kann da auch keine matschigen Barthaare oder Ähnliches ausmachen. Gehöre aber auch zu denen, die alle Bildver(schlimm)besserer am Fernseher ausstellen (bis auf sehr leichte Bewegungsglättung).


    Das einzige worauf ich achte: Vor einem Update immer ein Backup, damit man nicht in die nächste Treiberfalle läuft und lieber mesa-Versionen mit gerader Nummer (also besser 19.0.x statt 19.1.x usf.) verwenden. Aber wie gesagt, inzwischen vielleicht auch nur noch Schatten der Vergangenheit. Es hat sich alles bei mir sehr gut stabilisiert.


    Da mag es immer noch das tolle Hardware-Deinterlacing bei nvidia geben, aber mit aktuellen Prozessoren gibt es da doch inzwischen reihenweise hochwertige software-basierte Filter als Alternative. Und selbst alles was bei ServusTV & Co 1080i heißt scheint mir unter der Haube doch 25p - zumindest bei Spielfilmen?


    Fazit:

    Für den vdr ist nvidia die sicherere Wahl, da besser unterstützt und alles inkl. Deinterlacing auf der Hardware. Für den Betrieb mit mpv, vlc & Co sehe ich im wahrsten Sinne des Wortes keinen Grund mehr, eine extra Grafikkarte zu betreiben.

    I

    NUR !! Mesa 19.0.x ist mit kernel <= 5.1.x stabil bzgl vdpau/vaapi !!

    Habe mal auf mesa 19.0.6 downgegradet, den Kernel auf 5.2.5, noch kann ich keine Verbesserung feststellen. Versuche nochmal einen anderen Kernel.



    @berndb

    With actual ffmpeg you can try softhddevice from my git, all other with old ffmpeg only.

    This one works without problems so far - using vdpau driver. The only thing I noticed:

    I have no picture (and osd) and no sound, if I start vdr with the plugin in detached mode, after the first run with sofhddevice attached, I can detach or attach the plugin without problems so far.

    Also bei "Sources von github" reden wir alle weiter von:

    https://github.com/louisbraun/softhddevice-openglosd


    Hast Du ffmpeg 2.8.15?



    Ja, und damit es auch "gegen" ffmpeg-2.8.15" compiliert führe ich vor meinem make diesen Befehl aus:

    Code
    1. export PKG_CONFIG_PATH="/mnt/Data_bb/sda9/ProjectX/archlinux/vdr/vdr-2.4.1/ffmpeg-2.8.15-bin/lib/pkgconfig"


    Patches aus Anhang gegen Sources von github anwenden!

    Ich bleibe glücklos. Ich denke, gerade der Patch "softhddevice_ffmpeg3.patch" soll ja ermöglichen, das Plugin mit einem aktuellem ffmpeg zu compilieren. Ich habe beides versucht, im Anhang die Outputs.


    compile-output-ffmpeg-aktuell.txt   compile-output-ffmpeg-2.8.15.txt

    Da kann man AFAIK was bei Xine konfigurieren

    Ja, wenn ich meine alte /home/bernd_b/.xine/keymap verwende, dann habe ich Zugriff via Tastatur auf das vdr-osd.

    Lösche ich die Datei und starte xine neu, erstellt xine eine neue. Mit der komme ich aber gar nicht in das Menü, z.B. wird die Taste m offenbar nicht an den vdr durchgereicht.

    Irgendeinen Zauber habe ich da früher also gemacht, finde aber bisher nicht, was man da genau in xine im keymap-Editor anstellen muss.


    Da xine und vdr-sxfe sowieso nur launig gehen, scheint mir das team live und streamdev-server plus vlc/mpv für Bild im Moment der einzige stabile Weg für einen "wilden" vdr auf irgendeinen aktuelleren Linux-Desktop.

    So, jetzt habe ich die xine-lib nochmal mit Hilfe Arch-User-Repo (AUR) neu übersetzt (statt Version 1.2.9 nun "xine-lib-hg 1.2.9.r14489.bb2de2cd48b8-1")

    Ob das nun Zufall ist oder nicht:

    Jetzt klappt es mit der Tourde France auch über mehrere Minuten stabil ohne Aussetzer, sowohl mit xine-ui als auch vdr-sxfe.

    Allerdings hat die Backspace-Taste in xine-ui keine Funktion, das mach das Browsen durch das Menü ohne "zurück"-Funktion etwas hackelig.


    Also im Moment meine beste Wahl:

    a) streamdev-server mit vlc oder mpv als client (ist ja so unkomfortabel mit einmal gespeicherter Playlist auch nicht)

    b) xineliboutput mit vdr-sxfe und opengl2 als Videotreiber

    Hallo, danke für den Hinweis. Die Installation der ensprechenden AUR-Pakete, die offenbar die Binaries von ubuntu verwenden, führen zu keinen Unterschieden.


    vaapidevice bleibt schwarz und mit xinelibout und opengl(2) setzt nach ca. einer knappen Minute der Ton aus, dann steht kurz danach das Bild und dann von vorne.