Posts by GBruno

    Hi,

    Habe ich gemacht, ändert nichts. Das Problem ist wie gesagt, der Befehl "eval" in der shutown-Routine in /us/lib/vdr. Der Befehl macht aus der/den Eingaben und Ausgaben eines evtl. Befehls einen String, den er dann wieder als Befehl interpretiert. Ist die Ausgabe irgendein Text, kommt die Fehlermeldung xxx . not found.


    der Befehl "eval" ist als schwierig bekannt. Bisher habe ich keine Möglichkeit gefunden, die Pseudo-Befehle zu kaschieren.

    Man kann es mal testen mit

    Code
    eval echo 'Beim_Abschalten:_' & "$(cat /proc/driver/rtc | grep alrm)"


    MfG GBruno

    Hallo,

    ich habe noch ein anderes Problem: ich möchte gern, dass der Alarm beim Herunterfahren des VDR als Message angezeigt wird. Dachte, ich ändere einfach die S90.custom in shutdown-hooks.


    Als Ausgabe bekomme ich einen Fehler "no: command not found".


    Das liegt daran, dass

    Code
    cat /proc/driver/rtc

    im Script /usr/lib/vdr/shutdown.sh mit dem Befehl "eval" ausfgeführt wird, der alles, alles als bash-Befehl interpretiert.

    Code
    root@Tower-ssd:/etc/vdr/shutdown-hooks# echo 'Beim_Abschalten:_' & "$(cat /proc/driver/rtc | grep alrm)"
    [1] 6083
    Beim_Abschalten:_
    alrm_time    : 16:40:00
    alrm_date    : 2022-12-19
    alrm_pending    : no: Befehl nicht gefunden.

    Das führt bei der letzten Ausgabe von

    Code
    cat /proc/driver/rtc | grep alrm

    zu dem o. g. Fehler, exit code 127. Ich habe viel probiert, aber keine Lösung.

    Ist zwar nicht so wichtig, es interessiert mich aber.

    Danke MfG GBruno

    Quote

    Das kann mit cat /proc/driver/rtc getestet werden, was durch manuellen Neustart ins andere System sich ändert.

    Die Alarm-Time bleibt gleich, das Datum wird um einen Tag hoch gesetzt.


    Ich habe ein kleines Script "Timer_setzen" für mein Ubuntu 20.04.5 geschrieben, das zu funktionieren scheint

    Bash
    #!/bin/bash
    echo "############################################################"
    cat /ssdp2/var/cache/vdr/acpiwakeup.time > /sys/class/rtc/rtc0/wakealarm
    
    logger -t vdrtimer $(cat /ssdp2/var/cache/vdr/acpiwakeup.time)
    
    echo "TIMER wird gesetzt!!"
    echo "############################################################"
    sleep 5

    Dazu muss es in /etc/init.d gestellt und ausführbar gemacht werden und nach /etc/rc6.d verlinkt werden mit dem Praefix "K99" siehe



    PS (23.12.22): So einfach ist es nicht. Das Script wird beim Herunterfahren nicht ausgeführt, nur von Hand. Init-Scripte sind kompliziert :(


    https://ccm.net/computing/linu…p-and-shutdown-on-ubuntu/


    /ssdp2 ist der Einhängepunkt der SSD mit dem VDR 2.6.x

    Einige Zeilen sind nur zur Kontrolle der Funktion, können wahrscheinlich weg.

    Hallo,

    es funktioniert weiterhin. ABER: ich habe 2 Mal Ubuntu auf meinem PC, 20.04.5 zum Arbeiten und 22.04 zum Testen, hier auch der VDR. Wenn ich vor dem Aufwachzeitpunkt Ubuntu 20.04.5 starte, geht der Timer verloren und das Biest wacht nicht mehr auf.


    Gibt es eine Routine in Ubuntu 20.04.5, die beim Hoch- oder Runterfahren den Timer zurück setzt?

    @wmautner: Der Tip mit dem Energy-Star/CEC war gut. Zwar gibt es das in meinem BIOS nicht, aber ich habe das Item gefunden:

    Code
    Load USB-Devices in S5 State (oder so ähnlich): enabled.

    D. h., die USB-Anschlüsse stehen auch nach VDR-Abschaltung unter Strom. Meine optische Maus leuchtet dann nicht. Ich habe das o. g. auf "Disabled" gesetzt, und jetzt funktioniert es :), zumindest ein Mal. Muss noch weiter testen.

    Aber vielen Dank für den Hint!

    @seahawk1986:


    Quote

    Kannst du da mal zeigen, wie der Wechsel bzw. der Standby im Zusammenspiel mit den anderen Units im Syslog aussieht - was macht der VDR dabei?

    Wie soll ich das machen? Soll ich das ganze Syslog hochladen? Ich weiß es nicht. Der VDR startet richtig (automatisch), findet narürlich keine Kanäle.


    @SurfaceCleanerZ:


    Quote


    Du redest von echtem Ausschalten? Oder von Standby, S2R, S2D oder so?

    Ich schalte über den Power-off Befehl des VDR aus. Danach ist der PC völlig aus. Wie man das nennt, weiß ich jetzt nicht.


    Darüber hinaus habe ich auch, wie geschrieben, das Standby von Ubuntu versucht, und auch einen Neustart aus dem Shutdown-Menü. Gleiches Ergebnis. Nur wenn ich den PC ganz ausschalte (Power-off) und wieder hochfahre, geht es.


    Ich benutze weder systemd noch udev. Das Linux macht das ganz allein, ohne mich zu fragen ;)

    Aber die USB-Anschlüsse auf Stromversorgung untersuchen, das werde ich machen. Ist mir allerdings noch nie aufgefallen.

    Hallo,

    ich habe folgendes Problem: Wenn ich im VDR einen Aufnahme-Timer anlege und über VDR herunterfahre, wacht der PC wohl richtig auf, aber der DVB-T2/C USB-Stick (DVBSky T330) wird nach dem Aufwachen nicht mehr erkannt. Auch nicht, wenn ich im "Ausschalten-Menü" Neustart anklicke. Ich muss den Stick rausziehen und wieder einstecken, dann gehts. D. h. für zeitgesteuerte Aufnahmen ist das unbrauchbar.

    Weiß jemand, woran das liegen könnte? Ich habe die Regeln in udev im Verdacht. Die Treiber und die Firmware (?) werden richtig geladen.

    Im Anhang die Ausgabe von Syslog nach Einstecken des Sticks.

    Danke für Eure Hilfe.

    MfG GBruno

    @SurfaceCleanerZ: ACPI Wakeup (mit nvram) hatte ich früher probiert, funktionierte nicht. Meine Methode heißt ausührlich

    Code
    acpi-rtcwake

    Verwendet also auch acpi.

    @Dr. Seltsam: der Befehl hwclock mit all seinen Optionen hat bei mir nicht richtig funktioniert, auch timedatectl. Ich bin heillos mit den Zeiten durcheinander gekommen.

    Was macht "sh -c "echo 0 > $DEV""? D. h. "sh -c"?

    PS: ich habe es inzwischen gefunden (Google).

    Sonst sieht das Script gut aus, allerdings ist mein VDR-PC nicht ständig am Internet. Meines ist so lang, weil ich viele Zeolen zur Fehlersuche eingebaut habe.


    Inzwischen habe ich alle Zeiten, auch im BIOS, konsequent auf "local" gesetzt, und den Befehl

    Code
    rtcwake -m no -l -t ....

    angepasst. Die Abfrage auf UTC habe ich entfernt, und jetzt geht es (seit gestern!!) :)

    Allerdings muss ich beim Wechsel von Wnter-/Sommerzeit die Zeit im BIOS ändern. Mit UTC hat die automatische Umstellung nie funktioniert, war wohl im Ggegnteil eine der Ursachen für das Problem. Aber vielen Dank für Eure Hilfe.

    Grüße

    GBruno

    Danke für Eure Antworten.


    SurfaceCleanerZ: die Knopfzelle ist noch gut. Das Wakeup arbeitet einwandfrei mit dem Test:

    Code
    rtcwake -m no -t $(date -d "now + 30 min" +%s)

    Der PC wacht nach einer halben Stunde auf. Es gibt keinen Grund für ein neues Mainboard, außerdem kann ich z. Zt. nicht umbauen (Rücken).


    @cocobrother: die Einstellung gibt es in meinem BIOS nicht. APM - RTC Wakeup muss bei mir auf disabled stehen.


    Ich vermute, dass sich im System Ubuntu etwas geändert hat, damals 16.4, jetzt 20.4, sodass einige Befehle nicht mehr richtig funktionieren. Z. B. ist die

    Code
    /etc/default/rcS

    weg gefallen. Die Fehlersuche ist sehr mühsam.

    Hallo,

    nachdem mein Wohnzimmer-Rechner jahrelang richtig aufgewacht ist und aufgenommen hat, geht es nicht mehr. Mein Netzteil war kaputt, und ich musste es austauschen. Dabei sind wohl auch die BIOS-Einstellungen im CMOS verloren gegangen. Ich habe es soweit hinbekommen, dass er mit den Test-Scripts aufwacht. Wenn ich aber einen Timer setze, zeigt er im LOG-File alles korrekt an, startet aber nicht. Wenn ich dann von Hand starte und mit

    Code
    cat /proc/driver/rtc 

    die Alarmzeit auslese, ist das Datum um einen Tag hoch gesetzt, z. B. statt 28/11/2022 => 29/11/2022. Die Uhrzeit bleibt korrekt. Was passiert da?

    Das Script ist das in acpi-wakeup ändern von 2016.

    Danke für Eure Hilfe.

    MfG GBruno

    Hallo,


    ich habe noch den VDR 2.4.1 von Ubuntu 20.04. Bei mir klappt die Sortierung der Aufnahme (sind echt viele) überhaupt nicht, auch nicht mit der Taste "0". Muss ich da etwas einstellen oder mache ich etwas falsch?

    Danke für die Hilfe bei der wohl banalen Frage.

    MfG GBruno

    Mein Skript findest Du oben unter dem Link

    acpi-wakeup ändern

    Ist ein bisschen anders.


    17.05.22 Es gab eine längere Unterbrechung, sorry.


    Obwohl mir Dein Script gut gefällt, bleibe ich erst einmal bei meiner Version, die jetzt gut funktioniert. Vielleicht brauche ich sie später einmal.

    Optimal wäre es, wenn man das BIOS direkt abfragen könnte, ob UTC oder lokale Zeit. Ich b in auch nicht so gut in der Bash-Programmierung. Deshalb die vielen Ausgeben in die LOG-Files, wie gesagt, zur Fehlersuche. Ist aber ganz praktisch, wenn man nicht mehr weiß, welche Filme man zuletzt aufgenommen hat.


    Übrigens darf man die Systemzeit nicht mit der Zeit im BIOS verwechseln, so wie ich es gemacht habe. Die Zeitzone muss dann doch auf "Berlin ..." stehen.

    Das sieht gut aus. Allerdings verstehe ich die Zeilen 8 und 9 nicht. Könntest Du das erklären? Und wo muss das Skript stehen? /etc/vdr/shutdown-hooks? Und softhddevice habe ich nicht, auch nicht softhdcuvid.


    Mein Skript ist so lang, weil ich es 2016 von Tobias Grimm übernommen und dann abgeändert habe, außerdem viele Ausgaben zur Fehlersuche (es gab reichlich).

    Hallo,


    danke für die Tipps. Diese Energiesparfunktionen gibt es bei meinem ASUS-Mainboard F2A85-V Pro nicht, nur "EPU Power Saving" (?). Das Board ist aber schon älter, BIOS-Datum 2012.

    Aber ich habe den Fehler gefunden: mein Script acpi-wakeup greift auf die Datei /etc/rcS zu, um abzufragen, ob UTC oder lokale Zeit eingestellt ist. Diese Datei gibt es bei den neueren Versionen von Ubuntu nicht mehr, es wird alles über systemctl geregelt, leider:(. das ist völlig undurchsichtig. Ich habe als root eine /etc/rcS von Hand erstellt mit dem Inhalt "UTC=yes", und jetzt geht es :). Vielleicht hilft das jemandem weiter.


    MfG G. Bruno

    Danke für die Info.

    Noch eine andere Frage: ich versuche, das Plugin für den VDR-2.4.1 zu kompilieren (weil der bei mir schon läuft). Ich bekomme einen Fehler, der sich anscheinend nur auf eine Zeile in einer einzigen Datei bezieht, nämlich ttxtsubsdisplayer.c in verschiedenen Zeilen. Hier ein Auszug der Fehlermeldungen:

    Kennst Du Dich genug in C++ aus, um das zu korrigieren? Wäre toll :]

    Hallo, inzwischen konnte ich das ttxtsubs-Plugin bauen. Das Problem vorher war, dass "quilt import" nicht gepatcht hat, wie ich dachte, nur die Patch-Dateien geholt. Nachdem ich dann mit "patch -p1 -i ..." gepatched habe, ging es. Dann aber wieder neue Probleme, das kommt davon, wenn man mit mehreren Versionen arbeitet. Z. B. wurde auf einmal der g++-Compiler nicht mehr gefunden. Wenn man "make" die Anweisung "CXX=g++" mitgibt, geht es dann.

    Trotzdem, es läuft immer noch nicht, Probleme mit dem Grafik-Treiber für xineliboutput. Ich mache erst einmal Pause.