Posts by sirtobi

    Moin!


    Ich habe ein altes Nokia 6230 aus dem Muell gefischt. Auf der Homepage der serdisplib ist es leider nicht aufgeführt. Hat jemand schon mal das Display von diesem Handy am VDR betreiben können?


    Danke!


    wys


    SirTobi

    Hey! Trollparty!!!!!


    HolgerR : Du hast den richtigen Hinweis vergessen: :google (Bildersuche!) Davon abgesehen würde ich mit dem Grund ehr zu BSD tendieren (http://tom.digitalelite.com/img/bsd.jpg).


    Aber um mal die Diskussion ein wenig weiter zu zerfasern... Wieso WIndows und nicht Solaris? Ich hätte da gerne genauso viele Gründe, bin mit meinem Solaris-Desktop nämlich *sehr* zufrieden!!!


    ... mehr verkneife ich mir. Alle weiteren Antworten möge man aus den endlosen nervigen Beiträgen in diversen anderen Foren entnehmen. Jeder soll benutzen was ihm gefällt und gut! Ganz egal ob Linux, MacOS, Irix, Solaris, Windows NT 3.5 whatever....


    Just my 2 cents...

    Moin!


    Ich versuche nun schon seit geraumer Zeit nextvepg und xmltv2vdr in Gang zu bekommen.
    Mein Problem ist jedes Mal, dass der xmltv2vdr zwar so tut, als wuerde er die Daten zum VDR schieben, da aber "irgendwie" (ja, schlechte Fehlerbeschreibung) nichts ankommt.


    Nun habe ich mit Freunden gesehen, dass eine neue Version von xmltv2vdr raus ist, habe aber die selben Sorgen.


    Ich habe nun mal die Daten mit tvmovie2vdr gefuettert, die epg.data angesehen und bin zu dem Schluss gekommen, da stimmt was nicht.


    Um die Zeile 190 rum in der xmltv2vdr.pl sieht es in etwa so aus:

    Code
    1. $chanName{$myChannel} = $channel_name;
    2. # Save the Channel Entry
    3. if ($nid>0)
    4. {
    5. $chanId{$myChannel} = "C $source-$nid-$tid-$sid $channel_name\r\n";
    6. }
    7. else
    8. {
    9. $chanId{$myChannel} = "C $source-$nid-$epgfreq-$sid $channel_name\r\n";
    10. }


    Das passt auch zu dem was er unten raushaut, aber nicht zu dem, was in der epg.data steht.
    Ich habe nun brutal die Ausgabe an die epg.data angepasst und einfach an den Code-Teil oben folgendes angehaengt (und damit das if unbrauchbar gemacht, ist aber vorerst nur ein Versuch!).

    Code
    1. $chanId{$myChannel} = "C $source-$nid-".substr($epgfreq,0,3)."-$sid".substr($channel_name,0,index($channel_name,";"))."\r\n";


    (P.S.: Bein kein Perl-Held!)
    Nun schaut die Ausgabe konform aus und die Daten landen scheinbar(/hoffentlich) richtig im VDR.


    Das einzige was mich daran stört.... Kann mir irgendjemand sagen, was ich da gerade gemacht habe? Oder ob ich nur die Symptome eines ganz anderen blöden Fehlers wieder hingebogen habe, der mir nur noch nicht aufgefallen ist?


    Es kann ja eigentlich nicht sein, dass es nur bei mir wieder mal nicht so klappt, wie es ueberall steht.


    Hilfe und Danke im voraus!


    wys


    SirTobi


    Achja, P.S.: Meine channels.conf fuer xmltv2vdr sieht wie folgt aus (die normale channels.conf entsprechend), ich verwende das pvrinput-Plugin von drseltsam und wirbel.

    Hmmm. Klingt ja alles ehr ernüchternd.


    Aber auf jeden Fall ein ganz grosses Lob an Dich und Wirbel. Ich dachte zwischendurch schon, der VDR wäre für Analog endgültig gestorben, weil mir langsam aktuelle Plugins ausgingen.


    so long, happy hacking!


    wys


    SirTobi

    Retter! Danke ;-)


    Die Kombinationen aus "0" und "1" hatten mich wohl verwirrt und im Zweifelsfall nimmt man das neueste, war ja auch der neuste ivtv.


    Aber klär mich doch mal bitte auf... Ist die 1.0.0 dann die, die gerade in den Kernel integriert werden soll?


    Gruss,


    SirTobi

    Moin!


    Ich bin mal wieder am wirbeln und probiere einen neuen VDR (mit Myth-TV werde ich nicht wirklich warm) aufzusetzen.


    Als Hardware kommt dabei eine PVR350 zum Zuge, weil die ja *eigentlich* stabiler als die DXR3 laufen soll. Ausserdem bleiben dann mehr Slots fuer andere Karten frei.


    Zur Software:


    VDR 1.4.7
    Kernel 2.6.21.1
    IVTV 0.10.2


    Dazu dann das aktuelle pvrinput- und pvr350-Plugin von Dr. Seltsam.


    IVTV als solches laeuft mit diesem Treiber und Kernel endlich mal bestens und recht stabil.


    Leider konnte ich aber das pvr350 Plugin nicht zum rennen bewegen. In der Device.c ist es an folgender Stelle ausgestiegen (da wo ich auskommentiert habe):



    Nach dem ich das Ergebnis vom ioctl nun auskommentiert habe (s.o. Prinzip Hoffnung), startet er zwar, aber ich sehe nur das Menue, kein Fernsehbild. Ich habe daraufhin noch einmal mit dem wirbelscan die Channels.conf neu erstellt, aber no way.
    Sowohl der /dev/video16, als auch der /dev/fb sind aber vorhanden und funktionieren. Ansonsten haette Myth-TV auch aufgegeben...


    So Kleinigkeiten wie einen ioctl-Befehl haette man also vielleicht doch nicht einfach ignorieren duerfen ;-)


    Hatte irgendwer schon eine aehnliche Konfiguration am rennen? Oder sollte ich doch besser zur DXR3 zurueck?


    Bin fuer jede Hilfe dankbar...


    Viele Gruesse & wys,


    SirTobi

    Den ueber "Nextview"? Ja, den hatte ich gelesen und zum Teil verwurstet. Ich bin auch soweit, dass ich per Skript die EPG-Daten bekomme und in ein XML-File (alte Form) bringen kann. Das nimmt der xmltv2vdr auch ohne murren entgegen und schiebt die Daten zum VDR, da kommen Sie jedoch nicht an. Ich vermute, dass er aus irgendeinem Grund nicht die richtige Form des SVDRP-Befehls hinbekommt. Bisher fehlte mir nur leider die Zeit da nochmal näher reinzuschauen.

    Ja, so etwas in der Art probiere ich gerade. Einfach beim Shutdown nextvepg die Daten holen lassen, per xml2vdr wandeln und uebertragen. Aber beim wandeln und uebertragen gehts momentan noch schief. Muss ich nochmal mit etwas mehr Zeit und Musse ran.


    MythTV hatte ich auch probiert, kam aber nicht so richtig mit zu Potte und bin deshalb doch wieder beim vdr gelandet.

    Quote


    Wenn du n Bild hast kannst du auch aufnehmen, das hat dann schon nichts mehr mit dem Plugin zu tun..


    Dachte ich ja auch. Bin deshalb auch etwas überfragt. Habs gerade mal per streamdev probiert, der tut auch nicht.
    Irgendwie gelangt das Signal also zur DXR3-Karte, Streamdev und der Record-Thread vom VDR haben aber wohl keinen Zugriff ?!??!


    BobW : Meine channels.conf sieht genauso aus, leider.
    Welchen Kernel und welche ivtv-Version verwendest Du?


    Gruss,


    SirTobi

    Moin!


    Ich wollte heute mal ein anfangen ein paar alte Videos zu digitalisieren, dachte mir mit dem VDR und der PVR500 sollte das ja kein Thema sein.


    Ich benutze momentan PVRInput und habe die Channels.conf per w_pvrscan erstellt. Ueber den Composite-Eingang konnte ich dann auch das Bild vom Videoten sehen. Wenn ich es jedoch aufnehme, dann bleibt es schwarz und still, als wenn er den Video-Stream nicht erhalten hätte.


    Komisch. Ich hatte gedacht er würde die Eingänge aus SIcht des VDR wie einen normalen Stream vom Tuner behandeln.


    Meine Channels.conf sieht in etwa so aus:

    Code
    1. Composite 0:1:C12:C:0:301:300:305:A0:9001:0:0:0
    2. Composite 1:1:C23:C:0:301:300:305:A0:9002:0:0:0
    3. S-Video 0:1:C34:C:0:301:300:305:A0:9003:0:0:0
    4. S-Video 1:1:C45:C:0:301:300:305:A0:9004:0:0:0


    pvrinput und vdr sind in der aktuellsten Version eingespielt, ivtv in version 0.8.0.


    Spielereien mit den Cxx-Parametern brachten nichts und mit einigen geposteten channels.conf hier aus dem Forum hatte ich noch weniger Erfolg (damit konnte ich nicht mal ein Bild sehen)


    Hatte irgendwer schon mal ähnliche Sorgen?


    Gruss,


    SirTobi


    Nachtrag: Eben mal analogtv probiert. Damit kann ich aufnehmen, hab aber keinen Ton...

    Moin!


    Prinzipiell kann man jedes System auch im Laufenden Zustand backuppen. Dabei ist es egal, ob man tar, cpio, dumpe2fs oder sonstwas nimmt.
    Sobald das System aber auf Dateien zugreift kann es zu korrumpierten Dateien kommen, isnbesondere passiert dieses gerne bei Log-Files (im privaten Bereich egal), in /var/spool (Mails, PrintJobs, ... auch im privaten oft egal) und bei DB. Das wiederum ist boese.


    Wenn man aber zuerst die schlimmsten Dienste (DB, Apache, Mail,...) stoppt, dann das System sichert und hinterher wieder alles anschmeisst sollte es wenig Probleme geben.


    Achja... Falls in /tmp/ oder /var/tmp beim Sichern Daten gelagert werden sollte man die Verzeichnisse gegebenenfalls auch auslassen ;-)


    Gruss,


    SirTobi

    Moin!


    Ich benutze faulerweise immer partimage von einer zweiten Partition oder von einer Boot-CD (z.B. sysresccd) aus. Die Daten schiebe ich dann entweder direkt auf mein Datengrab (Samba oder eigener partimage-Server), oder brenne sie weg.
    Restaurieren geht dann mit Rescue-Boot, zurueckspielen und eventuell noch einmal grub oder lilo installieren.
    Man kann sogar direkt eine Boot-CD inclusive Image der Platte brennen, hab ich aber bislang noch nicht gemacht.


    wys


    SirTobi

    Moin!


    Ich bin nun umgezogen und haben einen DVB-T Empfang gegen 0, Kabel ist aber eh inclusive und der VDR lief viel zu rund, also mal wieder basteln.


    Habe nun eine PVR500 (zwei Tuner sind ja ganz nett) und die alte DXR3-Karte zum gucken. Mit Kernel 2.6.18 und einem CVS-ivtv (plus diverser Kernel-Parameter...) tut die Karte nun auch zufriedenstellend. Manchmal dauert es etwas bis sie richtig tuned und einige Sender muss ich wohl noch nachregeln, aber ok.


    Bin nun vom pvrinput testweise zum analogtv-Plugin gewechselt, weil:
    a) Finetuning ganz nett ist
    b) nxtview ist rechtschaffend genial!


    Das Problem ist nun aber, dass staendig der VDR (aktuelle Version) in der Kanalliste rumpfuscht und aus dem "B6C0D0" wieder ein "C0" friemelt. Damit gibts dann beim naechsten Start ein "Transfer-Mode"-Fehler.
    Kann man das ausser per umkopieren oder ACLs auf der Channels.conf abstellen? War dafuer vielleicht der erwaehnte Patch aus der Readme? (Oder wozu sonst, hab ihn bis jetzt nicht eingebaut oder gebraucht).


    Und ist es mittlerweile irgendwie moeglich mit Analog-TV beide Tuner zu verwenden? Wollte ganz schlau sein und habe die channels-conf gedoppelt (channels einmal mit B6C0D0 und einmal mit B6C1D0), sehe aber trotzdem jeden Kanal nur einmal. Schade, wäre schön einfach gewesen... ;-)


    Wäre toll, wenn schon mal jemand meine Probleme gelöst hätte...


    Danke,


    SirTobi

    Quote

    Per Setup kann es sogar komplett aus dem Hauptmenü verschwinden und ist somit unsichtbar.


    Das ist dann wie bei den kleinen Kindern. Was sie nicht sehen ist auch nicht da. Trotzdem habe ich aber im Hintergrund den (ja, geringen, klar) Speicherverbrauch extra verschwendet, eine Fehlerquelle mehr und ein Plugin mehr, bei dem das Update zur nächsten VDR-Version scheitert.


    Kann sein, dass nicht jeder der gleichen Meinung ist, aber ich finde meine Argumentation nach wie vor recht logisch...


    Code
    1. Naja, wieviele Linux-Dienste und -Programme laufen wohl auf jedem System, obwohl sie niemand benutzt.


    Bei mir? Geht gegen Null. Wenn ich einen Dienst nicht benötige stelle ich ihn ab. Und zwar ganz und gar, sie werden nicht nur über ein gepatchtes ps versteckt!


    Code
    1. Das ganze ist halt nach Euren und meinen Wünschen gewachsen. Und von Klaus werde ich wohl auch nicht verlangen, z.B. die CAM-Unterstützung rauszuwerfen, nur weil ich sie nicht


    Es geht ja auch ger nicht darum, das das EPGSearch-Plugin zuviele Features hat. Es geht darum, das meine Wenigkeit und ich denke auch noch ein paar andere Leute bisher das gesamte Plugin nicht benötigt haben, weil die Features des VDRAdmin genügten. Und da liegt es doch nahe, dass wir nicht sehr glücklich damit sind nun mehr oder minder dazu gezwungen zu werden (ja, sehr harter Ausdruck, mir fällt gerade kein schönerer ein) ein Plugin zu benutzen, welches in unseren Augen keinerlei Vorteil zum bisherigen Status quo bringt. Dafür bedeutet es aber für uns mehr Aufwand bei der Wartung und Pflege unseres VDRs, Einarbeitung in ein für uns viel zu komplexes Etwas und eine neue Fehlerquelle.


    Es geht hier wirklich nicht darum EPGSearch schlecht zu machen, denn das es ist für viele Benutzer auch mit Sicherheit nicht. Es geht denke ich viel mehr darum die Wahl zu haben auch ein schlankeres und bereits lange bewährtes System weiterhin benutzen zu können. Und eine schon existierende Funktion die zumal ein grosserer Benutzerkreis als Hauptanwendung sieht zu entfernen obwohl sie bis dato noch funktioniert, das schmerzt.


    Das Amir keine Zeit mehr in diese Funktion investieren möchte wenn er sie selbst nicht benutzt ist seine Entscheidung und - wenn auch traurig - in jedem Fall nachzuvollziehen.
    Aber vielleicht findet sich ja wer, der diesen Bereich weiterpflegen - nicht entwickeln, nur pflegen - würde. Dann könnte man ihn zumindest erhalten.