Posts by kovold

    [Erledigt]


    Ist zwar schon ein bisschen her aber kannst Du oder jemand anders in ein paar Zeilen genau beschreiben wie Du das hinbekommen hast. Habe genau das selbe problem mit der selben Hardware und habe schon zu viel Zeit drauf verwendet ;-(. Module compilieren und in Grub einbauen?


    -.> Kovold

    The best thing would be to point a dish at 28.2 degrees, which might not be feasible depending on where you live in Germany. The best kids channel is BBC's Ceebies. I moved to Ireland 10 years ago myself and it is save to say that your children at that age will have no problem picking up English "off the street". If you believe it or not in time it will be actually more difficult for them to speak a proper German. If you need any other advise let me know.


    Rgrds,


    -.> Kovold

    rookie1


    MAKEDEV ist ein Shell script. Einfach ins /dev Verzeichniss wechseln und ./MAKEDEV eingeben.


    Pruefe doch auch einmal bitte ob der link hinter der ERROR: dvd-plugin cannot open dvdnav device Fehlermeldung auf den richtigen mount point zeigt oder ob das Verzeichnis existiert.


    -.> Kovold

    Ist zwar schon eine Weile her seitdem ich xmltv2vdr bei mir fuer die BBC Kanaele implementiert habe aber soweit ich mich recht erinnere musst Du bei Deiner Channels.conf bei den Kanaelen fuer die Du das EPG importieren willst auch noch ein extra Feld hinzufuegen (sollte in der readme erklaert sein). Wenn das nicht geschehen ist lauft der import ins Leere.


    -.> Kovold

    beagle


    Kommisch das sich das BIOS nicht flashen lasst. Es gibt natuerlich eine Unmenge an Karten die den Radeon 7000 chip verwenden und sicherlich hat der eine oder andere Hersteller ja sein eigenes Suppchen gekocht. Es tut zwar weh aber ich denke Du kommst da nicht weiter. Ich wuerde mir 'ne andere Karte besorgen, da keine hier soviel Problem hatte. Davor kann es sicher nicht schaden, wie hotzenplotz schon erwaehnt hat, das ganze mit dem vesafb zu versuchen (wuerde ich sowieso empfehlen).


    -.> Kovold

    Den habe ich glaube auch von det ctvdr 3 uebernommen.



    vdr:~# cat /etc/init.d/lirc
    #! /bin/sh
    #
    #


    load_modules ()
    {
    setserial /dev/ttyS1 uart none
    local MODULES_MISSING=false


    for mod in $*
    do
    modprobe -k $mod 2> /dev/null || MODULES_MISSING=true
    done


    if $MODULES_MISSING; then
    echo "#####################################################"
    echo "## I couldn't load the required kernel modules ##"
    echo "## You should install lirc-modules-source to build ##"
    echo "## kernel support for your hardware. ##"
    echo "#####################################################"
    echo "## If this message is not appropriate you may set ##"
    echo "## LOAD_MODULES=false in /etc/lirc/hardware.conf ##"
    echo "#####################################################"
    START_LIRCMD=false
    START_LIRCD=false
    fi
    }


    build_args ()
    {
    local ARGS="$*"
    if [ -n "$DEVICE" ] && [ "$DEVICE" != "none" ]; then
    if [ -d /dev/lirc ] && [ "$DEVICE" = "/dev/lirc" ];then
    #new device names
    DEVICE="/dev/lirc/0"
    fi
    ARGS="--device=$DEVICE $ARGS"
    fi
    if [ -n "$DRIVER" ] && [ "$DRIVER" != "none" ]; then
    ARGS="--driver=$DRIVER $ARGS"
    fi
    echo $ARGS
    }


    test -f /usr/local/sbin/lircd || exit 0
    test -f /usr/local/sbin/lircmd || exit 0
    #test -f /etc/lirc/lircd.conf || exit 0
    #test -f /etc/lirc/lircmd.conf || exit 0


    START_LIRCMD=true
    START_LIRCD=true


    if [ ! -f /etc/lirc/lircd.conf ] \
    || grep -q "^#UNCONFIGURED" /etc/lirc/lircd.conf;then
    if [ "$1" = "start" ]; then
    echo "############################################"
    echo "## LIRC IS NOT CONFIGURED ##"
    echo "## ##"
    echo "## read /usr/share/doc/lirc/README.Debian ##"
    echo "############################################"
    fi
    START_LIRCD=false
    START_LIRCMD=false
    fi
    if [ ! -f /etc/lirc/lircmd.conf ] \
    || grep -q "^#UNCONFIGURED" /etc/lirc/lircmd.conf;then
    START_LIRCMD=false
    fi


    if [ -f /etc/lirc/hardware.conf ];then
    . /etc/lirc/hardware.conf
    fi



    case "$1" in
    start)
    if [ "$LOAD_MODULES" = "true" ] && [ "$START_LIRCD" = "true" ]; then
    load_modules $MODULES
    fi
    echo -n "Starting lirc daemon:"
    if $START_LIRCD; then
    echo -n " lircd"
    LIRCD_ARGS=`build_args $LIRCD_ARGS`
    start-stop-daemon --start --quiet --exec /usr/local/sbin/lircd -- $LIRCD_ARGS \
    < /dev/null
    fi
    if $START_LIRCMD; then
    echo -n " lircmd"
    start-stop-daemon --start --quiet --exec /usr/local/sbin/lircmd \
    < /dev/null
    fi
    echo "."
    ;;
    stop)
    echo -n "Stopping lirc daemon:"
    echo -n " lircmd"
    start-stop-daemon --stop --quiet --exec /usr/local/sbin/lircmd
    echo -n " lircd"
    start-stop-daemon --stop --quiet --exec /usr/local/sbin/lircd
    echo "."
    ;;
    reload|force-reload)
    if $START_LIRCD; then
    start-stop-daemon --stop --quiet --signal 1 --exec /usr/local/sbin/lircd
    fi
    if $START_LIRCMD; then
    start-stop-daemon --stop --quiet --signal 1 --exec /usr/local/sbin/lircmd
    fi
    ;;
    restart)
    $0 stop
    $0 start
    ;;
    *)
    echo "Usage: /etc/init.d/lircd {start|stop|reload|restart|force-reload}"
    exit 1
    esac


    exit 0



    -.> Kovold

    Ich habe die selbe Konfiguration. Ich benutzte wie hotzenplotz5 den vesafb (beim Kernel bauen aktiviert). Mit dem radeofb habe ich auch eine Weile rumgespielt, die Sache aber nie zum laufen bekommen. Das einzigste woran ich mich noch erinnern kann ist das ich den TV-OUT der Radeon von NTSC auf PAL im Bios der Karte umstellen muesste. Hangt natuerlich davon ab wo Du Dein PSONE Display her hast und ob die Sache im Radeon Bios nicht schon auf PAL steht.


    -.> Kovold

    Ich bekomme nur die folgenden Fehlermeldung: '0,700' ist kein gueltiger Gleitkommawert. Wird wohl an meinem Englischen XP liegen oder?


    Gruss


    -.> Kovold

    Images

    • videoclient.jpg

    Habe ungefaehr die gleiche Konfiguration. Da ich auch keine klare Aussage gefunden habe benutze ich den Poweroff-Kernel, was natuerlich zur Folge hat das ein Reboot benoetigt wird. Damit funktioniert es aber immer. Damit sind Aenderungen in der nvram-wakeup.conf und Deiner Lilo (Poweroff-Kernel einbinden) noetig.



    vdr:~# cat /etc/nvram-wakeup.conf
    ################################################
    ## Mainboard autodetection information:
    ##
    ## - Mainboard vendor: "ASUSTeK Computer INC."
    ## - Mainboard type: "P4P800-VM"
    ## - Mainboard revision: "Rev 1.xx"
    ## - BIOS vendor: "American Megatrends Inc."
    ## - BIOS version: "1012.002"
    ## - BIOS release: "03/22/2004"


    addr_stat = 0x98
    shift_stat = 4
    addr_day = 0x99
    addr_hour = 0x9A
    addr_min = 0x9B
    addr_sec = 0x9C


    addr_chk_h = 0x30
    addr_chk_l = 0x31


    upper_method = INTEL
    need_reboot = ON_ANY_CHANGE


    ----------------------------
    Lilo.conf
    # (don't remove) ----------------------# kernel-poweroff
    image = /boot/bzImage.2.4.24.poweroff # kernel-poweroff
    label = PowerOff # kernel-poweroff
    append = "acpi=off" # kernel-poweroff
    # append = "apm=off" # kernel-poweroff
    # -------------------------------------# kernel-poweroff


    Wenn ich mich recht erinnere wird der Eintrag in der Lilo.conf automatisch vorgenommen, wenn der Kernel ueber apt installiert wird.


    Gruss


    -.> Kovold