Posts by IcyA1

    Es sollte natürlich irgendwie ein TV angeschlossen sein, damit man was sehen kann. Nach kompletter (und richtiger Installation) schaltet der VDR beim Hochlaufen aufs TV-Programm um, dann sieht man auf dem angeschlossenen Monitor am VGA nix mehr.

    Ist das wirklich so? Ich meine, beim Digitainer - jedenfalls mit Budget-Karte - versorgt das Softdevice den VGA-Anschluss parallel zum Scart-Ausgang mit der Anzeige (hab's aber schon lange nicht mehr ausprobiert). Zum Installieren und Testen empfiehlt sich aber grundsätzlich ein Monitor am VGA (ohne angeschlossenen Fernseher).


    Ich werde jetzt eben mal Debian mit Freevo versuchen und danach hol ich mir mal die Logfiles von easyvdr!

    ritchy24, was läuft jetzt eigentlich auf Deinem Digitainer? Es wäre schön, wenn Du den Thread mit einem Feedback abschließen könntest und mitteilen, wie Du Dein Problem gelöst hast. Oberlooser und Antiriad haben Deine Fragen ja beantwortet. Dann könnte der nächste User von Deinen Erfahrungen lernen. Das ist der Sinn von einem solchen Forum. Andernfalls hieße es "Hotline" und wäre kostenpflichtig ;D

    Wenn nicht nur in Ba-Wü morgen gewählt würde, sondern auch hier im Forum, würde ich die SHAL wählen (SHAL = Slim-Header-Avatar-links-Partei). Vielleicht ist es ja wie beim Sams, wir wünschen uns alle was, und jedes Mal hat der Header einen Punkt weniger ...


    Ich hatte übrigens ein Problem mich einzuloggen. Drei Mal bekam ich die Meldung, ich sei eingeloggt, ohne dass ich im folgenden Screen "drin" gewesen wäre. Beim vierten Mal hat es dann geklappt.


    Aber vor allem: Herzlichen Dank Genka. Du hast Dir mit der Umstellung des Portals ein - auf gut schwäbisch - saumäßiges G'schäft gemacht (für Leute jenseits der Mainlinie: eine ganz außerordentliche Mühe).


    Gruß aus Stuttgart
    Albrecht

    Hallo Burn-Kundige bzw. -Entwickler,


    das Plugin ist eine der besten Erfindungen seit dem DVD-Player und dem vdr. Danke!


    Ich gehe mal davon aus, dass beim Erstellen eines Isos/Abbilds die Videodaten etliche Male umkopiert werden: Demuxen, Schneiden, Muxen, Vobs erstellen, ins Iso packen. Folglich solllte das Ganze deutlich schneller ablaufen, wenn man eine ohnehin eingebaute zweite Festplatte einbezieht und die Daten sequentiell gelesen und geschrieben werden können, ohne dass die Schreib-/Leseköpfe Kilometer zurücklegen müssen. Nun versteht sich das Burn-Plugin laut Doku dankenswerter Weise auf folgende Parameter:


    Quote

    DDVDDEV=/dev/dvd Angabe des DVD-Brenners (= Parameter -D --dvd=<DEV>)
    ISODIR=/video Angabe DIR zum Speichern der ISO-Images (= Parameter -i <DIR> --iso=<DIR>)
    datadir=/tmp Angabe DIR für die temporären Dateien beim Demuxen/Muxen/ISO-Erstellen (= Parameter -d <DIR> --datadir <DIR> )
    tempdir=/tmp Angabe DIR für die temporären Dateinen beim Demuxen/Muxen/ISO-Erstellen (= Parameter -t <DIR> --tempdir <DIR> )


    Welche Einstellungen wären sinnvoll, um das Burn-Plugin möglichst effektiv nutzen zu können? Mir ist der Unterschied zwischen "datadir" und "tempdir" nicht klar. Sollten Quellverzeichnis (/video0, also vdr-Daten) und datadir auf einer Platte liegen und tempdir und ISODIR auf der zweiten, damit die Platten immer schön abwechselnd drankommen, oder wie muss ich die Pärchen bilden?
    Danke
    Albrecht

    Klappt das bei Euch, mit dem ATV 2 (Jailbreak, XMBC) HD-Aufnahmen (z.B. Das Erste, 720p) von der SMB-Freigabe abzuspielen? Mein Apfel-Wunderkästchen ist eine Zicke und scheint mir die VDR-Gemeinde nicht zu mögen. Ich krieg' da nur Ton und null Bild, also nicht mal ruckelnde Einzelbilder. Ist das so, oder liegt das an irgendwelchen Einstellungen?


    Ich erlaube mir, die Frage an etwas weniger versteckter Stelle als am Ende dieses Threads nochmal zu stellen.


    Ich habe seither nochmal etliche Testvideos in HD vom SMB-Share angespielt oder es zumindest versucht, 720p, 1080p, teils avi, teils flv oder wmv oder eben auch ts (vom VDR). Manches geht sauber, manches ruckelt, aber nur bei ts (ARD-Aufnahme) gibt's überhaupt keinen Ton. Liegt das am PAL-Standard von 50 Hz, mit dem das ATV 2 nicht klarkommt, weil es 60 Hz erwartet? Allerdings gibt der VLC Media Player an, das HD-Video habe eine Bildwiederholrate von 100 (und der Inhalt sei H.264-MPEG-4-AVC, 1280x720; es handelt sich um eine Aufnahme der Tagesschau von Das Erste HD).


    Danke im voraus
    Albrecht

    Quote

    Original von digitaldesaster
    Hi,
    greife über Samba auf meinen VDR zu. Einfach ne quelle mit smb://ip/freigabe anlegen.....


    Hi digitaldesaster,


    hast Du tatsächlich HD-Aufnahmen von einem vdr als Dateien wiedergegeben, also h.264-Video als ts-Stream in 720p von einem SMB-Share? Ich kriege da nur den Ton zu hören und kein Bild und befürchte, das ATV 2 kommt nur mit Streams klar, nicht mit Dateien. Das wäre für mich ein Grund, es nochmal zurückgehen zu lassen und zu warten, bis das Ding als Universal-Mediaplayer taugt. Eine schicke Oberfläche und Fernbedienung sind halt nicht alles.


    Gruß aus Stuttgart
    IcyA1


    Falls die Frage noch aktuell ist: In der Anleitung von schnere fehlt in etlichen Befehlszeilen vorne "sudo", damit die Befehle mit Administratorrechten ausgeführt werden. Sonst können z.B. bestimmte Verzeichnisse nicht angelegt werden. Die Hinweise von schnere beziehen sich eventuell auf eine Root-Konsole/Rootshell (für Newbies: eine Konsole für einen Benutzer, der generell - und nicht nur zeilen- bzw. befehlsweise - Admin-Rechte hat, siehe Ubuntuusers-Wiki, Aufruf mit sudo -i). Bei mir hat die Anleitung jedenfalls ganz überwiegend funktioniert, als ich die "sudo"-Zusätze ergänzt habe.


    Danke an dieser Stelle für die präzisen Angaben, schnere, mit der man auch ohne jede Ahnung vom Kompilieren zu einem Erfolg kommt.


    Und im Übrigen, Mantus, solltest Du Dir klarmachen, dass vdr und xbmc erst mal zwei paar Schuhe sind. Der vdr ist das Spezialprogramm für Fernsehen auf dem Computer mit seinen verschiedenen Anzeigemöglichkeiten und Plugins. xbmc ist ein durchgestylter und erweiterbarer Universal-Mediaplayer, der zwar alle möglichen Medien wiedergeben und mit Infos aus dem Internet anreichern kann, aber von sich aus kein Live-TV bietet. Die Entwickler sind im Moment dabei, diese beiden Tools miteinander zu verheiraten, indem jedes der beiden Spezialprogramme eine Erweiterung verpasst kriegt (vnsiserver auf vdr-Seite, PVR-Klient auf xbmc-Seite). Bezogen auf Live-TV angeht soll sozusagen der vdr-Motor in die xbmc-Karosserie eingebaut werden. Im Moment kann aber xmbc selbst mit dieser vdr-Erweiterung noch nicht alles, was der vdr mit seinen herkömmlichen (und ebenfalls sehr schicken) Oberflächen kann. Deswegen kann ich Dir nur wie meine Vorredner empfehlen, die beiden Sachen auseinanderzuhalten und Dir eine Fertig-VDR-Lösung genauer anzuschauen, insbesondere yavdr und easyvdr. Die sind bei vielen Leuten im Alltagseinsatz, während die vdr & xmbc-Kombination noch ihre Tücken hat und Dir als Anfänger im Moment nur Frust macht.


    Dass Du Dich noch nicht allzu sehr mit Einlesen in die Thematik belastet hast, Mantus, merkt man Deinen Fragen nämlich deutlich an. Und deswegen solltest Du auch mit Deinem Ton hier etwas vorsichtiger sein, wenn sich schon Experten wie Gerald (gda) die Mühe machen, Dir die basics zu erklären. Sei entspannt und nimm Dir Zeit. Wenn Du die nicht hast, ist ein 60-Euro-Sat-Receiver und eine externe Festplatte allemal die bessere Lösung. Wenn Du Dich aber einarbeitest, ist das Basteln am eigenen HTPC aber ein wunderbares Hobby. Mich begeistert das seit meinem ersten (lin-) VDR von 2004, der heute noch läuft.


    Albrecht

    Quote

    nur standard plugins ?
    oder ist da noch wa anderes dabei ?


    Auch wenn die Frage nicht an mich ging: Mein yavdr läuft mit folgenden Plugins: bgprocess, burn, dvd, dvd-switch.
    Die übrigen yavdr-Pakete sind skin-pearlhd, skins-anthra, skins-speciallogos, tft-anthraize, tft-pearlhd, tft-standard.


    Kann das segfault-Problem oder allgemein das Hängenbleiben damit zusammenhängen, dass der VDR kein Antennensignal kriegt? Ich habe einen Verteiler, um das SAT-Kabel noch zu einem normalen SAT-Receiver zu leiten, der für Notfälle da ist (Stichwort WAF; das Ding ist aber hardwaremäßig abgeschaltet, stört den SAT-Empfang also nicht). Da scheint's mir manchmal Wackler zu geben, weil die Leitungen nicht fest verlegt sind, sondern auch mal bewegt werden. Das Signal als solches ist aber stark genug, ich bin jeweils im grünen Bereich.


    henfri : Hast Du auch öfter mal die Meldung "no signal" auf dem Schirm?


    Albrecht

    Quote

    Original von henfri
    in meinem Log habe ich einige Segfaults gefunden. Gesucht habe ich wegen diverser Situationen, in denen ich kein Bild hatte, der Rechner aber noch auf Pings reagiert hat. SSH Zugang ging aber nicht.


    Diesen Thread beobachte ich mit Interesse. Ich frage mich schon seit einer Weile, warum mein yaVDR immer mal wieder unbenutzbar wird, wenn er eine Weile vor sich hin gelaufen ist, ohne dass man was dran gemacht hat. Es kommt "no signal" u.ä. und er reagiert auf Fernbedienung und Tastatur nicht mehr. Da hilft dann nur noch Abwürgen per Power-Knopf abwürgen und neu starten. Mit den Tipps oben kann ich im Moment noch nichts anfangen, sondern muss mich erst ma' fortbilden. Jedenfalls sieht mein Log gar nicht gut aus:


    Dies nur als ergänzende Info. Vielleicht trägt's zum Gesamtbild bei.
    Albrecht

    Funktioniert das vga2scart-Kabel auch "andersrum", d.h. zur Ausgabe von (RGB-) Videosignal von einer Quelle am Scart-Anschluss an einem Bildschirm mit VGA-Eingang und einem aktiven Lautsprecher? Ich möchte an eine mediamvp einen TFT-Monitor anschließen. Scart-Kabel bzw. -Stecker sind ja wohl nicht unbedingt bidirektional, wenn ich das richtig verstanden habe.


    Danke, Albrecht.

    Wenn Du ne Antwort gefunden hast, lass es mich wissen, balta. Ich hätte meinen Digitainer gern als universellen Medienabspieler vor den Crosstrainer in den Keller verbannt (ohne VDR). Die aktuelle Live-CD des XBMC (10.0 Dharma final) bringt keine grafische Oberfläche ans Laufen, auch nicht im abgesicherten Modus.


    Albrecht

    Quote

    Original von hepi

    Code
    1. ffmpeg -i 00001.ts -acodec libmp3lame -f mp3 -metadata title="Gilles Peterson on BBC Radio One" -metadata author="Various Artists" -metadata year="2010" -metadata album="Gilles Peterson on BBC Radio One" -ss 00:01:58 -t 02:04:00 -ab 192k -ar 48000 gilles_peterson_2010-07-28.mp3


    Jetzt habe ich das mal ausprobiert. Guter Tipp. Mit der Option -vn (für "video none" oder so) müsste es auch für mich funktionieren. Ich demuxe aber erst mal mit PVAStrumento unter wine, um Fehler im Stream zu korrigieren. Das spart mir auch den Schnitt, weil sich bei mir die Spuren ändern mit Beginn und Ende der eigentlichen Sendung. PVAStrumento ("extract video stream" abwählen) erzeugt eine Reihe von .mpa-Dateien. Die größte davon ist meine gewünschte Tonspur. Die codiere ich dann nach hepis Vorschlag von mpa nach mp3 mit folgendem Kommando (für einen Vortrag, also Sprache):

    Code
    1. ffmpeg -i meinetonspur.mpa -acodec libmp3lame -f mp3 -metadata title="meintitel" -metadata author="meinautor" -metadata year="2010" -metadata album="meinalbum" -ab 64k meinmp3.mp3


    Wer's wie ich zum ersten Mal macht: Damit ffmpeg codiert, müssen zusätzlich zu ffmpeg die Codecs installiert werden, für Ubuntu siehe http://wiki.ubuntuusers.de/FFmpeg. Das hatte ich nicht gleich verstanden. In der Standardinstallation kann ffmpeg wohl nur decodieren, nicht encodieren.
    Albrecht

    Quote

    Original von hepi
    Taste 2 ist in der free-Edition von yaVDR deaktiviert. Für den vollen Funktionsumfang musst Du yaVDR-Premium kaufen. :unsch


    :cool1
    Aber nur, wenn's ein Weihnachts-Bundle zusammen mit den Tasten 4 und 6 gibt mit Update-Berechtigung für 3 Monate und Hotline für 1,19 €/Minute.

    Quote

    Original von hotzenplotz5
    ja hier tut taste 2
    :unsch


    Danke. Komische Sache. Dann muss es an einem Konfigurationsfehler bei mir liegen, denn es geht weder mit Tastatur noch mit der Fernbedienung. Generell ist die Taste nämlich bisher nicht negativ aufgefallen. Muss ich mal nachgraben.


    Albrecht

    Quote

    Original von hepi
    Es geht um Radioaufnahmen? Die liegen meist im mp2-Format vor. Ich wandle die so auf der Kommandozeile in mp3:


    Code
    1. ffmpeg -i 00001.ts -acodec libmp3lame -f mp3 -metadata title="Gilles Peterson on BBC Radio One" -metadata author="Various Artists" -metadata year="2010" -metadata album="Gilles Peterson on BBC Radio One" -ss 00:01:58 -t 02:04:00 -ab 192k -ar 48000 gilles_peterson_2010-07-28.mp3


    Nein, es handelt sich um Fernsehaufnahmen von Vorträgen von einem SD-Sender, die mit dem linvdr aufgenommn wurden, d.h. PES mit mpg2-Video und mp2-Audio, abgelegt in vdr-Dateien. Ich muss also erst mal demuxen. Es müsste also projextx, vdrsync oder so was davorgeschaltet werden, wenn ich's richtig verstehe.


    Danke trotzdem, hepi, den Tipp kann ich anderweitig brauchen.


    Albrecht.

    Ich suche eine einfache Lösung, um Aufnahmen im vdr(PES)-Format (von einem älteren VDR-Modell) mit dem yavdr in mp3's umzuwandeln.


    Die bisherigen Versuche mit yacoto waren nicht von Erfolg gekrönt und ich sehe z.B. in diesem Thread, dass das Plugin noch viel Handarbeit braucht, ehe es funktioniert.


    vdrconvert ist wohl out. Früher habe ich die Konvertierung unter Windows mit PVAStrumento und irgend einem Audiotool gemacht, das auf lame basiert (vielleicht audacity, weiß nicht mehr). PVAStrumento läuft unter wine zwar (und hat den schönen Nebeneffekt, dass häufig ein manueller Schnitt entfällt, weil sich die Daten der Tonspur am Anfang und Ende der Sendung ändern), aber es "sieht" z.B. die "_"-Unterzeichnisse von Serienaufnahmen nicht, was vermutlich an wine liegt. Noch blöder ist, dass audacity glatt 100 Minuten veranschlagt, um die 25-Minuten-mpa-Datei in mp3 umzuwandeln (vbr, -V=9, d.h. Sprache). Normalerweise macht das mein Netbook, das momentan unter Ubuntu 10.04 läuft, viel schneller als in Echtzeit.


    Das Ganze in der Art von vdrconvert bzw. vdr2mp3.sh zu automatisieren wäre natürlich eleganter. Wegen dem Ganzen ein große Konvertierungslösung wie VDR-Assistant über mein Rechnernetz zu verteilen wäre Overkill, auch wenn mich das anderweitig interessiert.


    Hat jemand eine einfache und probate Lösung für die Umwandlung?


    Gruß,
    Albrecht

    Ich habe ein Problem damit, eine Aufnahme im VDR (yavdr) zu schneiden. Ich kann in den Aufnahmen die üblichenTastenfolgen benutzen ("0" für Schnittmarke setzen, "9" für nächste Marke anspringen etc.), aber keinen Schnitt anstoßen mit der Taste "2". Den Logs kann ich keine Fehlermeldung entnehmen.


    Hat sich das was geändert oder habe ich was übersehen? Tut das bei Euch?


    Ich brauche den manuellen Start der Schnittfunktion nicht oft, weil z.B. das burn-Plugin die Schnittmarken selber auswertet, aber manchmal eben doch. Deswegen ist mir das auch jetzt erst aufgefallen.


    Gruß, Albrecht