Posts by gandalf

    Auch von mir ein riesiges Dankeschön! Vor allem wo es in der letzten Zeit Schlag auf Schlag ging.


    Ein Problem habe ich:



    Das wollte ich jetzt auch tun, kompilieren klappt auch. Das installieren des plugins, der Rest geht, scheitert aber an:


    Kommt das jemandem bekannt vor, und was ist vdrdevel-abi-1.7.13-multipatch?


    Danke schonmal,
    Gandalf

    Quote

    Original von Dr. Seltsam
    - The new setup option "Folders in timer menu" controls whether the file names in
    the timer menu are shown with their full folder path.
    Klaus


    Warum entweder ganz oder gar nicht? Ich wünsche mir eine Option die den Timernamen plus den umschliessenden Ordner enthält, was dann in den Fällen einer Serienaufnahme zur Anzeige von Serien- und Episodennamen führen würde aber alle weiteren Folder wären unterdrückt.


    Gruss,
    Gandalf

    @all


    Freut mich dass es jetzt tut. Wenn man jetzt noch herausbekommen würde warum das eine Paket, das plugin, nicht mit den anderen 5 aus Tobis Rep zusammenpassen. Werden die eigentlich alle von Tom oder Tobi gebaut oder macht der Eine das plugin der Andere die Final Five (sorry konnte nicht widerstehen ;) )?


    Gandalf

    xtract


    Zu deiner ersten Frage kann ich dir nicht helfen. Was die 2. betrifft, dazu steht einiges im ersten Post


    Quote

    Original von TomG
    Die Debian-Source-Pakete von VDRdevel sind normale VDR-Pakete. Um daraus VDRdevel-Pakete zu bauen, muss das Skript make-special-vdr aus dem gleichnamigen Paket (base-Bereich) verwendet werden. Das Skript wird beim Paketpacken explizit angegeben als Ersatz von debian/rules:
    z.B. PATCHVARIANT=multipatch SPECIAL_VDR_SUFFIX=devel fakeroot dpkg-buildpackage -b -uc -tc -Rmake-special-vdr


    Meine Vorgehensweise ist sicher nicht die offiziell abgesegnete aber ich gehe immer wie folgt vor:


    Code
    1. apt-get install make-special-vdr
    2. cd /usr/src
    3. apt-get source vdrdevel-plugin-xineliboutput
    4. cd vdr-plugin-xineliboutput-1.0.6+cvs20100306.2146
    5. PATCHVARIANT=multipatch SPECIAL_VDR_SUFFIX=devel fakeroot dpkg-buildpackage -b -uc -tc -Rmake-special-vdr


    Das baut dir dann das plugin, in diesem Fall ../vdrdevel-plugin-xineliboutput_1.0.6+cvs20100306.2146-1_i386.deb


    Anmerkung: 1. Zeile installiert ein paar Skripte die du zum Bauen von vdrdevel Paketen brauchst und die in der 5. Zeile benutzt werden. Das brauchst du natürlich nur beim ersten Mal zu machen. Das Verzeichnis in der 4. Zeile wird bei jeder Version und bei jedem Plugin natürlich anders heissen ;), also vorher nachschauen.


    Dann noch

    Code
    1. PATCHVARIANT=multipatch SPECIAL_VDR_SUFFIX=devel fakeroot dpkg-buildpackage -b -uc -tc


    baut dir den Rest, also
    ../libxine1-xvdr_1.0.6+cvs20100306.2146-1_i386.deb
    ../libxineliboutput-fbfe_1.0.6+cvs20100306.2146-1_i386.deb
    ../libxineliboutput-sxfe_1.0.6+cvs20100306.2146-1_i386.deb
    ../xineliboutput-fbfe_1.0.6+cvs20100306.2146-1_i386.deb
    ../xineliboutput-sxfe_1.0.6+cvs20100306.2146-1_i386.deb


    Alle 6 kannst du nun mit

    Code
    1. dpkg -i ../libxine1-xvdr_1.0.6+cvs20100306.2146-1_i386.deb ../libxineliboutput-fbfe_1.0.6+cvs20100306.2146-1_i386.deb ../libxineliboutput-sxfe_1.0.6+cvs20100306.2146-1_i386.deb ../xineliboutput-fbfe_1.0.6+cvs20100306.2146-1_i386.deb ../xineliboutput-sxfe_1.0.6+cvs20100306.2146-1_i386.deb ../vdrdevel-plugin-xineliboutput_1.0.6+cvs20100306.2146-1_i386.deb

    installieren, dann sollte es wieder gehen.


    Ich gehe dabei davon aus dass du weiterhin im Verzeichnis /usr/src/vdr-plugin-xineliboutput-1.0.6+cvs20100306.2146 geblieben bist. Wenn du per cd .. schon wieder nach /usr/src gewechselt bist musst du natürlich entsprechend die '../' löschen.


    Gruss,
    Gandalf

    Ich weiss nicht ob es daran wirklich liegt aber 2 Sachen sind mir aufgefallen



    Du sagst du hast die Versionen 1.06 des xineliboutput plugins und des vdr-sxfe frontends installiert, sie melden sich aber mit 1.09cvs. Das habe ich so auch noch nicht gesehen.


    Und Zweitens...


    ... hast du TS continuity Fehlermeldungen im log. Irgendjemand meinte hier neulich das das entweder an schlechtem Empfang oder veralteten Treibern liegen kann

    Quote

    Original von xtract
    :
    :

    Code
    1. tail -f /var/log/syslog
    2. Mar 12 11:03:26 vdr vdr: [4010] cAudioRepacker(0xC0): skipped 584 bytes to sync on next audio frame
    3. Mar 12 11:03:26 vdr vdr: [4010] PES packet shortened to 5976 bytes (expected: 6160 bytes)
    4. Mar 12 11:05:05 vdr vdr: [4010] TS continuity error (13)
    5. Mar 12 11:08:00 vdr vdr: [3064] EPGSearch: timer conflict check started
    6. Mar 12 11:08:00 vdr vdr: [3064] EPGSearch: timer conflict check finished
    7. Mar 12 11:12:39 vdr vdr: [4010] TS continuity error (15)
    8. Mar 12 11:14:20 vdr vdr: [4010] TS continuity error (10)
    9. Mar 12 11:15:45 vdr vdr: [4010] TS continuity error (9)
    10. Mar 12 11:16:02 vdr vdr: [4010] TS continuity error (1)


    :


    Gruss,
    Gandalf

    So,


    mittlerweile gibts es die Frontends (vdr-sx[fb]e) auch in der Version 1.06. Von Tobi?


    Leider kehrt nun etwas zurück was ich schon ausgestanden gewähnt hatte. Wenn ich die Versionen aus dem Repository nehme schmiert mir vdr-sxfe sofort nach dem Aufruf mit einem Speicherzugriffsfehler ab. Wenn ich die Sourcen selber kompiliere läuft es.


    Das hatten wir zuletzt vor ein zwei Monaten. Irgendwer hat es dann irgendwie behoben, das wurde nie berichtet, es tat halt einfach wieder. Nun tut es wieder nicht mehr.


    Gruss,
    Gandalf


    P.S.: Ich meine libxine1-xvdr, libxineliboutput-fbfe, libxineliboutput-sxfe, xineliboutput-fbfe und xineliboutput-sxfe

    Quote

    Original von sparkie
    [OT]Interessant finde ich auch Entwicklungen wie mit dem Broadcom. Hat dann allerdings weniger mit dem VDPAU- als mit dem Budget-Konzept an sich zu tun. [/OT]


    - sparkie


    Da hast du jetzt eine heisses Eisen angefasst. Das habe ich schon einige Monate im Auge da es u.a. eine, leider kommerzielle, Lösung gibt die das in ATVs einbauen, mitsamt Opensource Treibern und allem drum und dran. Das wäre in der Tat ein Hammer, aber könnte locker einige weitere Threads füllen!


    Jetzt aber definitiv zurück zum Topic ;)


    Gandalf

    Quote

    Original von HH_Maus
    Also ich wollte ja nicht den Thread hijacken, aber es wäre schon schön, wenn das Problem mal gelöst werden würde. Mir fehlt nur die Erfahrung, ob es nun wirklich am VDR 1.7.1x oder an Xine liegt.
    Da es wohl in 1.7.13 noch nicht gelöst ist, hoffe ich sehnsüchtig auf die 1.7.14 :unsch (oder aber je nachdem an ein stabiles Xine-Frontend)



    Lieben Gruß,
    Sandy


    Ist wohl definitiv kein vdr Problem sonder Xine geschuldet. Hatte das gleiche Problem auch seid der 1.7.10. Gestern nach update auf 1.7.13, und (vielleicht wichtiger noch) damit einhergehend auf xineliboutput (und vdr-sxfe) auf 1.06, kann ich zum ersten Mal seit langer Zeit in .ts Aufnahmen wieder spulen und auch Schnittmarken bewegen (mit '4' und '6').


    Gandalf

    Quote

    Original von Dr. Seltsam
    Ich plädiere dafür, die Änderung in vdr wieder rückgängig zu machen.

    Habe ich in über 7 Jahren nicht 1 x erlebt.


    Ich hatte das Problem zwar mal (Strukturen wie /Kinder/Serien/Serienname/etc. sei Dank), aber dank scrollen kann ich damit leben. Jetzt hingegen blicke ich nicht mehr durch da sich mir aus dem angezeigten Episodentitel nicht mehr die Serie erschliesst. Also auch ein Plädoyer von meiner Seite die Sache wenigstens konfigurabel zu machen.


    G.

    Wie gesagt funktionierte es bei mir auch nie.


    Erst seid 2 Tagen, mit dem Wechsel auf 1.7.13 und xineliboutput 1.06, geht es zum ersten Mal. Vielleicht bessert sich das für das xine-plugin jetzt endlich auch entsprechend.


    G.

    Es sieht so aus als ob das Problem mit 1.7.13 gelöst wäre. Bei mir ist es dies zumindest.


    Ich hatte aber auch mit dem xx Sekunden hin und herspringen (ich vermute du meinst die gelbe und die grüne Taste?) noch nie Probleme.


    Gandalf

    Quote

    Original von Mreimer
    Solange mit VDPAU Vor- und Zurückspulen und alle sonstigen VDR-Basisfunktionen nicht läuft, gilt es für mich als unbrauchbar.


    Seit vdrdevel 1.7.13 funktioniert das jetzt bei mir über das xineliboutput plugin. Wie andere hier berichten funktionierte es wohl über das xine plugin schon früher.


    Gandalf

    Quote

    Original von Paule99
    Warum eigentlich nur entweder oder?
    Wie wäre es mit einen VDPAU fähigen Mainboard und der S6400 und das Beste von beiden Seiten verwenden?
    Also beide Ausgaben nutzen, auf den IGP läuft ein Xserver mit XBMC, Firefox, Thunderbird oder was auch immer - die FF ist für TV zuständig. Alles was man braucht sind zwei HDMI-Eingänge am TV/Verstärker.


    Na endlich!
    Diese Konfiguration läuft bei mir schon seit Jahren (im Moment noch mit der SD FF) zur vollsten Zufriedenheit der ganzen Familie (zu Anfang mit der Option —video=xv. Es gibt immer auch Leute die wenn sie Fernsehen wollen sich nicht erst mit der Maus bis zur Fernsehfunktion hangeln wollen. Die gehen dann eben auf den HDMI Eingang auf den die FF ausgibt.


    In diesem Zusammenhang möchte ich nochmal bemerken das in der Tat überraschenderweise auch Frauen nicht alle gleich sind! In unserer Familie ist die FF mit ihrer "einfachen" Bedienbarkeit die mit dem eindeutig höheren WAF!!


    Gandalf