Posts by scotty

    Nee, nicht ganz was ich meine. Es gibt Webseiten, auf denen du deine Timer recht komfortabel zusammenclickern kannst (tvtv.de, tvinfo.de, ..). D.h. du stellst die Timer auf einer Webseite ein, der vdr holt sie sich von dort.


    Im Moment scheint es dafür keine funktionierende VDR Lösung mehr zu geben. Schade.
    Vielleicht mache ich mich mal dran und schreib sie Scripte neu.

    Moin!


    da TVinfo nun den alten Merkzettel abgeschaltet hat, gehen die tvinfomerk2vdr perl scripte nun ja leider nicht mehr.


    Frage:
    - gab es ausser mir noch user, die diese Scripte am Laufen hatten?
    - programmiert sich noch jmd. seine Timer über eine Webseite? tvtv, nimmt ja auch keine Kunden mehr an..


    Gruß
    scotty

    Morgen!


    ich habe zwar keine Lösung, aber exakt das selbe Problem.
    Aktuell habe ich zwei Partitionen mit yavdr 0.2, die ohne das Update spielt einwandfrei, die mit dem Update hat auf einigen Sendern Klötzchen bis zum abbruch [u.a. WDR, ZDF] andere Sender laufen einwandfrei.


    Karte ist ebenfalls die TT-S2 1600


    Edit: Log ist voll von:
    "wait_stream_sync: discard_index.."
    Anzeige erfolgt über sxfe, XBMC hatte/habe ich nie in Benutzung.


    scotty

    Moin!


    ich hänge mich mal mit in den Thread.
    xineliboutput läuft an sich hervorragend, ich habe eine selbst compilierte SMT100 seit Jahren damit am laufen. Aber: Auf meinem neuen vdr mit nForce730 + E5200 bekomme ich diese Ruckler leider auch nicht weg.
    Wobei ich xine 1.2 + xineliboutput aus dem CVS und vdr 1.7.9 (testweise 1.7.3) am Start habe. Das ganze auch auf Ubuntu 9.04 mit eigenem 2.6.30 Kernel. Ich vermute ein Problem im Treiber / Kernel, da ich, wenn das Bild ruckelt auch einen Hänger auf der Konsole beobachtet habe


    Haben hier alle mit dem Problem Ubuntu?


    Gruß
    scotty

    Typischerweise und auch nach Spec. benötigt es keinen Transistor. ATX Netzteile lassen sich mit TTL od. Transistor einschalten, beides ist explizit erlaubt:
    http://www.formfactors.org/dev…V_PSDG_2_2_public_br2.pdf


    Aber normalerweise müsste man testen, ob die Schaltung des Mainboards das PS_ON# Signal aktiv gegen '1' treibt, oder ob dort ein Open Collector Ausgang oder ein Controller mit einem weak high signal verwendet wird. Ansonsten kann es passieren, das das Mainboard eine '1' speist und die WakeUp Schaltung diese auf '0' zieht. Oft sind dort aber OC Ausgänge verwendet worden und selbst wenn nicht, sind die Ströme normalerweise nicht problematisch.


    Gruß
    scotty

    Quote

    Original von SHF

    Ich hatte da bislang keine Probleme, für die paar zu übertragenden Bytes kommt man mit einer relativ geringen Baudrate aus, da ist es nicht so problematisch.


    Das mit der langsamen Baudrate ist eine Milchmädchenrechnung. Der Fehler des Oszillators bleibt auch bei geringen Baudraten gleich, da er mit heruntergeteilt wird. Das würde nur etwas bringen, um einen kurzzeitigen Jitter des Oszillators bzw. dessen Einfluß auf den Fehler zu minimieren.


    Die Genauigkeit des Oszillators für den Usart it aber auch so völlig ausreichend, mehr als +-3% Abweichung habe ich noch nicht gesehen, auch nicht über Temperatur. Wenn man diesbzgl. Angst hätte, könnte man den Timer im übrigen auch mit einem höher getakteten Quarz ansteuern und auf die 32768Hz verzichten.


    Die Atmel Schaltung tut auch in der SMT. die Schnittstelle hat TTL Pegel, das Signal darf auch entsprechend nicht invertiert werden. Siehe:
    Wakeup2 Board weckt nicht auf:



    Edit:
    SHF : die IR-Erkennung hatte auch schon mal auf den Atmel gebracht:
    http://www.garrelts.de/index.html?/WakeUP2/index.html
    Welche Protokolle willst du unterstützen?


    Gruß
    scotty

    Du kannst probehalber kleine Kondensatoren an den Quarz löten. Jede Seite so 1-20pF gegen Masse o. VCC.


    Hast du das Lötzinn bei eingeschalteter Versorgung abgekratzt oder gelötet?


    Gruss
    scotty

    Schau dir mal die Löststellen des Quarzes und drumherum an. Die Zeit und auch die Blinkfrequenz wird vom 32kHz Quarz bestimmt. Wenn der einen Schuß hat könnte sich das so äußern. Ansonsten nochmal die Flags des Controllers programmieren welche die Lastkapazitäten des Quarzes setzen, evtl. schwingt der Quarz auf einer harmonischen, das wäre aber eigentlich ein Wunder.


    edit.

    Quote

    Auffällig ist auch das die LED auf der defekten Platine wenn man sie von der Stomversorgung trennt kurz nach leuchtet was die heile nicht macht.


    Das könnte auch darauf hindeuten, das der Controller bzw. die Flags (Fuses) einen Schuß haben. Programmier ihn einfach nochmal neu.


    Gruß
    scotty

    Was ich jetzt schreibe darfst du nur machen, wenn du sicher bist, das die Schnittstelle mit TTL Pegel arbeitet. Ansonsten schlachtest du den Controller.


    Der Transistor muss raus (er invertiert das Signal). Dann geh mit dem TTL TX von der internen Schnittstelle direkt auf den Controllereingang (evtl. von hinter dem 22k Widerstand, oder diesen gegen 1k tauschen). Solllte dann tun.


    Gruss
    scotty

    Naband!


    ich habe dich erst jetzt gesehen. Das Shutdownscript um den die Aufwachzeit an den Controller zu geben sollte in etwa so aussehen:


    >>
    #Timer scharf machen
    SECONDS=$2
    if test $SECONDS -ne 0; then
    if test $SECONDS -ge 120; then
    $SECONDS = $SECONDS - 90
    else
    exit 0
    fi
    echo ATS$SECONDS > /dev/ttyS1
    fi
    <<


    ..dann sollte er nach SECONDS wieder aufwachen.
    Das ganze vorausgesetzt, das das board an tty1 angeschlossen ist und auf wimre 9600 Baud konfiguriert ist.


    Klappt das programieren an deinem 'normalen' PC oder nicht?


    Hier fing das ganze damals an:
    Multitainer Board


    EDIT:
    Pin 3 und 10 sind prinzipiell erstmal richtig. Aber, wenn das ein interner Stecker ist, und die Schnittstelle nicht nach aussen geführt wird, nehme ich an, das dort nur TTL Pegel anliegt. Wenn es am PC tut und in der Samsung Box nicht, dann poste bitte nochmal, dann brauchst du einen Seitenschneider und etwas Draht ;) .. und den Lötkolben nochmal kurz.


    Gruß
    scotty

    Die Erkläreung stimmt schon so in etwa.


    D13/D14 bzw. D15/D16 leiten negative Spannungen kleiner -1.4V gegen Masse ab. Die Audioleitungen können wenn das Signal über Kondensator ausgekoppelt wird ein negatives Nutzsignal tragen (1Vss), deshalb zwei in Reihe.


    Hat mal jmd. ein Scope an Audio gehängt und DC gemessen? Ich bin nicht sicher das über Kondensator ausgekoppelt wird...


    Die Dioben D1-D8 sollen Überspannungen ableiten. Das Nutzsignal auf den Leitungen ist < 1V. Wenn man die niedrigst mögliche Überspannung abfangen möchte (alles über 1V gehört da nicht hin), dann macht man sich eine kleiner Referenzspannung mit R4, D9 und D10. zwischen R4 und D9 habe ich jetzt etwa 1.4V. Gegen diese 1.4V werden Überspannungen abgeletet.


    Problematisch ist R4, weil er den maximalen Strom, der abgeleitet werden kann begrenzt. Ich habe es nicht durchgerechnet, man müsste siche den Spannungteiler bestehend aus Filter und R4 über die Frequenz anschauen um zu beurteilen, ob das so gewollt ist.


    Ggf. noch ein Elko über D9 / D10 um Spitzen abzufangen, oder direkt nach VCC ableiten..


    Gruss
    scotty

    Jepp, Zenerdioden sind dort extrem nachteilig. Das liegt u.a. an der hohen Sperrspannung. Je höher diese Spannung, desto höher die Kapazität. Das ist das Funktionsprinzip von Kapazitätsdioden, die annodunnemal zur Tunerabstimmung herhalten mussten.
    Nur, auf die 4pF einer 1N4148 kann man bei Serienstreuungen von +-10% für die Keramikondensatoren der Filter sch**. :)


    Gruss
    scotty

    Quote

    Original von habichthugo
    Also, ich möchte Lightningman hier wirklich nicht ans Bein pinkeln, aber sein Filter scheint mir nicht so der Hit zu sein (


    ... für die Kapazitätsfrage gilt das selbe.


    Vishay kennt keinen Kapazitätsunetrschied zwischen 1N4148 und 1N4448 --> Datasheet
    Wie er ihn in seinem anderen Post angemerkt hat. Zitat LM:

    Quote


    WICHTIG: Ihr MÜSST die angegeben Dioden nehmen.
    Also nicht 1N4448 durch 1N4148 o.ä ersetzen. Die
    ausgesuchten Dioden sind von *niedriger* Kapazität
    (extrem wichtig für die Signalquali!!).


    Wer den ganzen Filter mit Kapazitäten als Ersatzschaltbild ( 2*4pF = 8pF gegen Masse) durchrechnet, wird den 'immensen' Einfluß dieser Kapazitäten sehen können.
    Nichts desto trotz kann man Dioden, mit 0.1 - 0.4pF (bei 1V Sperrspannung) kaufen. Die oben genannten sind es aber nicht.


    Zur Filterung hatte ich schon einen recht kontroversen Thread mit ihm. Ich steh nicht so auf Esotherik..


    Ich mach lieber so was:


    http://www.fl-electronic.de/modifikation/diy-kabel.html
    http://www.fl-electronic.de/modifikation/zickzack.html
    http://www.fl-electronic.de/live_connection/netz.htm


    ;)


    Gruss
    scotty