Posts by MartinKG

    I got the patch with:

    Code
    1. wget https://github.com/DigitalDevices/dddvb/pull/37/commits/e38f504aa02c05d3917bb65dbe5d13836b251b86.patch

    and apply it with the following command:


    Code
    1. [root@f31 dddvb]# patch -p1 < /tmp/e38f504aa02c05d3917bb65dbe5d13836b251b86.patch

    but this fails with:


    Quote

    patching file dvb-core/dvbdev.c

    Hunk #1 FAILED at 598.

    Hunk #2 FAILED at 667.

    Hunk #3 FAILED at 679.

    3 out of 3 hunks FAILED -- saving rejects to file dvb-core/dvbdev.c.rej

    Hallo,


    ich versuche für die Octopus CI S2 Pro den Treiber unter Fedora 31 zu kompilieren dies schlägt leider fehl.

    Die Karte habe ich noch nicht, ich werde diese vermutlich in 2020 zulegen, wollte aber schon im Vorfeld wissen, ob es das Kompilieren des Treibers reibungslos funktioniert.

    Die Fehlermeldung lautet:



    gibt es dafür bereits eine Lösung ?

    Hallo,

    der Versuch vdr-epg-daemon-1.1.146 unter der zukünftigen Fedora 31 mit Python 3.8 zu kompilieren schlägt fehl.

    vdr-epg-daemon fails to build with Python 3.8.0b3.


    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function `_Py_DECREF':

    /usr/include/python3.8/object.h:478: undefined reference to `_Py_Dealloc'

    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function `Python::init(char

    const*)':

    /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:262: undefined

    reference to `PyErr_Occurred'

    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function

    `Python::execute(cDbTable*, int, char const*)':

    /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:301: undefined

    reference to `PyObject_CallObject'

    /usr/bin/ld: /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:314:

    undefined reference to `PyUnicode_AsEncodedString'

    /usr/bin/ld: /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:315:

    undefined reference to `PyBytes_AsString'

    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function `_Py_DECREF':

    /usr/include/python3.8/object.h:478: undefined reference to `_Py_Dealloc'

    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function

    `Python::episodeName(_object*, _object*)':

    /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:63: undefined

    reference to `Py_BuildValue'

    /usr/bin/ld: /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:61:

    undefined reference to `Py_BuildValue'

    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function

    `Python::episodePart(_object*, _object*)':

    /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:119: undefined

    reference to `Py_BuildValue'

    /usr/bin/ld: /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:117:

    undefined reference to `Py_BuildValue'

    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function

    `Python::episodeNumber(_object*, _object*)':

    /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:127: undefined

    reference to `Py_BuildValue'

    /usr/bin/ld:

    ./lib/libhorchi.a(python.o):/builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.c:125:

    more undefined references to `Py_BuildValue' follow

    /usr/bin/ld: ./lib/libhorchi.a(python.o): in function `Python::PyInitEvent()':

    /builddir/build/BUILD/vdr-epg-daemon-1.1.146/lib/python.h:72: undefined

    reference to `PyModule_Create2'


    The build no longer links to libpython, resulting in undefined references to

    Python API like _Py_Dealloc.

    Code that embeds Python (rather than building an extension module) needs to

    pass `--embed` to any `python3-config --libs` invocation to build with Python

    3.8.

    More information:

    https://docs.python.org/3.8/wh…same-abi-as-release-build


    For the build logs, see:

    https://copr-be.cloud.fedorapr…/00992313-vdr-epg-daemon/


    Vielleicht hat jemand eine Idee wie man das beheben kann ?

    hatte ich schon gemacht, bringt aber auch nichts.

    Code
    1. g++ -O3 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fPIC -Werror=overloaded-virtual -Wno-parentheses -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include/alsa -I/usr/include/libdrm -I/usr/include/libdrm -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/local/cuda/include -I./opengl -I./ -DPLUGIN_NAME_I18N='"softhdcuvid"' -D_GNU_SOURCE -DCUVID -DHAVE_GL -DAV_INFO -DAV_INFO_TIME=3000 -DUSE_PIP -DUSE_MPEG_COMPLETE -DH264_EOS_TRICKSPEED -DUSE_VDR_SPU -DUSE_ALSA -DUSE_OSS -DUSE_OPENGLOSD -DUSE_GLX -DUSE_SCREENSAVER -DUSE_SWRESAMPLE -g -Wextra -Winit-self -Werror=overloaded-virtual -std=c++0x -Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -shared softhdcuvid.o softhddev.o video.o audio.o codec.o ringbuffer.o openglosd.o -lasound -lva-glx -lva -lGLEW -lGLU -lGL -lGLEW -lGLU -lGL -lfreetype -lavutil -lswscale -lavcodec -lxcb-screensaver -lxcb-dpms -lswresample -lrt -lX11-xcb -lX11 -lxcb-icccm -lxcb -L/usr/lib64/opengl/nvidia/lib -L/usr/local/cuda/lib64 -lGLEW -lGLX -ldl -lcuda -L/usr/local/cuda/targets/x86_64-linux/lib -lcudart -L/usr/lib64 -lnvcuvid -o libvdr-softhdcuvid.so
    2. /usr/bin/ld: cannot find -lnvcuvid
    3. collect2: error: ld returned 1 exit status


    Die Lösung ist ein Link nach libnvcuvid.so anlegen, damit diese gefunden wird.


    Code
    1. [root@fc29 tmp]# ln -s /usr/lib64/libnvcuvid.so.1 /usr/lib64/libnvcuvid.so

    [root@fc29 tmp]# ll /usr/lib64/libnvcuvid*

    lrwxrwxrwx. 1 root root 26 4. Jan 15:01 /usr/lib64/libnvcuvid.so -> /usr/lib64/libnvcuvid.so.1

    lrwxrwxrwx. 1 root root 20 26. Dez 18:03 /usr/lib64/libnvcuvid.so.1 -> libnvcuvid.so.415.25

    -rwxr-xr-x. 1 root root 2946896 12. Dez 17:14 /usr/lib64/libnvcuvid.so.415.25

    Versuch mal im Makefile noch ein LIBS += -L /usr/lib64/ einzufügen.

    hatte ich schon gemacht, bringt aber auch nichts.

    Code
    1. g++ -O3 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fPIC -Werror=overloaded-virtual -Wno-parentheses -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include/alsa -I/usr/include/libdrm -I/usr/include/libdrm -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/local/cuda/include -I./opengl -I./ -DPLUGIN_NAME_I18N='"softhdcuvid"' -D_GNU_SOURCE -DCUVID -DHAVE_GL -DAV_INFO -DAV_INFO_TIME=3000 -DUSE_PIP -DUSE_MPEG_COMPLETE -DH264_EOS_TRICKSPEED -DUSE_VDR_SPU -DUSE_ALSA -DUSE_OSS -DUSE_OPENGLOSD -DUSE_GLX -DUSE_SCREENSAVER -DUSE_SWRESAMPLE -g -Wextra -Winit-self -Werror=overloaded-virtual -std=c++0x -Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -shared softhdcuvid.o softhddev.o video.o audio.o codec.o ringbuffer.o openglosd.o -lasound -lva-glx -lva -lGLEW -lGLU -lGL -lGLEW -lGLU -lGL -lfreetype -lavutil -lswscale -lavcodec -lxcb-screensaver -lxcb-dpms -lswresample -lrt -lX11-xcb -lX11 -lxcb-icccm -lxcb -L/usr/lib64/opengl/nvidia/lib -L/usr/local/cuda/lib64 -lGLEW -lGLX -ldl -lcuda -L/usr/local/cuda/targets/x86_64-linux/lib -lcudart -L/usr/lib64 -lnvcuvid -o libvdr-softhdcuvid.so
    2. /usr/bin/ld: cannot find -lnvcuvid
    3. collect2: error: ld returned 1 exit status

    Hallo,


    ich versuche gerade das aktuell softhdcuvid auf Fedora29 zu kompilieren, das schlägt bei mir fehl.


    Code
    1. g++ -O3 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -fexceptions -fstack-protector-strong -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fPIC -Werror=overloaded-virtual -Wno-parentheses -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include/alsa -I/usr/include/libdrm -I/usr/include/libdrm -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/include/ffmpeg -I/usr/local/cuda/include -I./opengl -I./ -DPLUGIN_NAME_I18N='"softhdcuvid"' -D_GNU_SOURCE -DCUVID -DHAVE_GL -DAV_INFO -DAV_INFO_TIME=3000 -DUSE_PIP -DUSE_MPEG_COMPLETE -DH264_EOS_TRICKSPEED -DUSE_VDR_SPU -DUSE_ALSA -DUSE_OSS -DUSE_OPENGLOSD -DUSE_GLX -DUSE_SCREENSAVER -DUSE_SWRESAMPLE -g -Wextra -Winit-self -Werror=overloaded-virtual -std=c++0x -Wl,-z,relro -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -shared softhdcuvid.o softhddev.o video.o audio.o codec.o ringbuffer.o openglosd.o -lasound -lva-glx -lva -lGLEW -lGLU -lGL -lGLEW -lGLU -lGL -lfreetype -lavutil -lswscale -lavcodec -lxcb-screensaver -lxcb-dpms -lswresample -lrt -lX11-xcb -lX11 -lxcb-icccm -lxcb -L/usr/lib64/opengl/nvidia/lib -L/usr/local/cuda/lib64 -lGLEW -lGLX -ldl -lcuda -L/usr/local/cuda/targets/x86_64-linux/lib -lcudart -lnvcuvid -o libvdr-softhdcuvid.so
    2. /usr/bin/ld: cannot find -lnvcuvid
    3. collect2: error: ld returned 1 exit status
    4. make: *** [Makefile:274: libvdr-softhdcuvid.so] Error 1

    installiert habe ich den vdr-2.4.0 und ffmpeg-devel-4.0.3

    die nvcuvid Libraries liegen hier:

    Code
    1. /usr/lib64/libnvcuvid.so.1
    2. /usr/lib64/libnvcuvid.so.415.25

    Das cuda Zeugs habe ich aus dem nvidia repo installiert, ist zwar für Fedora27, aber vielleicht funktioniert es ja.


    nvcc ist 10.0.130

    Code
    1. nvcc --version
    2. nvcc: NVIDIA (R) Cuda compiler driver
    3. Copyright (c) 2005-2018 NVIDIA Corporation
    4. Built on Sat_Aug_25_21:08:01_CDT_2018
    5. Cuda compilation tools, release 10.0, V10.0.130

    die ~/.bashrc wurde ergänzt um

    Code
    1. # cuda
    2. export PATH=/usr/local/cuda/bin:$PATH
    3. export LD_LIBRARY_PATH=/usr/local/cuda/lib64:$LD_LIBRARY_PATH

    Da sollte es eine Option in den Einstellungen von dvbhddevice für die Unterstützung von TrueColor geben - hast du schon versucht dvbhddevice.TrueColorOsd = 1 zu setzen?

    Habe jetzt den skinnopacity wieder am Laufen, weis jetzt nicht genau was ich geändert habe.

    Die Logmeldungen passen wieder.


    In der setup.conf hatte ich auf jeden Fall dvbhddevice.TrueColorOsd = 0 ungeändert belassen.

    Files

    Du willst mit Grafikkarte ausgeben, richtig? Warum lädst du dann dvbhddevice?

    Ich möchte auf dem Gnome Desktop über die Grafikkarte mit Hilfe des softhddevice Plugin ausgeben und wenn ich nur TV schauen möchte, schalte ich auf HDMI-2 um. Das ging ja seither auch immer.


    Jetzt habe ich nur noch eine Meldung, wenn ich das nopacity plugin mit rein nehme:


    Code
    1. nopacity: No TrueColor OSD found! Aborting!



    Wie kann ich das noch beseitigen ?

    Eine gleichzeitige Ausgabe über zwei Ausgabeplugins geht nicht - du müsstest dann jeweils das primary device umschalten bzw. in den Einstellungen von softhddevice festlegen, dass es sich automatisch zum primary device macht, wenn es attached wird (was laut Log aktuell nicht der Fall ist:

    nachdem ich in der /etc/vdr/setup.conf
    softhddevice.MakePrimary = 1 eingestellt hatte, ging es.


    Vielen, Dank :tup

    Hallo,


    Seit Samstag habe ich ein Problem mit dem VDR-2.4.0 unter Fedora 29, ich bekomme einfach keine Ausgabe mehr über das vdr-softhddevice Plugin, das softhddevice Fenster bleibt schwarz.

    Die DVB-Treiber für die TT6400-S2 sind korrekt geladen, da ich ansonsten an meinem Monitor auf HDMI-2 kein Bild hätte.


    Die Logmeldungen sehen glaube ich in Ordnung aus:

    Aufruf mit dem softhddevice Plugin lautet:

    Code
    1. /usr/sbin/vdr -v /video -D0 -u vdr -p 6419 --plugin='dvbhddevice' --plugin='dvbsddevice' --plugin='softhddevice -g 1680x1050 -a hw:0,0 -d :1.0 -v vdpau'

    Hat jemand eine Idee ?

    Ich habe mich jetzt mal selber an einer "trim"-Funktion versucht.

    Bitte mal den GIT-Stand testen ob es damit geht.

    Also kompilieren lässt es sich schon mal.

    Ich habe die Informationen an den User weitergegeben und erwarte von ihm eine Rückmeldung. bzw. eventuell meldet er sich dann hier direkt.

    (Kann die Anwendung in der Praxis selbst ja nicht testen, da keine H/W vorhanden).

    Vielen Dank schon mal für deinen Einsatz.:tup


    Und dann so bauen und ausführen:

    Code
    1. g++ test.cpp
    2. ./a.out

    Bei mir knallt das mit Fedora 29, aber nicht mit gcc 8.2.0 unter Arch Linux und früheren gcc-Versionen unter Ubuntu.

    das macht er bei mir mit ( g++ (GCC) 8.2.1 20181011 (Red Hat 8.2.1-4 )

    Code
    1. g++ test.cpp -o test
    2. $ ./test
    3. /builddir/build/BUILD/gcc-8.2.1-20181011/obj-x86_64-redhat-linux/x86_64-redhat-linux/libstdc++-v3/include/bits/basic_string.h:1039: std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::const_reference std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::operator[](std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type) const [with _CharT = char; _Traits = std::char_traits<char>; _Alloc = std::allocator<char>; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::const_reference = const char&; std::__cxx11::basic_string<_CharT, _Traits, _Alloc>::size_type = long unsigned int]: Assertion '__pos <= size()' failed.
    4. Aborted (Speicherabzug geschrieben)

    benötigt graphlcd-base-1.0.1 noch einen Patch ? und wo bekomme ich den ?


    Die folgenden Pakete wurden installiert:

    glcdgraphics-1.0.1-1.fc29.x86_64

    graphlcd-common-1.0.1-1.fc29.x86_64

    graphlcd-devel-1.0.1-1.fc29.x86_64

    graphlcd-tools-1.0.1-1.fc29.x86_64

    Ehrlich gesagt verwende ich das Plugin gar nicht.

    Ich wollte eigentlich nur einem Benutzer der weiterhelfen, der sich in der vdr mailing list

    mit einem Problem zu graphlcd gemeldet hatte. Ich hatte ihm hierzu für Fedora rpm Pakete zur Verfügung gestellt.


    Hier seine Fehlermeldung aus der vdr mailing list: