Posts by mamomoz

    Ich fürchte langfristig müsste man das Zeug mal auf die V3 umstellen, mit dem C++ Stil und den C-Bibliotheken (curl, libjansson) in epgd ist das leider etwas mühsam - ich hatte mit der Authentifizierung (JWT holen) und ein paar Beispiel-API Abfragen schon mal angefangen, aber hatte noch keine Zeit mir zu erarbeiten, was man alles an Abfragen mit der neuen API machen muss, um das sinnvoll zu ersetzen, was mit der bisherige Code macht.

    Hallo Seahawk,

    gibt es eine Chance das Du uns das auf die V3 umstellst ? Da wären wir Dir sehr dankbar.

    Hallo,

    ich nutze epgd und scraper2vdr in der aktuellen Version. Da ich kein großer Serienfan bin, ist mir das erst gar nicht aufgefallen.

    Die Anzeige von ScrapInhalten funktioniert bei nur noch mit Spielfilmen. Zu Serien werden keine Banner mehr angezeigt.


    Habe nur ich das Problem ? Was könnte man tun?

    Moin,

    nachdem ich die Stellen auskommentiert hatte, lief es wieder, Das scheint es gewesen zu sein.


    Allerdings hab ich mit der DRM-Version noch was festgestellt. Mit git Version 49db402 ist nach dem Umschalten Bild und Ton sofort synchron.

    Mit der aktuellen Version braucht er nach dem Umschalten ein wenig bis er Bild und Ton synchron hat. Das Bild geht dazu 1-2 Sekunden in Zeitlupe bis es wieder zusammenpasst.

    Ist da vielleicht noch eine Regression?

    Hallo,

    ich nutze die DRM-Version des Plugins auf einem NUC8I3BEH.

    Das läuft auch gut und stabil mit git Version 49db402,


    Heute habe ich mal den aktuellen Git-Stand gezogen. Damit kommt kein Bild und der Ton läuft nur kurz an

    und das Log hat Ring buffer overflows Einträge.


    Das Log habe ich beigefügt.

    Gruß

    Files

    • vdrlog.txt

      (73.93 kB, downloaded 112 times, last: )

    Moin,

    das oben im Titel genannte versuche ich auf meinem NUC zum laufen zu bringen.

    Nach dem Start des VDR mit softhddrm auf DP-1 ist das Device /dev/dri/card0 belegt.

    Starte ich nun den XServer meldet X "/dev/dri/card0 Permission denied"


    In der xorg.conf Disable ich den Monitor den VDR nutzt (DP-1), das bringt aber nichts. X startet nicht.


    Habt ihr Xorg und softhddrm parallel zum Laufen bekommen ?

    Wenn ja wie?


    Gruß

    Damit sollte dann HDR10 mit einem Intel NUC mit LSPCON funktionieren. Das ist auch die Voraussetzung damit es dann auch mit meinem Plugin geht.


    Ich denke damit kann dann auch Kodi HDR mit dem NUC und LSPCON.


    Moin,

    nur zum Verständnis: Dein Plugin läuft aktuell mit dem Kernel intel-drm (5.4.0.rc8) nicht. Da musst Du erst noch was anpassen.

    Stimmt das so?


    Gruß

    Ja, danke, das klappt.


    Aber in meiner xorg.conf war nichts besonderes drin.

    Irgendeine Idee was das Tearing auslösen könnte?


    EDIT: Ok ich antworte selbst.


    Es ist der modesettings Treiber, der das Problem verursacht.

    Man kann es auch in verschiedenen Foren nachlesen.

    Mit dem intel Treiber tritt der Fehler nicht auf.

    Seit 6acd2feb3f2f9515a28c028c757b26d8f8574e98 gibt es allerdings im oberen Zehntel des Bild Tearing.

    Weil es so weit oben im Bild es, fällt es nicht sofort auf, sondern nur bei Kameraschwenks oder schnellen Bewegungen.

    Es scheint unabhängig vom Codec und Auflösung zu sein.

    Hallo,

    ich habe heute meinen neuen NUC8i3BEH aufgesetzt.

    Ich beobachte bei mir genau das gleiche. Bei schnellen Bewegungen und Bildwechsel ist dort im oberen Drittel ein Tearing Balken.

    Sowohl bei SD als auch HD. UHD kann ich grad nicht testen.


    Gruß

    moz


    EDIT: Kaum gepostet schon fällt noch was auf.


    Es liegt wohl doch nicht am Plugin.

    Entferne ich meine xorg.conf und überlasse die Konfig X komplett selbst tritt kein Tearing auf.

    Dafür habe ich nun die Wiedergabe in 60hz, ich möchte aber auf 50hz.

    Weiß jemand wie ich das nun lösen könnte?

    ich hatte mir vor Jahren mal einen eigenen API Key generieren lassen und hab damit derzeit keine Fehler im Log.


    er scraperd die Serien auch ganz normal


    Genau das habe ich auch gemacht vor Jahren schon. In der epgd.conf diesen hinterlegt:

    ScrapMovieDbApiKey = ....


    Will aber bei mir nicht mehr funktionieren.


    Hast Du den noch woanders hinterlegt?

    Ist bei mir auch.

    Er meldet

    Code
    1. Nov 15 12:24:57 epgd-debian epgd: Error: Getting URL failed; HTTP response code said error (22); http code was (403) [thetvdb.com/api/E9DBB94CA50832ED/mirrors.xml]
    2. Nov 15 12:24:57 epgd-debian epgd: Error while connecting tvdb scraper
    3. Nov 15 12:24:57 epgd-debian epgd: Retry #27 failed, retrying in 60 seconds!
    4. Nov 15 12:24:57 epgd-debian epgd: Closing mysql connection and calling mysql_thread_end(1449)
    5. Nov 15 12:24:57 epgd-debian epgd: Closing mysql connection and calling mysql_thread_end(1449)
    6. Nov 15 12:24:58 epgd-debian epgd: Trying to re-connect to database!

    Hallo moz,

    bei mir läuft es normal.


    Gruß

    Murry

    Hmm,

    X läuft bei mir in UHD, OSD ist auf HD eingestellt.

    EIgentlich richtig wenn das OSD dann auf 1/4 des Screen dargestellt wird.

    Bis dato wurde das OSD aber immer richtig skaliert. Mit der neuen Version nicht mehr.


    Stelle ich das OSD auf Custom und 3840x2160 wird skindesigner nicht mehr richtig dargestellt und es kommt zum Absturz.


    Moin jojo61,

    dieser Fehler ist im aktuellen git wieder enthalten 146b826 funktionierte.

    Gruß

    moz

    Hallo,

    im aktuellen git kommt es beim deta zu diesem Fehler und Absturz VDR,

    Code
    1. checkCudaErrors() Driver API error = 0219 "CUDA_ERROR_INVALID_GRAPHICS_CONTEXT" from file <video.c>, line 1602.


    Git aktuell, nvidia 430 / cuvid 10.1/ opengl / ohne libplacebo / skindesigner mit opengl patch


    Gruß

    moz