Posts by mamomoz

    Was ich mich schon lange frage: kann man diese Myriaden von <softhddevice Abkömmlingen> aka {va-api, vdr-plugin-softhddevice-vpp_support_hevc, vdr-plugin-softhddevice-vdpau-vaapi-cuvid, vdr-plugin-softhddevice-FooBar} endlich mal wieder zu einem einzigen zusammenführen?


    Hallo. also ich bin dankbar, dass es hier Leute gibt die ihre private Zeit in diese Entwicklungen stecken. Ist halt kein kommerzielles Produkt, und auf Initiative von Freiwilligen angewiesen. Die Vielfalt/Redundanz die dabei entsteht muss man dann in Kauf nehmen und selber versuchen den Überblick zu behalten. Daher würde ich mich mit so einer Kritik ein wenig zurückhalten oder eben selber aktiv werden.

    Moin,

    ich habs nicht zum Laufen bekommen, softhddrm auf tv und osd2web mit XOrg auf zweiten Display.

    Da osd2web ja webfähig ist, habe ich es mit einem zusätzlichen RPI hinbekommen.


    Wenn der NUC gestartet wird, startet automatisch ein RPI der am USB-Port des NUCs hängt.

    Der RPI macht nichts weiter als automatisch X zu starten und die osd2web-Adresse aufzurufen per Chromium.

    Somit ist das Resultat dann zufriedenstellend.

    Gruß

    Hallo,

    ich habs mir gestern angesehen, so läuft es auf jeden Fall schon mal besser als mit Start-Verzögerung.

    Nachdem Bild und Ton da ist nach dem Umschalten, wird wohl noch eine kleine Korrektur vorgekommen. Das Bild hängt für ca. 1 Sekunde. Das konnte ich auf allen Sendern bemerken.

    Es wird nicht an den Plugin's liegen, der Code wurde ja nicht geändert, wenn liegt es auf der Gegenseite wo umgestellt wird / wurde das nichts mehr kommt.

    Das ist schon klar, ich fragte das weil anscheinend bei einigen nur Banners zu einigen Episoden fehlen. Das kann ja eigentlich nicht sein, wenn die API nicht mehr funzt. Dann musste ja gar keine mehr kommen.

    Ich fürchte langfristig müsste man das Zeug mal auf die V3 umstellen, mit dem C++ Stil und den C-Bibliotheken (curl, libjansson) in epgd ist das leider etwas mühsam - ich hatte mit der Authentifizierung (JWT holen) und ein paar Beispiel-API Abfragen schon mal angefangen, aber hatte noch keine Zeit mir zu erarbeiten, was man alles an Abfragen mit der neuen API machen muss, um das sinnvoll zu ersetzen, was mit der bisherige Code macht.

    Hallo Seahawk,

    gibt es eine Chance das Du uns das auf die V3 umstellst ? Da wären wir Dir sehr dankbar.

    Hallo,

    ich nutze epgd und scraper2vdr in der aktuellen Version. Da ich kein großer Serienfan bin, ist mir das erst gar nicht aufgefallen.

    Die Anzeige von ScrapInhalten funktioniert bei nur noch mit Spielfilmen. Zu Serien werden keine Banner mehr angezeigt.


    Habe nur ich das Problem ? Was könnte man tun?

    Moin,

    nachdem ich die Stellen auskommentiert hatte, lief es wieder, Das scheint es gewesen zu sein.


    Allerdings hab ich mit der DRM-Version noch was festgestellt. Mit git Version 49db402 ist nach dem Umschalten Bild und Ton sofort synchron.

    Mit der aktuellen Version braucht er nach dem Umschalten ein wenig bis er Bild und Ton synchron hat. Das Bild geht dazu 1-2 Sekunden in Zeitlupe bis es wieder zusammenpasst.

    Ist da vielleicht noch eine Regression?

    Hallo,

    ich nutze die DRM-Version des Plugins auf einem NUC8I3BEH.

    Das läuft auch gut und stabil mit git Version 49db402,


    Heute habe ich mal den aktuellen Git-Stand gezogen. Damit kommt kein Bild und der Ton läuft nur kurz an

    und das Log hat Ring buffer overflows Einträge.


    Das Log habe ich beigefügt.

    Gruß

    Files

    • vdrlog.txt

      (73.93 kB, downloaded 27 times, last: )

    Moin,

    das oben im Titel genannte versuche ich auf meinem NUC zum laufen zu bringen.

    Nach dem Start des VDR mit softhddrm auf DP-1 ist das Device /dev/dri/card0 belegt.

    Starte ich nun den XServer meldet X "/dev/dri/card0 Permission denied"


    In der xorg.conf Disable ich den Monitor den VDR nutzt (DP-1), das bringt aber nichts. X startet nicht.


    Habt ihr Xorg und softhddrm parallel zum Laufen bekommen ?

    Wenn ja wie?


    Gruß

    Damit sollte dann HDR10 mit einem Intel NUC mit LSPCON funktionieren. Das ist auch die Voraussetzung damit es dann auch mit meinem Plugin geht.


    Ich denke damit kann dann auch Kodi HDR mit dem NUC und LSPCON.


    Moin,

    nur zum Verständnis: Dein Plugin läuft aktuell mit dem Kernel intel-drm (5.4.0.rc8) nicht. Da musst Du erst noch was anpassen.

    Stimmt das so?


    Gruß

    Ja, danke, das klappt.


    Aber in meiner xorg.conf war nichts besonderes drin.

    Irgendeine Idee was das Tearing auslösen könnte?


    EDIT: Ok ich antworte selbst.


    Es ist der modesettings Treiber, der das Problem verursacht.

    Man kann es auch in verschiedenen Foren nachlesen.

    Mit dem intel Treiber tritt der Fehler nicht auf.

    Seit 6acd2feb3f2f9515a28c028c757b26d8f8574e98 gibt es allerdings im oberen Zehntel des Bild Tearing.

    Weil es so weit oben im Bild es, fällt es nicht sofort auf, sondern nur bei Kameraschwenks oder schnellen Bewegungen.

    Es scheint unabhängig vom Codec und Auflösung zu sein.

    Hallo,

    ich habe heute meinen neuen NUC8i3BEH aufgesetzt.

    Ich beobachte bei mir genau das gleiche. Bei schnellen Bewegungen und Bildwechsel ist dort im oberen Drittel ein Tearing Balken.

    Sowohl bei SD als auch HD. UHD kann ich grad nicht testen.


    Gruß

    moz


    EDIT: Kaum gepostet schon fällt noch was auf.


    Es liegt wohl doch nicht am Plugin.

    Entferne ich meine xorg.conf und überlasse die Konfig X komplett selbst tritt kein Tearing auf.

    Dafür habe ich nun die Wiedergabe in 60hz, ich möchte aber auf 50hz.

    Weiß jemand wie ich das nun lösen könnte?