Posts by Jesus

    das Erste was mir dazu eingefallen ist:


    Du könntest unter dem anderen OS ja ein Tool installiert haben, daß die Systemzeit anhand eines Time-Servers im Internet setzt. dann wäre das Script nicht mehr zu gebrauchen ...

    Ich habe es jetzt mal ausprobiert:


    Sobald ich einen einmaligen Timer setzte, dann springt er zum richtigen Tag. Sobald aber nur Serientermine existieren, dann springt er zum 30.10.


    Aber ansonsten finde ich das Plugin wirklich genial. Immer weiter so. :)

    Nachtrag zum Auffinden des nächsten Events (damit der richtige Tag angezeigt wird):


    wie machst Du das in dem Plugin? Berechnest Du das selber oder nutzt Du eine Funktionalität von VDR? Vermutlich ersteres, da ich mittels des "NEXT"-Kommandos über SVDRP nämlich den korrekten Tag zurück bekomme ...


    Das kann man doch auch bestimmt innerhalb von VDR nutzen und so zuverlässig auf den richtigen Tag springen ... nur so ein Vorschlag.

    Heute laufen definitiv Aufzeichnungen... 4 Stück, um genau zu sein. Dieses sind alles periodische Timer (zwei laufen jeden Arbeitstag und die beiden anderen nur mittwochs).


    Also muß es an was anderem liegen. Vielleicht stimmt etwas an der Routine nicht, über die das nächste Event bestimmt wird.


    --
    Gruß,
    Oliver

    Ich habe auch ein kleines Problem mit dem timeline-Plugin:


    Immer wenn ich das Plugin aufrufe, dann startet das momentan mit dem 30.10.2003, anstatt den heutigen Tag hervorzuheben (8.10.2003).


    Ist das gewollt und warum? Ich finde es auf jeden Fall unpraktisch. Wenn es mit Absicht so ist, dann würde ich es bevorzugen, wenn es sich übers OSD konfigurieren ließe ...



    Desweiteren hatte ich heute einen Absturz von VDR, als ich wärend einer Aufnahme das Plugin aufgerufen habe und es mit "Ok" beenden wollte. Vielleicht nur ein unglücklicher Zufall, denn ich konnte es noch nicht reproduzieren, aber vielleicht ist es auch schon jemand anderem passiert ...


    Gruß,
    Oliver

    meine Probleme gehören jetzt auch der Vergangenheit an ...


    das mit den zwei Stunden Differenz hatte ich nachher auch. Lag daran, daß Linux im Startscript die Systemzeit setzt und dabei davon ausgeht, daß die Uhr nach UTC läuft. Naja, kann man ihm ja leicht abgewöhnen... einfach den Parameter "--utc" entfernen ...

    dann muß es da irgendwo ein Script geben, daß das macht, denn im Bios steht die korrekte Zeit und nicht die geänderte...


    Nur mal das Script finden, daß dafür zuständig ist.


    Momentan behelfe ich mir damit, daß ich auf ARD wechsle (das ist der KAnal, nachdem ich die Uhr synchronisieren lasse durch VDR) um nach dem Neustart die Uhrzeit wieder korrekt zu setzten. Aber das ist lästig und klappt nur, wenn ich vor Ort bin ...


    Aber schon mal danke für die Antworten :)


    Gruß,
    Oliver

    Coole Geschichte... wenn ich meinen PS/2-Port nicht schon für die Tastatur brauchen würde, dann wäre ich zumindest Kandidat für Deine Schaltung. Einschalten über FB wäre die Krönung für meinen VDR-Rechner im CD-Player-Case ...


    ich wünschte, ich hätte auch nur ein wenig Erfahrung mit den Atmels... überall im Netz stolpert man über Bauvorschläge, die Teile scheinen ja ziemlich universell zu sein.


    Gibt es eigendlich sowas wie ein HowTo zu den Dingern? Denn ich habe keine Lust, mir erst ein Buch von 400 Seiten durchzulesen und mir im Anschluss dann erst Gedanken machen zu können, wie ich die Sache angehe ...


    Gruß,
    Oliver

    Hmm, bei mir funktioniert das Script set_timer nicht richtig... es wird zwar die Datei time_diff angelegt, aber die Hardware-Zeit nicht verändert. Wenn der Rechner dann das nächste mal eingeschaltet wird, dann findet das Script die Datei und setzt entsprechend die Uhrzeit um. Dummerweise lebt der Rechner dann in einer anderen Zeit (momentan der 2.10., 5:43 Uhr). Dadurch habe ich dann natürlich auch kein EPG mehr, weil es für diesen Tag keins gibt...


    Aber woran liegt es?


    Als Basis kommt bei mir ein TTyLinux zum Einsatz (da ich keinen Platz für eine andere Distribution habe; keine Festplatte in dem Rechner, bootet von einer CF-Karte), welchem ich noch fehlende Binaries untergeschoben habe ('who'; eine vollständigere Version von 'date', da die mitgelieferte leider nicht den notwendigen Parameter für set_timer hatte; und noch ein paar mehr). Als Hardware ein VIA EPIA 5000.


    __
    Gruß,
    Oliver

    Das läuft bei dem Teil hier zumindest so, daß er nur die Einträge nutzt, zu denen es auch ein entsprechendes Device gibt...


    also nur wenn es ein tty2 auch gibt, so nimmt er dessen Eintrag in der inittab, hab ich schon probiert. Aus dem Grund muß ich bei mir sogar Einträge für die Version mit devfs machen, also vc/2, sonst findet er bei devfs Support die Terminals nicht.


    So könnte ich auch abhängig von den vorhandenen Devices andere Befehle für diverse Konsolen verwenden.


    Wenn ich die alle auskommentiere, dann idelt der init einfach nur rum und ich bekomme keine Konsole (nicht mal, wenn ein Bildschirm dran ist).


    Einen Sonderfall stellt die Zeile


    Code
    1. ::respawn:/usr/local/bin/runvdr -t /dev/tty1


    dar. Hier wird der Verwendete Befehl immer ausgeführt, egal welche Art der Konsole verfügbar ist.


    Leider ist die Zeile nicht korrekt, da es diese Konsole, die ich hinten mit -t übergebe nicht gibt, wenn die GraKa fehlt...

    Sorry, Tipp-Fehler...


    Meine Einträge in der inittab sehen so aus:


    Code
    1. ::respawn:/usr/local/bin/runvdr -t /dev/tty1
    2. #tty1::respawn:/sbin/getty 38400 tty1
    3. tty2::respawn:/sbin/getty 38400 tty2
    4. tty3::respawn:/sbin/getty 38400 tty3
    5. tty4::respawn:/sbin/getty 38400 tty4
    6. tty5::respawn:/sbin/getty 38400 tty5
    7. tty6::respawn:/sbin/getty 38400 tty6


    Weicht leicht von Distributionen wie Mandrake ab, da es auf BusyBox basiert...

    Ja, deswegen funktioniert es ja auch mit Grafikkarte wunderbar... leider scheint das Device /dev/tty0, welches per -t angehängt wird, nicht zu existieren/funktionieren, sobald die GraKa fehlt.


    Aber was ist ohne GraKa die richtige Konsole, auf der die Tastatur liegt?


    Gruß,
    Oliver

    Ich habe ein ähnliches (vielleicht auch gleiches Problem?):


    Ich betreibe meinen VDR-Rechner ohne Grafikkarte. Aus diesem Grund scheint es nun kein Device ttyX, bzw. vc/X (ich benutze devfs mit devfsd) auf der Kiste zu geben...


    Auf jeden Fall durchläuft 'rundvdr' laufend seine Endlosschleife und lädt permanent die DVB-Treiber neu. Was genau passiert, kann ich leider nicht sagen, da ich ja keinen Bildschirm dran habe.


    Aber wie trichter ich dem VDR jetzt ein, daß es die Tastatur nutzen soll? Ich habe mir extra die Arbeit gemacht und habe die ursprünglichen Tasten des CD-Player-Gehäuses an einen Tastatur-Controller gelötet...


    Wenn ich die Grafikkarte drin lasse, dann läuft es einwandfrei ... kann ich nur nicht machen, weill das Gehäuse dann nicht zu geht ;)


    Bitte helft mir,
    Oliver