Posts by habichthugo

    pat
    Dein Beitrag verwirrt mich etwas. Geht das Aufwachen nun, oder nicht?


    Falls nicht:
    Gieb mal auf der Console einen Aufwachzeitpunkt ein, der ca. zehn Minuten in der Zukunft liegt, z.B.:
    # echo 2004-04-16 15:00:00 >/proc/acpi/alarm
    Dann fahre Deinen Rechner runter und warte ab, ob er wieder aufwacht. Wenn ja, funktioniert es prinzipiell...

    cooper


    Quote


    Es ist wirklich schwierig, mit der Suchfunktion eine Message zu diesem Thema zu finden, die einem wirklich konkret weiterhilft. Danke für den direkten Verweis! :)


    Quote

    Wenn er idle ist oder keine Aufnahme läuft, schickt er nach ein paar Minuten die 2. los zum Scannen.


    Was heisst den idle? Mit "2." meinst Du wahrscheinlich eine zweite DVB-Karte. Mein System hat aber nur eine! Und dann? ?(


    Quote

    Nein, weil da ist das EPG nicht aktualisiert.


    O.k., soweit Deine Annahme, das die Sender ihr EPG erst ab 2:00 sicher aktualisiert haben richtig ist. Falls das mit dem "everyday" bei mir nicht klappt, wird mir jedoch nichts anderes übrig bleiben! :rolleyes:


    Quote

    Genau das. Also einfach verkürzen auf 45 Minuten oder so.


    Wäre nicht so schön. :(


    Summa sumarum: Wenn sich das Datum generell nicht stellen lässt, schreit das nach pragmatischen Patches. poweroff.pl könnte das automatisch erkennen und entsprechend verfahren. Mal sehn, ob ich am Wochenende was gezaubert kriege.... :]

    cooper

    Quote

    ...ich nutze das und lasse ihn täglich um 2:00 aufwachen, damit er sich das EPG für den nächsten Tag holt...


    Wie machst Du das genau mit dem um 2:00 aufwachen? Unter welchen Umständen aktualisier der VDR eigentlich das gesamte EPG (scannt alle Kanäle)?


    Bei mir würde ja ein generelles Aufwecken um 23:59 helfen. Bis 'er' dann wieder runterfährt wäre der nächste Tag und gut! Allerdings: Erkennt der VDR ein händisch programmiertes Aufwecken bzw. wartet 'er' dann nicht die 'Benutzerinaktivität' (bei mir 120min) ab, bis 'er' wieder runterfährt?

    bob
    Nein, tut er i.d.R. eben nicht! Ich habe unter der Woche eine Serienaufnahme programmiert (Nachmittags). Wenn ich die Kiste nun (i.d.R.) Abends vor 0:00 Uhr schlafen lege, wird der Wegzeitpunkt auf den (bereits vergangenen) Nachmittag gelegt, da z.B. 2004-04-16 16:15 am 2004-04-15 22:15 2004-04-15 16:15:15 ergibt!

    Code
    1. # es ist jetzt 2004-04-15 22:15!
    2. linvdr:~# echo 2004-04-16 16:15 >/proc/acpi/alarm
    3. linvdr:~# cat /proc/acpi/alarm
    4. 2004-04-15 16:15:15

    HFlor


    Ich habe das Forum schon ausgiebig duchstöbert. Ausser, dass andere das Datums-Problem offenbar auch haben, habe ich nichts hilfreiches dazu finden können. Es gibt offensichtlich Mitmenschen, die ihre Probleme durch Umstellung auf NVRAM gelöst haben. Da lag es dann wohl offenbar nicht am Board :D, sondern an ACPI ;(! Dazu haben offensichtlich viele dieses Problem erst nach Umstellung auf LinVDR 0.6.


    Ich schliesse: ACPI im LinVDR 0.6 hat einen Knaks, aber welchen und wie zu beheben? :rolleyes:

    Boergen

    Quote

    Genau das kann VDRAdmin.


    Du spielst auf die Autotimer an? Das ist nach meinem Verständnis doch etwas anderes.
    Dazu läuft VDRAdmin bei mir (noch) nicht richtig. Damit muss ich mich erst noch eingehender beschäftigen. Und mein WinXP steht im Arbeitszimmer (dritte Etage), mein VDR im Wohnzimmer (Erdgeschoss). Ich programmiere meinen VDR 'klassisch' über OSD und das wird wohl i.d.R. auch so bleiben.

    Mein VDR fährt zu Aufnahmen nicht automatisch hoch. Ich habe das analysiert und bin letztlich darauf gekommen, dass /proc/acpi/alarm bei mir schlicht das übergebene Datum ignoriert ;(, z.B.:

    Code
    1. linvdr:~# echo 2004-04-16 0:15 >/proc/acpi/alarm
    2. linvdr:~# cat /proc/acpi/alarm
    3. 2004-04-15 00:15:15

    Hat irgend jemand 'ne Idee, woran das liegen könnte? :]

    Falls überhaupt noch jemand an dem Thread hängt, mal 'ne blöde Frage an die Kracks zum VPS:
    Warum sich damit soviel Mühe geben, wenn's eh kaum unterstützt wird?Allerdings scheinen mir viele Sender die EPG-Daten sauber zu aktualisieren, wenn sich Sendungen verschieben. Das könnte der VDR doch verfolgen und die programmierten Zeiten (mit Puffer) entsprechend verschieben! :] Oder? ?(

    iNOB

    Quote

    lesen macht schlau, ausprobieren ebenso! Schau mal über den Tellerrand hinaus...


    Also wenn Du schon stäkerst, dann doch bitte etwas konkreter. Meinst Du vieleicht, das es bezüglich libdvdcss in den Staaten auch einige Rechtsstreitigkeiten gibt oder was?

    Quote

    Wie groß ist denn die Anzahl der DVDs die sich nicht abspielen bzw . das Menü nicht dargestellt wird? Gibts da dann keinen Weg, die DVDs doch abzuspielen?


    Ich hatte bisher noch keine DVD, wo sich das eigenztliche Filmmaterial Aufgrund von Menü-Darstellungsproblemen nicht abspielen liess. Die Menü-Darstellungsprobleme sind unschön, aber nicht wirklich hinderlich (soweit hierüber nicht Spiele oder ähnliches realisiert sind, was ich auch schon hatte). CSS-geschützte DVDs sind mit derzeitigen VDR-Distributionen nicht abspielbar, weil offenbar keiner mehr bereit ist, die im System notwendige libdvdcss mitzuliefern. Das Ganze wird sehr mystifiziert und kaum deutlich ausgesprochen. Ich vermute als Hintergrund den neuen Paragrafen 95a UrhG, der seit Ende letzten Jahres die Umgehung eines Kopierschutzes für unzulässig erklärt...

    Was Du vorhast, wollte ich auch immer und will es noch immer. Ich habe solche Lösungen schon seit rund drei Jahren im Einsatz. Kurz und knapp: Alle Deine Anforderungen wirst Du nicht erfüllen können!


    Das, was dem am nähesten kommt ist (Lin)VDR (0.6). LinVDR 0.6 habe ich seit rund einem Monat im Einsatz und es ist definitiv um Längen besser, als alles was die Windows-Welt zu bieten hat.


    Wenn Du noch unschlüssig bist, schau mal bei c't vorbei:
    Fernseh-PC (c't-VDR-Distribution)
    VDR-Alernativen
    Heft 20/2003, Media Center mit Windows und myHTPC, S. 186
    ...


    (Lin)VDR (0.6) ist so ziemlich das einzige, was halbwegs Plug-And-Play funktioniert. ISO-File herunterladen, auf CD-ROM brennen, einlegen, den Anweisungen folgen und fertig!? Als nächstes noch ein paar Patches einspielen...Für alles Weitere ist dieses Forum Dein Freund!


    Das mit dem 'nicht Autoplay' würde ich nicht überbewerten. Du kannst z.B. eine Taste Deiner Fernbedienung (oder Tastatur) mit dem Media-Select-Plugin verknüpfen, dann reicht ein Knopfdruck, um 'jedes' Medium zu starten. Ohne Fernseher (OSD) wird's so auf Dauer jedoch kaum ohne LCD-Display (-Plugin) gehen...

    @marlow+Torsten/WarEagle


    Ich glaube, ihr redet wirklich aneinander vorbei. Was marlow - glaube ich - wissen will, ist, wie er die Ausgaben in ein Log-Datei umleitet.


    Ich dachte am einfachsten wäre, den vdr zu stoppen und aus putty neu zu starten:
    /etc/init.d/runvdr stop
    /etc/init.d/runvdr start
    Nun sollten eigentlich alle Ausgaben des vdr im putty-Fenster ankommen. Dem ist aber bei mir nicht so. Weiss jemand wieso?


    Zweiter Versuch: An Zeile '$BINDIR/vdr -L $PLUGINDIR ...' in /etc/init.d/runvdr ' 2>&1 | tee /vdr.log' anhängen und vdr wie oben stoppen und neu starten (reboot tut's auch). Dann scheint in /vdr.log das Gewünschte mitprotokoliert zu werden (cat /vdr.log).


    Nebenbei: '/etc/init.d/runvdr start 2>&1 | tee /vdr.log' aus putty hängt sich auf. Weiss jemand wieso?

    marlow


    "...also liegt es wohl doch am netzt oder der ac3 übers netz macht probleme..."
    Am ac3 liegt es damit definitiv nicht! Damit bleibt das Netz (oder Windows(-Platte)).


    "...da ich jetzt dvdselect drauf habe, kann ich nun keine dvd direkt vom player abspielen..."
    DVDSelect verbiegt den Link /dev/dvd (hierauf greift das DVD-Plugin zurück) auf das entsprechende Verzeichnis mit dem abzuspielenden Film. Nach Abspielen des Films stellt DVDSelect nicht den Vorzustand her, sondern sellt /dev/dvd auf einen Pfad ein, der unter OSD->Einstellungen->Plugins->DVD Wechsler konfigurierbar ist. Dieser stand nach Erstinstallation des Plugins bei mir auf /dev/hdc (unterstellt, dass das DVD-ROM als Master am zweiten IDE-Port hängt). Das kann bei Dir anders sein. Unter LinVDR ist /dev/dvd standardmässig nach /dev/cdrom verlinkt (dies wiederum nach /dev/hd<x>). Also: Probier mal unter ...Einstellungen... /dev/cdrom oder /dev/hd<x> (<x> = a für IDE1/Master...d für IDE2/Slave). Dann Film über DVDSelect anspielen, abbrechen und dann einen Film im DVD-ROM direkt über DVD-Plugin probieren.

    marlow


    Keine Panik! Ich hab' auch 'nen Sprössling (acht Monate), der abends meiner harrt. Das Ganze hier sollte schon for fun bleiben!


    Die Übertragungsrate hängt von vielen Faktoren ab. Auch die Platten tragen dazu bei. Grob gesagt betimmt das schwächste Glied in der Übertragungskette die Übertragungsrate. Das ist in Fällen wie dem Deinen normaler weise das Netz, es können aber auch die Platten sein (wenn diese z.B. nicht über DMA angesprochen werden). Dazu ist die Transferrate bei Platten schreibend normaler Weise deutlich geringer als lesend. Der Weg Win-Platte->Netz->VDR-Platte kann also deutlich schneller sein als umgekehrt. Schliesslich kommen dann noch Dinge wie die (mittlere) Zugriffszeit, der Fragmentierungsgrad, andere Netzlasten etc. ins Spiel. Also: Je präziser Du Dein System beschreibst, desto eher kann Dir jemand helfen.

    marlow


    Ich denke, wenn Du von hier Hilfe erwartest, musst Du schon etwas präziser werden und Empfehlungen konsequenter umsetzen. Und wenn Dich das Ganze wirklich nicht grossartig interessiert, dann lass es halt.


    Nachdem Dir nun auch Bob empfohlen hat, mal zu versuchen direkt von Deiner VDR-Festplatte abzuspielen, mach's halt einfach mal!


    Zur Beschreibung Deines Netzwerks: Du hast Deinen Windows (XP (Home Edition)) Rechner... über dessen 100MBit-LAN-Karte/On Board mit einem Cross-Over-Kabel direkt an den 100MBit-LAN-Konnektor Deines VDR EPIA-ME6000-Boards verbunden?...

    marlow


    "...ich machte mal den test..." Welchen/wie den?


    Geh doch mal systematisch an die Sache und teste zuerst, ob das Abspielen von der lokalen VDR-Platte klappt. Erst dann würde ich woanders weitersuchen.


    Deine "2,63 MB<yte>/s" sollten theoretisch reichen (~20MBit/s). Für ein angebliches 100MBit/s-LAN ist das jedoch grotten schlecht. Wie sieht Dein Netzwerk den aus (2x100MBit/s-LAN-Karten, Cross-Over-Kabel / HUB(s), Windows (XP))? Gibt es andere Netzlastverursacher? Für ein ruckelfreies Abspielen muss nicht nur die mittlere Transferrate stimmen, die Daten müssen auch halbwegs kontinuierlich fliessen...