Posts by jha

    Wenn es nicht hilft:
    Einfach mal am Anfang des runvdr-Skripts folgendes einfügen:


    Code
    1. set > /tmp/environment.txt

    Das schreibt alle gesetzten Umgebungsvariablen und deren Inhalt in eine Datei. Nach dem Booten die Datei sichern, VDR killen und runvdr von Hand starten. Danach die neue mit der gesicherten Datei Vergleichen. Mögliche Kandidaten sind vor allem $PATH und $HOME.


    Gruß,
    Juri

    Hi,


    vermutlich startest du runvdr per inittab oder rc-Skript. Allerdings sind zu diesem Zeitpunkt noch nicht alle Umgebungsvariablen voll gesetzt. Vermutlich enhält $PATH nicht /usr/local/bin wo dein mplayer.sh-Skript liegt. Deshalb kann VDR das mplayer.sh-Skript nach dem Booten nicht finden. Wenn du aber von Hand runvdr startest, dann sind die Umgebungsvariablen voll gesetzt und deshalb funktionert es.


    Ansonsten bitte bei neuen Problemen einen neuen Thread aufmachen, oder kommt bei dir auch die Fehlermeldung aus dem Titel dieses Threads (device or resource busy).


    Gruß,
    Juri

    Hmm, sieht eigentlich recht normal aus - MPlayer ist mit sogenannter "runtime CPU detection" kompiliert, d.h. die Fähigkeiten werden (erst) beim Starten des MPlayer festgestellt und dann (hoffentlich) optimierte Routinen benutzt.


    Du kannst höchsten probieren, den MPlayer mal selbst zu kompilieren, dann wird er i.a. gleich mit optimalen Routinen gebaut.


    Ansonsten fällt mir momentan auch nichts weiter ein. Ich kann nur sagen, daß es auf meinem P4 mit 2,4 GHz problemlos läuft. Und die Vergleiche mit WinXP oder direktem Abspielen auf einem X11-Desktop sind Vergleiche von Äpfel und Birnen, da ja in diesen beiden Varianten nicht in Echtzeit in MPEG1 encodiert werden muß, beim Abspielen über FF-Karte aber schon.


    Gruß,
    Juri

    Auch wenn dieser Thread schon etwas älter ist:
    Nein, ein P4 mit 2.4 GHz sollte reichen, es sei denn, du versuchst HD-Videos abzuspielen, aber das scheint ja nicht der Fall zu sein.


    Mir fallen zwei Möglichkeiten ein:
    1) der Zugriff auf die Videos ist zu langsam (DMA für Festplatte eingeschaltet?, von Netzlaufwerk -> Netzwerkprobleme?)


    2) dein MPlayer ist ohne Optimierungen kompiliert. Rufe doch einfach mal "mplayer | grep CPU" auf und poste die Meldungen.


    Gruß,
    Juri

    Hmm, liegt wohl am automatischen Laden der Treiber durch den Kernel - offensichtlich lädt er mal den einen, mal den anderen zuerst. Da hilft wohl nur, die Treiber in die sogenannte Blacklist aufzunehmen und später von Hand/ per Skript in einer definierten Reihenfolge zu laden. Dazu schreibst du die Treibernamen in die Datei /etc/modprobe.d/blacklist.
    Das Skript-gesteuerte Laden (und Entladen) erledigst du am besten mit dem runvdr-Skript, das Teil der VDR-Sourcen ist.


    Gruß,
    Juri

    Schön, daß du auf uralte Threads antwortest, aber mittlerweile gibt es für dieses Problem eine elegantere Lösung:


    Die MPlayer-Parameter -vo mpegpes und -ao mpegpes akzeptieren eine Option, mit der man die Karte angeben kann, über die der MPlayer ausspielen soll:


    mplayer -vo mpegpes:card=2 -ao mpegpes:card=2
    Hier also auspielen über die zweite DVB-Karte - die Option fängt bei '1' an zu zählen, die Einträge in /dev/dvb/ ab '0'...


    Das ist auch schon seit einiger Zeit in der Konfigurationsdatei des mplayer.sh-Skriptes als Kommentar eingefügt.


    Gruß,
    Juri

    Ich gehe davon aus, daß du das Video per MPlayer(-Plugin) abspielst.


    Leider wertet das mplayer.sh-Skript noch nicht die Aspect-Ratio-Werte in einem Video aus, wenn sie denn vorhanden sind. Du kannst allerdings in der mplayer.sh.conf MPEG_DIRECT=true setzen, dann könnte es gehen, wenn denn beim Erstellen der Datei auf der dbox diese Informationen nicht entfernt wurden.


    Gruß,
    Juri

    weil das mplayer.sh-Skript, welches vom vdrmplayer-Plugin aufgerufen wird, wissen muß, wo das MPlayer-Binary liegt - wenn du da Unsinn einträgst, dann kann kein Video abgespielt werden, da der MPlayer nicht gefunden wird.


    Alte Regel:
    Immer nur eine Sache zur zeit ändern und die Auswirkung abwarten. Niemals mehrere Dinge zugleich ändern, sonst weiß man nicht was nun was ausgelöst hat...

    Gratulation!


    Wie schon geschrieben, die vob-Dateien enthalten entweder das Menü, welches meist ein (zu) kurze Sequenz ist, oder das eigentliche Video, aufgeteilt in 1GByte-Teile. Zum eigentlichen DVD-gucken empfehle ich das vdr-dvd-plugin, nicht das mplayer-plugin. Gehen denn sonst irgendwelche avis oder mpegs?

    Original von ctvdrnoob

    Quote

    /media/cdrom habe ich zurückgebogen auf /cdrom.

    OK, dann sollten die entsprechenden Ausschnitte aus den Dateien wie folgt aussehen:


    /etc/fstab:
    /dev/sr0 /cdrom udf,iso9660 user,noauto 0 0


    /etc/vdr/plugins/mplayersources.conf:
    /cdrom;DVD;1


    Quote

    Den zusätzlichen mount Befehl habe ich auch drin (mount /cdrom).

    Wie meinen? Wo drin? Du solltest das Skript mal von Hand testen... Funktioniert das denn?


    Quote

    echo $PATH gibt das aus:
    /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

    Wie schon vermutet, steht /etc/vdr/plugins/music nicht mit drin (wäre auch ungewöhnlich - dafür gibt's ja den '-m' Parameter.)


    Quote

    Jetzt kommt bei der Auswahl des Datenträgers der Fehler "Einbinden fehlgeschlagen".

    Das ist immerhin ein Fortschritt, denn jetzt wird wirklich erst versucht, die DVD einzubinden.

    Du mußt dich schon entscheiden, ob das DVD-Laufwerk unter /cdrom oder unter /media/cdrom gemounted werden soll - mein Beispielaufruf von mount.sh ging aufgrund deines ersten Postings von /cdrom aus. Probiere also nochmal sicherheitshalber mit:
    '/etc/.../mount.sh mount /media/cdrom'


    Weiterhin meinte ich mit "...glaube ich kaum, daß /etc/vdr/plugins/music/mount.sh in $PATH ist...", daß VDR das Skript mount.sh nicht finden kann, solange "/etc/vdr/plugins/music" nicht Teil der Umgebungsvariablen $PATH ist. Einfach mal mit 'echo $PATH' überprüfen. Deshalb solltest du explizit mittels der Option '-m ...' angeben, wo mount.sh zu finden ist (hast du ja wohl jetzt getan).


    Was 'auto' versus 'noauto' angeht: Wo genau hast du das ausgetausch? Ich sehe in den fstab-Zeilen

    Quote

    #/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/sr0 /media/cdrom auto user,noauto 0 0

    an dritter Stelle ein 'auto', von dem ich mir nicht sicher bin, ob das ein gültiger Wert ist. Sowohl in der man-Page von fstab als auch von mount steht nichts davon, daß man als Dateisystem-Typ 'auto' angeben kann. Hier sollte meines Erachtens für DVD-Laufwerke/-Brenner immer 'udf,iso9660' stehen - zumindest ist es auf allen meinen Maschinen so. Bei den Optionen sollte 'noauto' stehen, sonst wird beim Booten versucht, eine eingelegte CD/DVD zu mounten.


    Und wie schon zweimal geschrieben, muß in der mplayersources.conf muß eine '1' am Ende stehen, sonst geht das MPlayer-Plugin davon aus, daß der Pfad/das Volume bereits gemountet ist und vom User nicht verändert werden kann/soll.


    Zum Wiedergeben von DVDs:
    Die *.vob-Dateien sind diejenigen, die den Film enthalten, aber auch Menüs und ähnliches.


    Allgemein empfehle ich zum Abspielen von DVDs das DVD-Plugin und nicht MPlayer.


    Gruß,
    Juri

    Die mplayer.sh.conf dient zur Konfiguration der Abspieloptionen des MPlayer und hat hiermit erstmal nichts zu tun.


    Erstens glaube ich kaum, daß /etc/vdr/plugins/music/mount.sh in $PATH ist, deshalb solltest du wohl besser beim Starten vom VDR dem mplayer-plugin noch mittels des Parameter '-m' die Date angeben:
    '-m /etc/vdr/plugins/music/mount.sh'.


    Zweitens poste doch bitte mal die ganze '/etc/fstab', denn daß das Skript sich über /media/cdrom beschwert, obwohl du /cdrom angibst, finde ich merkwürdig.


    Gruß,
    Juri

    Ja genau, du mußt eine '1' angeben, damit du mit der grünen Taste die CD mounten kannst (wie schon im anderen Beitrag geschrieben). Was ich meinte ist folgendes: Ich weiß nicht, ob der VDR sich die mplayersources.conf nach dem Starten nochmals anguckt. Deshalb vorsichtshalber nach Änderungen an der mplayersources.conf den VDR neu starten.


    In der fstab muß auch ein entsprechender Eintrag vorhanden sein - bei Änderungen hier ist aber kein Neustart notwendig.


    Wenn dein VDR *nicht* mit root-Rechten läuft ("ps auxwww|grep vdr" am Anfang der Zeilen muß 'root' stehen), dann fehlt meist die Berechtigung zum Mounten/Unmounten von Medien. Deshalb mußt du dann zwingend 'user' mit in den Optionen in der fstab haben (was du aber laut deinem ersten Posting bereits hast).


    Hast du denn dem vdrmplayer-Plugin auch mit der Option '-m ...' gesagt, wo das Skript mount.sh liegt, falls es nicht in $PATH zu finden ist?


    Ansonsten kannst du das Skript ja mal direkt aufrufen. Sollte in etwa so gehen:
    /pfad/zu/mount.sh mount /cdrom


    Gruß,
    Juri

    Hi,


    mit dem User, als der der VDR läuft. Das hat allerdings nichts mit dem VDRAdmin-User zu tun.
    Um herauszubekommen, als wecher User der VDR läuft, logst du dich ein und führst folgendes aus und postes hier das Ergebnis:


    ps auxwww | grep vdr


    Der VDR sollte dabei laufen.


    Gruß,
    Juri